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H o w  t o  u s e  t h i s  m a n u a l

H ow  th e  c o n te n t s  a r e  o r g a n iz e d

The manual is organized into sections, a m axim um  o f  four levels deep. The top-level sections divide the 
manual into the broadest topics, w hile su ccessive levels are progressively more specific. Here are 
descriptions o f  the top-level sections:

•  B efore  Y ou  B egin: This section covers things that are helpful to know  before you begin using  
N am o W ebEditor. It also includes useful information about the help system , such as the page you  
are looking at now.

• N am o W eb E d ito r  F u nd am enta ls: This section contains the m ost basic information about using  
N am o W ebEditor, including an introduction to N am o WebEditor's user interface and information 
about w orking with files and sites.

•  L ay in g  O u t W eb  Pages: This section  is all about page layout— how  to use features o f  N am o  
W ebEditor to lay out visually  interesting and user-friendly pages w ith the m inim um  effort.

•  B asic  P age C ontent: This section deals w ith the basic building blocks o f  W eb docum ents, such as 
text, im ages, tables, and hyperlinks. It also covers various w ays o f  formatting content.

• S p ic in g  U p Y o u r  Site: In this section, you’ll learn about tools in N am o W ebEditor you can use to 
go beyond the basics and add exciting features to your sites, such as JavaScript effects, photo  
album s, and d iscussion  forums.

•  W ork in g  W ith  Sites: This section covers in depth the concept o f  N am o WebEditor's "local 
sites"— how  to create them and how  to use them to m ake organizing and navigating your W eb  
sites easier and more pow erful.

•  P u b lish in g  and  M ain ta in in g  a Site: This section talks about publishing sites to the W eb and 
managing them with N am o W ebEditor's site maintenance tools.

•  A d van ced  T ech n iq u es: This section includes topics that are geared more toward experienced  
W eb authors— such as database-driven docum ent design, using shared content, and working  
directly w ith source code.
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•  A p pendices: This section is a catch-all for topics that don't com fortably fit in any o f  the other 
categories. It covers m iscellaneous features o f  N am o W ebEditor and includes a list o f  keyboard  
shortcuts and a troubleshooting FAQ.

T y p o g r a p h i c a l  c o n v e n t i o n s

The follow ing typefaces and sym bols have special m eanings in this manual:

Program text

W ords and phrases found in N am o WebEditor's user interface, such as menu item s and button 
labels, appear in bold M S Sans Serif.

W indow title s

The titles o f  w indow s and d ialog boxes appear in bold Trebuchet MS.

K ey stro k es

Keystrokes and keystroke com binations, such as Ctrl+E, appear in Arial.

Code e x a m p le s
HTML and other markup or code exam ples appear in Courier N ew . B lock  exam ples additionally 
appear with a light background color.

3  Note

* 3  Browser note 

Tip
N otes, w hich contain important information such as warnings; browser notes, w hich  contain  
information about a feature or function's com patibility w ith various browsers; and tips, w hich  
contain helpful supplem entary information, all appear in italics and with a distinctive icon in the 
left margin.

About this manual 3
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G l o s s a r y  o f  c o m m o n  t e r m s

attrib ute

T echnically, a p iece  o f  information that m odifies an HTML elem ent in som e w ay. An attribute 
consists o f  a nam e/value pair in the form n am e= "  v a l u e " .  For exam ple, in the tag < t a b l e  
w i d t h = " 4 0 0" > , the w idth  attribute specifies the width o f  the table. The term is also used  
generally to m ean any quality o f  an elem ent that can be controlled by an author (aside from its 
content).

au th or

Som eone w ho creates documents. A  Web author is som eone w ho creates W eb docum ents, 

b lock  elem ent

A n elem ent that is  displayed with automatic line breaks before and after it. 

conta iner

A n elem ent that contains other elem ents, 

elem ent

The basic building block o f  an HTM L docum ent. A n elem ent generally consists o f  som e content, 
such as a paragraph o f  text, and a pair o f  opening and closing HTM L tags surrounding the content, 
such as <p> and < /p> . Elem ents can contain other elem ents; for exam ple, a paragraph (<p>  
elem ent) can contain a hyperlink (<a>  elem ent). Empty elements have only a single tag and no  
content; an exam ple is <im g>, w hich causes an inline im age to be inserted in the document.

in line e lem en t

A n elem ent that d oes not have automatic line breaks before or after it. An inline elem ent is alw ays 
contained in a b lock  elem ent.

in sertion  point

The blinking vertical bar that indicates the point in the current docum ent at w hich content w ill be 
inserted or deleted. A lso  called the "cursor”.

in tranet

A private network that uses the sam e protocols and file formats as the public Internet.

local files and  fo lders

F iles and folders that reside on the local file  system .
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loca l file system

The collection  o f  all hard drives, CD-R O M s, and other file storage devices connected to the user’s 
computer, as w ell as any servers on the local area network.

loca l site

A  collection  o f  docum ents and resource files that exist in a local folder, are intended for 
publishing as a W eb site, and are managed w ith N am o W ebEditor’s Site Manager.

m ark up

The parts o f  a docum ent that control the presentation o f  content, as distinct from being content. 
HTM L markup consists o f  tags that tell browsers how  to organize or format the content w ithin  
them.

p aren t con ta in er

The elem ent, frame, or w indow  that im m ediately contains the current elem ent, 

p oin ter

The arrow or other shape that m oves when you  m ove the m ouse, indicating w here som ething w ill 
happen when you click  the m ouse button.

prop erty

C om m only used as a synonym  for attribute or to mean any quality o f  an elem ent that can be 
controlled by an author (aside from its content). T echnically, how ever, a property is a quality that 
an elem ent or class o f  elem ents can have, w hich is defined in the C ascading Style Sheets (C SS) 
standard for formatting W eb content. C olor, w id th , and b order are exam ples o f  C SS properties.

rem ote site

A  collection  o f  docum ents and resource files, on a W eb server, that constitute a W eb site, 

root fo ld er

The ’’hom e” or top-level folder o f  a local or remote site; the folder that contains the site’s hom e 
page or main index file. A  root folder may contain subfolders in addition to docum ents.

tag

A  unit o f  HTML markup, such as < p>  or < im g  s r c = " e x a m p l e . g i f  ">. M ost HTM L tags 
com e in pairs o f  opening and closing tags that surround som e content; for exam ple, < p > T h is  i s  
a  p a r a g r a p h . < / p > .  The com bination o f  a pair o f  opening and closing tags and the content in  
betw een them is called an element. A tag m ay contain one or more attributes, nam e/value pairs 
that qualify the tag in som e w ay, as the src attribute in the <im g> exam ple provides the location o f  
the im age.

About this manual 5



tem p orary  docu m en t

A n open docum ent that has never been saved.

user

U nless otherwise specified, "user” refers to som eone w ho view s your docum ents in a browser.

Namo WebEditor 6 User Manual



Chapter 1: Before You Begin

S y s t e m  r e q u i r e m e n t s

The fo llow ing are the system  requirements for N am o W ebEditor 6:

M in im u m

O p eratin g  System  W indow s 98/M e/N T  4 .0  

W eb B row ser Internet Explorer 4 .0  

C P U  Pentium 166 or faster 

M em ory  64 M B  

F ree D isk  Sp ace 50  M B

R ecom m en d ed

W indow s 2000/X P  or newer 

Internet Explorer 5.5 or new er  

Pentium 266 or faster

128 M B or more 

135 M B or more

D isp lay  800 x 600, 256  colors 1024 x 768 or larger

In addition, i f  you  plan to create dynam ic docum ents using N am o WebEditor's Database W izard, you must 
have M icrosoft Personal W eb Server (PW S) or Internet Information Server (IIS) installed on your 
computer, as w ell as access to an O D B C -com patible database. PW S is included on the W indow s 98 setup  
CD. IIS is included w ith W indow s 2000/X P .

System requirements 7
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I n s t a l l i n g  N a m o  W e b E d i t o r

To in s ta ll N a m o  W eb E d itor  from  a  CD-ROM

1. Insert the N am o W ebEditor C D-R O M  in your C D-RO M  drive. In a few  seconds, the setup 
program should start autom atically.

2. I f  the setup program does not start autom atically, do the follow ing:

1. On the Start m enu, c lick  Run.

2. T ype D :\se tu p .exe  and press Enter. (Substitute your CD-ROM  drive’s letter for the letter 
’D \)

3. F ollow  the on-screen instructions in the setup program.

To in s ta ll N a m o  W eb E d itor  fro m  a  d o w n lo a d e d  s e t u p  f ile

1. D ouble-click  the dow nloaded setup file.

2. F ollow  the on-screen instructions in the setup program.

8 Installing Namo WebEditor
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G e t t i n g  t e c h n i c a l  s u p p o r t

Generally, your primary provider o f  technical support for N am o W ebEditor is the master distributor o f  
Sejoong N am o Interactive's products in your country or region. P lease find the appropriate support contact 
for your country or region on our W eb site at http://w w w .nam o.com /com pany/contact/w orld_contacts.htm l.

Y ou  can also get help directly from SJ N am o Interactive. There are three w ays to submit a question to 
our technical support team:

•  Post your question on the N am o W ebEditor Support Forum at 
http://ww w.nam o.com /support/board/. This is the preferred m ethod. Y ou  can ch oose  to post either 
publicly (your question and our response can be seen  b y  all forum  users) or privately (on ly  N am o  
support sta ff w ill see your question and respond privately). P lease note that you m ust register your 
copy o f  N am o W ebEditor online before you can create a forum account and log  in. To register, 
please visit http://ww w.nam o.com /support/register/.

•  Send us an e-m ail at support@ nam o.com .

•  Fax us at 781-279-1301 . P lease address your fax to "W ebEditor Support". N ote that 
long distance charges w ill probably apply.

B efore contacting technical support, w e suggest that you  first check  the N am o W ebEditor K now ledge B ase  
on our W eb site and the troubleshooting section o f  the N am o W ebEditor online help. To search the 
K now ledge B ase, go  to http://w w w .nam o.com /support/w ebeditor/. T o v iew  the troubleshooting section  in 
H elp, press F1 and click  Troubleshooting in the Contents pane.

In addition, you  can easily  check for program updates by selecting Namo WebEditor U pdates in the Help 
m enu. Y ou m ust be connected to the Internet to check for updates.

P lease do not contact SJ N am o Interactive regarding non-technical issues, such as product delivery  
and billing. Y ou  should direct such questions to the reseller from  w hich  you purchased N am o W ebEditor or 
the master distributor in your country or region. I f  you  purchased N am o W ebEditor through our online  
store, p lease visit http://w w w .digitalriver.com /dr/v2/ec_M A IN .Entryl l?S P ss10107& P N = l for a list o f  
support options regarding your order.

Getting technical support 9
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W h a t ' s  n e w  i n  N a m o  W e b E d i t o r  6

A  list o f  the most important new  and improved features o f  N am o W ebEditor 6.

D o c u m e n t e d it in g

The Formatting panel........................................p. 11

Simultaneous source view................................p. 11

Tag Selector........................................................p. 12
Shortcut Bar........................................................p. 12
Improved Inspector........................................... p. 13

New style definition interface......................... p. 14

User-created document templates.................. p. 16
iframe support.....................................................p.20
Floating boxes.................................................... p.21

Improved Smart ClipArt editing.....................p .21

Improved Color Palette.....................................p.23
Image bullets.......................................................p.23
Custom scrollbar colors................................... p.25

Assigning class or ID ........................................p.25

Improved find & replace.................................. p.26
Media Wizard.....................................................p.26
Preview in more browsers................................p.27

S crip tin g

Table cell rollovers........................................... p.24

Popup control cookie script............................ p.24
Custom script support.......................................p.27

S ite  m a n a g e m e n t

Find Files command.......................................... p. 13

CSS-based Themes............................................ p. 14
Site asset library................................................. p. 16

User-created site templates...............................p. 16

Improved site tree v iew .................................... p. 17

New node types for site trees........................... p. 17
Zipping local sites for import/export..............p.26

One-step zip & e-mail resource folder........... p.26

WebDAV support...............................................p.27

P u b lish in g

Quick Publish......................................................p. 18
Mirror Upload & Download............................ p. 18

Opening and saving documents directly 
from/to a Web site..............................................p. 19
Selecting linked files for publishing...............p.25

A d v a n ced  fe a tu r e s

Shared content blocks........................................p. 15

SSI support.......................................................... p. 16

Online HTML/CSS reference.......................... p. 19
More source verification options.................... p. 19

UNC-format hyperlink support.......................p.27

10 What's new in Namo WebEditor 6
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U se the Form atting panel to quickly apply heading levels or custom  styles to 
text content. W ith the Form atting panel, you  can:

•  apply a custom  style to the current paragraph or selection  w ith one click

•  add or m odify a custom  style  

add a custom  style based on the style o f  the current selection  

change a normal paragraph to a heading, or v ice  versa, w ith one click  

change the default style o f  headings

T h e  F o r m a tt in g  p a n e l

The Form atting panel appears by default on the right side o f  the main 
w indow , but you can m ove it as a floating w indow  or collapse it so that only  
its left border is visib le.

See Using the Formatting panel, p.227

S im u lta n e o u s  s o u r c e  v ie w

I v ï  Formatting -

Clear Formatting A

H e a d i n g  1 A  !

H eading 2 A.
H e a d i n g  5 A : '
H ead in g  4 Л
Heading 5 A

A :  '

Fluffy
Corswa
L istl

List2

Delete *TDelete
Reviï I ,

I= —

1= V
a  or a - -  &

Y ou can now split the docum ent w indow  into Edit and HTM L panes, making it easier to go back and forth 
betw een visual and source editing. Changes in the Edit pane are instantly reflected in the HTM L pane.

!  D:\work\wescratcMnoname1 Jrtml

lorem ipsum

lorem ipsum

8 <body bgcolor-"white" text-"black" link-" 
blue" vlink-"purple" alink-"red">

9 <toble border-"l">
10 <tr> j
11 <td vidth-"15G">loren> ^^0</td> —
12 <td vidth-"150">£nbsp;</td>
13 </tr>
14 <tr>

L Edü A  Edit tH T M L ^  HTML/y Preview f \ <  1_________ II

See Viewing Edit and HTML modes simultaneously, p.34

What's new in Namo WebEditor 6 11
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S h o r tc u t Bar

The new  Shortcut Bar provides one-click  access to som e frequently-used  
com m ands to do things like publishing a site or inserting a Script Wizard effect. 
The Shortcut Bar appears on the left side o f  the main w indow  and is collapsible.

See Toolbars and the Shortcut Bar, p.36

Genera! ► IGZLIiAIInsert ^ 
Advanced
3 <ntle>4 </heacb
5 <body>6 <p styl7 el it .  /8 Suspenc9 est. Cr10 laoreet11 ipsum п

/ Tv 12 condime

Lorem ip sun 
male su ad a ir 
posuere et, 1 
Nam laoreet 
orcL Maece: 
ipsum neque 
soHicitudin. i

T ag S e le c to r

The Tag Selector appears in the low er panel area w henever you are in Edit m ode, revealing the HTM L tags 
o f  the current elem ent and its ancestors. C lick a tag to select the desired elem ent. R ight-click a tag to access  
a pop-up m enu o f  actions for the elem ent. I f an elem ent is a mem ber o f  a class, the class name appears with  
the elem ent name.

What a beautiful day to be authoiiii

documents!

\  Edit A Edit & HTML Л HTML A Preview 7
j О  Tag Selector
<body> <table> <tr> <td> < p >  <span.boldish> <a#namo!ink>

ПИ Results
Press F I for help.

И  TimeB Remove Tag 
----------------  View Source

Eroperties...

tor

See The Tag Selector, p.40
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Im p ro v ed  In sp e c to r

The Inspector now  show  properties for m any more elem ent types than in the previous version o f  N am o  
W ebEditor. It now  supports virtually every elem ent that you can create in Edit m ode.

p Iffjrerl
200"
200~

X 210
Y; ,W

Background hcsvtn.fli ("1
yet*y: [ 5 5 1 7 3 ]  |i r  <LAYER> |

fc. 3  4k I * & * }  : l a  tl] EfilH

■¡3
1 Path: 

V.Vth: 21
^  llamc: «Jöts* 

Border 1

Tarytf: f  

Scrol; [y

Find F iles  c o m m a n d

U se the new  Find F iles comm and to find files in a local site or folder that match a specified file  nam e 
pattern.

See Finding files, p.405

What’s new in Namo WebEditor 6 13
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C S S -b a se d  th e m e s

N am o WebEditor's them es now  use Cascading Style Sheets (C SS) to define the formatting properties o f  
various text elem ents, such as headings, paragraphs, and list items. Y ou can edit any o f  these CSS  
properties, giving you m ore control over a them e’s appearance.

Theme Properties

Document 
Headngl 
Headng2 
List 1 
List 2_

Cel 
Header Cel
Norma! Hyperlink 
Vdted Hype ink 
Active Hyperink 
Hove* Hype ink 
Banner
Horizontal Button 
Vertical Button 
Bufetl 
8uBet2 
Cool loonMr* Imn

Character | Paragraph Boidert I Background |

Properties - ------

Style: m
Color: □
tfidthc F

r
Padding: F

Background

Add- 1 ^ y . ' \
Ccdor.

See Editing a theme, p.276

N e w  s ty le  d e fin it io n  in te r fa c e

N am o W ebEditor 6 has a com pletely redesigned interface for defining CSS styles. The new  Styles dialog  
box integrates selector and property definition in one screen, and organizes available properties into three 
intuitive tabs: Character, Paragraph, and Borders & Background. N ew  controls make defining borders and 
other properties easier than before.

14 What's new in Namo WebEditor 6
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w i n —\
iloud
00 fancy 
tatiî 
td
td cod

Ô arxJcf | Paragraph Eerier* I Exkgrxrd J

ScfeclAI |

Çcfcr

Widh
Hyginc

Background

o a C

Invvx: jvwwpo 
Ccfx | | - |

|Deu№ d
Î----------------

|5 3 1 * *

|1 3|ciC4» d

E'owta .. | Ocÿon;-

[Save A3 External Ffe.ITl QK C-ancd

See Defining a style, p.213

S h a r e d  c o n te n t  b lo c k s

A  shared content block is an HTM L fragment that you can insert in many docum ents w hile keeping the 
shared block's source in a separate, special file. W hen you edit the shared block in its source file, every  
cop y  o f  it in other docum ents can be autom atically updated with one click. Shared content blocks are great 
for page elem ents that are repeated identically on many pages and yet change from tim e to time, such as 
top-level navigation bars and page footers.

ropyrî -it (c) 2004 Sejoortg Na ^  CM 
Q] Copy
Ca
1̂5 Cell Rollover...

X®bl® Properties...
Bä £«• Properties...
m Select T¿bio
H 1 ¿elect CeB

Table ►
Qocument Properties...

SEESSKatäd Co*Updata SKu&d Content Block 
flatten Shared Content Block

See Shared content blocks, p.420
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U se r -c r e a te d  d o c u m e n t  te m p la te s

Y ou can now  save any HTM L docum ent as a template and store it in the Resource Manager, along with  
factory-created tem plates. S ince tem plates are saved as M HTM L files, im ages and other resource files are 
saved right in the tem plate.

See Saving a document as a template, p.64

U se r -c r e a te d  s i t e  t e m p la te s

Y ou can now  save a local site as a tem plate for use with the Site W izard. Nam o W ebEditor preserves every  
aspect o f  a site w hen you save it as a tem plate, including the site tree, style sheets, im ages, and other 
resource files.

SSI su p p o r t

N am o W ebEditor 6 supports inserting Server-Side Include (SSI) com m ands in Edit m ode. A n SSI 
com m and instructs the W eb server to insert som e content, such as the contents o f  an HTM L file, into a 
W eb page w hen it serves the page to a browser.

See Server-side includes, p.423

S ite  a s s e t  library

A  new  S ite  Library panel acts as a library o f  all the resource files, 
docum ents, and hyperlinks in use in the current site. Q uickly insert im ages, 
shared content blocks (p. 15), hyperlinks, and other items into your 
docum ents by sim ply dragging them  from the library.

See Using the site library, p.377

J ¿5} Site Library -

Q  #  ( З Ц ®  L  a

Q  coHapsedgif l lma9e Nesl 1KB | :
Q  expanded gif 1KB ; j
Q  nth_gridpad_bg.gif 1 K B ^
Q  nthJheme_vector_a... 1KB
[ à  bufletl.gif 1KB
Q  buüel2.gif 1KB
[¿J rv3Y_42_contact_sh... 2KB
Q  nav_42_contact_shr... 2KB
( â  nav_42_contact_$v.... 2KB
Eà nav_42_contact_svr... 2KB
Q  nav_42_conlact_th.gif 2KB
Q  nav_42_contact_thi.... 2KB
Q  nav_42_faqjhgif 2KB
Q  nav_42Jaq.ihr.gif 
^ I

2KB y ;
<_________ i l>_
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Im p ro v ed  s i t e  t r e e  v ie w

The Site Manager’s site tree v iew  by default now  uses larger document icons that show  both file nam e and 
navigation name. The tree can be toggled betw een large icons and small icons, and it can be show n either 
horizontally or vertically. In addition, a thumbnail representation helps you navigate a large site tree by  
dragging a box over the part you want to see. There is also a new  comm and to capture the site tree to an 
im age file.

SfteTiee

, . ~ n  I Q  Widgets

I Q  Products j I

Q  index, html

K Q  Gewgaws

>

See Site structure and navigation, p.355

N e w  n o d e  t y p e s  for  s i t e  t r e e s

N am o W ebEditor 6 supports four new  node types for insertion in site trees, in addition to the traditional 
docum ent and external link nodes:

•  Shortcut nodes are "virtual” nodes that link to docum ent nodes elsew here in the tree.

•  Folder nodes are special nodes that represent subfolders in the site. W hen you drag a folder from  
the file  list to the site tree, N am o W ebEditor creates a folder node and child nodes for all the 
docum ents in the folder.

•  Forum nodes are a special type o f  docum ent node. A  forum node represents a document that 
contains an inline frame linking to a forum page.

•  Temporary nodes act as placeholders that reserve positions where you w ill add docum ent or other 
nodes later.

In addition, new  com m ands in the Site M anager let you quickly insert docum ent nodes for empty 
docum ents o f  specific  types, including HTM L, A SP, PHP, JSP, and plain text files.

What's new in Namo WebEditor 6 17
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See Building the site tree, p.356

Q uick  P u b lish

U se the new  Quick Publish comm and to instantly upload selected  
files to your W eb server w ith one click.

See Quick publishing, p.392

I ✓ Enable Navigation 

0 1
Ratten Shared Content!

Mirror U p load  & D o w n lo a d

W hen you use the new  Mirror Upload com m and in the Publish w indow , N am o W ebEditor autom atically  
uploads the selected  local items to the sam e place in the folder structure o f  your W eb server. Mirror 
Download does the sam e in reverse.

j~*[^ tree bmp
t-CMUU.!.!.,].-«
[-Qweddinghtn =MWoad 
~Qyukon.html effi, Mrror Upload

935KB 2003/04/2318:15
1 i/o 'inno /n 1 m  1 c.-i q

9 
9

See The Publish window, p.394

P u b lish in g  t o  a  lo c a l or n e tw o r k  fo ld e r

I f  you have a W eb server running on the local com puter or a server on the local area network, you can now  
specify  a local or network folder as a remote site for publishing using direct file copy rather than FTP.

Remote Site Settings

Site £)ame: [Localhost Type | Win32 3

Local/Network Target Information
E^h: | C:\lnetpub\vvwwroot\ Browse... |

See Defining a remote site using Windows file copy, p.390
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N ew  com m ands let you open a docum ent from and save a docum ent to a W eb server directly, w ithout 
having to dow nload or upload it through the Publish w indow .

O p e n in g  a n d  s a v in g  d o c u m e n ts  d ire c t ly  f r o m / t o  a  W e b  s ite

pHHIM
Remotest: | member * - - 3  A a  &■ s- in
Name | Size 1 Modlied 1

2003/03/1411:22
EÎ-index.Üm 1KB 2003/03/2414:13 !

Fferwne: | index.him Open 1

Cancel |

See Opening and saving files directly on a Web server, p.404 

O n lin e  HTM L/CSS r e fe r e n c e

N am o W ebEditor 6 includes a handy online HTM L/CSS reference. To open the reference w indow , Press 
S h ift+ F 1 .

M ore so u r c e  v e r if ic a t io n  o p t io n s

N am o W ebEditor 6 can now  validate a document's source code against the XHTM L standard and check  it 
for com patibility w ith several distinct versions o f  the m ost popular browsers.

What's new in Namo WebEditor 6 19
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Venfy HTttL
HTML version----------------------------------------------------

С HTML 20 С tfUMt 1.0 (Strict)
r  HIMl 12 c WTML 1.0 (Loom. TimfenA FwneSet)
С HTML 4.0 (Sbicl)
С HTMt4.0(Leo$e,Twttttor%aLFi«neSe()

Г UettttpeNeviplo'aO 
Г Mettt«peN«vfcatoi40 
P NeUctptNevçrfof&O
P 0до«4.0 
Г Op«« SO 
P Op«« SO

I fl* I С*ЮН I

See Validating source code, p.508

ifram e su p p o r t

N am o W ebEditor 6 supports creating inline frames (ifram es) in Edit m ode. A n inline frame is like a 
w indow  in a docum ent, through w hich another docum ent is v isib le.

¿iLoremipsmn
! I: | dolor sit amet, 

i consectetner 

^dipiscmg diL 

AHquammi 

j est, solEdtadm 

sed, malesaada
. . . .  . ■  .m, adipisdng a, poms. Suspendisse id lacns. 

Donee neqne est, accumsan non, posnere et,

See Inline frames, p.416

Biomer ertenaon -------
& P̂ecfc fcfow« cornp«(èfcÿ| 

Г Internet Effarer aO 
Г Internet Ефкпг 4.0 
P Internet ЕфЬгег SO 
P internet ЕфЬгег S5 
P Internet E*4orer &0
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A floating box is a container that is aligned on  one side o f  a content block, and around w hich other content 
flow s. N am o W ebEditor now  supports inserting floating boxes in Edit m ode.

aliqua. Ut enim ad minim veniam, quis nostrud exerdtation 
ullamco l3boris nisi ut aliquip ex ea commodo consequat.

Duis aute irure dolor in 
reprehenderit in voluptate 
velit esse cillum dolore eu 
fugiat nulla pariatur.
Excepteur sint occaecat 
cupid3tat non proident, 
sunt in culpa qui officia 
deserunt mollit anim id est 
laborum. Lorem ipsum dolor 

sit amet, consectetur adipisicing elit, sed do eiusmod tempor 
incididunt ut labore et dolore magna aliqua. Ut enim ad 
minim veniam, quis nostrud exerdtation ullamco laboris nisi 
ut aliquip ex ea commodo consequat.
A floating box example

See Using floating boxes, p. 121

F lo a tin g  b o x e s

Im p ro v ed  S m a rt C lipArt e d it in g

N am o W ebEditor 4 .0  introduced Smart Buttons, ready-m ade vector-based im ages that you could custom ize  
w ith an integrated Smart Button editor. N am o W ebEditor 5.5 extended Smart Button support with an  
external application— W ebCanvas— that offered more powerful editing features and a new  file  format.

N am o W ebEditor 6 goes even further by integrating W ebCanvas more tightly than before. N ow , w hen you  
want to edit a Smart Button (now  called Smart ClipArt), N am o W ebEditor opens the Smart ClipArt 
Editor— a specialized  version o f  W ebCanvas that is fine-tuned for editing Smart ClipArt w ithin the m ain  
application. The full version o f  W ebCanvas is still included (in selected versions o f  N am o W ebEditor 6) 
and is still available as an external program.

This text is in a floating box. 
Any content th a t follows a 
floating box "flows* around it, 
as a stream flows around a 
rock. Of course, rocks don’t 
float, unless they're very 
small, but what can you do.
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5 ^

See Modifying Smart ClipArt images, p.259
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The Color Palette now  displays recently-used colors and has a menu from w hich you can select various 
palettes, including custom  color sets.

Im p ro v e d  C o lo r P a le t te

Custom Colon______
. HIE9H0E3E
U J  l I 1 I i r  

. Recgrt Cofart
n m i m

See Selecting colors, p.233

Im a g e  b u lle ts

N am o W ebEditor 6 supports the use o f  im ages as the bullets in bulleted lists.

Q  This is a Kst ’with image bullets.

^  n is Am w A M m m m m
Q  Try it to

IHj

List I 

lype:

Image path: |..A^6docwouces/images/icorvb

See Using an image as a bullet, p. 133
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T ab le  c e ll  r o llo v ers

Y ou can now  create a rollover effect on a table cell. C ell rollovers 
are based on CSS properties.

Mozart Beethoven | Stravinksy

See Script Wizard: Cell rollover, p.303 Mozart Stravinksy

P o p -u p  w in d o w  c o o k ie  sc r ip t

The Script Wizard includes a new  script that you can use to set a cookie for a pop-up w indow , allow ing  
your users to "opt out" o f  seeing the pop-up w indow  again for 24 hours.

This is a  popup window.

H D on't show agamfor one day

. See Script Wizard: Pop-up window cookie, p.301
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C u sto m  scro llb a r  c o lo r s

Y ou can now specify  custom  scrollbar colors for a docum ent. Custom scrollbar colors are supported by  
Internet Explorer 5.5 and later.

............. ... . C
Preview Color properties ------

---- Base: □  H Highlight: □ ' r

Face: □ ¡-I 3D light: Q  | ▼
Arrow: ■  H Shadow: 0 ! ^ |

t r I
Track: M d Dark shadow: H > ^

>^Sctolibar colors are supported on|y by
c d I ^'internet Explorer version 5.5 and later.

Pie v i e w ------

Lorem ipsum d o lo r  s i t  omet, c o n s e c te  
Àliquam mi e s t ,  s o l l i c i t u d i n  se d , ma 
S u sp en d isse  id  la c u s  
Donee neque e s t  
Cras g ra v id a  t in c id u n t

la c u s .  M
:, accurosan non, p o s u e H  
Lncidunt m assa. Rj

Restore Defaults QK | Cancel |

See Setting document scrollbar colors, p.242

A ss ig n in g  c la s s  or ID

Y ou can now  directly assign  a class or ID in Edit m ode to many elem ent types, including paragraphs, other 
block elem ents, spans, im ages, table cells, layers, and so forth. This makes using CSS styles in Edit m ode  
m ore convenient.

See Applying a class style, p.215

S e le c t in g  lin k ed  f i le s  for  p u b lish in g

W hen you right-click a docum ent in the local pane o f  the Publish w indow  and click  S e lect Linked Files, 
N am o W ebEditor autom atically selects all the local docum ents and resource files to w hich the docum ent 
you clicked contains links. That w ay, you can upload all o f  them at once and not worry that you m ight have

What’s new in Namo WebEditor 6 25



Namo WebEditor 6 User Manual

m issed  a linked resource som ew here.

See Selecting files for publishing, p.397

Im p ro v ed  fin d  & r e p la c e

The F ind/R eplace dialog box is now  m odeless, so you can continue editing or selecting content w hile the 
dialog box is open. Find/Replace now  supports the special character "\n” for matching line breaks in source 
code. A lso , a new  Match hyperlinks only check box in both local and global find/replace com m ands lets you  
search for and replace text just w ithin hyperlinks.

find: | <tr>\n<td> j * ]

W Replace with* |<li><ld>

M edia  W izard

The M edia W izard m akes it easier than ever to add video and audio objects to your pages. O nce you  
specify  a source file, the wizard chooses the appropriate player for you. Then just tw eak a few  settings, and 
you're done.

See Inserting video and audio files, p.252 

Z ipp ing  lo ca l s i t e s  fo r  im p o r t /e x p o r t

Y ou can now  export a local site to a com pressed Zip archive and import a local site from a Zip archive. 
T hese functions make it easier to copy or m ove local sites from one computer to another.

See Exporting and importing a local site to/from a zip archive, p.353 

O n e -s te p  z ip  & e -m a il r e so u r c e  fo ld e r

A  new  comm and button in the R esource M anager lets you zip  and e-m ail a folder full o f  resources in one 
step, perfect for sharing user-created resources for collaborative projects.

See Sharing resources with other people, p.52
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P r e v ie w  in  m o re  b r o w se r s

Y ou can now  specify  up to five W eb  
browsers to use for preview ing your 
documents. O f course, N am o WebEditor's 
internal preview is still available.

C u sto m  scr ip t su p p o r t

Y ou can now  add your ow n custom  JavaScripts to N am o W ebEditor’s A ctions folder, and they w ill appear 
in the Action m enu along with the factory-installed scripts w hen you attach an action to an elem ent.

U N C -form at h yp er lin k  su p p o r t

Y ou can now  specify  the destination o f  a hyperlink in U niversal N am ing C onvention (U N C ) format— for 
exam ple, "\\jazz\w eb\index.htm r. This is usefu l in intranet sites w hen a link must point to a docum ent on a 
W indow s network.

W ebD AV  su p p o r t

N am o W ebEditor 6 now  supports W eb Distributed Authoring and V ersioning (W ebD A V ), in addition to 
M icrosoft SourceSafe, for source control.

f ë  tr.säfa»Is iJü 2 i iriil

. :. View F12

Define Browsers...
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2  N a m o  W e b E d it o r  

F u n d a m e n ta ls

This section deals w ith the basics o f  w orking w ith N am o W ebEditor 6. Authors w ho are n ew  to N am o  
W ebEditor or to w eb authoring in general should especially  read this section.

In th is  s e c t io n

Starting Namo WebEditor......................................................................................p.30

The visual authoring environment........................................................................ p .31

Preferences and settings......................................................................................... p.53
Working with documents.......................................................................................p.59

Basic document editing.......................................................................................... p.70

Working with local sites.........................................................................................p.78
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S t a r t i n g  N a m o  W e b E d i t o r

To s ta r t  N am o W eb E d itor

•  Do one o f  the follow ing:

o  On the W indow s Start menu, point to Programs, point to Namo WebEditor 6, and then 
click  Nam o WebEditor 6.

o  D ouble-click  the Namo WebEditor 6 icon on your W indow s desktop.

0  The Namo WebEditor 6 icon on the desktop will only be available i f  you chose to install it in Namo 
WebEditor 6 Setup.

The first time you start N am o W ebEditor 6, the program w ill prompt you to enter your serial number and 
C D /license key. If you purchased N am o W ebEditor on CD-ROM , this information can be found on the 
packaging o f  the N am o W ebEditor setup CD. If you received N am o W ebEditor electronically (by 
dow nloading), this information should have been provided online when you purchased the software.
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T h e  v i s u a l  a u t h o r i n g  e n v i r o n m e n t

N am o W ebEditor is a visual, or WYSIWYG ("What Y ou See Is W hat Y ou Get"), W eb authoring program. 
This means that what you see on the screen w hile you are creating or editing a W eb page w ith  N am o  
W ebEditor closely  resem bles what you  w ould see i f  you  were to open the page in a W eb browser. T his 
visual orientation m akes N am o W ebEditor different from "code-oriented" HTM L editors, in w hich you edit 
HTM L code directly (although you can also do that in N am o W ebEditor).

The largest part o f  N am o W ebEditor's main w indow  is taken up by the document window (p.33), the 
workspace where you create and edit a W eb docum ent. At first, w hen you start a new  docum ent, the 
document w indow  is an em pty w hite space. To build a W eb document, you  fill the w indow  with content—  
the elem ents that make up a W eb p age— by typing words, dragging and dropping image files from your 
hard disk, and so forth.

Entering content into a W eb docum ent w ith N am o W ebEditor works much like entering content in a word 
processing program. A  blinking vertical bar, called the insertion point, indicates where text you type or 
im ages you insert w ill appear on the page. In a new  docum ent, the insertion point begins in the upper left 
com er o f  the docum ent w indow . A s you  add content, the insertion point m oves toward the right; w hen it 
reaches the right edge o f  the docum ent w indow , it m oves down one line and back to the left edge. U nlike a 
page in a word processing docum ent, how ever, a W eb page has no fixed size. A s you add content, the page 
gets longer and longer. That’s w hy W eb brow sers, and N am o W ebEditor, provide a scroll bar at the right 
side o f  the w indow — so you can see an entire docum ent, even i f  it doesn’t fit on one screen.
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N ote that you cannot sim ply click anywhere on an empty page and starting typing at that location. A s in a 
word processing program, the insertion point cannot m ove beyond the end o f  the docum ent’s existing  
content. H ow ever, there are w ays to place content at a specific location on a page, using layout boxes (p.91), 
tables (p.99), or layers (p.l 11). (T hese topics are discussed in the section Laying Out W eb Pages, p .89.)

A t the bottom  o f  the docum ent w indow  are a set o f  mode tabs, labeled Edit, Edit & HTML, HTML, and 
Preview. U se these tabs to sw itch am ong N am o W ebEditor’s three basic m odes o f  operation:

•  Edit mode is N am o W ebEditor’s normal m ode, in w hich you edit docum ents visually. W hen N am o  
W ebEditor starts, it is alw ays in Edit m ode.

•  In HTML mode, the docum ent w indow  show s the HTM L source code that underlies the current 
docum ent. In this m ode, experienced authors can work directly w ith HTML code to achieve  
advanced effects that m ay be difficult to realize in Edit m ode. To quickly switch betw een Edit 
m ode and HTM L m ode, press F 6  on your keyboard.

•  Preview mode d isplays the current document exactly as it w ould appear in the version o f  Internet 
Explorer that is installed on your computer. U se this m ode as a quick alternative to preview ing the 
docum ent in a real browser. Y ou cannot edit a document in this m ode.

C licking the Edit & HTML tab show s Edit m ode and HTML m ode sim ultaneously (p.34) in a split w indow .

W hen you  are w orking on a frameset (p.101), three more m ode tabs are available: NOFRAMES Content, 
Fram eset Source, and F ram eset Preview. See U sing frames, p. 101 for information about these additional 
m odes. ( I f  all seven  m ode tabs are not v isib le  w hen you are working on a frameset, click the View menu, 
point to Mode Tabs, and then click  Show  All T abs.)

The rest o f  this section  covers the docum ent w indow  and other basic parts o f  N am o WebEditor's user 
interface in more detail.

In th is  s e c t io n

Document w indow s.................................................................................................p.33

Viewing Edit and HTML modes simultaneously...............................................p.34
Toolbars and the Shortcut Bar...............................................................................p.36
The Inspector and other tool panels..................................................................... p.38

The Tag Selector.......................................................................................................p.40

The status bar............................................................................................................ p.42
Rulers, layout guides, and layout grids................................................................p.43

Special marks in Edit m ode................................................................................... p.44

The Resource Manager........................................................................................... p.45
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D o c u m e n t  w i n d o w s

W orking w ith  m u ltip le  d o c u m e n ts

B y default, N am o W ebEditor displays only one m axim ized docum ent w indow  at a time, even  i f  you  have 
more than one docum ent open. To sw itch am ong m ultiple open docum ents, use the document tabs at the 
top o f  the docum ent w indow . Y ou can also press C trl+Tab to cycle  through open documents.

index, html X profile.htm ^  favorite.htm

Use document tabs to snitch among open documents

ï
U  If  an open document has been modified but not yet saved, an asterisk appears next to the file  name in 

its document tab.

tJ Right-clicking a document tab reveals a shortcut menu containing commands fo r frequently-used 
operations on the corresponding document, like saving or closing.

Double-clicking a document tab opens the Document Properties dialog box fo r  the corresponding 
document.

^  To hide the document tabs, on the View menu, point to Toolbars, and then click Document Tabs.

If you want to see  tw o or more docum ents at the sam e time, unm axim ize the document w indow  by click ing  

the Restore button J9] at the far right end o f  the menu bar. W hen m ultiple docum ent w indow s are v is ib le , 
you can arrange them neatly using com m ands in the Window menu:

•  C lick C ascad e to arrange w in dow s in a staggered "waterfall".

•  C lick Tile Horizontally to tile the docum ent w indow  area with sam e-sized w indow s one on top o f  
another.

•  C lick Tile Vertically to tile the docum ent w indow  area with sam e-sized w indow s side by side.

Y ou can also m inim ize a document w indow  to just a short title bar by click ing the M inim ize button -=J If 
you m inim ize a w indow  w hile it is m axim ized, other document w indow s w ill becom e unm axim ized.
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To v iew  a list o f  open docum ents, on the W indow m enu, click Window List. Y ou can bring a docum ent to 
the front by double-click ing its path in the list.

S e tt in g  w in d o w  m a g n if ic a t io n

You can set the m agnification o f  the docum ent w indow  to "zoom in” closer to or "zoom out" farther from a 
document. Z oom ing does not affect how  the docum ent w ill appear in a W eb browser.

1. On the Standard Toolbar, click  (Zoom  In/Out).

2. Select the desired m agnification factor from  the menu, or type a m agnification factor and press 
E nter.

A lternatively, i f  you use a w heel m ouse, you can zoom  in and out by turning the m ouse w heel w hile  
holding dow n the Ctrl key.

V i e w i n g  E d i t  a n d  H T M L  m o d e s  s i m u l t a n e o u s l y

Y ou can v iew  a docum ent in Edit m ode and HTM L m ode at the same time. W hen you do this, N am o  
W ebEditor splits the docum ent w indow  into tw o panes. The top pane show s the docum ent’s HTML source 
code; the bottom  pane, its W Y SIW Y G  view . B y v iew in g  both m odes at once, you  can instantly see what 
effect changes you m ake in visual editing have on a docum ent’s source code, or what effect changes to
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source code have visually. This is especia lly  useful w hen troubleshooting HTM L problem s or w hen you  
want to learn how  HTML works.

LD Changes you make in Edit mode are reflected instantly in the HTML pane. However, changes you make 
in HTML mode are not reflected in the Edit pane until you click inside the Edit pane.

lorem

lorem ip sum

lorem ip sum

8 <body b g co lo r* " u h ite"  te x t« " b la c k ” lin k = ” /v 
b lu e"  v lin k «" p u rp le"  alink="red">

9 < ta b le  b ord ersrfl rr>
10 <tr>  _____
11 < td  width*" 150rr>lorem
12 < td  u id th “ "150,r>£nbsp; < /td >
13 < /tr >
14 <tr> v

\ Edit Л Edit «■ HTMLA HTML Д Pieview /  I < I J j
Simultaneous Edit/HTML view

To v ie w  a  d o c u m e n t in E dit an d  HTML m o d e s  s im u lta n e o u s ly

•  Click the Edit & HTML m ode tab at the bottom  o f  docum ent w indow .

To a d ju s t  th e  r e la t iv e  s i z e s  o f  th e  E dit an d  HTML p a n e s

•  Drag the border betw een the tw o panes.

To rea rra n g e  th e  Edit a n d  HTML p a n e s

1. On the Tools m enu, click Preferences, and then click  the Edit tab.

2. Under Mode settings, next to Top pane in sim ultaneous m ode, click either HTML or Edit.

To synchronize the Edit and HTML panes so that they display the same portion o f  the document, click 
inside either pane .
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T o o l b a r s  a n d  t h e  S h o r t c u t  B a r

A b o u t th e  to o lb a r s

N am o W ebEditor provides several toolbars so that you can execute any o f  a w ide variety o f  com m ands 
with just one click. Initially, two toolbars are visib le just below  the menu bar: the Standard Toolbar and the 
Formatting Toolbar. Other toolbars are initially hidden. Y ou can reveal or hide a toolbar through the View  
menu: point to Toolbars, and then click  the name o f  the toolbar you want to reveal or hide. V isib le  toolbars 
are show n w ith check marks next to their nam es in the menu.

To find out the function o f  any toolbar button, m ove the m ouse pointer over it. A  description o f  the button's 
purpose w ill appear in the status bar at the bottom o f  the main w indow .

B y default, toolbars reside in the toolbar dock— a variable-size space reserved for toolbars— just under the 
menu bar. W hen a toolbar is in this space, it is said to be "docked”. Y ou can m ove a toolbar within the dock  
by dragging its handle, a thin vertical line at the toolbar's left edge. You can "undock" a toolbar by dragging 
it o f f  the dock. W hen a toolbar is undocked, it acts like a sm all, floating window: you can m ove it 
anywhere on the screen by dragging its title bar, and it alw ays appears on top o f  other w indow s. To dock  
the toolbar again, drag it back to the toolbar dock or double-click its title bar.

j É l ! h  - -
The Image Toolbar (docked)

a n s a ? l i

[Ê] iEî* EÎ . •

The Image Toolbar (undocked)

O If part o f  a docked toolbar is hidden because the dock is not wide enough to show all o f  it, click the 
chevron at the right end o f  the visible part to temporarily reveal the hidden buttons.

A b ou t th e  S h o r tc u t Bar

The Shortcut Bar is the vertical bar w ith large icons on the left side o f  the main w indow . It provides fast 
access to som e o f  the m ost com m only used com m ands with large, easy-to-click  buttons.

The Shortcut Bar has three sets o f  buttons, labeled General, Insert, and Advanced. To select a button set, 
click  the triangle at the top o f  the bar.

To hide the Shortcut Bar, click  the colum n o f  dots in the m iddle o f  its right edge. C lick it again to reveal 
the Shortcut Bar.
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Hiding the Shortcut Bar 

C u sto m iz in g  to o lb a r s

Each toolbar has a default set o f  buttons that are appropriate to the toolbar's overall purpose. Y ou can  
custom ize a toolbar by rearranging its buttons, adding buttons for other functions, or rem oving buttons you  
don't need.

To move a button on a toolbar
•  W hile holding dow n the Alt key, drag the button to another location on the toolbar.

To move a button from one toolbar to another toolbar
•  W hile holding dow n the Alt key, drag the button o f f  the first toolbar and drop it on the second  

toolbar.

To add a button to a toolbar
1. On the View m enu, point to Toolbars, and click  Customize.

2. Click the Buttons tab.

3. Under C ategories, click the category containing the comm and (button) you want to add.

4. Under C om m ands, choose the com m and you want to add and drag it to the desired toolbar.

5. W hen you are finished adding buttons, c lick  C lose.

To remove a button from a toolbar
•  W hile holding dow n the Alt key, drag the button o f f  the toolbar and drop it anywhere except on  

another toolbar.

To restore a toolbar’s default set of buttons
1. On the View m enu, point to Toolbars, and click  Customize.

2. Under Toolbars, click  the name o f  the toolbar you want to reset.
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3. C lick R eset. (Or click  R eset All to reset all toolbars.)

0  You cannot customize the Shortcut Bar.

C reatin g  n e w  to o lb a r s

Y ou can create a new , custom  toolbar containing exactly the buttons you want.

To create a new toolbar
1. On the View menu, point to Toolbars, and click C ustom ize.

2. C lick New.

3. T ype a nam e for the new  toolbar and click  OK. A new , empty toolbar w ill appear at the bottom  o f  
the toolbar dock.

4. C lick the Buttons tab.

5. Under C ategories, click a category containing a comm and (button) you want to add to the new  
toolbar.

6. Under C om m ands, choose a com m and to add and drag it to the new  toolbar.

7. Repeat steps 5 and 6 for each button you want to add to the new  toolbar.

8. W hen you are finished adding buttons, click C lose.

To remove a custom toolbar
1. On the View m enu, point to Toolbars, and click Custom ize.

2. Under Toolbars, click  the name o f  the toolbar you want to rem ove.

3. C lick D elete.

T h e  I n s p e c t o r  a n d  o t h e r  t o o l  p a n e l s

A b ou t to o l p a n e ls

At the bottom and right side o f  the main w indow  are tw o areas that contain various tool panels. T hese tool

panels are initially v isib le . To reveal them , click  (Show/H ide P anels) on the Shortcut Bar (p.36) or press 
Ctrl+/. Y ou can also reveal just the bottom  panel area or just the right panel area by clicking the row or 
colum n o f  dots in the m iddle o f  the appropriate border o f  the main w indow . C lick the dots again to hide 
that set o f  panels. To resize the bottom panel area, drag its top border. To resize the right panel area, drag 
its left border.
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HTML (F6) A Preview /  H
--------------------------------------------------------

Revealing the bottom tool panel area

The bottom panel area contains four too l panels: the Inspector and the T ag S e le c t o r  (p.40), w hich  are 
initially visible; and the T im eline and R esu lts panels, w hich are initially hidden.

The right panel area contains four m ore tool panels: the Form atting panel (p.227), the A ctions panel, and 
the S ite  Library panel, w hich are in itially  visible; and the Layers panel, w hich is initially hidden.

W hen a tool panel is hidden (w hile the panel area that contains it is v isib le), an icon representing the panel 
appears at the bottom o f  its hom e area. ( I f  there is enough room, the panel’s name also appears.) To reveal 
the panel, click  its icon according to the table below , or, on the View menu, point to P anels, and then click  
the name o f  the panel you want to reveal.

Icon P anel
Inspector

o Tag S e lecto r

0 T im eline

E Results

-A Form atting

A ctions

3 Site Library

m Layers

To hide a single tool panel, click  the C lo se  box at the right end o f  the panel's title bar. W hen all the panels 
in a panel area are hidden, the area co llap ses to its border only.

Y ou can rearrange the visib le panels in  a panel area by dragging one panel and dropping it above or below  
another. (To drag a panel, click and drag its title bar.) H ow ever, you  cannot m ove a panel from  its hom e  
area to the other panel area.

You can "undock" a tool panel b y  dragging it com pletely aw ay from its hom e area. A n undocked panel 
"floats" on top o f  other w indow s. To dock  it again, drag it back to its hom e area.

W h a t th e  to o l p a n e ls  d o

Insp ector

The Inspector provides a quick  w ay to v iew  and m odify the properties (HTML attributes) o f  the 
current elem ent in the current docum ent, without having to open a dialog box. The controls in the 
Inspector vary depending on w hat kind o f  elem ent is currently selected.
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Tag Selector
The Tag S e lec to r  displays the HTM L tags surrounding the insertion point. C licking a tag in the 
Tag Selector selects the page elem ent corresponding to it. (See The Tag Selector, p .40.)

Timeline
U se the T im elin e  panel to create a timeline— a kind o f  animation that uses layers and JavaScript to 
m ove page elem ents over time. (S ee  Creating tim elines, p .3 16.)

Results
The R esults panel displays the results o f  the Verify HTML comm and. (See Validating source code, 
p.508.)

Formatting
U se the Form atting panel to quickly apply standard and custom  styles (p.212) to selected elem ents. 
(S ee  U sing the Formatting panel, p .227.)

Actions
The Actions panel lists the Javascript actions (p.304) that have been attached to the current elem ent, 
and lets you attach n ew  actions. (S ee  W orking w ith actions and events, p .304.)

Site Library
U se the Site Library panel to insert and m anage various resources that are com m on to the entire 
site to w hich the current docum ent belongs. (See U sing the site library, p .377.)

Layers
The Layers panel lists any layers (p.l 11) that exist in the current docum ent, and lets you m anage 
them. (See U sin g  the Layers w indow , p .l 19.)

T h e  T a g  S e l e c t o r

The Tag Selector is one o f  the tool panels (p.3 8) available in the bottom  panel area o f  the main w indow . It 
displays the HTML tags surrounding the insertion point or current selection. T he Tag Selector provides 
several useful functions:

•  It identifies the type o f  elem ent in w hich  the insertion point is located and the types o f  that 
elem ent’s ’’ancestor’’ elem ents.

•  B y  clicking a tag in the Tag Selector, you can select an elem ent that m ay be difficult or im possible  
to select directly in  the docum ent w indow .
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B y right-clicking a tag in the Tag Selector, you can quickly execute a com m only-used comm and  
on the corresponding elem ent.

auguc uiguiddiiu шсш*. п и ш  эсшр
гШатсогрег D

T ir r y E d it /“ Editée HTML A HTML (Fl

J <> Teg Selector
<body> <p> <span. special > < a >

t3 Timeline |T) Result!
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ÿtew Soiree
эЫта

Style...

properties.,
Right-clicking a tag in the Tag Selector

0  I f  an element identified in the Tag Selector belongs to a class (p.213), the class name appears inside the 
tag, preceded by a period . For example, i f  the insertion point is in a paragraph (<p> element) whose 
class is "blurb"\ then the paragraph will appear as <p.blurb> in the Tag Selector.

To s h o w  or h id e  t h e  T ag  S e le c to r

•  D o one o f  the follow ing:

o  O n the View menu, point to Panels, and then click  Tag Selector, 

o  Press A lt+5.

C o m m a n d s in  t h e  T ag  S e le c to r 's  sh o r tc u t  m e n u

R ight-click a tag in the Tag Selector to execute any o f  the fo llow ing  com m ands that appear in the shortcut 
m enu. (D epending on the elem ent, som e o f  the com m ands may not be available.)

•  R em ove Tag: D elete the entire elem ent associated with the tag

•  View Source: Sw itches to HTM L m ode and highlights the associated elem ent

•  Style: O pens the Style dialog box for the associated elem ent

•  Properties: O pens the P roperties dialog box for the associated elem ent

R e la te d  to p ic s

The Inspector and other tool panels.................................................................... p.38
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T h e  s t a t u s  b a r

The status bar, at the bottom o f  N am o W ebEditor's main w indow , displays useful information regarding 
the working environm ent.

!.............  !
i j i 1
L... . _ J

ut mauris. Cras omar>r | 
nonummy vulputate. ,v ¡

< | Í ft Edit A Edit íc HTML A HTML (F6) A Ptev
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The status bar (shown with collapsed bottom tool panel)

W hen the m ouse pointer is over a menu com m and or toolbar button, the left side o f  the status bar displays a
brief description o f  the com m and or button.

The right side o f  the status bar contains four inset areas that display various kinds o f  status information.
From left to right, these areas show:

•  The m odification state o f  the current docum ent. I f the docum ent has been m odified since you  last 
saved it, the word Modified appears here.

•  The typing m ode. In the default Insert m ode, w hatever you type "pushes" existing text on the right 
side o f  the insertion point further right to make room  for the new  text. In Overwrite m ode, 
w hatever you type overwrites ex isting text on the right side o f  the insertion point. (To change the 
typing m ode, press the Insert key. B y  default, how ever, the typing m ode is locked in Insert m ode. 
To unlock it, on the T ools menu, c lick  P references, click  the Edit tab, and then clear the Lock 
Insert key check box.)

•  The write status o f  the current docum ent. I f  the current docum ent is read-only (m eaning changes 
cannot be saved), the phrase Read-Only appears here.

•  The current page number. W hen the current docum ent w indow  is in page layout m ode, this area 
displays the number o f  the page w here the insertion point is currently located.

To h id e  or  r e v e a l t h e  s t a t u s  bar

•  On the View menu, point to Toolbars, and click  Status Bar.

R e la ted  to p ic s

The Tag Selector............................................................................................................ p.40

42 The visual authoring environment



Chapter 2: Namo WebEditor Fundamentals

R u l e r s ,  l a y o u t  g u i d e s ,  a n d  l a y o u t  g r i d s

N am o W ebEditor’s visual authoring environm ent includes three optional design aids that can help you  lay  
out W eb docum ents m ore precisely. T hese are rulers, layout guides, and layout grids.

Rulers, guides, and grid 

U sin g  ru ler s

W hen you need to know  exactly how  b ig  or how  far apart various page elem ents are, you can turn on  the

distances in pixel units. To show  or hide both rulers: on the View menu, point to Rulers, and click Show  All 
(or press Shift+A lt+R ). Y ou can also show  or hide the horizontal and vertical rulers independently. N ote  
that show ing or hiding rulers applies to all open docum ent w indow s.

U sin g  la y o u t  g u id e s

A  layout guide is a thin, horizontal or vertical line that you can place across a docum ent w indow  to help  
align page elem ents. T he guide is not a part o f  the document and does not appear in a brow ser or in 
Preview  m ode. W hen the Snap option is enabled, the edges o f  layers (p.l 11) "snap” to layout guides, 
m aking it easier to position  or align the layers. In a table (p. 182), cell borders also snap to layout guides 
w hen you resize cells by dragging their borders.

•  To create a layout guide, c lick  anywhere within the horizontal or vertical ruler and drag dow n or to 
the right. W hen the dotted line is at the desired position, release the m ouse button, and the guide  
w ill appear.

•  To m ove a gu ide, click and drag it to  the desired position.

•  To remove a guide, drag it back to the ruler. To remove all guides, on the View m enu, point to 
G uides, and click  Clear All.

•  To hide all gu ides, on the View m enu, point to G uides, and click Show. U se the sam e com m and to 
reveal hidden guides.

•  To lock all gu ides in place so that they cannot be m oved, on the View menu, point to G uides, and 
click  Lock.

, o _

display o f  rulers in docum ent w indow s. A horizontal ruler and a vertical ruler are available, both show ing
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•  To enable or disable snapping to guides, on the View menu, point to Guides, and click Snap.

•  To change the color and/or line style o f  all guides, do the follow ing:

o  O n the View m enu, point to G uides, and click  Settings, 

o  Under Guides, click  the Color box and select a color (p.233). 

o  T o change the line style, click Solid or D ashed.

U sin g  a  la y o u t grid

A  layout grid is com posed o f  thin, horizontal and vertical lines that run across a docum ent w indow  at 
regular intervals. A  layout grid can help you  align and distribute page elem ents more easily  and precisely. 
The grid is not a part o f  the docum ent and does not appear in a browser or in Preview  m ode. Y ou can adjust 
the spacing betw een grid lines— the default spacing is 50 p ixels. W hen the Snap option is enabled, the 
edges o f  layers (p.l 11) ’’snap” to grid lines, making it easier to position or align the layers. In a table (p. 182), 
cell borders also snap to grid lines w hen you  resize ce lls  by dragging their borders. B etw een grid lines there 
are invisible subdividers, to w hich layers and cell borders also snap.

•  To show  or hide the layout grid for the current docum ent, on the View menu, point to Grid, and 
click Show .

•  To enable or disable snapping to grid lines and subdividers, on the View menu, point to Grid, and 
click  Snap.

•  To change the spacing betw een grid lines and/or invisib le subdividers, do the follow ing:

o  On the View menu, point to Grid, and click  Settings, 

o  In the Grid spacing box, enter the desired space betw een grid lines, in pixels, 

o  In the Subdivisions box, enter the desired space betw een subdividers, in pixels.

•  To change the color and/or line sty le  o f  the layout grid, do the follow ing:

o  O n the View m enu, point to Grid, and c lick  Settings.

o  U nder Grid, c lick  the Color box and select any color, or click  the Standard colors box and 
select one o f  the standard colors.

o  T o change the line style, click  Solid or D ashed.

S p e c i a l  m a r k s  i n  E d i t  m o d e

B y default, N am o W ebEditor displays various kinds o f  special "marks" in document w indow s that are in 
Edit m ode. T hese marks, w hich are not part o f  a docum ent and do not appear in a browser or in Preview  
m ode, help to v isually  identify and locate various kinds o f  page elem ents or parts. Y ou can enable or 
disable the display o f  any o f  these marks in the View menu. The most com m on marks are listed in the table 
below . (Note: space marks are not show n b y  default.)
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Mark

u

p

c?

I T

Name
Paragraph Mark 

Line Break Mark 

Space Mark

List B egin Mark 

Bookmark Mark 

Layer Mark 

Floating B ox Mark 

Table Gridlines 

Current Table Outline 

Layer Outline

Description
A  backwards "P" with tw o vertical bars indicates the end o f  a paragraph.

A  carriage return sym bol indicates the location o f  a manual line break.

A  gray dot indicates a space character. A  red dot indicates a non-breaking  
space.

A  red arrow indicates the beginning o f  a numbered or bulleted list.

A  ye llow  bookmark icon indicates the position o f  a bookmark.

A  ye llow  layer icon indicates the position o f  a layer tag.

A  y e llow  floating box icon indicates a floating box.

D ashed lines indicate the borders o f  cells in tables with invisib le borders. 

A  solid  blue outline indicates the table containing the insertion point.

A  solid  gray outline indicates the edges o f  a layer or floating box.

To h id e  or s h o w  s p e c ia l m a rk s

• On the View menu, point to Marks, and click the item corresponding to the type o f  mark you  want 
to hide or show . (The Special Tag Marks item controls list begin marks, layer marks, and other 
yellow  icons for special elem ents.)

O You can also toggle the display o f paragraph marks, space marks, table gridlines, and special tag 
marks by clicking the appropriately-named buttons on the Standard Toolbar.

3  Special tag marks, with the exception o f  list begin marks, take up space in Edit mode. As a result, they 
can decrease the accuracy with which a document is rendered in Edit mode.

T h e  R e s o u r c e  M a n a g e r

In W eb authoring term inology, resources are various kinds o f  files that you can use in a docum ent. Im ages 
and m ovie clips are w ell-know n types o f  resources, but there are many other kinds as w ell. A  com m on  
characteristic o f  resources is that they can be collected  and then reused in many docum ents.

N am o W ebEditor com es with a library o f  ready-m ade resources that you can use in your docum ents. Y ou  
access these resources through the Resource Manager. Y ou can also organize resources and add your own  
resources to the library using the R esource Manager. To open the Resource Manager, on the W indow menu, 
click R esource Manager.
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The Templates tab of the Resource Manager

The Resource M anager has six  tabs, corresponding to six kinds o f  resources: T em plates, Clip Art, Color 
Sets , Smart ClipArt, Flash Buttons, and T hem es. Under each tab you w ill see a list o f  categories (folders), a 
pane displaying the resources in the selected category, and several com m and buttons. The Import,
Download More, and C lose buttons are com m on to all tabs, w hile other buttons vary depending on the 
selected tab. Each tab also  has its ow n shortcut m enu that appears w hen you right-click a resource.

The contents and special com m ands in each tab are described below .

T he T e m p la te s  ta b

This tab includes tem plates for w hole docum ents and insertable docum ent sections.

•  To create a new  document based on the selected  tem plate, c lick  New Document.

•  To insert a section  based on the selected tem plate into the current document, click Insert.

•  Y ou can designate one tem plate as the default tem plate for new  docum ents that you create by  

pressing Ctrl+N or click ing Q  (N ew ) on the Standard Toolbar. To do so, right-click the desired  
template and then click  S e t a s  Default Template.

•  You can m od ify  the title and/or description o f  a tem plate by right-clicking it and then click ing  
Properties.

T he Clip Art ta b

This tab includes a w id e variety o f  bitmapped (GIF and JPG) im ages that you can use in your docum ents, 
including background textures, buttons, banners, and so forth.
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•  To insert a clip  art im age into the curent document, select it and click Insert. To use the selected  
im age as the docum ent’s background im age, click  Insert a s  Background.

•  Y ou  can filter the im ages show n in the resource pane by file  type. C lick the file type b ox  b e low  
the category pane and select an item to v iew  on ly  GIF im ages, only JPEG im ages, o n ly  PNG  
im ages, or all im ages.

T h e C olor S e t s  ta b

This tab contains color sets, w hich  are sets o f  com plem entary colors that are designed to be used  together in 
a docum ent or site.

•  To make a color set available for use in your docum ents, select it and click Insert Color Set. The 
color set w ill then be available in any docum ent w hen you click the color set menu on  the C olor 
Palette (p.233).

•  Y ou  can add any individual color in a color set to the Custom  Colors group in the C olor Palette 
(p.233). To do so, right-click a color and click Add to Custom Colors. (N ote that the Custom  Colors 
group can hold a m axim um  o f  36 colors. I f  you add more than this number, the oldest ones are 
dropped to make room .)

•  To add a new  color to a color set, right-click the color table, click New Color, and then select a 
color in the C olor Picker (p.234).

•  To change a color in a color set, right-click it and click Edit Color.

•  T o delete a color, right-click it and click  D elete.

T h e S m a r t ClipArt ta b

This tab contains a library o f  vector-based clip  art in the Smart ClipArt (.tng) format. Y ou can use Smart 
ClipArt in the same w ays as ordinary, bitmapped clip art, but w ith the added advantage that y o u  can resize 
or edit a Smart ClipArt im age w ithout loss o f  sharpness or information.

•  T o insert a Smart ClipArt im age into the curent document, select it and click Insert. Y ou  cannot 
use Smart ClipArt as docum ent background im ages.

•  Y ou  can edit a Smart ClipArt im age from within the R esource Manager. R ight-click an im age and 
click  Modify. The im age w ill open in the Smart ClipArt Editor (p.259). N ote that any changes you  
m ake to a Smart ClipArt item  from w ithin the R esource M anager are permanent. I f  you  do not 
w ant to permanently m odify  a Smart ClipArt im age, you can m odify a copy o f  it by  right-clicking  
the im age and click ing Modify As N ew.

0  The Smart ClipArt Editor is not available if  you do not have Namo WebCanvas installed. I f  Namo
WebCanvas was not included in your Namo WebEditor 6 package, it must be purchased separately
and installed to enable the Smart ClipArt Editor.

T h e  F la sh  B u tto n s  ta b

Flash Buttons are animated, vector-based im ages created in M acrom edia’s Flash (.sw f) format. This tab 
contains a number o f  predesigned Flash Buttons meant to be used as buttons and banners.
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4. In the resource pane, find the new  tem plate you just created. (It w ill have the title "No T itle”.)

5. R ight-click the thumbnail preview  and click  Properties.

6. In the Title box, type a title for the template. I f  you  want to add a description, type it in the 
Description box. C lick OK.

9  You can also add a document to the template library by dragging an HTML or MHTML fd e  to the 
Resource Manager from Windows Explorer.

A dd ing  c lip  a r t

Y ou can add any GIF, JPG, or PNG im age to the clip  art library.

1. On the Window m enu, click R esource Manager, and then click the Clip Art tab.

2. Select the category (folder) in w hich you want to put the im age, and then click  Import.

3. N avigate to the folder containing the desired im age, select the GIF, JPG, or PNG im age file, and 
click O pen.

Q  You can also add an image to the clip art library by dragging a GIF, JPG, or PNG fd e  to the Resource 
Manager from Windows Explorer.

A d d in g  S m a rt C lipArt

Y ou can add your ow n  Smart ClipArt (.tng) im ages, and Smart Button (.npi) im ages from pre-5.0 versions 
o f  N am o W ebEditor, to the Smart ClipArt library.

1. On the W indow m enu, click  R esource M anager, and then click the Smart ClipArt tab.

2. Select the category (folder) in w hich you want to put the im age, and then click  Import.

3. N avigate to  the folder containing the desired im age, select the TNG or NPI im age file, and click  
Open.

9  You can also add an image to the Smart ClipArt library by dragging a TNG or NPI fd e  to the Resource 
Manager from Windows Explorer.

A dding F lash  B u tto n s

Y ou can add your ow n  Flash (.sw f) anim ations to the Flash Button library.

1. On the W indow m enu, click R esource M anager, and then click  the Flash Button tab.

2. Select the category (folder) in w hich you want to put the Flash anim ation, and then click Import.

3. N avigate to  the folder containing the Flash (.sw f) file, select it, and click  Open.

9  You can also add a Flash animation to the Flash Button library by dragging an SWFfde to the 
Resource Manager from Windows Explorer.
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A d d in g  th e m e s

Y ou can add a new  or m odified them e that you  have received from another N am o W ebEditor user to the 
them e library.

1. On the Window menu, c lick  R esource M anager, and then click  the T hem es tab.

2. Select the category (folder) in w hich you want to put the theme, and then click  Import.

3. N avigate to the folder containing the theme (.ntc) file , select it, and click  O pen.

You can also add a theme to the theme library by dragging an NTCfde to the Resource Manager from  
Windows Explorer.

A d d in g  r e so u r c e s  from  a z ip  a r c h iv e

Other N am o W ebEditor users can send (p.52) you (or you can send yourself) a zip  archive containing one or 
more resources. To add the resources from such a zip file  to the resource library, do this:

1. On the Window menu, c lick  R esource Manager.

2. C lick the tab corresponding to the type o f  resource in the zip archive.

3. Select the category (folder) in w hich you want to save the new  resources, and then click  Import.

4. C lick the Files of type b ox  and select Zip Files.

5. N avigate to the folder containing the zip (.zip) file , select it, and click  Open.

A ll resources o f  the appropriate type found in the zip archive w ill be added in a new  subcategory o f  the 
category you selected. The nam e o f  the subcategory w ill be the sam e as the name o f  the category or 
subcategory from w hich the other user exported the resources.

D o w n lo a d in g  n e w  r e s o u r c e s  fro m  th e  In te r n e t

From tim e to tim e, Sejoong N am o Interactive m ay m ake available new  clip  art, them es, and other resources 
on its W eb site for free dow nload by registered N am o W ebEditor users. To check i f  new  resources are 
available and download them , do the follow ing:

1. On the Window menu, c lick  R esource Manager.

2. Click the tab corresponding to the type o f  resource you want to dow nload.

3. Select the category (folder) in w hich  you want to save the new  resources, and then click Download  
More.

Y our browser w ill open and go to Sejoong N am o Interactivefs resource dow nload page. F ollow  the 
instructions on that page to v iew  and dow nload any new  resources that m ight be available.

R e la te d  to p ic s

Sharing resources with other peop le................................................................... p.52
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S h a r i n g  r e s o u r c e s  w i t h  o t h e r  p e o p l e

I f  you work with other N am o W ebEditor users in a team, it can be useful to share with them  resources that 
you’ve created. Or, you might need to copy your custom  resources from the computer on w hich you created 
them to another computer on w hich  you use N am o W ebEditor. U sing the R esource M anager’s Zip & E-Mail 
and Import com m ands, you can send resources to other people (or yourself) as com pressed e-m ail 
attachments and add resources other people have sent you to your resource library.

0  When you send resources, all the resources in the category or subcategory you select are copied to the 
zip archive. I f  you only want to send some o f  the resources in the selected category, open the zip 
archive and delete the unwanted resources.

To z ip  a n d  e -m a il r e s o u r c e s

1. On the Window menu, c lick  R esource Manager.

2. C lick the tab corresponding to the type o f  resource you want to send.

3. R ight-click the category (folder) containing the resources you want to send, and then click Zip & E- 
Mail.

N am o W ebEditor w ill create a temporary zip archive containing the selected resources, and a new  m essage  
w indow  w ill open in your default e-m ail program. The zip archive w ill be autom atically attached. N o w  you  
can specify  the recipient(s), enter a subject line, and send the e-m ail.

I f  you ju st want to create a zip archive containing resources, without e-mailing it, right-click the 
desired category and click Zip. You will be prompted fo r  the location in which to save the zip archive.

To ad d  r e s o u r c e s  fro m  a z ip  a r c h iv e

1. On the W indow menu, click  R esource Manager.

2 . C lick the tab corresponding to the type o f  resource you want to send.

3. Select a category (folder). The new  resources w ill be saved into a new  subfolder o f  the selected  
folder.

4. C lick the Import button.

5. C lick the Files of type box and select Zip Files.

6. Locate and select the zip  archive containing the resources to be added, and then click  Open. 

R ela ted  to p ic s

Adding resources to the resource library............................................................ p.49
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P r e f e r e n c e s  a n d  s e t t i n g s

Y ou can configure many aspects o f  N am o W ebEditor's interface and behavior in the P re feren ces d ialog  
box. Other interface settings are controlled through the View menu.

In th is  s e c t io n

Setting image display options...............................................................................p.53
Setting the default display fonts for Edit m ode................................................. p.54
Specifying default colors and character set for new documents.................... p.55

Configuring editing preferences........................................................................... p.56
Configuring file saving and backup settings......................................................p.58

R e la ted  to p ic s

Toolbars and the Shortcut Bar............................................................................... p.36
The Inspector and other tool panels.....................................................................p.38
Rulers, layout guides, and layout grids...............................................................p.43

Special marks in Edit mode....................................................................................p.44

S e t t i n g  i m a g e  d i s p l a y  o p t i o n s

To h id e  a ll im a g e s  in  Edit m o d e

•  On the View menu, point to Image, and click View Im ages.

To h id e  d o c u m e n t b a ck g ro u n d  im a g e s  in Edit m o d e

•  On the View menu, point to Image, and click View Background Im ages.

0  This command does not affect the display o f  background images o f  tables, table cells, layers, floating 
boxes, and other containers.

To s to p  GIF a n im a tio n s  in Edit m o d e

•  On the View menu, point to Image, and click View GIF Animations.

CE) This command does not hide animated GIF images. It only stops the animations from running.
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R ela ted  to p ic s

Images.........................................................................................................................p. 137

S e t t i n g  t h e  d e f a u l t  d i s p l a y  f o n t s  f o r  E d i t  m o d e

W hen you have text in a docum ent to w hich you have not applied a specific font, N am o W ebEditor 
displays the text in one o f  the default fonts specified  in the P referen ces dialog box. There are tw o default 
fonts: a proportional font, used  for m ost text, and a fixed-width font, used for <pre> and < code>  elem ents. 
Initially, these default fonts are set to 12pt T im es N ew  Roman and lOpt Courier N ew , respectively, but you  
can change them to w hatever font and size you w ish.

It is important to realize that the default display fonts only apply in N am o WebEditor's Edit m ode. W hen a 
document that contains text w ith no specified font is v iew ed  in a browser, the browser w ill display the text 
in its ow n default font, w hich  m ay not be the sam e as N am o W ebEditor’s default font. I f  you want to make 
sure the text you see in Edit m ode uses the sam e font as it w ill in a browser, you need to apply a specific  
font to it— either through the Font comm and on the Format m enu or by applying a style (p.210).

To s e t  th e  d e fa u lt  d isp la y  fo n t s  for  Edit m o d e

1. On the T ools menu, click  Preferences, and then click  the Docum ent Defaults tab.

2. Under Character se t  and fonts, do one or both o f  the follow ing:

o  C lick the Proportional font box and choose a font. Then click the size box and choose a 
point size.

o  C lick the Fixed-width font box and choose a font. Then click the size box and choose a 
point size.

3. C lick OK.

R e la ted  to p ic s

About formatting and styles................................................................................... p.210
Setting character-related properties.......... .......................................................... p.219
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S p e c i f y i n g  d e f a u l t  c o l o r s  a n d  c h a r a c t e r  s e t  f o r  n e w  

d o c u m e n t s

S p e c ify in g  d e fa u lt  c o lo r s

In the P referen ces dialog box, you can specify  the default colors that new  docum ents w ill use for various 
item s, including:

•  ordinary text

•  the docum ent background

•  unvisited hyperlinks

•  visited hyperlinks

•  "active" hyperlinks (a hyperlink is "active" w hen the m ouse pointer is over it)

T o sp e c ify  d e fa u lt  c o lo r s  for  n e w  d o c u m e n ts

1. On the T ools menu, click  P references, and then click the Docum ent Defaults tab.

2. Under Colors, click  the co lor  box for any desired item and select a color (p.233).

Y ou can override any o f  these default colors either on the document level— by specifying different colors 
for the current docum ent in the A ppearance tab o f  the D ocum ent P roperties dialog box— or on the elem ent 
level, by applying a different color to selected  content.

S p e c ify in g  a d e fa u lt  c h a r a c te r  s e t

I f  you use a particular character set (p.238) for m ost o f  your docum ents, you  can save tim e by specify ing  it 
as the default character set for n ew  docum ents. Initially, the default character set is set to user-defined, 
m eaning unspecified, so new  docum ents w ill not use any specific character set. But i f  you  set the default to, 
for exam ple, U nicode (UTF-8), then new  docum ents w ill autom atically use the U nicode character set.

O f course, i f  you specify  a default character set, you can still override that setting by specify ing a different 
character set for a particular docum ent in the General tab o f  the D ocum ent P roperties d ialog box.

To sp e c ify  t h e  d e fa u lt  c h a r a c te r  s e t  fo r  n e w  d o c u m e n ts

1. On the T ools menu, click  Preferences, and then click  the Docum ent Defaults tab.

2. C lick the Character se t b ox  and select a character set.

R e la ted  to p ic s

Selecting colors........................................................................................................p.233
Setting default colors for the current document................................................p .241

Setting character-related properties......................................................................p.219

Setting background colors and im ages................................................................p.225
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Setting hyperlink colors..........................................................................................p. 174
Specifying a character set for the current document.........................................p.238

C o n f i g u r i n g  e d i t i n g  p r e f e r e n c e s

U se the Edit tab o f  the P re feren ces  dialog box to configure various settings and behaviors that apply  
w henever you work in Edit m ode.

G en era l s e t t in g s

L oad m o st r e c e n t d o c u m e n ts  a t startup

I f  this check  box is selected, the docum ents that are still open w hen you next quit N am o  
W ebEditor w ill be autom atically opened again w hen you next start it. I f  it is deselected, N am o  
W ebEditor w ill open w ith a new , blank document.

D isp lay  actu a l fo n ts  in font m en u

I f  this check  box is selected , the Font menu on the Formatting Toolbar w ill display font nam es in 
the actual font faces they correspond to.

Lock Insert k ey

I f  this check  box is selected , pressing the Insert key on the keyboard w ill have no effect. I f  it is 
deselected, pressing the Insert key w ill toggle insert/overwrite m ode. (S ee  Inserting text, p .70.)

A utom atic  link crea tio n

I f  this check box is selected , N am o W ebEditor w ill autom atically create a hyperlink w hen you  
type certain kinds o f  U R L s in Edit m ode. This feature works w ith the fo llow ing  kinds o f  URLs:

•  URLs that start w ith  "www" and have at least tw o dots
•  U RLs that start w ith  "http://”, "https://", "ftp://", "file://", "gopher://", "nntp://", or "wais://".
•  e-m ail addresses, such as "jason@ nam o.com "

N ote that the link w ill not be created until you press either the space bar or the E nter key after the 
URL.

C op y  form atting of tex t o n  left s id e  o f cu rsor  w h e n  typing

I f  this check  box is selected , w hen you insert text im m ediately (w ithout any intervening spaces) to 
the left or the right o f  existing text to w hich character-level formatting (p.219) has been applied, 
the new  text w ill "pick up" the formatting from the existing text. I f  it is deselected, the new  text
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w ill have the default character formatting o f  the paragraph. N ote that text you insert in the middle 
o f  character-formatted text ahvays p icks up the existing formatting.

Clip art fo lder

This setting specifies the location o f  the folder containing N am o WebEditor's clip art library 
(p. 143). I f  no location is specified , N am o W ebEditor w ill look in the default location, w hich  is a 
subfolder o f  the N am o W ebEditor installation folder. H ow ever, i f  you chose not to install the clip  
art library w hen you installed N am o W ebEditor, this folder w ill be empty. In that case, you  can 
specify  the location o f  the clip art folder on the N am o W ebEditor installation C D-R O M  ( i f  you  
have one).

M od e s e t t in g s

O p en  d o c u m e n ts  in

Select the default m ode in w hich to open docum ents. I f  you  select S am e m ode a s  current 
document, N am o W ebEditor w ill open the next docum ent in whatever m ode you are using to edit 
the document that is active at the tim e you open or create the new  document.

T op  p a n e  in s im u lta n e o u s  m o d e

This setting determ ines w hether the Edit pane or the HTM L pane w ill be on top w hen Edit & 
HTM L m ode is active.

S p e ll c h e c k  s e t t in g s

C h eck  sp e llin g  a s  y o u  ty p e

If this check box is selected , N am o W ebEditor w ill h ighlight m isspelled words w ith  w avy red 
underlines as you type in Edit m ode.

H ide sp e llin g  errors

This option is only available i f  C heck spelling a s  you type is enabled. I f  this check box is selected, 
N am o W ebEditor w ill still check your spelling as you type in Edit m ode, but m isspelled  w ords 
w ill not be highlighted.

S p e llin g  dictionary 1

Select the primary language for spell checking.

S p ellin g  d ictionary 2

Select the secondary language for spell checking.
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C o n f i g u r i n g  f i l e  s a v i n g  a n d  b a c k u p  s e t t i n g s

Use the Save tab o f the Preferences dialog box to configure settings related to saving and backup up files. 

Make backups
If this check box is selected, whenever you resave a document, Namo WebEditor will rename the 
old version with a ".bak" file name extension instead of simply overwriting it with the new version. 
Thus, you can "undo" the saved changes in the latest version of a document by changing the 
backup file's extension to ".html" and opening it.

Autosave interval
If this check box is selected, Namo WebEditor will automatically save all open, modified 
documents at regular intervals of the specified length. Note that Namo WebEditor does not 
autosave to the original file but rather to a copy with a ".asv" file name extension in the same 
folder. If your computer crashes or Namo WebEditor unexpectedly quits for any reason while you 
have modified documents open, you may be able to recover some or all of your lost work by 
changing the autosave file's ".asv" extension to ".html" and opening it.

Save Smart ClipArt, equation, and chart images in
Specifies the path o f  the folder in which Nam o W ebEditor will save the bitm apped images it 
generates from  Smart C lipA rt (p.258) images, charts (p.484), and equations. The default path, 
"images", m eans that these bitm apped images will be saved in an "images" subfolder o f  the 
docum ent's folder. I f  you want, you can specify a different path relative to the docum ent's folder, 
such as "../bitmaps". The new  path will be used the next tim e you save a docum ent that contains 
Smart C lipArt, charts, or equations.
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W o r k i n g  w i t h  d o c u m e n t s

Web documents, like most other documents you work with on your computer, are stored as files on your 
hard disk or other mass-storage device. This section covers the various commands in Namo WebEditor that 
deal with basic file-oriented aspects of authoring for the Web, such as creating, saving, and printing 
documents.

In th is section

Creating new documents.............................................................................. p.59
Opening documents...................................................................................... p.60
Previewing documents..................................................................................p.61
Saving documents.........................................................................................p.62
Exporting a document to MHTML.............................................................. p.63
Saving a document as a template................................................................. p.64
Moving and renaming resource files............................................................p.64
Viewing transfer information....................................................................... p.65
Printing documents...................................................................................... p.66

Related topics

Document properties.................................................................................... p.236

C r e a t i n g  n e w  d o c u m e n t s

To crea te  a new  docum ent using the  default tem plate

• Do one of the following:

o Click □  (New) on the Standard Toolbar, 
o Press Ctrl+N.

GO By default, the default template is a completely empty document. You can designate a different template 
as the default template in the Tem plates (p .46) tab o f the Resource Manager.

To create  a new  docum ent using a tem plate

1. On the File menu, click New.
2. In the folder list on the left, click a template category.
3. In the preview area, click a template, and then click OK.
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Opening documents

To open a docum ent on th e  local file system

1. Do one of the following:
o On the File menu, click Open.

o Click Q  (Open) on the Standard Toolbar.
2. Find the file you want to open, select it, and then click Open.

9  You can open multiple files at the same time. In the Open dialog box, click each fde you want to open 
while holding down the C trl key, and then click Open:

9 To quickly open one o f the last ten documents you have opened recently, on the Fife menu, point to 
Recent Files, and then click the item corresponding to the fde you want to open.

To open a docum ent on th e  Web

1. Do one of the following:
o On the File menu, click Open.

o Click €3 (Open) on the Standard Toolbar.
2. In the URL box, enter the URL of the Web document you want to open, and click Open URL.

To open a docum ent directly from a rem ote site

A remote site is a folder on a Web server that contains a Web site you have published. You can open a 
document on a remote site directly, instead of downloading it first and then opening the local copy. For 
more information about remote sites, see Defining remote sites for publishing, p.388.

1. On the File menu, click Open on Web Server.
2. In the Remote site box, dick the remote site that has the document you want to open.
3. Select the desired document and click Open.

To open the  docum ent currently  open in a Web brow ser

• On the File menu, point to Import, and then click the item corresponding to the browser that is 
showing the document you want to open.

0  By default, Namo WebEditor is set up so that you can import an open document from Internet Explorer 
or Netscape. You can change the browsers from which you can import by editing the settings in the 
Browsers tab o f the Preferences dialog box. The first two browsers in the list are the ones you can 
import from.
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Previewing documents

Although Namo WebEditor tries to display documents in Edit mode as closely as possible to the way they 
will appear in a Web browser, it’s not perfect. That’s why it provides two ways to preview most documents 
as they would actually appear on the Web.

Namo WebEditor's built-in preview mode uses Internet Explorer's rendering engine to render HTML, so it 
can display a document almost exactly as the version of Internet Explorer you have installed on your 
computer would. However, it does have some limitations: it can only emulate the particular version of IE 
you have installed, and even so, there can be some minor visual differences from IE itself due to operating 
system and IE service pack issues.

For the most realistic previews, use Namo WebEditor's View with commands to view documents in an 
actual Web browser installed on your computer. You can set up up to five different browsers with which to 
view documents, two of which are accessible with shortcut keys. Using a View with command is a much 
more reliable way to preview how a document will appear in a non-Microsoft browser, such as Mozilla or 
Opera, than using the built-in preview mode.

£ 3  Some kinds o f Web content cannot be previewed reliably without actually uploading the document to a 
Web server and viewing it through the Web. This includes most content that uses a server-side script 
(such as ASP or PHP) or server side includes (SSI). However, you can use Namo WebEditor's built-in 
preview mode to preview dynamic documents you create using the Database Wizard (p.430), as long as 
you have either Internet Information Server (IIS) or Personal Web Server (PWS) installed on your 
computer.

To preview th e  curren t docum ent in Namo W ebEditor's built-in preview  m ode

• Click the Preview tab at the bottom of the main window.

To preview th e  curren t docum ent in a designated  Web brow ser

• On the View menu, point to Preview, and then click the item corresponding to the browser you 
want to use.

If the browser you want to use is not on the menu, you need to set up Namo WebEditor to use it in the 
Preferences dialog box.

1. On the View menu, point to Preview, and then click Define Browsers.
2. If there is an empty slot in the list of designated browsers, click it. Otherwise, click one of the 

already designated browsers to replace it. Then, click Edit.
3. In the Name box, type the name of the desired browser. (For example, "Mozilla 1.4".)
4. In the Program file box, enter the path of the browser's main executable file. (For example, 

"C:\Program Files\Mozilla\1.4\mozilla.exe".) You can click Browse to locate and select the 
program file instead of entering the path manually.
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5. In the DDE name box, type the system name used by Windows to reference the browser program. 
This is usually the same as the name of the program file, minus the ".exe" extension. (For example, 
"mozilla".) If you don't know what to enter, leave the box blank.

6. Click OK. Click OK again to close the previous dialog box.

Saving documents

To save a docum ent

1. Do one of the following:
o On the File menu, click Save.

o Click ^ 3  (Save) on the Standard Toolbar.
2. If you are saving the document for the first time, in the File name box, type a name for the file, 

and then click Save.

To save a docum ent w ith a new  file nam e or in a d ifferent location

1. On the File menu, click Save As.
2. Navigate to the folder in which you want to save the document.
3. In the File name box, type the new name for the file, and then click Save.

To save a docum ent directly to  a rem ote site

A remote site is a folder on a Web server that contains a Web site you have published. You can save a 
document directly to a remote site, instead of saving it locally and then uploading it to the remote site. For 
more information about remote sites, see Defining remote sites for publishing, p.388.

1. On the File menu, click Save on Web Server.
2. In the Remote site box, dick the remote site on which you want to save the document.
3. In the File name box, type the desired file name for the document, and then click Save.

Copying resource files when saving a docum ent

When you save a document after inserting new images or other resource files in it, the Resource File 
Handling dialog box (pictured below) may appear, offering you various options, including the option of 
copying the newly inserted resource files to the document’s folder. This dialog box appears only if the 
resource files are located outside the folder containing the document itself. If you choose the default action 
(Copy the files to the document folder), Namo WebEditor will copy the resource files to the document 
folder and modify their paths in the document’s source code to point to the copies.
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Resource File Handling . ^

&

What do you want to do?

(* £opy the files to the document folder 

C Maintain existing URLs to the original file locations 

C Use lelative URLs to the original file locations

Copy the files to another folder or choose action for each file

Cancel

it3 l

1 % At least one image or other resource file used in this document is 
* \  not located in the document folder. This can cause problems 

when publishing the document.

Unless you have a specific reason to leave a resource file outside the document folder, you should choose 
the default option. This avoids potential problems later, when you publish the document, since you won’t 
have to worry about keeping track of resource files located in other folders.

If you want to copy some but not all of the newly inserted resource files to the document folder, choose 
Copy the files to another folder or choose action for each file and manually set the paths of the files you 
want to copy to the document folder.

Exporting a document to MHTML

Sending a Web document to another person through e-mail or another medium can be tricky. If a document 
uses images, and the URLs of those images are not on the Web, it’s not enough to just send the HTML file; 
you have to find all the image files and send them, as well. For a complicated document, you may wind up 
sending dozens of files, just so the other person can view one page.

To simplify the process of sending an individual Web document through e-mail and other media, you can 
export the document as a MIME HTML (MHTML) archive. An MHTML archive combines an HTML 
document with all the resource files (images, multimedia, and so forth) that it uses, into a single file. 
MHTML is the same system e-mail programs use to store attachments in an e-mail message. Internet 
Explorer—and browsers based on Internet Explorer—can open and display MHTML files as easily as 
HTML files, so most people should have no difficulty viewing an MHTML archive you send them.

The file name extension of MHTML archives is .mht. In Windows, .mht files are set up to open in Internet 
Explorer by default when double-clicked.
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To export th e  cu rren t docum ent as an MHTML archive

1. On the File menu, click Save As.
2. Click the Save as type box and select MHTML Files.
3. In the File name box, type the desired file name for the MHTML archive, and click Save.

S a v i n g  a  d o c u m e n t  a s  a  t e m p l a t e

Although Namo WebEditor comes with a variety of predesigned document templates, it can be useful to 
create your own templates. You can save any document as a template, and it will appear with the original 
Namo templates on the Templates tab of the Resource Manager (which opens when you click New on the 
File menu). When you save a document as a template, any resource files (images and so forth) it uses are 
saved along with it in a single MHTML archive, so the same resource files will be present in new 
documents you create from the template.

To save a docum ent as  a tem plate

1. On the File menu, click Save As Template.
2. Double-click the folder corresponding to the template category in which you want to save the 

template. (In most cases, use the "Document" folder.)
3. In the File name box, type a file name for the new template, and click Save.

(El When you add a custom template, it initially appears in the Resource Manager without a title or
description. To give your custom template a title and/or description, right-click its thumbnail preview 
in the Resource Manager and click Properties.

To remove a custom  tem plate

1. On the Window menu, click Resource Manager.
2. Click the Templates tab, and then click the folder containing the template you want to remove.
3. Right-click the desired template’s thumbnail preview and click Delete.

M o v i n g  a n d  r e n a m i n g  r e s o u r c e  f i l e s

You can use the Resource File Manager to move or rename images and other resource files used in the 
current document. The following operations are supported:
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• Moving a resource file to another location relative to the document
• Converting a resource file’s URL from an absolute, file-type path (p. 165) to a relative path (p. 167), 

or vice versa
• Renaming a resource file

When you move or rename a resource file, Namo WebEditor also updates its URL in the document's source 
code to the new path.

£ 3  When you move a resource file using the Resource File Manager, Namo WebEditor copies the fde to 
the new location. It does not delete the file in the original location.

To move a resource file

1. On the Window menu, click Resource File Manager.
2. Select the file you want to move. (To select multiple files, click each while holding down the Ctrl 

key.)

3. Click Choose Folder.
4. Select the folder to which you want to move the file(s), and then click OK.
5. Click OK.

To convert a resource file's URL betw een  abso lu te and relative

1. On the Window menu, click Resource File Manager.
2. Select the file whose URL you want to convert. (To select multiple files, click each while holding 

down the Ctrl key.)
3. Click Absolute/Relative Path, and then click OK.

To renam e a resource file

1. On the Window menu, click Resource File Manager.
2. Select the file you want to rename, and then click Rename.
3. Type the new file name and press Enter.
4. Click OK.

V i e w i n g  t r a n s f e r  i n f o r m a t i o n

W hen creating a docum ent that contains large images or multimedia resources like m ovies and background 
sounds, it's a good idea to keep an eye on the total size o f  the docum ent and its resource files. Large 
docum ents can take an excessively long tim e to load over slow Internet connections. W hile it's not always
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possible to avoid this, you should be aware of it and perhaps warn your users before they try to open slow- 
loading, resource-heavy pages.

The Advanced tab of the Document Properties dialog box displays the current document’s total size 
(including any images or other resource files) and its theoretical download time at various connection 
speeds. Keep in mind that Internet connections rarely reach their maximum theoretical speed, so actual 
download times are likely to be significantly longer.

To view transfer inform ation for th e  curren t docum ent

1. On the File menu, click Document Properties, or press Ctrl+F2.
2. Click the Advanced tab.
3. In the Connection speed box, select a speed to see the document's minimum total download time 

at the selected speed.

P r i n t i n g  d o c u m e n t s

To print th e  curren t docum ent

1. Do one of the following:
o On the File menu, click Print.

o Click a  (Print) on the Standard Toolbar.
2. Specify the range and number of copies you want to print, and then click OK.

0  Since Web documents are generally designed for viewing in a browser rather than printing on paper, 
it's a good idea to preview how a document will look on paper before printing it. (On the File menu, 
click Print Preview.) Also, you may want to adjust page setup options before printing a document. (On 
the File menu, click Page S etup)

Related Topics

Controlling page breaks................................................................................p.66

Controlling page breaks

Web documents are generally meant for viewing with a browser, not printing on paper. As a result, when 
you print Web documents, the pages often break in awkward places. Fortunately, Namo WebEditor 
includes several features that help you control how page breaks will occur when you print a document:
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• You can view and edit a document in page layout mode, which shows the document as it would 
appear if printed within Namo WebEditor (in the current font, font size, and paper size). This lets 
you identify potential pagination problems.

• You can insert manual page breaks. By inserting a manual page break at an appropriate place 
above the location where an undesirable automatic page break would occur, you can override the 
automatic break.

• You can force a page break before or after a specific paragraph, and you can prevent a page break 
before, after, or inside a specific paragraph.

• You can control the behavior of widows and orphans—single lines that fall just before or after an 
automatic page break and are thus visually separated from the paragraphs to which they belong. 
You can prevent these unsightly occurences by specifying that a certain number of lines in a 
paragraph must fall before or after an automatic page break.

3  You should use manual or forced page breaks only to control how a document prints in Namo
WebEditor. Since other people who view your document in a browser may print it in a different font, 
font size, and/or paper size from the one you used, it is not possible to predict the effect o f any manual 
or forced page breaks you have inserted in the document

In page layout view, Namo WebEditor displays your document as it would look if printed in Namo 
WebEditor. Dashed red lines appear wherever automatic page breaks would occur. If a page break occurs 
in an awkward position, you can insert a manual page break at an appropriate location before it, overriding 
the automatic page break. Manual page breaks are visible as solid red lines.
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P a rt o f a docum ent in page layout mode

To sw itch to  page layout view

• On the View menu, click Page Layout.

To insert a m anual page break

1. Place the insertion point in the line above which you want the manual page break to occur.
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2. Press Ctrl+Enter.

There are some things you should be aware of when you insert a manual page break with Ctrl+Enter:

• If you insert a manual page break in the middle of a paragraph, the paragraph will be split into two 
paragraphs. As a result, some empty space will appear above the line where you insert the break, 
and this space will be visible in a browser. To avoid this space, set both the bottom margin of the 
upper paragraph and the top margin of the lower paragraph to 0. (See Setting margins, padding, 
and borders, p.222.)

• If you insert a manual page break while the insertion point is in the first line of a paragraph, Namo 
WebEditor will insert an empty paragraph above the break. You should delete this empty 
paragraph to avoid the empty space it creates, which is visible both in a browser and in print.

• If you insert a manual page break within an item in a numbered or bulleted list, a new list item will 
be created. To avoid this, insert the page break above a list item and then delete the extra item that 
is created.

To force a page break  before or afte r a paragraph

1. Place the insertion point anywhere in the desired paragraph.
2. On the Insert menu, point to Page Break, and then click Page Break Properties.
3. Depending on whether you want to force a page break before or after the paragraph, click one of 

the following options under either Page break before or Page break after:
o Always: Click this option to force a normal page break.
o Left: Click this option to force one or two page breaks before (after) the paragraph, so that 

the next page is printed as a left page.
o Right: Click this option to force one or two page breaks before (after) the paragraph, so 

that the next page is printed as a right page.
4. Click OK.

To prevent a page break before, after, or inside a paragraph

1. Place the insertion point anywhere in the desired paragraph.
2. On the Insert menu, point to Page Break, and then click Page Break Properties.
3. Click the Avoid option under Page break before, Page break inside, and/or Page break after.
4. Click OK.

To resto re default (autom atic) page break behavior for a paragraph

1. Place the insertion point anywhere in the desired paragraph.
2. On the Insert menu, point to Page Break, and then click Page Break Properties.
3. Click the Auto option under Page break before, Page break inside, and/or Page break after.
4. Click OK.

To control widows and  orphans

1. Do one of the following:
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o If you are specifying widow/orphan settings for one paragraph, place the insertion point 
in that paragraph.

o If you are specifying settings for multiple (adjacent) paragraphs, select the paragraphs.
2. On the Insert menu, point to Page Break, and then click Widow and Orphan Control.
3. To prevent widows, click Prevent widows and then specify the minimum number of lines of a 

paragraph that must fall before a page break.
4. To prevent orphans, click Prevent orphans and then specify the minimum number of lines o f a 

paragraph that must fall after a page break.
5. Click OK.
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B a s i c  d o c u m e n t  e d i t i n g

As with many other kinds of documents, much of the time spent in authoring Web documents is taken up 
with the mundane tasks of inserting and editing text. Fortunately, you will not have to learn anything new 
to work with text in Namo WebEditor. Its WYSIWYG (What You See Is What You Get) interface makes 
adding and editing text in Web documents as familiar as working with a word processing program.

In th is section

Inserting text....................
Editing text......................
Finding and replacing text 
Inserting special items.....

I n s e r t i n g  t e x t

Typing tex t

To add text to a document, just create or open it and start typing. Whatever you type appears in the 
document at the insertion point—the blinking vertical bar that moves when you type. You can move the 
insertion point by clicking the mouse or pressing the arrow keys on your keyboard. Note, however, that you 
cannot move the insertion point beyond the end of the content that exists in the document.

To start a new paragraph, press Enter. To break the line you are typing without starting a new paragraph, 
press Shift+Enter.

Pasting tex t from an o th er program

If the text you want to insert into a Web document already exists in another document—such as a word 
processing document or a plain text file—you can copy the text from the other program by selecting it and 
pressing Ctrl+C, and paste it into the Web document by pressing Ctrl+V.

Inserting a tex t file

You can also insert the entire contents of a text file into a Web document.

1. Create or open the Web document in Namo WebEditor, if it is not already open.
2. In My Computer or Windows Explorer, locate the text file whose contents you want to insert.
3. Drag the text file into the document window in Namo WebEditor.
4. Press Enter.

..p.70 
-P -71  

..p.72 

..p.74
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Norm ally, when you type text at the beginning or in the middle o f  a line o f  existing text, the new  text 
"pushes” the existing text out o f  the way. But you can also type "over" existing text, if  you want. First, you 
need to unlock the Insert key:

1. On the Tools menu, click P references, and then click the Edit tab.

2. Deselect the Lock Insert key check box and click OK.

Then, to enter overwrite mode, press the Insert key. On the right side o f  the status bar, the w ord Overwrite 
will appear to indicate Namo W ebEditor is in overwrite mode. To return to insert mode, press Insert again.

Using overw rite m ode

E d i t i n g  t e x t

Ways to select tex t

• Position the mouse pointer at the beginning of the desired text, press the mouse button down, drag 
the mouse pointer to the end of the desired text while holding down the button, and then release 
the button.

• Click at the beginning of the desired text, and then, while holding down the Shift key, click again 
at the end of the desired text.

• Double-click a word to select it.
• Place the insertion point at the beginning of the desired text and then press the right arrow key 

and/or the down arrow key while holding down the Shift key until you reach the end of the desired 
text.

• Place the insertion point at the beginning of the desired text and then press the right arrow key 
and/or the down arrow key while holding down both the Shift and Ctrl keys until you reach the 
end of the desired text. (The selection will be extended one word at a time.)

W ays to  delete tex t

• Place the insertion point at the beginning of the text you want to delete, and then repeatedly press 
Delete until all the unwanted text is deleted.

• Place the insertion point at the end of the text you want to delete, and then repeatedly press 
Backspace until all the unwanted text is deleted.

• Press Delete or Backspace while holding down the Ctrl key to delete one word at a time.
• Select the text you want to delete, and then press either Delete or Backspace.

To copy tex t from one location or docum ent to  ano ther

1. Select the text you want to copy.
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2. Do one of the following:

o On the Standard Toolbar, click Q) (Copy), 
o Press Ctrl+C.

3. Move the insertion point to the place where you want to insert the text (after switching to the other 
document, if  necessary).

4. Do one of the following:

o On the Standard Toolbar, click (Paste), 
o Press Ctrl+V.

To move tex t from one location or docum ent to  ano ther

1. Select the text you want to move.
2. Do one of the following:

o On the Standard Toolbar, click &  (Cut), 
o Press Ctrl+X.

3. Move the insertion point to the place where you want to insert the text (after switching to the other 
document, if necessary).

4. Do one of the following:

o On the Standard Toolbar, click a  (Paste), 
o Press Ctrl+V.

y  You can also move a selection o f text by dragging it with the mouse. Similarly, you can copy a selection 
o f text by dragging it while holding down the S h i f t  key.

To change th e  case  of selected tex t

1. On the Tools menu, point to Change Character Format, and then click Change Case.
2. Select the option corresponding to how you want to change the case, and then click OK.

F i n d i n g  a n d  r e p l a c i n g  t e x t

You can search for a specific word or phrase in the current docum ent and optionally replace it w ith other 
text. The Find and Replace com m ands can also operate on all open docum ents, instead o f  ju s t the current 
one. (To find and replace text in docum ents that are not open, use the Global Find & Replace (p.406) 
com mand.)
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1. On the Edit menu, click Find (or press Ctrl+F).
2. In the Find box, type the text you want to find. (Note that the word containing the insertion point is 

already entered for you.)
3. Under Options and Direction and range, select the desired options. (See Options and settings for 

find/replace, p.73, below.)
4. Click Find Next. The found text will be selected in the document window. If necessary, keep 

clicking Find Next until the desired occurrence of the search text has been found.

After closing the Find/Replace dialog box, you can quickly search for the next occurrence o f the
search text by pressing F3.

To Find and replace specific text
1. On the Edit menu, click Replace (or press Ctrl+H).
2. In the Find box, type the text you want to find. (Note that the word containing the insertion point is 

already entered for you.)
3. In the Replace box, type the text you want to replace the search text with.
4. Under Options and Direction and range, select the desired options. (See Options and settings for 

find/replace, p.73, below.)
5. Do one of the following:

o If you want to decide for each occurrence of the search text whether to replace it or not:
1. Click Find Next.
2. If a match is found, click Replace to replace it or Find Next to skip it.
3. Repeat step 2 until all occurrences of the search text have been found.

o If you want to replace all occurrences of the search text at once, click Replace All.

Options and settings for find /rep lace

Options
• Match case: Only finds occurrences that have the same capitalization as the search text. For 

example, if this option is selected and you search for "hello", any occurrence o f "Hello" will be 
ignored.

• Match whole words only: Only finds occurrences that are whole words. For example, if this option' 
is selected and you search for "art", words like "heart" will be ignored.

• Match ¡n hyperlinks only: Only finds occurrences in the URLs of hyperlinks. For example, if  this 
option is selected and you search for "namo", all links to "www.namo.com" will match, but the 
word "namo" in text content will be ignored.

• Match full-/half-width: Only finds occurrences that match the same "width" as the search text. This 
option only applies to documents using double-byte characters, such as Korean or Chinese 
characters.

To find specific tex t
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Direction and range
• Up: The current document will be searched starting at the location of the insertion point and 

progressing upward. The search will terminate at the top of the document.
• Down: The current document will be searched starting at the location of the insertion point and 

progressing downward. The search will terminate at the bottom of the document.

• Start at top of document: The current document will be searched starting at the top, regardless of 
the location of the insertion point.

• Search all open documents: All open documents will be searched, starting at the top of the 
document that was opened first.

E3 The Find and Replace commands do not accept wildcard characters, such as "?" and 

Related topics

Finding and replacing text throughout a site ...................................................... p.406

I n s e r t i n g  s p e c i a l  i t e m s

In this section

Inserting a non-breaking space ............................................................................. p.74

Inserting horizontal ru le s ....................................................................................... p .75

Inserting symbols and special characters............................................................ p.76

Inserting com m ents..................................................................................................p.77

Inserting the current date/tim e.............................................................................. p.77

Inserting a non-breaking space

When a browser (or Namo WebEditor's Edit mode) displays a paragraph of text, it "wraps” the paragraph 
by automatically breaking it at the right edge of the window (or the paragraphs’ parent container, such as a 
table cell) so that no line is wider than the window or container. This saves you and your users the trouble 
of scrolling the window horizontally to see all of a long paragraph. These automatic line breaks can occur 
wherever there is a space between words or characters. However, there may be occasions when you do not 
want an automatic line break to occur in a particular place, no matter what. For example, you may have a 
heading that you want to always be displayed on a single line, even if it means having to scroll horizontally 
to see all of it.
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In such cases, instead of inserting ordinary spaces between words, you can insert non-breaking spaces. If a 
browser encounters a non-breaking space in a paragraph, it will never break the paragraph at that space. To 
prevent a paragraph from breaking at all, you can insert non-breaking spaces between all o f its words, as in 
the example below:

r -------—----- --------—,------- -— ----------------------4
Щ D:\work\wescratch\Up5umJi... ffifE lffc ) Ш D:\work\wescratch\tipsuma.... f£ )(5 ](5}

L o r e m  i p s u m  d o l o r  “  

s i t  a m e t

Consectetuer^dipiscing élit. Non 
nummi fahrvergnügen. Aliquam mi 
est, solücitudin sed, malesuada in, ¿v

L o r e m  i p s u m  d o l o r  s ~

Consectetuer|idipiscing élit. Non 
nummi fahrvergnügen. Aliquam mi 
est, solücitudin sed, malesuada in, 
adipiscing a, purus. Suspendisse

jVEdil/^ EditîcHTML À JfT M t-À  Pieview / i\Ed¡l^ Edit&HTML / | « |  I

A heading with normal spaces A heading with non-breaking spaces

To insert a non-breaking space

• Do one of the following:
o On the Insert menu, point to Other, and click Non-Breaking Space, 
o Press the space bar while holding down the Ctrl key.

9  I f  you have many or long paragraphs that you do not want wrapped, instead o f using non-breaking 
spaces, it is more convenient to define a style (p.213) that includes the white-space property with the 
value "nowrap " and apply the style to the paragraphs.

To prevent wrapping in a table cell, you can apply the "nowrap" attribute to the cell. (On the Inspector, 
select No wrap.)

Related topics

Controlling text wrapping in a table. . p.204

Inserting horizontal rules

A horizontal rule is a line used to visually divide sections of content in a document. By default, it stretches 
all the way across its parent container.

To insert a horizontal rule

1. Place the insertion point where you want to insert the horizontal rule.
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2. On the Insert menu, click Horizontal Rule.

0  I f  you insert a horizontal rule in the middle o f a paragraph, list item, or similar block element, the 
element will be split into two elements above and below the rule.

To ad ju st a horizontal ru le 's  w idth, height, and o ther properties

1. Select the horizontal rule.
2. On the Inspector, do any of the following:

o In the Width and/or Height boxes, enter values for the rule's width and/or height and press 
Enter. Width can be specified in pixels or as a percentage of the parent container's width; 
height can only be specified in pixels.

o Click the Alignment box and select the alignment of the rule with respect to its parent 
container. (This only has an effect if the rule's width is smaller than that of the parent 
container.)

o Select the Solid check box to remove the rule’s 3-D effect, making it a solid bar.
o Click the color box and select a color for the rule. (If you specify a color, the rule 

becomes a solid bar regardless of the state of the Solid check box.)

Inserting symbols and special characters

Use the Symbol command to insert a symbol or special character that cannot be typed on the keyboard, 
such as the copyright symbol ©.

To insert a symbol o r special charac ter

1. On the Insert menu, click Symbol (or press Ctrl+F7).
2. If the character you want to insert does not exist in the ASCII character set, click the Unicode tab.
3. Double-click a character to insert it into the document. Repeat as desired. When done, click Close.

I f  you insert a Unicode character, you must specify the character set o f the document as Unicode; 
otherwise, the character will not display properly in a browser (or in Preview mode). To specify the 
document's character set: on the File menu, click Document Properties, click the G eneral tab, and then 
click the Character S et box and select Unicode (U TF-8)

0  The Symbol dialog box is non-mo dal, so you can click on the document window and continue editing 
while the dialog box is open. In the dialog box, you can also click Copy to Clipboard to save the 
selected character in the clipboard for future pasting.
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Inserting comments

In HTML, a comment is text that appears in the source code of a document but is not displayed in a browser 
and has no effect on the appearance of the document. If you are an advanced author and work directly with 
source code, inserting comments is a good way to remind yourself or other authors what particular sections 
of the source code are for.

Although comments are usually inserted in HTML mode, you can also insert a comment in Edit mode. If
the display of special tag marks (p.44) is enabled, a comment mark ( O ) will appear in Edit mode at the 
location of the comment. In the HTML source code, a comment is surrounded by the character strings 
" < !-"  and

To insert a com m ent

1. Place the insertion point at the location where you want to insert the comment.
2. On the Insert menu, click Comment.
3. Enter the text of the comment and click OK.

0  To enable or disable the display o f special tag marks: on the View menu, point to Marks, and then click 
Special Tag Marks. Alternatively, click □  (Show/Hide Special Tag Marks) on the Standard Toolbar.

Inserting the current date/time

To quickly insert the current date and time as text in the current document, use the Date and Time 
command. You can choose among various date/time formats.

To insert th e  curren t d a te  an d /o r  tim e

1. On the Insert menu, point to Other, and click Date and Time.
2. Select the desired date/time format and click OK.

S  Namo WebEditor gets the current date and time from your computer's internal clock. I f  the clock is 
wrong, the wrong date and/or time will be inserted. To adjust your computer's clock, use the Date and 
Time icon in Windows's Control Panel.
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W o r k i n g  w i t h  l o c a l  s i t e s

In th is section

What is a local site?.............................................................................. ............. p.78
Creating a local s ite .............................................................................. ............. p.79

Related topics

Working With Sites.............................................................................. ............. p.339

W h a t  i s  a  l o c a l  s i t e ?

A local site is a managed collection of Web documents, folders, and resource files on the local file system 
that you intend to publish as a Web site. A local site gathers local files into a cohesive whole and lets you 
manage them as a whole, with Namo WebEditor's Site Manager. A mere bunch of HTML and image files 
in a folder on your hard disk is not a local site, in the sense in which Namo WebEditor uses the term. A 
local site must be explicitly created through a command in Namo WebEditor, and its members (files) must 
be explicitly included.

Benefits of using a local site

Creating a local site makes possible several things that cannot be done with a simple folder full of files. The 
most important of these are automatic link updating, dynamic navigation bars, and a site library.

Automatic link updating
When you move or rename a file or folder in a local site, any paths or URLs that point to the file 
(or include the folder) can be automatically updated. For example, if several documents in a local 
site all link to an image whose path is "images/Iogo.gif’, and you move the image to an 
images/logos folder, Namo WebEditor will offer to change all of the affected image paths 
automatically to "images/logos/logo.gif

Dynamic navigation bars
If youVe surfed the Web even a little, you'll be familiar with the concept of the navigation bar—a 
row or column of links that provide shortcuts to key pages on a site or to pages closely related to 
the current page. Often, the same navigation bar appears on many pages in the same site. 
Navigation bars are popular because site visitors find them useful, not because they are easy for 
site authors to create and manage: if you remove or add a page that a navigation bar link points to, 
or should point to, you may have to update the navigation bars on dozens, if not hundreds, of 
pages.
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You can avoid such headaches by using Namo WebEditor’s dynamic navigation bars, which are 
made possible when you set up a site tree in a local site. A dynamic navigation bar updates 
automatically when you add or remove a page at the same level in the site tree as the other pages 
the bar links to.

Site library
In any medium-size to large site, there will be resources—images, blocks of text, hyperlinks, and 
so forth—that are used repeatedly throughout the site. When you use a local site in Namo 
WebEditor, the Site Library panel presents categorized lists of all such resources in use in the site. 
Inserting an existing resource into a document that is part of the site is as easy as dragging it from 
the Site Library.

Other advantages of using a local site include one-button publishing and the ability to use a source control 
system to prevent conflicts when more than one person edits the same set of documents. For all of these 
reasons, it is always a good idea to create a local site whenever you work on multiple documents that will 
be published to the same Web site.

Related topics

Creating a local site..............
Site structure and navigation 
Using the site library............

C r e a t i n g  a  l o c a l  s i t e

There are three ways to create a local site:

• You can use the Site Wizard to create a new site from a site template. The wizard automatically 
creates a local site, complete with a site tree (p.355), to contain the documents it generates.

• You can create an empty local site with the New Site command. After creating an empty site, you 
can add documents to it by dragging them from Windows Explorer or by creating them from 
scratch.

• You can create a local site from the contents of an existing folder on the local file system with the 
New Site command. (The folder contents may consists of files imported (p.351) from a Web site.) 
Any HTML documents and resource files in the folder and any subfolders will automatically be 
added to the local site, and Namo WebEditor will automatically generate a site tree (p.355) from 
the documents and subfolders.

GE) When you create a local site, Namo WebEditor adds a special fde named site.wejand a special folder
named _w eJn fo 5  in the local site's top-level folder. These special items store site information and

p.79
p.355
p.377
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internal resources. By default, these items are not visible in the Site Manager, although you can see 
them in Windows Explorer. Do not delete these items unless you want to delete the local site.

In this section

Creating a local site with the Site Wizard................
Creating an empty local site.......................................
Creating a local site from files in an existing folder

Related topics

Site structure and navigation.............................................................................. p.355

Creating a local site with the Site Wizard

Use the Site Wizard to create a complete site in seconds. Just choose a site template and a theme, and 
Namo WebEditor generates a local site for you, complete with ready-to-customize documents and a site 
tree that defines the navigational structure o f the site.

To start the Site Wizard, click the Site Wizard button on the Shortcut Bar or, on the File menu, point to Site, 
and click Site Wizard. The wizard walks you through the process of creating a site in four easy steps:

.p.80 

.p.85 

.p.85
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Step 1: Choose a site tem plate
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In the first step of the Site Wizard, you choose a site template on which to base your new site. The choice 
of template affects both the structure of the site (how many pages there are and how they are related) and 
the title and layout of each page. Select a template under Templates, and its site tree will appear in the 
Preview area.

Keep in mind that a site template's initial structure (site tree) is only a starting point. You can always add, 
rearrange, or remove documents after you finish the Site Wizard. However, if you want to modify your new 
site's site tree right at the beginning, you can do so right in the Site Wizard by manipulating nodes in the 
Preview area and using the buttons below it.

• To move a node in the tree, drag it to the desired position.
• To add a node, select an existing node and click New. In the menu that appears, select a node type 

(p.356). A new node will be added as a child of the selected node.
• To copy a node, select it and click Duplicate. The copy will be given the same navigation name as 

the original, so be sure to rename it.
• To rename a node, select it and click Rename.
• To delete a node, select it and click Remove.

For more information about working with a site tree, see Building the site tree, p.356.

Working with local sites 81



Ñamo WebEditor 6 User Manual

0  Modifying the template stmcture in the Site Wizard affects only the site you are currently creating; it 
does not modify the template itself I f  you want to save changes to a site template so that future sites 
based on the template inherit the changes, complete the Site Wizard, make the desired modifications, 
and then save the site as a new site template (p.349).

Step 2: Choose a them e
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In the second step o f the wizard, you choose a theme for your new site. A theme is a collection of 
formatting styles and graphical design elements that combine to give a consistent look to a site (or some 
documents in a site). Namo WebEditor comes with over 200 predesigned themes, and you can create new 
themes (p.276) of your own either from scratch or by customizing (p.276) the included themes.

To see a preview of your new site with the selected theme applied, click Site Preview. Namo WebEditor 
will generate a temporary site based on the template selected in the previous step, apply the selected theme 
to it, and then open its index page in your default browser. While examining the temporary site in the 
browser, use the navigation bars on each page to jump to other pages.

82 Working with local sites



Chapter 2: Namo WebEditor Fundamentals

Step 3: Enter s ite  inform ation
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In the third step of the wizard, you enter a few pieces of information that will be used throughout the new 
site, and specify the local folder in which to save the site.

Title
Type a title for your new site in this box. This title will not actually appear on any page in the site; 
it just makes it easier to tell what local site you are working on at any given time.

Author
Type your name in this box. Like the title, the author name does not actually appear on any page 
in the site. The only place it appears is in the Properties dialog box for the site.

Administrator e-mail address
The e-mail address you type in this box will appear near the top and/or bottom of every Site 
Wizard-generated page in the site. If you don’t want any e-mail address to be automatically 
inserted on every page, leave this box blank.

Copyright information
Whatever you type in this box will appear near the bottom of every Site Wizard-generated page in 
the site. You can use it to specify copyright information or any other piece of text you want to 
appear at the bottom of every page. If you don't want any text to be automatically inserted at the 
bottom of every page, leave this box blank.
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Save site in
Enter the path of the local folder (a folder on your hard drive or somewhere on your local area 
network) in which to save the site. You can click the Browse button to locate and select an existing 
folder. Note that you must specify a local folder, not a directory on a Web server. You will upload 
the local site to a Web server later, using one of the publishing (p.387) commands.

Step 4: Specify a Web server
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In the fourth and last step of the Site Wizard, you specify the Web server to which the local site will be 
uploaded, or published, once you are finished customizing it. If the server you want to use has not been 
defined yet, you can click New to define it now. However, this is not required; you can always define a 
Web server later using the Remote Sites command (see Defining remote sites for publishing, p.388).

Finishing th e  Site Wizard

Click Finish to complete the Site Wizard. If the folder you specified in the third step does not yet exist, 
Namo WebEditor will ask you whether it’s okay to create it; click Yes. Then, Namo WebEditor will spend 
a few moments generating the new site and applying the selected theme to it. When it has finished, the Site 
Manager window will appear. Now you can start opening and customizing the generic documents the 
wizard has generated. To open a document for editing, double-click its icon in either the Site Files pane or 
the Site Tree pane of the Site Manager.

Related topics

Adding files and folders to a local site..............................................................p.347
Site structure and navigation.............................................................................. p.355
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Using themes......................................
Defining remote sites for publishing 
Basic document editing.....................

p.270 
p.388 
p.70

Creating an empty local site

If you plan to create a new Web site entirely or mostly from scratch, start by creating an empty local site 
with the New Site command. Creating a local site and adding new documents to it—instead o f simply 
storing new documents in an ordinary Windows folder—will make it easier to manage the documents and 
make it possible to use automatic link updating, dynamic navigation bars, and a site library, among other 
benefits.

After creating an empty site, you can add documents (p.347) to it by using commands in the Site Manager to 
create new documents, or by dragging existing documents to the Site Manager from Windows Explorer. 
You can also add other files, such as images, by dragging them from Windows Explorer.

To create  an  em pty local site

1. On the File menu, point to Site, and then click New Site.
2. In the Site title and Author boxes, enter a name for the site and your name, respectively. (This 

information will not appear on the Web site.)
3. Click Create empty site, and then enter the path o f the folder in which you want to store the site's 

files. (You can click ... to browse for a folder or to create a new one.)
4. Click OK.

The Site Manager window will come to the front, with the new local site open and ready for you to add 
new (or existing) documents.

Related topics

Adding files and folders to a local site...................................................... p.347
Site structure and navigation.....................................................................p.355

If you already have a local copy of a Web site in a folder on your hard drive, and you want to manage the 
folder as a local site with the Site Manager, you can do so by creating a new local site in that folder. All 
files and subfolders in the folder will be automatically added to the local site. This provides a convenient 
way to let Namo WebEditor "take over" a site that you have created using other software.

Creating a local site from files in an existing folder
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To crea te  a site  from an existing folder

1. On the File menu, point to Site, and then click New Site.
2. Under Site information, enter a name for the new site and (optionally) the author's name.
3. Under Site origin, click Import existing files in a folder, and then enter the path of the folder that 

contains the existing files. You can click the ... button to browse for a folder.
4. Specify the file types, if any, you want the Site Manager to include in the site tree. (See 

"Generating a site tree automatically", below.)
5. Click OK.

The Site Manager window will come to the front, with the new local site open and ready to use. 

G enerating a site  tree  autom atically

When the Site Manager takes over an existing folder containing Web site files, it can optionally generate a 
site tree for the new local site, automatically populating the tree with nodes based on the files and 
subfolders in the folder. The Site Manager can create nodes from any of the following file sets:

• all Web documents (HTML/ASP/PHP/JSP/SHTML files)
• all image files (GIF/JPG/PNG/BMP files)
• all Web documents and image files
• all files, regardless of type

Before having the Site Manager autogenerate a site tree for the new local site, you should decide which file 
types you want the Site Manager to create nodes for. In most cases, choosing Documents only is the best 
choice. Note that the Site Manager will always create folder nodes from any subfolders in the site folder; 
this behavior cannot be disabled.

To understand how the Site Manager constructs automatic site trees, consider the following, highly 
simplified file/folder structure for a hypothetical company site:
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P i  www.namo.com 
$ C l  products 

B n  webeditor
index, html 

Q  tour.html 
index.html 

support 
h Q  forumhtml 

index, html 
ebouthtml 
contact ht ml 

~ t i  ¡ndex.hlml

If you create a new local site in the mvw.namo.com folder and enable automatic site tree generation, the 
Site Manager will generate the following site tree. (Note: node titles have been changed from their 
defaults.)

©Naao
a 

^ I
14 Index

_______________ 9  _______ _________ -i
[J about Q  contact | products | support

B  B,-------•------- - I------L----- ,
index [^Jvebeditor forum Qindex

sr*

Notice that the Site Manager has correctly identified index.html as the site's "home page", appropriately 
placing its node at the top (root) of the tree, just under the node representing the site itself. Each of the other 
two top-level documents, about.html and contact.html, becomes a child node of the home page node. The 
top folder's immediate subfolders, products and support, become folder nodes at the same level, while the 
contents of those subfolders become their child nodes, and so forth.

The purpose of creating folder nodes in autogenerated site trees is mainly to provide a way to visualize the 
folder structure of the site. Folder nodes are not actually represented in dynamic navigation bars. If the top- 
level index page in the above example contains a dynamic navigation bar linking to its child nodes, that bar 
will not include links to the products and support index pages, since those index pages are not immediate 
children of the top-level index page. To include the products and support index pages in the navigation bar, 
you would need to move (p.362) those nodes up, putting them on the same level as the "about" and 
"contact" pages. In fact, it often makes sense to eliminate folder nodes altogether, after moving their 
(document) child nodes to appropriate positions in the tree, as in this example:
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Q n b *  o

T
QIndex 

0
ab out. [J c ont act [^products 

n  ?  [¿web edit or
El

Q tour

(Note that the moved "index" nodes have been renamed to "products", "webeditor", and "support", 
respectively.)

Related topics

Site structure and navigation..............................................................................p.355
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3 Laying Out Web Pages
In Web documents as in printed documents, layout refers to the spatial arrangement of elements—usually 
text and graphics—on a page. Besides being pleasing to the eye, good layout makes documents easier to 
read and understand. HTML provides several tools you can use to design an effective page layout, and 
Namo WebEditor makes using these tools as easy as possible.

In this section

About page layout...............................................................................................p.90
Using layout boxes..............................................................................................p.91
Using a table for layout...................................................................................... p.99
Using frames........................................................................................................p. 101
Using layers.........................................................................................................p. 111
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A b o u t  p a g e  l a y o u t

In many ways, Web documents are like documents you create in a word processor. Content begins at the 
top left (or top right, depending on the language) comer of the page and proceeds toward the right (or left) 
and down in a single, continuous column. But a single-column layout is often not what Web authors want. 
For example, you may prefer to have a column of links on the left side of a page, a middle column for body 
content, and a third column on the right for supplementary content. Fortunately, HTML and cascading style 
sheets (CSS) offer the following techniques to create more useful and visually interesting layouts than the 
default single column:

Tables (p.99)
Tables are elements that arrange content in rows and columns. By creating a table that fills the 
entire page and placing all the page’s content in it, you can create virtually any page layout.

Frames (p.101)
Frames are a way of dividing the browser window into two or more panes. Among other things, 
you can place links in one frame and have the links' destinations open in another frame. Frames 
scroll independently, so your links can remain always visible while the content frame is scrolled.

Positioned elements (layers) (p.lll)
Normally, the position o f an element—such as a paragraph or an image—is determined by its 
position within the sequence of all the elements on the page and the size of the elements that go 
before it. However, cascading style sheets provide a way to specify the position of an element in 
terms of absolute page coordinates, so you can position an element independently of other content.

In addition, with Namo WebEditor's layout boxes (p.91), even beginning Web authors can start creating 
versatile layouts right away. When you drag layout boxes on a layout grid, Namo WebEditor automatically 
creates an invisible table that reflects the arrangement of your content.

Related topics

Tables.......................................................................................................p. 182
Shared content areas........................................................................................... p.420
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U s i n g  l a y o u t  b o x e s

To overcome the limitations of the normal single-column flow of content in HTML, Web authors often use 
a table (p. 182) to hold all the content of a page. The rows and columns of the table provide a convenient 
structure for authors to place content in specific locations on the page. However, setting up and managing a 
table for page layout is not easy, even for experienced authors. To make using tables for layout more 
accessible, Namo WebEditor includes a feature called layout boxes.

A layout box is an invisible box that contains layout cells that hold content. Within a layout box, you draw 
cells using the mouse. You move cells by dragging them, and you can resize cells without affecting the size 
of other cells or of the layout box. By default, a layout box has a grid to help you align layout cells.

When you create a layout box, Namo WebEditor automatically creates a borderless table in the underlying 
HTML source code with the same dimensions as your layout box. When you draw, move, resize, or remove 
cells in the layout box, Namo WebEditor automatically changes the table code to reflect your changes. 
Although you can see the layout box in Edit mode, it is invisible in browsers.

You can do the same kinds of layout tasks with layout boxes that you can with ordinary tables, but layout 
boxes are easier to use.

________________________________________________  A
This cell is for the top-of-page banner. I

Links win TKs ceil is for main content \ 
go in this i ;
tdL I j

.This cdl is for footer content.
v

A small layout box containing four layout cells, as seen in Edit mode

In th is section

Creating a layout box and layout ce lls.............................................................p.92
Resizing layout boxes and layout cells.............................................................p.93
Moving and removing layout cells................................................................... p.94

C:\Sc rate hMboxtesL html
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Aligning and distributing layout cells...............................................................p.95
Changing properties of layout boxes................................................................p.96
Changing properties of layout ce lls.................................................................. p.97
Converting between layout boxes and tables...................................................p.98

R elated topics

Using a table for layout.......................................................................................p.99
Tables................................................................................................................... p. 182
Layers...................................................................................................................p. 111

C r e a t i n g  a  l a y o u t  b o x  a n d  l a y o u t  c e l l s

To c rea te  a layout box for an  en tire  page

1. Create a new document (click D (New) on the Standard Toolbar).
2. On the Table menu, point to Layout Box, and then click Draw Layout Box.
3. Click near the top left comer of the document and drag downward and to the right until the dotted 

rectangle is approximately the size you want for your page layout.
4. Delete the empty paragraphs above and below the new layout box.
5. If you want to adjust the size of the layout box, double-click it and enter new values in the Width 

and Height boxes.

S  Note that even i f  there are no other elements above or to the left o f a layout box, there will still be a 
small margin between the layout box and the top and left sides o f the browser window. To remove this 
margin, define a style sheet rule (p.213) for the <body> element with the declaration: "margin: 0".

Although in most cases you will probably want to use a layout box to contain all the content on a page, it is 
also possible to use a layout box for just part o f a page. Any number of layout boxes can coexist in the 
same document. (However, a layout box cannot contain another layout box.)

To crea te  a layout box for part of a page

1. Place the insertion point in the line below which you want the layout box to appear.
2. On the Table menu, point to Layout Box, and then click New Layout Box.
3. Enter the desired dimensions in Width and Height.
4. If you want content following the layout box to flow around it, click Alignment and select Left 

(Floating) or Right (Floating).
5. Click OK.
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1. Do one of the following:
o On the Table menu, point to Layout Box, and then click Draw Layout Cell, 
o On the Layout Box Toolbar, click 0  (Draw Layout Cell).

2. For each layout cell you want to create, draw a box inside the desired layout box.
3. When finished, press Esc to exit drawing mode.

Layout cells cannot overlap. While drawing a layout cell, if you move the pointer into another layout cell, 
the pointer will change to , indicating that the layout cell cannot grow further.

To create  layout cells

R e s i z i n g  l a y o u t  b o x e s  a n d  l a y o u t  c e l l s

To resize a layout box

1. Select the layout box by clicking its border or an empty space inside it. (The pointer should look 
like before you click.)

2. Drag any of the box's resize handles.
3. If you need to make fine adjustments to the size of the box, right-click the box, select Layout Box 

Properties, and then enter the desired dimensions in Width and Height.

To resize a layout cell

1. Select the layout cell by clicking its border or an empty space inside it. (The pointer should look 
like before you click.)

2. Drag any of the cell's resize handles.
3. If you need to make fine adjustments to the size of the cell, double-click its border and enter the 

desired dimensions in Width and Height.

Resizing a layout cell does not affect the size or position of any other layout cell. Also, layout cells cannot
overlap. As a result, you cannot increase the size of a layout cell beyond the borders of any adjacent cells.

L3 While editing a layout box, it is possible to set the size o f a layout cell so that all o f its contents are not
visible. Such a cell will appear with a red border in Edit mode. However, when the document is viewed
in Preview mode or a browser, the layout cell will expand to show all its contents.

To ad just the size of a layout cell to  fit its con ten ts

1. Select the layout cell by clicking its border or an empty space inside it. (The pointer should look 
like before you click.)
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2. Do one of the following:
o On the Format menu, point to Layout, and then click Fit to Contents,

o On the Layout Toolbar, click M  (Fit to Contents).

If necessary, the layout box will be expanded to accommodate the resized layout cell. However, any 
adjacent cells will not be moved automatically, so the Fit to Contents command will be unavailable if it 
would require adjacent cells to be moved.

M o v i n g ,  d u p l i c a t i n g ,  a n d  r e m o v i n g  l a y o u t  c e l l s

To move a layout cell

• Drag the cell to a new location. (If the cell is full, start dragging by clicking the cell’s border.)

The pointer should look like before you drag, and it will change to a hand while you drag.

If you drag a layout cell so that it overlaps any other layout cell, when you release the mouse button the cell 
will ’’snap” to the nearest position that avoids overlapping other cells.

If you drag a layout cell beyond the layout box’s right or bottom border, when you release the mouse button 
the layout box will expand to enclose the layout cell. If you drag a cell beyond the layout box’s left or top 
border, the cell will snap to the nearest position that is completely within the layout box.

You cannot move a layout cell from one layout box into another layout box. To duplicate a layout cell in 
another layout box, create a cell o f the same size in the second layout box and then copy or drag the 
original cell’s contents into it.

Q  I f  you hold down the Shift key while dragging a layout cell, its movement will be limited to sideways 
and up-and-down movement only (no diagonal movement).

Duplicating a layout cell

• Drag the cell to a new location while holding down the Ctrl key.

To rem ove a layout cell

• Click the cell’s border and then press Delete.

To rem ove several layout cells

1. Click each cell’s border while holding down the Shift key.
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2. Press Delete.

A l i g n i n g  a n d  d i s t r i b u t i n g  l a y o u t  c e l l s

You can align, distribute, and resize layout cells with respect to each other using the Layout Toolbar or the 
commands in the Layout submenu of the Format menu. To reveal the Layout Toolbar, in the View menu, 
point to Toolbars, and then click Layout.

J |§a c*ac=a|| Uj K ) [ } - J ^ | 0 2 ] § 3 | M X | H

T h e  L a y o u t T o o lb a r

To align two or m ore layout cells w ith each  o ther

1. Select the cells by clicking each cell’s border while holding down the Shift key.
2. Click one of the alignment buttons (the first six buttons) on the Layout Toolbar.

The cells will be aligned with respect to the last selected cell.

Depending on the arrangement of the selected cells, not all of the alignment commands may be available. 
Since layout cells cannot overlap, only those alignment commands that would not result in overlapping 
cells are available at any given time.

To evenly d istribute th ree  or m ore layout cells

1. Select the cells by clicking each cell’s border while holding down the Shift key.

2. On the Layout Toolbar, click M  (Space Across) or X  (Space Down).

If the Space Across or Space Down command is not available even though three or more layout cells are 
selected, there may not be enough space to distribute the cells. In the example below, the cells cannot be 
distributed horizontally because there is not enough space between Cell 1 and Cell 3 for Cell 2. Similarly, 
they canot be distributed vertically because there is not enough space for Cell 3 between the other two cells.
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To m ake tw o or m ore layout cells th e  sam e size

1. Select the cells by clicking each cell’s border while holding down the Shift key.
2. On the Layout Toolbar, click 0  (Make Same Width), QD (Make Same Height), or E9 (Make Same 

Size).

The cells will be resized to the same size as the last selected cell. Cells are never moved automatically, so if 
there is not enough space to resize all selected cells, some or all of the resize commands will be unavailable.

C h a n g i n g  p r o p e r t i e s  o f  l a y o u t  b o x e s

To change th e  alignm ent of a layout box w ith respect to  its paren t elem ent

1. On the Layout Box Toolbar, click i-d (Layout Box Properties).
2. Click the Alignment box and select Left, Right, or Center.

To m ake surrounding conten t flow around a layout box

1. On the Layout Box Toolbar, click Q  (Layout Box Properties).
2. Click the Alignment box and select Left (Floating) or Right (Floating).

To change th e  background color of a layout box

1. On the Layout Box Toolbar, click Q  (Layout Box Properties).
2. Click the Color box and select a color (p.233).

To add a repeating background im age to  a layout box

1. On the Layout Box Toolbar, click i-d (Layout Box Properties).
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To change grid spacing

1. On the Layout Box Toolbar, click i-fil (Layout Box Properties).
2. Enter the desired horizontal and vertical distance between gridlines in the Horizontal and Vertical 

boxes.

To tu rn  off snap-to-grid

1. On the Layout Box Toolbar, click E3 (Layout Box Properties).
2. Clear one or both of the Snap check boxes. (Snap-to-grid can be enabled or disabled 

independently for horizontal and vertical gridlines.)

To hide gridlines

1. On the Layout Box Toolbar, click 53 (Layout Box Properties).
2. Clear one or both of the Visible check boxes. (Visibility can be enabled or disabled independently 

for horizontal and vertical gridlines.)

Related topics

Selecting colors.........................................................................................p.233

2. Enter an image file URL in the Image box.

C h a n g i n g  p r o p e r t i e s  o f  l a y o u t  c e l l s

To change the  horizontal alignm ent of th e  con ten ts of a layout cell

1. On the Layout Box Toolbar, click S i (Layout Cell Properties).
2. Under Alignment, click the Horizontal box and select an alignment type.

To change the  vertical alignm ent o f th e  con ten ts of a layout cell

1. On the Layout Box Toolbar, click ¡SJ (Layout Cell Properties).
2. Under Alignment, click the Vertical box and select an alignment type.

To change the  background color of a layout cell

1. On the Layout Box Toolbar, click 23 (Layout Cell Properties).
2. Under Background, click the Color box and select a color (p.233).
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To add a repeating  background im age to  a layout cell

1. On the Layout Box Toolbar, click S  (Layout Cell Properties).
2. Under Background, enter an image file URL in the Image box.

To change a layout cell's m argins

1. On the Layout Box Toolbar, click S i (Layout Cell Properties).
2. Under Margins, enter new values in any or all of the Left, Right, Top, and Bottom boxes.

E l  Margins appear on the inside o f a layout cell, so they affect the size o f its content area but not the size 
o f the cell itself I f  a layout cell also has non-zero borders, the borders are drawn outside the margins.

To change a layout cell's borders

1. On the Layout Box Toolbar, click S i (Layout Cell Properties).
2. Under Borders, enter new values in any or all of the Left, Right, Top, and Bottom boxes.
3. Click the Color box and select a color (p.233).

CD Borders are drawn on the inside o f a layout cell, so they affect the size o f the cell's content area but not 
the size o f the cell itself. I f  a layout cell also has non-zero margins, the margins appear inside the 
borders.

Related topics

Selecting colors..........................................................................................p.233

C o n v e r t i n g  b e t w e e n  l a y o u t  b o x e s  a n d  t a b l e s

To convert a layout box to  a  tab le

• Right-click the layout box’s border and select Convert Layout Box to Table in the shortcut menu.

To convert a tab le  to  a layout box

• Right-click the table, point to Table on the shortcut menu, and then click Convert Table to Layout 
Box.
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U s i n g  a  t a b l e  f o r  l a y o u t

Although novices and intermediate Web authors generally find it easier to use a layout box (p.91) than an 
ordinary table to create a multi-column layout, experienced authors may prefer tables for their familiarity or 
their greater flexibility. Creating a layout table is not difficult, but you do need to be aware of various 
behaviors of tables and cells and how they can affect your layout. Here are some guidelines for using layout 
tables:

Use th e  tab le  draw ing tools

Namo WebEditor's table drawing tools can greatly simplify creating a layout table. Use the Table Pencil to 
draw a single-cell table of the desired size, and then draw column and row borders to create cells for 
content. Use the Table Eraser to merge cells by "erasing” the border between them.

Align con ten t w ith th e  to p s of cells

If you don’t specify the vertical alignment o f content in a cell otherwise, most browsers put content in the 
middle of the cell. For a layout table, you’ll probably want content to start at the top of most cells. To 
specify top vertical alignment in a cell, do this:

1. Right-click the cell and select Layout Cell Properties in the shortcut menu.
2. Click the Vertical alignment box and select Top.

You can select several cells and set the vertical alignment of all of them in one operation.

Pay atten tion  to  borders, m argins, and padding

For layout tables, you'll usually want the borders to be invisible in browsers. After creating a layout table in 
Namo WebEditor, make sure to set the border width to zero (enter 0 in the Border box of the Inspector) to 
make the borders invisible.

In most browsers, the default spacing between cells is 2 pixels, and the default cell padding is 1 pixel. This 
may interfere with your page design if your design calls for adjacent cells to contain images that have no 
space between them. On the other hand, you might want more space between cells that contain text, for 
better readability. You can adjust the cell spacing and padding values for a table in the Inspector.

Note that these values apply to an entire table; pure HTML does not provide a way to control spacing and 
padding on a cell-by-cell basis. For greater control, set both cell spacing and cell padding to zero and use 
the padding properties of cascading style sheets on individual cells as needed.

S3 To hide borders and set cell spacing and padding to zero in one step, click L-1 (Hide Borders) on the 
Inspector.
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Be careful w hen se tting  tab le  and cell w idths

When you create a table using the table drawing tools or the Create Table button on the Standard Toolbar, 
Namo WebEditor automatically sets column widths in absolute, pixel units. However, pixel units are not 
always appropriate for layout tables. If you use only pixel units, your table’s width cannot grow or shrink in 
response to changing browser window sizes, so people who view your page in a small window may have to 
scroll sideways to see all your content. It’s usually best to leave the width of at least one column 
unspecified, so that column can grow or shrink depending on the window size.

In the example below, the ’’content” cell’s width is unspecified, while the table’s width is set to 100%. This 
allows the table width to shrink or grow while the width of the ’’navigation" cell remains fixed.

S  C:\Scratch\tabletesthtnil ' .

banner (width unspecified)

nirigation
(100 pixels wide)

content
(width unspecified)

footer (width unspecified)

<| >l\Etttj( HTML(F6) A PWview /  ll < |_______________ jJ
A layout table using bo th  fixed and unspecified cell w idths

Also, try to avoid specifying table and cell sizes that conflict with one another. Conflicting size settings can 
confuse browsers and lead to unexpected results. For example, avoid specifying a table width that is 
smaller than the combined width of its columns.

Don't rely on cell heigh t

If you specify the height of a row or cell, keep in mind that browsers treat the value as a minimum value 
only. Browsers will always override the specified height of a cell when necessary to show all its contents.

Related topics

Using layout b o x es .................................................................................................. p.91

T ab les......................................................................................................................... p. 182
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U s i n g  f r a m e s

This section deals with creating and using frames. Like layout boxes and tables, Web authors can use 
frames to create complex page layouts. However, the most important aspect of frames is that authors can 
use them to display multiple documents in the same browser window.

In th is section

About frames and framesets.............................................................................. p. 101
Creating a frameset............................................................................................ p. 102
Setting a frame’s initial document.................................................................... p. 103
Saving a frameset................................................................................................p. 104
Printing a frameset............................................................................................. p. 104
Previewing a frameset........................................................................................ p. 104
Resizing frames...................................................................................................p. 105
Adding and removing frames............................................................................p. 106
Setting a frame's default target..........................................................................p. 107
Naming or renaming a frame............................................................................ p. 108
Setting frame margins, scrollbars, and borders...............................................p. 108
Modifying frameset document properties....................................................... p. 109
Adding "noframes" content............................................................................... p.l 10

A b o u t  f r a m e s  a n d  f r a m e s e t s

On the Weby frames are used to display more than one document in the same browser window. Each frame 
in a frameset displays a different document (or different parts of the same document). Frames act almost 
like independent windows: they can be scrolled independently of other frames, and the document appearing 
in one frame can change without affecting other frames.

A typical use of frames is to display a set of links together with the destination of one of those links. 
Clicking a link in the links frame loads its destination in the content frame. Since frames scroll 
independently, a viewer can scroll the content frame while the links in the links frame stay in place. 
Additional frames might be used, for example, to display a banner that always stays at the top of the 
window and a footer that always stays at the bottom of the window.
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: Banner Frame

Content Frame

: Frame
Tbis is whsre the destination of

Link 1 each Enk in the Enks franc

i Link 2 opcn.
Link3

; etc.

A fram eset with b anner, links, and content fram es

Each frame in a frameset must have an initial document (p.l03)—the document that appears in the frame 
when the frameset is first opened in a browser. A frame’s initial document may later be replaced by another 
document in the course of browsing the site. In the example above, the initial document of the content 
frame will be replaced by another document when the user clicks a link in the links frame. An initial 
document does not need to be located on your site; it can be any document on the Web.

To open a frameset in a browser, you open the frameset document—this is the document that contains the 
information the browser needs to display the frames and fill them with content from other sources. The 
frameset document itself normally does not appear in the browser window, although its URL appears in the 
browser’s address bar. However, if a browser does not support frames, then it will display the contents of a 
<noframes> element (p.l 10) in the frameset document.

О  To link to a frameset, use the URL o f the frameset document. Similarly, to use a frameset as the default 
document for a site, specify the fde name o f the frameset document in your Web server’s default 
document setting (or rename the frameset document to index.html).

C r e a t i n g  a  f r a m e s e t

To create  a fram eset

1. Do one of the following:
o On the File menu, click New, and then click the Frameset folder, 
o On the Frame menu, click New Frameset.

2. Click a frameset template and then click OK.
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When you create a new frameset, Namo WebEditor opens the frameset in Edit mode and displays a new, 
blank document in each frame. At this point, you should specify the initial document (p. 103) for each frame 
and then save (p. 104) the frameset. If you have not yet created the initial documents, you can go ahead and 
compose them directly in each frame. When you save a document in a frame, Namo WebEditor 
automatically sets that frame's initial document to the saved document.

Related topics

Setting a frame's initial document.....................................................................p. 103
Saving a frameset................................................................................................p. 104
Adding and removing frames............................................................................ p. 106

□  Namo Web Editor will not create a new fram eset i f  one is already open.

S e t t i n g  a  f r a m e ' s  i n i t i a l  d o c u m e n t

Each frame in a frameset must have an initial document—the document that appears in the frame when the 
frameset is first opened in a browser.

To se t th e  initial docum ent for a fram e

• If you are composing the initial document in the frame, simply save the document (p. 104). The 
initial document URL will be set automatically.

• If you want to set the initial document to an existing document, do this:
1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Open Document in Frame.
3. Select a local file or enter a URL in the URL box and press Enter.

Each time you open a document in a frame, Namo WebEditor sets the initial document for that frame to the 
opened document.

To view the initial docum ent URL for a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.

The initial document URL is shown in the Source path box.

Ë3 The initial document URL for each frame is stored in the frameset document. Therefore, to save the 
initial document URLs, you must save the frameset document (p. 104).
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S a v i n g  a  f r a m e s e t

To save a complete frameset, you need to save both the frameset document and the documents in the 
frames, if any of them are local files.

To save th e  fram eset docum ent

1. On the Frame menu, click Save Frameset.
2. If you have not previously saved the frameset, type a file name and press Enter.

To save a docum ent in a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the File menu, click Save.
3. If you have not previously saved the document, type a file name and press Enter.

To save docum ents in all fram es

1. On the Frame menu, click Save All Frames.
2. For each document that was not previously saved, type a file name and press Enter.

P r e v i e w i n g  a  f r a m e s e t

When you are working on a frameset, the Preview tab that normally appears at the bottom of the main 
window is replaced by the Frameset Preview tab. Click this tab to preview the entire frameset.

P r i n t i n g  a  f r a m e s e t

To view a prin t preview  of a fram eset

1. On the Frame menu, click Frameset Print Preview.
2. When done, click Close.

To print a fram ese t

1. On the Frame menu, click Print Frameset.
2. Choose the desired options and click OK.
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To print th e  docum ent in a particular fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the File menu, click Print.
3. Choose the desired options and click OK.

Related topics

Printing documents............................................................................................ p.66

R e s i z i n g  f r a m e s

To resize a fram e using th e  m ouse

• Drag a frame border. (The pointer should look like v  or *\\* before you begin dragging.)

To specify an  exact w idth or height for a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. Enter a number in the Frame width or the Frame height box.
4. Click the corresponding units box and select a unit:

o Select Pixels to specify a size in pixels. The frame size will stay the same if the browser 
window is resized.

o Select % to specify a size as a percentage of the width or height of the browser window. 
The frame size will vary in proportion to the browser window size.

o Select ‘(relative) to specify a size in relation to the sizes of other frames. Only integer 
values are accepted.

About relative sizes

When you specify frame sizes in relative terms, the size values act as relative proportions. In the example 
below, Frame A has a relative height of 2, so it is twice as high as Frame B, which has a relative height of 1. 
Frame C has an absolute height in pixels. If only some frames have relative sizes while others have 
absolute sizes along the same dimension, then the relatively-sized frames share the space that remains after 
subtracting the space occupied by the absolutely-sized frames.
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H d :8 !(3
A

Frame A
(height = *2)

,V

Franc B A

(haght = *l) V

Frame C
A

(heigh! = 100 pixels)

V

An example of relative frame sizing

^  I f  you specify the width or height o f one or more frames in pixels, it is a good idea to set the size o f at 
least one other frame to *1 in the same dimension, so that it can shrink or grow as needed for different 
browser window sizes.

A d d i n g  a n d  r e m o v i n g  f r a m e s

Although the frameset templates included with Namo WebEditor cover the most common frame layouts, 
you may still need to add frames to or remove frames from a frameset in order to meet your design goals. 
To add a frame, you simply split an existing frame in two. Removing a frame causes an adjacent frame to 
grow, filling the space previously occupied by the removed frame.

To add a fram e above o r below an existing fram e

1. Click inside the frame above or below which you want to add another frame.
2. On the Frame menu, point to Split Frame, and then click Top or Bottom (depending on whether 

you want the new frame to be above or below the existing frame).

To add a fram e to  th e  left or right of an  existing fram e

1. Click inside the frame next to which you want to add another frame.
2. On the Frame menu, point to Split Frame, and then click Left or Right (depending on whether you 

want the new frame to be to the left or to the right of the existing frame).
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To remove a fram e

1. Click inside the frame you want to remove.
2. On the Frame menu, click Delete Frame, and then click OK.

Oil You cannot undo a frame add or remove operation using the Undo command. To restore a removed 
frame, close the frameset without saving and then reopen it. Note that any other changes you made to 
the frameset will be lost.

S e t t i n g  a  f r a m e ' s  d e f a u l t  t a r g e t

The target (p. 170) attribute of a hyperlink is used to instruct browsers where to open the link’s destination. 
For example, the target of a link might tell browsers to open the destination in a frame named 
"article_view". If not specified, the target of any hyperlink is the window or frame containing the link. In a 
frameset, however, it is often desirable to have the destinations of hyperlinks in one frame open in another 
frame. Although it is possible to manually set the target for each hyperlink in a frame, it is much more 
convenient to set a default target for the frame. If a frame has a default target, every hyperlink in that frame 
will open in the specified target frame unless the link has its own, different specified target.

To se t th e  default ta rg e t of a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. In the Default target box, type the name of a frame. To select a frame visually, click E&i (Select 

Target Frame).

Four special targets can be selected if you click the triangle on the Default target box:
_blank Links will open in a new window.
_parent Links will open in the frame's "parent", replacing the frameset. The parent is usually the

browser window, but if the frameset is being displayed in a frame of another frameset, then the 
parent is the containing frame in the higher-level frameset.

_self Links will open in the current frame.
_top Links will open at the topmost level o f the current window (replacing all framesets).

To override th e  defau lt ta rg e t for a specific hyperlink

1. Double-click the hyperlink.

2. In the Target box, enter the name of a frame. To select a frame visually, click Isi (Select Target 
Frame).
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Related topics

Setting a link's target window or fram e............................................................p. 170
Setting a default target for hyperlinks...............................................................p.240
Naming or renaming a frame............................................................................. p. 108

N a m i n g  o r  r e n a m i n g  a  f r a m e

Each frame in a frameset can optionally have a name, which is used when referring to the frame in the 
target attribute (p. 170) of a hyperlink or the default target setting (p. 107) of another frame. If you create a 
frameset using one of the templates supplied with Namo WebEditor, each frame already has a default name 
(which you can change). However, if you add a frame to a frameset, the new frame initially has no name; if 
you want to use the frame as a link target, you need to give it a name.

To nam e or renam e a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. Enter a name in the Name box. The name must begin with a letter (A-Z or a-z).

Related topics

Adding and removing frames.....................................................................p. 106
Setting a frame’s default target...................................................................p. 107

S e t t i n g  f r a m e  m a r g i n s ,  s c r o l l b a r s ,  a n d  b o r d e r s

You can adjust the left and top margins of a frame (the empty space between a frame’s borders and its 
content) in pixel units. If you don't specify the margins, Web browsers apply their own default margins.

To specify th e  left or top  m argin of a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. Enter a number of pixels in either or both of the Left margin and Top margin boxes.

You can specify for each frame in a frameset whether it should have scrollbars. The Auto setting means 
scrollbars will appear only when necessary.
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To specify scrollbars for a fram e

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. Click the Scrollbar box and select an option.

You can specify the width of the border around every frame in a frameset, and whether users can resize a 
frame by dragging its border.

To se t the  border w idth (applies to  all fram es)

1. On the Frame menu, click Frame Properties.
2. Enter a number of pixels in the Border thickness box.

To specify w he ther a fram e can be resized

1. Click inside the frame to make it active. (The active frame is shown with a blue border.)
2. On the Frame menu, click Frame Properties.
3. Select or clear the Enable frame resizing in browser check box.

Related topics

Modifying frameset document properties........................................................p. 109

M o d i f y i n g  f r a m e s e t  d o c u m e n t  p r o p e r t i e s

Like any other Web document, a frameset document has various properties that apply to the document as a 
whole. However, most of the properties of a frameset document have no effect in Web browsers that 
support frames—most of the properties are only relevant when a browser does not support frames and thus 
displays the content of the frameset document itself rather than the frames it defines.

Some properties of frameset documents do take effect, even when the frameset is opened in a browser that 
supports frames. These properties are listed below.

• In the General tab:
o Title — The frameset document’s title is displayed in the browser’s title bar.
o Author, Classification, Description, and Keywords — Although these properties have no 

effect in a browser, they can be used by Internet search engines to find and categorize the 
frameset document.

• In the Styles tab:
o Page transitions — The selected effect will occur when the frameset is opened.
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o Background sound — The specified sound will play when the framset is opened.
• In the Advanced tab:

o Auto refresh/redirect — When the frameset is opened, the specified URL will be opened 
automatically after the specified length of time.

To modify fram eset docum ent properties

• On the Frame menu, click Frameset Properties.

Related topics

Document properties..........................................
Setting frame margins, scrollbars, and borders

A d d i n g  " n o f r a m e s "  c o n t e n t

When a frameset is opened in a Web browser that does not support frames, the browser will instead display 
the content of the <noframes> element in the frameset document, if present. The <noframes> element can 
contain anything that an ordinary document can contain—text, images, and so forth.

When you create a frameset, Namo WebEditor automatically adds a brief message as the noframes content. 
To change the noframes content, click the NOFRAMES Content tab at the bottom of the main window and 
enter the desired content. (This tab is initially hidden. To reveal it, on the View menu, point to Mode Tabs, 
and then click Show AN.)

To save the noframes content, save (p. 104) the frameset.

You cannot preview noframes content in Namo IVebEditor's Preview mode. To preview your noframes 
content, open the frameset document in a browser that does not support frames.

.p.236 

.p. 108
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U s i n g  l a y e r s

In HTML, a layer is a container for other elements, such as paragraphs, images, tables, and so forth. Layers 
have two noteworthy properties:

• The position of a layer is explicitly specified.
• Layers can overlap each other and other elements.

You can think of a layer as a movable box that you put content into and that you can place anywhere on a 
page. Layers are a powerful, yet intuitive way to create complex page layouts, since you can put anything 
in a layer and simply drag the layer wherever you want.

An example of a layer overlapping other content

In th is section

Creating and positioning a layer........................................................................p.l 12
Resizing a layer...................................................................................................p. 114
Adding content to a layer.................................................................................. p. 114
Deleting a layer...................................................................................................p. 115
Setting a layer’s Z-order.................................................................................... p. 115
Setting a layer's initial visibility........................................................................p.l 16
Changing a layer's ID.........................................................................................p.l 16
Setting a background color or image on a layer............................................. p.l 17
Setting borders, margins, and padding for a layer.......................................... p.l 17
Aligning and distributing multiple layers........................................................ p.l 18
Using the Layers window.................................................................................. p.l 19

Using layers 111



Ñamo WebEditor 6 User Manual

Related topics

Using floating boxes...........................................................................................p. 121
Adding JavaScript effects.................................................................................. p.288
Creating timelines............................................................................................... p.316

Deciding which tag to use for layers.............................................................p.l 19

C r e a t i n g  a n d  p o s i t i o n i n g  a  l a y e r

To crea te  a layer

1. Place the insertion point anywhere in the document.

2. Click -3 (Insert Layer) on the Standard Toolbar.

A new layer will appear above the paragraph that contained the insertion point, and the insertion point will 
be moved inside the layer. If the display of special tag marks is enabled, a layer mark ( I@1) will indicate 
the location of the layer tag in the document.

The new layer has a transparent background (p.l 17), so if there is any content below the point where you 
inserted the layer, it will be visible through the layer.

By default, in Edit mode, layers are shown with gray outlines so that you can see their boundaries. This 
outline is not visible when the document is viewed in a browser. To hide layer outlines: On the View menu, 
point to Marks, and then click Layer Outlines.

El

Я

The location o f the layer tag has no relationship to the position o f a layer. You can insert a layer tag 
anywhere in a document, and you can move the layer to any position, independently o f the layer tag. 
However, note that deleting the layer tag deletes the layer.

I f  you find layer marks distracting, you can hide them: Click £3 (Show/Hide Special Tag Marks) on the 
Standard Toolbar.

To position a layer

1. Click inside the layer to reveal its handle—the small box at the top left comer of the layer. (The 
handle is only visible when the layer is selected or the insertion point is inside it.)

2. Drag the handle. A dotted outline of the layer follows the pointer. Stop dragging when the layer is 
in the desired position.
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Position a layer by dragging 

is handle--the small box at 

he top left comer.
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Positioning a layer by dragging its handle

y  You can also drag a layer by its outline. When the pointer is over the outline, it turns into a hand to 
indicate that dragging is possible.

To move a layer one pixel a t  a tim e

1. Click the layer’s outline or layer mark to select it.
2. Press any of the arrow keys. Each keypress will move the layer one pixel in the corresponding 

direction.

*i
*i*
?«i*»■
*

To specify th e  exact position of a  layer

1. Click the layer’s outline or layer mark to select it.
2. On the Inspector, enter numbers representing the distance of the layer from the document’s left and 

top edges, respectively, in the X and Y boxes.

E3 You can enter negative values for a layer's X  and/or Y position. This will place the layer partially or 
completely outside the document boundaries. To reposition a layer that is completely outside the 
document boundaries, click the associated layer mark and enter a new position in the Inspector.
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R e s i z i n g  a  l a y e r

To resize a layer

1. Click the layer's handle or outline to reveal its resize handles.
2. Drag any resize handle.

D ....................,
)R.esize a layer 1Lesize a layer by dragging
i
'¡any o f its resize handles.

Resizing a layer

To specify an exact size for a layer

1. Click the layer's outline or layer mark to select it.
2. On the Inspector, enter numbers of pixels in the Width and Height boxes.

To ad just th e  size of a layer to  fit its contents

1. Click the layer's outline or layer mark to select it.
2. Do one of the following:

o On the Format menu, point to Layout, and then click Fit to Contents, 

o On the Layout Toolbar, click a  (Fit to Contents).

G3 You can specify any width for a layer, but you cannot set its height so small that all o f its contents 
would not fit vertically. Even if  you enter the height value in the Inspector or in HTML mode, Namo 
WebEditor will automatically readjust the height to fit the layer's contents vertically. I f  you resize a 
layer by dragging its resize handles, Namo WebEditor will not allow the bottom boundary o f the layer 
to be moved above the bottom o f the layer's contents.

A d d i n g  c o n t e n t  t o  a  l a y e r

To start adding content to a layer, click inside the layer to place the insertion point in it.

114 Using layers



Chapter 3: Laying Out Web Pages

You can put any kind of content into a layer that you can put into a document—text, images, multimedia, 
tables, forms, and so forth. You can also use most of the same methods to insert content into a layer that 
you can with a document, including typing, pasting, and drag-and-drop.

As you add content to a layer, its height will grow automatically to accommodate the content.

Related topics

Resizing a layer................................................................................................... p. 114

D e l e t i n g  a  l a y e r

To delete  a layer

1. Click the layer's outline or layer mark to select it.
2. Press Del.

When you delete a layer, Namo WebEditor replaces it with an empty paragraph. This paragraph is safe to 
delete.

S e t t i n g  a  l a y e r ' s  Z - o r d e r

Since layers can overlap each other, it is sometimes necessary to specify exactly in what order several 
layers should overlap. You do this by specifying each layer's Z-index. Z-indexes are positive or negative 
integers. A layer with a higher Z-index will display on top of a layer with a lower Z-index. If two or more 
layers have the same Z-index, their relative Z-positions are determined by the order of their layer marks in 
the document (that is, the order of their layer tags in the document source): the layer with the last layer 
mark is topmost.

To se t a layer's Z-order

1. Click the layer's outline or layer mark to select it.
2. On the Inspector, enter a whole number in the Z-index box.
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S e t t i n g  a  l a y e r ' s  i n i t i a l  v i s i b i l i t y

You can specify that a layer be initially invisible when the document is opened in a browser. Later, a script 
(p.288) can make the layer visible as a result of some event (p.304), such as the user clicking a link.

You can specify any of four initial states for the visibility of a layer:
• Show: The layer is initially visible.
• Hide: The layer is initially invisible.
• Inherit: The initial visibility of the layer is the same as that of its parent element.
• Default: (same as Show)

To se t a layer's initial visibility

1. Click the layer's outline or layer mark to select it.
2. On the Inspector, click the Visibility box and select an option.

To select a  hidden layer

Do one of the following:
• Click its layer mark.
• Click its name in the Layers window. (To open the Layers window: On the Window menu, click 

Panels and then select Layers.)

Q  Although a hidden layer is invisible, it still "takes up space" in one sense: I f  a hidden layer extends 
beyond the bottom or right edge o f the browser window, the browser's scrollbar(s) will be enabled as if  
the layer were visible. I f  you wish to avoid this, you can set the layer's display property to "none" in 
HTML mode instead o f using the Visibility option.

Related topics

Adding JavaScript effects..........................................................................p.288

C h a n g i n g  a  l a y e r ' s  I D

Each layer in a document can have a unique ID, which is used to refer to the layer in a script (p.288). Namo 
WebEditor automatically generates unique IDs for layers when you create them: l a y e r l ,  l a y e r 2 ,  and so 
forth. You can change the ID of a layer, for example to give it an ID that better describes its function. An 
ID must begin with a letter and may contain letters, digits, hyphens, underscores, colons, and periods.
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1. Click the layer's outline or layer mark to select it.
2. On the Inspector, type a new ID in the ID box.

Related topics

Adding JavaScript effects................................................................................. p.288
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S e t t i n g  a  b a c k g r o u n d  c o l o r  o r  i m a g e  o n  a  l a y e r

By default, layers have transparent backgrounds, allowing any document content or background "under" 
the layer to show through them. You can change this behavior and make a layer opaque by assigning it a 
background color or image.

To se t a background color on a layer

1. Double-click the layer's outline or layer mark.
2. Under Background, click the Color box and select a color (p.233).

To se t a background image on a layer

1. Double-click the layer's outline or layer mark.
2. Enter an image path or URL in the Image box.

GD I f  you set a background image that is smaller than the layer, the image repeats to fill the layer by 
default. I f  you do not want the background image to repeat, switch to HTML mode and insert the 
background-repeat cascading style sheets property with a value o f vno-repeat” in the layer's style 
attribute.

Related topics

Selecting colors...................................................................................................p.233

S e t t i n g  b o r d e r s ,  m a r g i n s ,  a n d  p a d d i n g  f o r  a  l a y e r

To se t borders, m argins, and padding for a layer

1. Click the layer's outline or layer mark to select it.
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2. On the Format menu, click Borders & Background.

Related topics

Setting margins, padding, and borders..............................................................p.222

A l i g n i n g  a n d  d i s t r i b u t i n g  m u l t i p l e  l a y e r s

You can align, distribute, and resize layers with respect to each other using the Layout Toolbar or the 
commands in the Layout submenu of the Format menu. To reveal the Layout Toolbar, in the View menu, 
point to Toolbars, and then click Layout.

-J |3i sS| | m

The L ayout T oolbar

To align tw o or m ore layers w ith each o ther

1. Select each layer by clicking its outline while holding down the Shift key.
2. Click one o f the alignment buttons (the first six buttons) on the Layout Toolbar.

The layers will be aligned with respect to the last selected layer.

To evenly d istribu te  th ree  or m ore layers

1. Select each layer by clicking its outline while holding down the Shift key.

2. On the Layout Toolbar, click M  (Space Across) or X  (Space Down).

G!D Overlapping layers cannot be distributed. Please make sure no layers overlap before using this 
command.

To m ake tw o or m ore layers th e  sam e size

1. Select each layer by clicking its outline while holding down the Shift key.
2. On the Layout Toolbar, click 0  (Make Same Width), E  (Make Same Height), or 83 (Make Same 

Size).

The layers will be resized to the same size as the last selected layer.
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U s i n g  t h e  L a y e r s  p a n e l

The Layers panel displays a list of the layers in the current document. You can see basic information about 
all the document's layers at a glance, and you can click an item in the list to select the corresponding layer 
or double-click an item to access the layer's properties.

To open the Layers panel: On the View menu, point to Panels, and then click Layers.

[3
Snap to layer

ID I Z I Visibility 1
layerl 1
Iayer2 0 Hide
Iayer3 2 Show

Iayer4 1 Inherit
Iayer5 •1

The Layers panel

The layer list includes the name, Z-index, and visibility attribute of each layer. If a layer is a child of 
another layer (that is, its layer mark is inside another layer), the name of the layer will appear indented 
under the name of its parent. Click an item in the list to select the corresponding layer. Double-click an 
item to open the Layer Properties dialog box for the corresponding layer.

If you select the Layers snap to each other check box at the top of the window, then layers will "snap" to 
each other when you drag them—that is, when you drag a layer within six pixels of another layer, the layer 
you are dragging will move automatically so that its boundary touches the boundary of the stationary layer.

D e c i d i n g  w h i c h  t a g  t o  u s e  f o r  l a y e r s

By default, Namo WebEditor represents layers using <div> elements in the document's HTML source. This 
behavior conforms to the World Wide Web Consortium's HTML 4.01 recommendation and is well 
supported by contemporary browsers. However, versions of Netscape browsers earlier than 6 do not 
correctly support the <div> tag. To work around this problem, Namo WebEditor gives authors the option to 
use <layer> elements to represent layers. The <layer> tag is a Netscape-only tag that is supported by 
Netscape 4.x browsers.

l ^ r Ü s t& ,ß
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Unfortunately, the < layer> tag is not supported by  N etscape 6 and later, and it is not supported at all by  
Internet Explorer and other browsers. Therefore, use caution w hen choosing the <Iayer> tag to represent 
layers. Y ou  should prefer the default <d iv>  tag and use <layer> on ly  in docum ents that are designed  
specifica lly  for users o f  older N etscape versions.

T h ere  is no  w a y  to  f o r c e  a l l  la y e r s  to  u se  <layer> ta g s  in o n e  s te p . I f  y o u  h a v e  m o re  than  o n e  la y e r  in a  
d o c u m en t a n d  y o u  w a n t a l l  o f  them  to  u se  <layer> tags, y o u  m u st f o l lo w  th e  s te p s  g iv e n  a b o v e  f o r  each  
la ye r .
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U s i n g  f l o a t i n g  b o x e s

A  floating box is a container for content around w hich  other content flow s. The effect o f  a floating b ox  is to 
"push" the content fo llow ing  it to the side. In the exam ple below , the dark text is inside a floating box; the 
light gray text is in paragraphs before and after the floating box. A  gray border has been added to the  
floating box to highlight its boundaries.

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed 
do eiusmod tempor incididunt ut labore et dolore magna 
aliqua. Ut enim ad minim veniam, quis nostrud exercitation 
ullamco laboris nisi ut aliquip ex ea commodo consequat.

Duis aute irure dolor in 
reprehenderit in voluptate 
velit esse ¿Hum dolore eu 
fugiat nulla pariatur.
Excepteur sint occaecat 
cupidatat non proident, 
sunt in culpa qui officia 
deserunt mollit anim id est 
laborum. Lorem ipsum dolor 

sit amet, consectetur adipisicing elit, sed do eiusmod tempor 
incididunt ut labore et dolore magna aliqua. Ut enim ad 
minim veniam, quis nostrud exercitation ullamco laboris nisi 
ut aliquip ex ea commodo consequat.
A floating box exam ple

Floating boxes can be aligned on either the left or the right side, but not the m iddle, o f  the parent container. 
N ote that a floating box only "pushes aside" content that fo llow s it, not content that precedes it.

In this section
Creating and positioning a floating b o x .............................

Resizing a floating box..........................................................

Adding content to a floating box .........................................

Deleting a floating box ..........................................................

Setting a floating box's initial visibility..............................

Setting a background color or image on a floating box...

Setting borders, margins, and padding for a floating box

Related topics
Using layers............................................................................................................. p . l l l

p. 122 

p .122 

p .123 

p. 124 

p.124 

p .125 

p .125

This text is in a floating box. 
Any content that follows a 
floating box "flows" around it, 
as a stream flows around a 
rock. Of course, rocks don't 
float, unless they're very 
small, but what can you do.
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C r e a t i n g  a n d  p o s i t i o n i n g  a  f l o a t i n g  b o x

To create a floating box

1. Place the insertion point in the (first) paragraph you want the floating box to float next to.

2. On the Insert m enu, click  Floating Box.

An empty box w ith a gray outline w ill appear in front o f  the paragraph that contained the insertion point, 
and the insertion point w ill be m oved inside the box. I f  the display o f  special tag marks is enabled, a

floating box mark ( O ) w ill mark the location o f  the floating box elem ent in the document.

B y default, in Edit m ode, floating boxes are show n w ith gray outlines so  that you can see their boundaries. 
This outline is not v is ib le  w hen the docum ent is v iew ed in a browser. To hide floating box outlines: On the 
View menu, point to Marks, and then click Layer Outlines.

^  I f  y o u  f in d  f lo a t in g  b o x  m a rk s  d is tra c tin g , y o u  can  h id e  th em : C lic k  □  (Show/Hide Special Tag Marks) 
on th e  S ta n d a rd  T oo lbar.

To position a floating box

1. Select the floating box by click ing its outline.

2. On the Inspector, click the Position box and select Left or Right.

To move a floating box

1. Select the floating box by click ing its outline.

2. On the Edit m enu, click Cut. (Or press Ctrl+X.)

3. Place the insertion point at the beginning o f  the (first) paragraph you want the floating box to float 
next to.

4. On the Edit m enu, click P aste. (Or press Ctrl+V.)

0  W hen y o u  p a s te  a  f lo a tin g  b o x , N a m o  W e b E d ito r  in se r ts  a  b la n k  p a ra g r a p h  a b o v e  it. You ca n  sa fe ly  
d e le te  th is  e m p ty  p a ra g ra p h .

R e s i z i n g  a  f l o a t i n g  b o x

To resize a floating box

1. C lick the floating box’s outline to reveal its resize handles.

2. Drag any resize handle.
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W hen you finish dragging, the content surrounding the floating box w ill reflow  around it.

r ................ ......... l - . - C ................................... 9
To resize a floating box, Lorqm ipsi

i
drag any o f its resize magtia aliq 

i “n
handles. conslequat.

•Excepteur sint occaecat cupidatat nor 

consecteto adipisicing elit, sed a!o eiu 

exercitation ullamco laboris nisi ut aliq 
Resizing a floating box

To specify an exact size for a floating box

1. Click the floating box's outline to select it.

2. On the Inspector, enter num bers o f  p ixels in the Width and Height boxes.

mtv
liiJ  You can  sp e c ify  a n y  w id th  f o r  a  f lo a t in g  b o x , b u t y o u  ca n n o t s e t  its  h e ig h t s o  sm a ll  th a t a l l  o f  its

c o n ten ts  w o u ld  n o t f i t  v er tica lly . E v en  i f  y o u  e n te r  the h e ig h t v a lu e  in th e  In sp e c to r , N a m o  W eb E d ito r  
w ill  a u to m a tic a lly  r e a d ju s t the h e ig h t to  f i t  th e  f lo a tin g  b o x 's  c o n ten ts  v e r tica lly . I f  y o u  r e s iz e  a  f lo a t in g  
b o x  b y  d ra g g in g  its  r e s ize  h a n d le s , N a m o  W eb E d ito r  w ill  n o t a l lo w  th e  b o tto m  b o u n d a ry  o f  th e  f lo a t in g  
b o x  to  b e  m o v e d  a b o v e  th e  b o tto m  o f  its  co n ten ts .

A d d i n g  c o n t e n t  t o  a  f l o a t i n g  b o x

To start adding content to a floating b ox , click  inside the floating box to place the insertion point in it.

Y ou can put any kind o f  content into a floating box that you can put into a document?text, im ages, 
multim edia, tables, forms, and so forth. Y ou  can also use m ost o f  the sam e m ethods to insert content into a 
floating box that you can with a docum ent, including typing, pasting, and drag-and-drop.

A s you add content to a floating box, its height w ill grow autom atically to accom m odate the content.

Related topics
Resizing a floating box ........................................................................................... p. 122
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D e l e t i n g  a  f l o a t i n g  b o x

To delete a floating box

1. C lick the floating box's outline or floating tag mark to select it.

2. Press D el.

W hen you delete a floating box, N am o W ebEditor m ay replace it w ith an empty paragraph. This paragraph 
is safe to delete.

S e t t i n g  a  f l o a t i n g  b o x ' s  i n i t i a l  v i s i b i l i t y

Y ou can  specify  tha t the con ten ts o f  a floating  box  be in itia lly  inv isib le  w hen  the docum en t is opened  in a 
b row ser. L ater, a  sc rip t (p.288) can  m ake the floa ting  box  conten ts v is ib le  as a resu lt o f  som e even t (p.304), 
such as the u se r c lick ing  a  link.

Y ou can specify  any o f  four initial states for the v isib ility  o f  a floating box's contents:

•  Show : T he co n ten ts  are in itia lly  v isib le.

•  Hide: The contents are initially invisible.

• Inherit: The initial v isib ility  o f  the contents is the sam e as that o f  the floating box's parent elem ent.

• Default: (sam e as Show)

GD E ven  i f  the  c o n te n ts  o f  a  f lo a t in g  b o x  a re  in v is ib le , the  f lo a tin g  b o x  ta k es  up s p a c e  e x a c tly  a s  i f  its  
c o n ten ts  w e re  v is ib le .

To set a floating box's initial visibility

1. Click the floating box's outline or floating tag mark to select it.

2. On the Inspector, c lick  the Visibility box and select an option.

To select a hidden floating box

Y ou cannot select a hidden floating box by click ing its outline, because the outline is also hidden. To select 
a hidden floating box, click  the corresponding floating box mark. (I f  the display o f  special tag marks is off, 
turn it on by clicking □  (Show/Hide Special Tag Marks) on the Standard Toolbar.) The floating box w ill 
becom e temporarily v is ib le  as long as it is selected.

Related topics
Adding JavaScript effects..........................................................................p.288
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S e t t i n g  a  b a c k g r o u n d  c o l o r  o r  i m a g e  o n  a  f l o a t i n g  

b o x

B y default, floating boxes have transparent backgrounds, allow ing the document's background to show  
through them. Y ou can change this behavior and make a floating box opaque by assigning it a background 
color or image.

To set a background color on a floating box

1. D ouble-click the floating box's outline or floating tag mark.

2. Under Background, click the Color box and select a color (p.233).

To set a background image on a floating box

1. D ouble-click the floating box's outline or floating tag mark.

2. Enter an im age path or URL in the Image box.

3  I f  y o u  s e t  a  b a c k g ro u n d  im a g e  th a t is  s m a lle r  than  th e  f lo a tin g  b o x , th e  im a g e  re p e a ts  to  f i l l  the f lo a t in g  
b o x  b y  d e fa u lt. I f  y o u  d o  n o t w a n t the  b a c k g ro u n d  im a g e  to  re p e a t, sw itc h  to  H T M L  m o d e  a n d  in se r t  
th e  b a c k g ro u n d -re p e a t c a sc a d in g  s ty le  sh e e ts  p r o p e r ty  w ith  a  v a lu e  o f f,n o -r e p e a tn in the  f lo a t in g  box's 
style a ttr ib u te .

Related topics
Selecting colors........................................................................................ p.233

S e t t i n g  b o r d e r s ,  m a r g i n s ,  a n d  p a d d i n g  f o r  a  f l o a t i n g  

b o x

To set borders, margins, and padding for a floating box

1. Click the floating box's outline or floating tag mark to select it.

2. On the Format menu, click Borders & Background.

Related topics
Setting margins, padding, and borders...................................................... p.222
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4 Basic Page Content and 
Formatting

M ultim edia and D ynam ic HTM L m ay be all the rage these days, but the m ost important content W eb  
content still consists o f  the basics: text and im ages. Just as basic, and just as important, are the hyperlinks 
that connect everything on the W eb. A nother standard feature o f  m any W eb pages is tables, w hich g iv e  
authors a w ay to present com plex inform ation in an organized and easy-to-read w ay. In this section, w e ’ll 
take a look at all o f  these basic W eb elem ents, along w ith w ays to control the w ay they look in the browser  
w indow .

In this section
Text elem ents........................................................................................................... p. 128

Im ages........................................................................................................................p. 137

Hyperlinks and bookm arks....................................................................................p. 164

Tables.........................................................................................................................p.182

Formatting content.................................................................................................. p .210

Document properties...............................................................................................p.236
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T e x t

On the W eb, not all text is created equal. Like a book, a W eb page can contain not only ordinary 
paragraphs but also headings, bulleted or numbered lists, and so forth. Fortunately, HTML includes several 
kinds o f  text elem ents for different purposes. It's important to use the right kind o f  elem ent for the job.

In this section
Paragraphs.................................................................................................................p. 128

H eadings.................................................................................................................... p. 129

L ists ............................................................................................................................ p. 129

Preformatted te x t..................................................................................................... p. 134

Addresses................................................................................................................... p. 135

Definition lis ts ..........................................................................................................p. 136

Related topics
Formatting content...................................................................................................p.210

P a r a g r a p h s

Paragraphs are the m ost basic text elem ents in HTML. A  paragraph is a block o f  text (although it m ay also 
include im ages and other inline elem ents) that, by default, has no special formatting. W henever you enter 
text (by typing or pasting) in Edit m ode without applying a particular HTML style, N am o W ebEditor 
autom atically creates a paragraph elem ent to contain the text. Pressing Enter com pletes the current 
paragraph and starts another. B y  default, paragraphs are separated from each other and other elem ents by  
w hite space above and below . The exact size o f  this space is determined by the W eb browser unless you  
specify  a particular top and/or bottom  margin (p.222).

To s ta r t  a  n e w  lin e  o f  tex t w ith o u t s ta r t in g  a  n e w  p a ra g r a p h , p r e s s  S h i f t + E n t e r .

To modify common paragraph properties:

•  On the Format menu, click  Paragraph.

Related topics
Setting paragraph indentation and line height 

Setting margins, padding, and borders...........
.p.221
.p.222
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H e a d i n g s

A  heading is a text b lock  that is generally used as a title or label for content that fo llow s it. For exam ple, 
the word "Headings" above is the heading for this section  o f  the N am o W ebEditor documentation. H TM L  
provides six  heading levels, intended to distinguish different levels o f  content in a hierarchically-organized  
document.

B y default, browsers typically display headings in bold type. L ev e l-1 headings use the largest font s ize , and 
successive heading levels use su ccessively  sm aller font sizes. A s w ith other text elem ents, all visual 
properties o f  headings can be altered using cascading style sheets (p.210).

To create a heading:

1. Place the insertion point in an em pty line.

2. On the Inspector or the Formatting Toolbar, click  the Element box and select any o f  Heading 1 
through Heading 6.

3. Type the heading.

To change the level of a heading:

1. Place the insertion point in the heading w h ose  level you want to change.

2. On the Inspector or the Formatting Toolbar, c lick  the Element box and select any o f  Heading 1 
through Heading 6.

To change a paragraph or other text element into a heading:

1. Place the insertion point in the text elem ent you  want to change to a heading.

2. On the Inspector or the Formatting Toolbar, c lick  the Element box and select any o f  Heading 1 
through Heading 6.

L i s t s

A  list in HTML is com posed o f  tw o or m ore consecutive blocks o f  text (the list items) that have bullets or 
numbers autom atically inserted at the beginning o f  each item. Items in ordered lists are preceded b y  
numbers, w hile item s in unordered lists are preceded by bullets. A  list item  may itse lf  contain a list, thus 
allow ing lists to be nested hierarchically.
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T o d a y 's  A g e n d a

-»1. Read newspaper.

2. Play with dog.

3. Shop for groceries:

-+ •  hot dogs

• broccoE

• orange juice

4. Watch L ord  o f  the Rings.

A num bered (o rdered) list. The th ird  item contains a bulleted (unordered) list. In E dit mode, the beginning of 
each list is m arked  w ith  a red  arrow .

In this section
Creating lists ..............................................................................................................p. 130

Creating nested lists .................................................................................................p.131

Splitting and merging lis ts ..................................................................................... p.131

Modifying bullets and numbering.........................................................................p. 132

Using an image as a bu lle t..................................................................................... p. 133

C r e a t i n g  l i s t s

To create a numbered or bulleted list:

1. Place the insertion point in an em pty line.

2. On the Inspector or the Formatting Toolbar, click the Element box and select Bulleted List or 
Numbered List.

3. Enter the text o f  each list item , pressing Enter after each item.

4. Press E nter tw ice to exit the list.

To convert paragraphs into a list:

1. Select the paragraphs you want to convert into a list.

2. On the Inspector or the Formatting Toolbar, click the HTML Style box and select Bulleted List or 
Numbered List.

Related topics
Creating nested lists .................................................................................................p.131
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Splitting and merging lis ts .................................................................................... p.131

Modifying bullets and numbering........................................................................p. 132

Using an image as a bu lle t.....................................................................................p. 133

C r e a t i n g  n e s t e d  l i s t s

A list item  can itse lf  contain a list. Such a list-within-a-list is called a nested list. List items can be 
promoted (m oved from a nested list to its parent list) or demoted (m oved from a parent list to a nested list).

To create a nested list:

1. Press Enter inside a list to start a new  list item.

2. On the Inspector or the Formatting Toolbar, click § i  (Increase Indent).

3. Enter the item s o f  the nested list, pressing Enter after each item.

To promote a nested list:

1. Place the insertion point in the first item o f  the nested list.

2. On the Inspector or the Formatting Toolbar, click £ 1  (D ecrease  Indent).

To promote or demote one list item:

1. Place the insertion point in the list item you want to promote or demote.

2. On the Inspector or the Formatting Toolbar, click 1 ?  (Increase Indent) or * 1  (D ecrease Indent).

Related topics
Creating lis ts ............................................................................................................ p. 130

Splitting and merging lis ts .....................................................................................p. 131

Modifying bullets and numbering........................................................................p. 132

Using an image as a bu lle t.................................................................................... p. 133

S p l i t t i n g  a n d  m e r g i n g  l i s t s

A  list can be split into two lists, and tw o consecutive lists can be joined  into one list.

To split a list into two lists:

1. Place the insertion point in the list item  you want to becom e the first item in the second list.

2. On the Format menu, click  Split List.
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To merge two consecutive lists:

1. Place the insertion point in the first item o f  the second list.

2. On the Format menu, click Merge Lists.

Related topics
Creating lists..............................................................................................................p. 130

Creating nested lists.................................................................................................p.131

Modifying bullets and numbering.........................................................................p. 132

Using an image as a b u lle t..................................................................................... p. 133

M o d i f y i n g  b u l l e t s  a n d  n u m b e r i n g

HTML provides som e control over numbering and bullet styles in lists. For numbered lists, the number 
format (e.g ., 1-2-3 or I-II-III) can be changed for the w hole list or for individual items. A lso , the starting 
number o f  a numbered list can be changed, and the number sequence can be reset at any point in the list. 
For bulleted lists, the bullet style can be changed from the default disc to a square or a circle.

To change between bulleted and numbered lists:

1. Select the entire list.

2. On the Inspector or the Formatting Toolbar, click  (Bulleted List) or i =  (Numbered List).

To change the number format or bullet type of a list:

1. Select the entire list.

2. On the Format m enu, click  List.

3. C lick the Style box  and select a bullet type or number format.

To change the number format or bullet type of a single list item:

1. Place the insertion point in the desired list item.

2. On the Format m enu, click List.

3. Click the Style box and select a bullet type or number format.

To change the starting number of a numbered list:

1. Select the entire list.

2. On the Format m enu, click  List.

3. Enter a number in the Start at box.
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To reset the numbering sequence within a numbered list:

1. Place the insertion point in the desired list item.

2. On the Format menu, click  List.
3. Enter a number in the Start at box.

S  C a sc a d in g  s ty le  sh e e ts  o ffer  g r e a te r  c o n tro l  o v e r  b u lle t  a n d  n u m b er s ty le s  f o r  l is ts  a n d  l is t  item s th an  
H T M L  a lo n e  d o es. S e e  lis t- s ty le  in th e  C S S  re fe re n c e  f o r  m o re  in fo rm a tio n .

Related topics
Creating lists .............................................................................................................p. 130

Creating nested lis ts ................................................................................................ p. 131

Splitting and merging l is ts .....................................................................................p.131

Using an image as a b u lle t.....................................................................................p. 133

U s i n g  a n  i m a g e  a s  a  b u l l e t

Y ou can use an im age file as a bullet in bulleted lists. The list in the exam ple below  uses sm all, diam ond­
shaped im ages as the bullets.

K in d s o f  A n im als

^ D o g s

OCals
^  Technical Writers

To use an image bullet for a whole list or selected list items:

1. Select the w hole list or som e list item s.

2. On the Format m enu, click List.

3. Under Type, click  Image.
4. In the Image path box, enter the path or U RL to the im age file.

Related topics
Creating lis ts .............................................................................................................p. 130

Text 133



Ñamo WebEditor 6 User Manual

Creating nested lists.................................................................................................p. 131

Splitting and merging lists ..................................................................................... p. 131

Modifying bullets and numbering.........................................................................p. 132

P r e f o r m a t t e d  t e x t

When displaying text, Web browsers normally compress multiple consecutive spaces into a single space 
and "wrap" paragraphs at the edge of the window so users don’t have to scroll horizontally to see a whole 
paragraph. This behavior is usually convenient for both authors and users, but there are cases—such as 
poetry and code samples—where text needs to be displayed exactly as entered by the author. To 
accommodate such cases, HTML includes an element type called preformatted text.

Preformatted text elements are text blocks that browsers display exactly as given in a document’s source 
code. Multiple spaces are not compressed, and long lines are not wrapped at the window edge. Additionally, 
most browsers display preformatted text in a monospaced font by default, although you can specify any 
font you wish.

This is normal text Paragraphs are wrapped at 

die window's edge and multiple spaces m the 

source are compressed into one.

This i s  prefom atted  te x t .
Paragraphs are not wrapped ac the vindc 
and m lt ip le  spaces are not cozpre:

Preform atted  text com pared  to norm al text.

To create a preformatted text element

1. Place the insertion point in an empty line.
2. On the Inspector or the Formatting Toolbar, click the Element box and select Preformatted text.
3. Enter the text. To start a new line, press Shift+Enter.
4. When done, press Enter, click Element, and select Normal.
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To convert paragraphs to preformatted text

1. Select the paragraphs to convert to preformatted text.
2. On the Inspector or the Formatting Toolbar, click the Element box and select Preformatted text.

To change the font of some preformatted text

1. Select some preformatted text.
2. On the Inspector or the Formatting Toolbar, click the Font box and select a font.

To change the font of all preformatted text in a document

1. On the Format menu, click Define Styles.
2. Click a  (Add).
3. Click the Element box, select pre, and click OK.
4. Click the Font box and select a font. If desired, specify other font properties such as size and style.
5. Click OK.

L-3 If you enter preformatted text in HTML mode, any line breaks within the <pre> element are preserved 
and displayed as entered.

A d d r e s s e s

In HTML, an address element can be used to contain street addresses and other contact information. 
Address elements behave just like ordinary paragraphs, except that browsers typically display them in 
italics and without top and bottom margins, by default.

This is an ordmaiy paragraph. The text 

below is an address.

John Smith 

222 Lockhart Lane 

Oregano, CA 93727

Address text compared to normal text
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To create an address element

1. Place the insertion point in an empty line.
2. On the Inspector or the Formatting Toolbar, click the Element box and select Address.
3. Enter the address, pressing either Enter or Shift+Enter to begin new lines.
4. When done, press Enter to begin a new line, click the Element box, and select Paragraph.

D e f i n i t i o n  L i s t s

In HTML, a definition list is a list of terms and their definitions. The list consists of one or more pairs of 
special block elements: the term and the definition. Unlike ordinary paragraphs, browsers usually render 
terms and definitions with no top or bottom margin, and definitions are indented.

Some names and descriptions of dinosaurs: 

Ichttyosaar 

An aquatic dinosaur that resembled a large, 

scary fish. 

Pterodactyl 

A  flying dinosaur. Most of them had no tails. 

More dinosaur names to come!

A definition list w ith two pairs of term  and  definition. Boldface has been added to the term s.

To create a definition list

1. Place the insertion point in an empty line.
2. On the Inspector or the Formatting Toolbar, click the Element box and select Defined Term.
3. Enter the first term and press Enter.
4. Click the Element box and select Definition.
5. Enter the first definition and press Enter.
6. Enter additional terms and definitions, following steps 2 through 5.
7. When done, press Enter one last time to close the definition list.
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I m a g e s

Perhaps one of the most important reasons for the rapid rise in popularity of the Web since the mid-1990s is 
the inline image. By allowing authors to place photographs, illustrations, and other graphical content 
directly on the page next to text content, inline images turned bland text-only sites into the visually rich 
showcases that we take for granted today.

The term inline image refers to an image that appears embedded in a Web document, rather than viewed 
separately as the result of clicking on an image file link. In this section, we’ll see how Namo WebEditor 
makes inserting inline images as easy as possible and take a look at various things you can do with an 
image once it is in a Web document.

In  th i s  s e c t io n

About Web im ages.................................................................................................. p. 138

Inserting im ages.......................................................................................................p. 141

Saving a document with im ages........................................................................... p. 145

Setting an image's display size..............................................................................p. 147

Setting an image's alignment................................................................................. p. 148

Setting image margins and borders......................................................................p. 149

Adding alternative text to an im age.................................................................... p. 151

Specifying an alternate low-resolution im age................................................... p. 151

Creating an image rollover effect......................................................................... p. 152

Applying image effects.......................................................................................... p. 153

Setting a transparent color on an im age..............................................................p. 160

Slicing an image into pieces.................................................................................. p. 161

Changing an image's file format........................................................................... p. 163

R e la te d  to p ic s

Creating photo a lbum s........................................................................................... p.281

Creating an image m ap........................................................................................... p. 177

Using Smart C lipA rt...............................................................................................p.258

Using Flash B uttons................................................................................................p.265

Adding multimedia ob jects................................................................................... p.252

Creating charts from table d a ta ............................................................................ p.484
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A b o u t  W e b  i m a g e s

In this section
How Web documents use im ages......................................................................... p. 138

Web image form ats.................................................................................................. p. 139

Viewing estimated load tim es................................................................................p. 141

H o w  W e b  d o c u m e n t s  u s e  i m a g e s

When you insert an image into a Web document, the image data—the bits and bytes that represent the 
image—are not stored in the document. Instead, the Web document contains a link to the image. Like any 
Web link, an image link can refer to a file that is in the same folder as the document itself, or in a different 
folder, or on a different Web site altogether.

For example, the link to the image in the document fragment below:

might look like this in the document’s HTML source:

<p>The A f r i c a n  b e e  <img s r c = " i m a g e s / b e e . j p g " > i s
a  f e i s t y  l i t t l e  c r i t t e r . < / p >

In the example above, the image file (bee.jpg) resides in an "images" subfolder in the same folder as the 
document.

When you publish a Web document, make sure to upload any image files that are used by the document in 
addition to the document itself. You should also make sure that the image files have the same path relative 
to the document on the Web server that they do on your local file system. If your document is part of a 
local site, Namo WebEditor takes care of these details for you.

Related topics
Saving a new document with im ages................................................................... p. 145

Publishing and maintaining a s ite ......................................................................... p.387
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W e b  i m a g e  f o r m a t s

The term image format commonly refers to the method by which an image is stored as a computer file. A 
variety of image formats are used on the Web; Namo WebEditor supports the most common ones.

There are two broad classes of image formats: bitmap and vector-based.

Bitmap images

A bitmap image file stores an image as a two-dimensional array of pixels (dots). Each pixel has a certain 
color, represented by a number. An 8-bit image uses 8-digit binary numbers to represent colors, so each 
pixel can have any of 256 (2A8) possible colors. 16-bit and 24-bit images use larger numbers and thus can 
represent finer color distinctions for more accurate color rendition.

The pixels that make up a bitmap image become obvious when magnified, as in the image below.

The bitmap image formats supported by Namo WebEditor are:

G IF

The Graphics Interchange Format (GIF) is probably the most common image format in use on the 
Web. GIF images are fairly compact because they are limited to 8-bit color and use lossless 
compression, which compresses repetitive visual information without discarding it. GIF is most 
appropriate for simple images with few colors, such as bullets and other design elements. GIF files 
use a .gif file name extension. All modem visual browsers support GIF.

A special feature of GIF, not shared by the other common image formats, is that a GIF file can 
actually contain more than one image. In such animated GIF files, multiple images are displayed 
sequentially, as in a movie.
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JPEG
The Joint Photographic Experts Group (JPEG) format is most commonly used for photographic 
images. Since it uses 24 bits to represent the color of each pixel, JPEG’s color fidelity is much 
higher than that of GIF. JPEG uses lossy compression to keep file sizes down—this means that 
visual information is selectively discarded while maintaining as much fidelity as possible. When 
you save an image in JPEG format, you choose a quality level: the lower the quality level, the 
more information is discarded and the smaller the file size. JPEG files use a .jpg or a .jpeg file 
name extension. All modem visual browsers support JPEG.

PNG
The Portable Network Graphics (PNG) format is a relatively new image format that combines 
some of the strengths of GIF and JPEG. Like GIF, it uses lossless compression; but like JPEG,
PNG supports 24-bit color (and even higher—up to 48-bit color). Another strength of PNG is its 
support for alpha channels, which allow authors to assign a transparency level to any pixel. These 
features make PNG an excellent format for image editing and archival. However, high-color (24- 
bit or higher) PNG images can have very large file sizes, so it is advisable to use PNG in Web 
documents only for low-color applications. PNG files use a .png file name extension. Most 
modem visual browsers support PNG.

Vector-based images

Rather than storing a bunch of pixels, a vector-based image stores an image as a set of mathematical 
descriptions of lines, curves, and fills. It could be said that a vector-based image stores a description of the 
image, rather than the image itself; the image "unfolds” when a program, such as a Web browser, interprets 
the description and renders the image. So, for instance, a circle would be described by its center coordinates, 
its radius, and the thickness and color of its curve, instead of being stored as an array of pixels.

Exam ples of vector-based images. The screen cap tu res on the righ t reveal the lines and curves th a t m ake up 
each image.
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The mathematical nature of vector-based images makes them ideal for line art and illustrations, but ill- 
suited to photographic images, for which a mathematical description would be extremely complicated and 
take up far more space than simply storing the pixels. However, some vector image formats support mixing 
vector-based content with bitmap content, taking advantage of the strengths of each. Unfortunately, no 
vector-based image format is universally supported by current browsers, limiting the usefulness of vector- . 
based images for the Web (although the recently-developed SVG format is rapidly gaining acceptance, 
thanks to the wide availability of browser plugins to view SVG images).

Namo WebEditor has its own vector-based format, called TNG. Based on SVG, TNG is the format used by 
Namo WebEditor's Smart Clipart (p.258) (editable vector-based graphic elements). Some versions of Namo 
WebEditor 6 include a standalone TNG editor, Namo WebCanvas, which can be used to create and edit 
Smart Clipart. WebCanvas can also export images to SVG format.

To work around the lack of universal browser support for vector-based images, Namo WebEditor 
automatically rasterizes each TNG image to bitmap format. When you publish a document containing TNG 
images to the Web, the rasterized versions of the images are what is displayed by browsers. However, the 
TNG versions are retained in encoded form in the document's source code, so you can edit the images at 
any time.

V i e w i n g  e s t i m a t e d  l o a d  t i m e s

A document that contains many or large images can take much longer to open in a browser than one with 
few or small images, especially over a slow Internet connection. When designing a document that use 
images or multimedia files, you should consider the probable load time for your target audience. Unless all 
of your users will load your document over a local area network or fast broadband connections, consider 
keeping the total size (in kilobytes) of all the resources in the document down to a level that will allow 
comfortable viewing by users with slow Internet connections.

To view information about the total size of the resources used in a document: On the File menu, click 
Document Properties, and then click the Advanced tab. The same dialog box also displays estimated load 
times for various connection speeds. Click the Connection speed box to select a speed, and the estimated 
transfer time will be updated.

I n s e r t i n g  i m a g e s

Namo WebEditor provides various ways to insert images into Web documents. In addition to image files on 
the local file system, you can use images copied from other programs, images on the Web, or any of the 
thousands of images in the clip art library included with Namo WebEditor.

Images 141



Ñamo WebEditor 6 User Manual

E1 Whenever you insert an image from a location other than the folder containing the document, or a 
subfolder of the document's folder; the next time you save the document, Narno WebEditor will ask 
whether you want to copy the image file to the document’s folder. To avoid problems when you publish 
the document later, it is a good idea to let Namo WebEditor copy the image. For more information, see 
Saving a document with images, p. 145.

In this section
Inserting an image from a local f ile ..................................................................... p. 142

Inserting an image from the Clip Art library.......................................................p. 143

Inserting an image from the site............................................................................ p. 143

Inserting an image from the W eb..........................................................................p. 144

Pasting an image from another program ............................................................. p. 144

Related topics
Saving a document with images............................................................................ p. 145

I n s e r t i n g  a n  i m a g e  f r o m  a  l o c a l  f i l e

Much of the time, images you insert into your Web documents will come from your local file system, such 
as photographs you have taken with a digital camera or artwork you have created in a paint program. Namo 
WebEditor supports most popular image file types, including GIF, JPEG, PNG, and BMP.

To insert an image from a local file

1. Place the insertion point where you want to insert the image.
2. Do one of the following:

o Click C[ll](lnsert Image) on the Standard Toolbar, 
o Press Ctrl+Shift+I.

3. In the Image path box, enter the path of the image file; or click p3](Browse), select an image file, 
and click Open.

4. Click OK.

|5j The Open dialog box, which appears when you click the C f jBrowse) button in the Image Properties 
dialog box, initially shows only GIF, JPEG, and PNG files. To show other types of image files, click 
the Files of type box and select AH Files.

You can also insert a local image file by dragging it into the document window from Windows Explorer 
and clicking Insert File or Image.
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I n s e r t i n g  a n  i m a g e  f r o m  t h e  c l i p  a r t  l i b r a r y

Namo WebEditor comes with a library of thousands of ready-made clip art images that you can use in your 
Web documents.

To insert an image from the clip art library

1. Place the insertion point where you want to insert the image.
2. Do one of the following:

o On the Insert menu, point to Image, and then click Clip Art.

o Click O  (Insert Clip Art) on the Standard Toolbar.
3. In the left pane, select the category and subcategory containing the desired type of image.
4. In the right pane, select the desired image.
5. Click OK.

You can also insert a clip art image by dragging it into the document window from the Resource 
Manager (p.45) and clicking insert Fiie or image.

I n s e r t i n g  a n  i m a g e  f r o m  t h e  c u r r e n t  s i t e

If you are working with a local site and need to insert an image that is already in use anywhere in the site, 
you can select it from a list of site images instead of having to specify the image location explicitly. This 
can save time when you frequently reuse images in the same site.

To insert an image from the current site

1. Place the insertion point where you want to insert the image.
2. Do one of the following:

o Click [^(Insert Image) on the Standard Toolbar, 
o Press Ctrl+Shift+I.

3. Click the C^](Site) button to the right of the Image path box.
4. Select the desired image and click OK.
5. Click OK again.
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I n s e r t i n g  a n  i m a g e  f r o m  t h e  W e b

There are two ways to insert an image directly from the Web into a Namo WebEditor document: you can 
paste the image from a Web browser, or you can manually specify an image URL.

To paste an image from a Web browser

1. In the Web browser, right-click the desired image and click Copy.
2. Switch to Namo WebEditor.
3. Place the insertion point where you want to insert the image.

4. Press Ctrl+V or click (Paste) on the Standard Toolbar.

To insert an image from a URL

1. Place the insertion point where you want to insert the image.
2. Do one of the following:

o Click Cpfylnsert Image) on the Standard Toolbar,
o Press Ctrl+Shift+I.

3. In the Image path box, enter the URL of the desired image (for example, 
http://www.example.com/example.gif).

4. Click OK.

B  When you save a document after insert an image from the Web in it, Namo WebEditor will suggest that 
you copy the image (pA45) to the document's folder. If you copy the image as suggested, the image 
source mil become the local copy and mil no longer be the original copy on the Web. If you do not 
copy the image to a local folder, the image source mil remain the original copy on the Web, even after 
you publish the document.

Related topics
Saving a document with images............................................................................ p. 145

P a s t i n g  a n  i m a g e  f r o m  a n o t h e r  p r o g r a m

Most graphics programs and some other types of programs support using the Windows clipboard to copy 
and paste images. You can take advantage of this fact to paste an image from a graphics program into a 
Namo WebEditor document, without having to save it in a file first. As long as the graphics program places 
the image on the clipboard in bitmap format, you can paste it into Namo WebEditor. When you paste the 
image, Namo WebEditor will save it as a GIF, JPG, or PNG file in the location you specify.
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1. In the other program, use the appropriate command to copy the desired image to the clipboard.
2. Switch to Namo WebEditor and place the insertion point where you want to insert the image.

3. Press Ctrl+V or click E l (Paste) on the Standard Toolbar.
4. (optional) In the Save as box, enter the path and file name for the image file to be saved.
5. Click the button corresponding to the desired format (p. 139) for the image file and specify the 

desired options for the chosen format.
6. Click OK.

Related topics
Web image form ats.......................

Inserting an image from the Web

To p aste  an im age from ano ther program

S a v i n g  a  d o c u m e n t  w i t h  i m a g e s

When you insert an image into a Web document, the image itself is not actually saved in the document. 
Instead, an image tag is inserted into the document’s HTML source code, and this tag specifies the location 
of the image file. The location might be specified in one of the following ways:

• as a relative path from the document’s location to the image file's location (on the same drive)
• as a file-type URL (p. 166) containing an absolute path to the image file, if it is on another drive or 

in a network folder
• as an Internet URL, if the image is on a Web site

When you open the document in a browser, the browser reads the image tag, finds the image file at the 
specified location, loads the image, and displays it in the document.

This system of storing image files separately from the documents that use them generally works very well 
and allows for great flexibility, but it can lead to problems when you publish (p.387) a document that uses 
images, if you are not careful. These problems generally fall into three types:

• If you inserted an image from a folder on the same drive as the document, you must make sure to 
upload the image to the same relative location on the remote site (relative to the document). 
Otherwise, the image will not display.

• If you inserted an image from a different drive or from a network folder, the image will not 
display because the absolute path that specifies its location will be invalid with respect to the 
remote site's file system.

• If you inserted an image using an Internet URL, your users’ Web browsers will always retrieve the 
image from that URL rather than from your own site. This can cause bandwidth problems for the

p .139 
p. 144
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site hosting the image and can lead to complaints from that site's owners if you did not receive 
permission to host the image on their site.

To help avoid such problems, when you first save a document after inserting one or more image files, 
Namo WebEditor may display the following dialog box, which lets you decide how Namo WebEditor 
should handle the newly inserted images:

- f a

At least one image or other resource file used in this document is 
not located in the document folder. This can cause problems 
when publishing the document.

What do you want to do?

(• Copy the files to the document folder 

C Maintain existing URLs to the original file locations

C Use felative URLs to the original file locations

C Copy the files to another folder or choose action for each file

OK I Cancel |

The Resource File H andling dialog box

The four options file handling options are described below:

• Copy the files to the document folder: If you choose this option, Namo WebEditor will copy the 
images to the document’s own folder and convert the image URLs to just the images' file names. 
(This is the default option.)

• Maintain existing URLs to the original file locations: If you choose this option, Namo WebEditor 
will not copy the images, and it will leave the existing image URLs as they are.

• Use relative URLs to the original file locations: If you choose this option, Namo WebEditor will not 
copy the images, but it will convert any absolute URLs to relative URLs wherever possible. (Note 
that file-type URLs pointing to files on another drive or a network folder cannot be converted to 
relative URLs.)

• Copy the files to another folder or choose action for each file: If you choose this option, Namo 
WebEditor will open the Resource File Manager dialog box, allowing you to specify another 
folder to which to copy all the images or to specify an action independently for each image.

In most cases, you should choose the default option, allowing Namo WebEditor to copy the image files to 
the document folder. This way, you can make sure the document does not contain any file-type URLs that 
will not work on the Internet. If the document includes images inserted from another drive or a network 
folder, it is strongly recommended that you choose either the first or the third option.

¿¿source Fite Handling
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3  If you choose to copy an image file to the document folder, and you later remove the image from the 
document, Namo IVebEditor will not delete the copied image file.

S e t t i n g  a n  i m a g e ' s  d i s p l a y  s i z e

You can specify that an image display at a certain size other than its true size. Changing its display size 
does not actually modify the image in any way. Note that when you change the display size of a bitmapped 
image (p. 139)—especially when you increase its display size—the image may appear blocky or pixellated.

You can set an image's display size visually, by dragging its resize handles; or precisely, by entering pixel 
or percentage values in the Inspector or a dialog box.

To set an image's display size visually

1. Click the desired image.
2. Do any of the following:

o To reduce or enlarge the image while keeping its original proportions, drag any of the 
resize handles at the four comers of the image.

o To reduce or enlarge the image without regard to its original proportions, drag any of the 
resize handles at the four comers of the image while holdiing down the Shift key.

o To increase or decrease the width or height of the image, drag any of the resize handles 
centered on the sides of the image.

When you place the mouse pointer over a resize handle, it will change to a double-arrow shape to 
indicate that you can click and drag to resize.

To set an image's display size as numbers of pixels

1. Click the desired image.
2. On the Inspector, enter numbers of pixels in the Width and Height boxes.

To set an image's display size as a percentage of the available space

1. Click the desired image.
2. On the Inspector, enter percentage values in the Width and Height boxes.

When you specify an image's display size in percentage terms, the percentages are usually relative to 
the available space—that is, the size of the image's parent container. However, when the image's 
parent container is something that has no defined vertical size, such as the entire document body, 
browsers may interpret a percentage height as being relative to the image's width.
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Q  If the Inspector is hidden, you can also specify an image's display size in the Image Properties dialog 
box. To open it, double-click the image.

9  To restore an image to its true size, click the §3 button on the Inspector or Restore Original Size in the 
image Properties dialog box.

El Some browsers, such as Internet Explorer 6, may automatically adjust the display size of images that 
are too large to fit in the browser window.

S e t t i n g  a n  i m a g e ' s  a l i g n m e n t

By default, the bottom of an inline images is aligned with the bottom of the line of content it is on. 
However, you can specify a different vertical alignment; for example, you can align the top of the image 
with the top of the line. Alternatively, you can specify that the image be forced to left or right side of the 
paragraph it is in and that other content after the image "flow" around it. Examples of each of the alignment 
options are shown below.

Defautt (Bottom) Top Middle
Lorem ipsum dolor sit am et, 
consectetuer adip[scjn<3 élit.

Aliquam mi est, 
sollicitudin sed, m alesuada in, 
adipiscing a, purus que. 
Suspendisse id lacus.

Lorem ipsum dolor sit am et, 
consectetuer adioisdng élit. 
Aliquam mi est,

OLi
sollicitudin sed, m alesuada in, 
adipiscing a , purus que. 
Suspendisse id lacus.

Lorem ipsum dolor sit am et, 
consectetuer adipiscing élit.

Aliquam j est,

t l  A d
sollicitudin sed, m alesuada in, 
adipiscing a, purus que. 
Suspendisse id lacus.

Bueline Left Right
Lorem ipsum dolor sit am et, 
consectetuer adipiscing élit.

. • ♦ Alîquam mi L-------est,
sollicitudin sed, m alesuada in,
adipiscing a , purus que.
Suspendisse id lacus.

Lorem ipsum dolor sit am et, 
consectetuer adipiscing élit. 
Aliquam _mï est, sollicitudin sed, 

m alesuada in,
V  | adipiscing a, purus 

!1 ‘ i que. Suspendisse id 
LLJJ!S~tLi lacus. Morbi 
consequat. Aliquam venenatis. 
Nulla nulla quam , rutrum .

Lorem ipsum dolor sit am et, 
consectetuer adipiscing élit. 
Aliquam mi est, sollicitudin sed,^  
malesuada in, adipis 
dng a, purus que. F i * . ) 
Suspendisse id 1/, i 
lacus. Morbi conse L l -  
quat. Aliquam venenatis. Nulla 
nulla quam , rutrum commodo.

Top o f Text Abf olute Middîe Absolute Bottom
Lorem ipsum dolor sit am et, 
consectetuer adipiscincj élit. 
Alîquam mi est,

sollicitudin sed, m alesuada in, 
adipiscing a, purus que. 
Suspendisse id lacus.

Lorem ipsum dolor sit am et, 
consectetuer adip|scin£ élit.

Aliquam mi * es*,
• y l J & û

sollicitudin sed, malesuada in, 
adipiscing a, purus que. 
Suspendisse id lacus.

Lorem ipsum dolor sit am et, 
consectetuer adipisrintj élit.

Aliquam mi ^  A i  est, 
sollicitudin sed, m alesuada in, 
adipiscing a, purus que. 
Suspendisse id lacus.
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To set an image's alignment

1. Click the desired image.
2. On the Inspector, click the Alignment box and select the desired alignment option.

Q If the Inspector is hidden, you can also specify an image's alignment in the Image Properties dialog 
box. To open it, double-click the image.

S e t t i n g  i m a g e  m a r g i n s  a n d  b o r d e r s

An image margin refers to empty space around the image. Normally the size of the margins is controlled by 
the browser, but you can specify the horizontal and/or vertical margins explicitly (in pixels) using the 
Inspector.

Images can also have visible borders, although they have none by default. You can specify a uniform, solid 
border of a specific thickness (in pixels) around an image using the Inspector.

If you need to specify margins and/or borders independently for any or all of the four sides of an image, 
you can do so using the Borders & Background command on the Format menu.

To set an image's horizontal and vertical margins

1. Click the desired image.
2. On the Inspector, enter a number of pixels in either or both of the Horz. spacing and Vert. Spacing 

boxes, and then press Enter.

To set margins independently for each side of an image

1. Click the desired image.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the side for which you want to set the margin. To select multiple 

sides at once, click each while holding down the Ctrl key. (See the examples below.) To select all 
four sides, click Select All. To deselect all sides, click in the middle of the box. By default, all four 
sides are selected.
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Click while holding down C trl to 
select m ultiple sides.

4. Enter a number in the Margin box and then click the unit box next to it and select a unit. If you do 
not specify a unit (p.231), the value will be interpreted as pixels.

5. Repeat steps 3 and 4 if you want to set a different margin size for another side.
6. Click OK.

To set a uniform image border

1. Click the desired image.
2. On the Inspector, enter a number of pixels in the Border box and press Enter.

To set borders independently for each side of an image

1. Click the desired image.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the side for which you want to set the border. To select multiple 

sides at once, click each while holding down the Ctrl key. (See the examples below.) To select all 
four sides, click Select All. To deselect all sides, click in the middle of the box. By default, all four 
sides are selected.

▼ т

J-I Y L

&

Г À

Ч Г i  г
ж ж

Click a side to  select it. C lick while holding down C trl to 
select m ultiple sides.

4. Click the Style box and select a border style.
5. Click the Color box and select a color (p.233).
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6. In the Width box, enter a number and then click the unit box next to it and select a unit. If you do 
not specify a unit (p.231), the value will be interpreted as pixels.

7. Repeat steps 3 through 6 if you want to set a different border for another side.
8. Click OK.

If the Inspector is hidden, you can also set an image's margins and border in the Image Properties 
dialog box. To open it, double-click the image.

A d d i n g  a l t e r n a t i v e  t e x t  t o  a n  i m a g e

Not all users can view images in Web documents. Some users use aural or other non-visual browsers, and 
some users disable images in visual browsers to reduce page load times. For these users, it is useful to 
supply a text description of an image that will stand for the image itself. Such text is called alternative text 
or alt text. Most visual browsers also display alt text when a user holds the mouse pointer over an image, 
possibly providing useful information about the image for ordinary users.

To add alternative text to an image

1. Click the desired image.
2. On the Inspector, in the Alt text box, type a brief description of the image.
3. Click OK.

m

я

When you insert an image from the clip art library or by dragging an image file from Windows 
Explorer, Namo WebEditor automatically add the image file name as alt text.

Do not add alt text to images that are merely decorative.

Q  If the Inspector is hidden, you can also set an image's alt text in the Image Properties dialog box. To 
open it, double-click the image.

S p e c i f y i n g  a n  a l t e r n a t i v e  l o w - r e s o l u t i o n  i m a g e

Over slower Internet connections, loading a large image can take a significant amount of time. To give 
users something to look at while a large image is loading, you can specify an alternate, low-resolution
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image that browsers will load first. When the primary image has finished loading, it will replace the low- 
resolution image.

To specify an alternative low-resolution image

1. Double-click the desired image.
2. Click the Advanced tab.
3. In the Low res img box, enter the path of the low-resolution image, or click S i  (Browse) to locate 

and select the low-res image file.
4. Click OK.

CEI Most browsers do not support alternative low-resolution images. They begin loading the primary 
image immediately.

C r e a t i n g  a n  i m a g e  r o l l o v e r  e f f e c t

In a rollover effect, one image is replaced by another when a user ’’rolls" the mouse pointer over the 
original image. The transition takes place when the mouse pointer enters the bounds of the original image; 
when the mouse pointer exits the bounds of the second image, the original image is restored.

The most common use of rollover effects is to provide visual feedback when the user moves the pointer 
over an image that serves as a button. The button looks different when the pointer is over it, indicating that 
the image is indeed a button that can be clicked.

To create a rollover effect on an image

1. Double-click the desired image.
2. Click the Rollover tab.
3. In the Second image path box, enter the path of the replacement image, or do one of the 

following:

o Click Q  (Browse) to find and select an image file from your local file system.

o Click (Clip Art) to select an image from the clip art library.

o Click SX (Site) to select from a list of image files belonging to the current local site (if 
one is open).

4. To preview the rollover effect, move the mouse pointer over the Preview pane.
5. Click OK.
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To remote a rollover effect on an image

1. Double-click the desired image.
2. Click the Rollover tab.
3. Click Remove Rollover, and then click OK.

A p p l y i n g  i m a g e  e f f e c t s

With Namo WebEditor's Image Effects tools, you can modify and apply effects to images in your Web 
documents in a variety of ways. You can:

• Crop and resize images
• Rotate and flip images
• Adjusting brightness, contrast, and sharpness
• Add text on an image
• Add a frame around an image
• Add a drop-shadow or beveled-edge effect

To apply an image effect, right-click the image, point to Image, and click Image Effects. You can apply 
more than one modification or effect without closing the dialog box. Effects are cumulative. To undo the 
last applied effect, click (Undo). To reset the image to its original state, click Reset. After applying the 
desired modifications and effects, click OK.

When you click OK to save your changes, Namo WebEditor will prompt you for the path and file name 
under which to save the modified image. If you use the original path and file name, the original image file 
will be permanently replaced. If you do not want the original image file to be replaced, change the path 
and/or the file name.

For information about a particular modification or effect, see the individual subsections within this section.

ED If you save the modified image under the same path and file name as the original image, you will not 
be able to undo the modifications.

In this section
Cropping and resizing im ages...............................................................................p. 154

Rotating and flipping im ages................................................................................p. 155

Adjusting brightness, contrast, and sharpness................................................... p. 156

Adding text on an im age........................................................................................p. 157

Adding a border around an im age........................................................................ p. 158
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p.161

Adding a beveled-edge effect 

Adding a shadow to an image

Related topics
Slicing an im age......................

C r o p p i n g  a n d  r e s i z i n g  i m a g e s

To "crop" an image is to remove unwanted portions of it. When you crop an image, you draw a rectangle 
around the part you want to keep, and then remove the areas around the rectangle.

Resizing an image means simply making it bigger or smaller. Unlike changing an image’s display size 
(p. 147), this operation permanently modifies the image itself.

To crop an image
1. Select the image you want to crop.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click ^3 (Image Effects) on the Image Toolbar.

3. On the toolbar, click ^  (Crop). A  rectangle with resize handles will appear around the image.
4. Click and drag any of the resize handles so that the rectangle defines the area you want to keep. To 

preserve the rectangle's proportions while you size it, hold down the Shift key while dragging a 
comer handle. You can move the cropping rectangle by clicking inside and dragging. To start over, 
click (Cancel Crop/Resize) and then click t j . (Crop) again.

5. When the cropping rectangle surrounds the area you want to keep, click V  (Accept Crop/Resize).
6. Click OK.
7. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image’s path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

8. Under Save format, select the desired image format (p.138).

9. Click OK.

*3 To make the cropping area an exact size in pixels, enter the desired width and height in the Wand H 
boxes on the toolbar. Then, drag the cropping rectangle so that it surrounds the area you want to keep.

9  You can round the corners of the cropping area by dragging the slider on the toolbar before clicking 
yf (Accept Crop/Resize). Drag the slider to the right to make the corners more rounded. If you round
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the comers of the cropping area, it's a good idea to select the Transparent check box to make the 
corners of the cropped image invisible.

U You can "feather" the cropping area, causing the edges of the cropped image to blend with the
background color specified in the BG color box. To feather the cropping area, enter a number in the
£-i (Feather) box before clicking V  (Accept Crop/Resize). The number represents the width of the 
feathered area in pixels.

3  It is possible to set the cropping area so that it is partially outside the original image bounds. In such a 
case, the outside area will effectively be added to the image, and it will have the color specified in the 
BG color box. To make the added area transparent, select the Transparent check box.

To resize an image

1. Select the image you want to resize.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click (Image Effects) on the Image Toolbar.

3. On the toolbar, click if! (Resize). A rectangle with resize handles will appear around the image.
4. Click and drag any of the resize handles until the rectangle is the size you want to make the image. 

To preserve the rectangle's proportions while you size it, hold down the Shift key while dragging
the comer handle. To start over, click X  (Cancel Crop/Resize) and then click (Resize) again.

5. When the rectangle is the size you want to make the image, click (Accept Crop/Resize).
6. Click OK.
7. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image's path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

8. Under Save format, select the desired image format (p. 138).
9. Click OK.

O To resize the image to an exact size in pixels, enter the desired width and height in the Wand Hboxes 
on the toolbar.

)

R o t a t i n g  a n d  f l i p p i n g  i m a g e s

To rotate or flip an image

1. Select the image you want to rotate or flip.
2. Do one of the following to open the Image Effects dialog box:
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o Right-click the image, point to Image, and then click Image Effects.

o Click &  (Image Effects) on the Image Toolbar.
3. On the toolbar, click any of the following buttons:

o ^  (Rotate Left) 
o (Rotate Right) 
o sp* (Flip Vertical)

o flli (Flip Horizontal)
4. Click OK.
5. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image's path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

6. Under Save format, select the desired image format (p. 138).
7. Click OK.

A d j u s t i n g  b r i g h t n e s s ,  c o n t r a s t ,  a n d  s h a r p n e s s

To adjust an image's brightness, contrast or sharpness

1. Select the image you want to adjust.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects.

o Click ^3 (Image Effects) on the Image Toolbar.
3. On the toolbar, click any of the following buttons:

o (Lighten) 

o ^  (Darken) 
o CP (Increase Contrast) 
o ©  (Decrease Contrast) 
o A  (Sharpen)

o 0  (Blur)
4. Click OK.
5. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image's path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

6. Under Save format, select the desired image format (p. 138).
7. Click OK.
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A d d i n g  t e x t  o n  a n  i m a g e

Using the Image Effects Text tool, you can superimpose text on an image using the font, color, and style of 
your choice.

To add text on an image

1. Select the image on which you want to add text.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click ^3 (Image Effects) on the Image Toolbar.
3. On the toolbar, click A  (Text).
4. Click at the location on the image where you want the text to start.
5. In the Text box, type the desired text.
6. In the Font, Size and Color boxes, specify the font, size and color for the text.
7. Under Style, select the desired style(s).
8. Click OK.
9. To exit text insertion mode, click A . (Text) again or press Esc.
10. If you need to reposition the text box, drag it to the desired position.
11. Click OK.
12. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image’s path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

13. Under Save format, select the desired image format (p. 138).
14. Click OK.

^  After exiting text insertion mode, you can double-click a text box to reopen the Add Text dialog box 
and change the text and/or its properties.

Q If you want to specify an exact position for a text box, double-click it and enter X and Y coordinates 
(relative to the image’s top left corner) in the Coordinates boxes.

3  You can enter only one line of text at a time. To add more than one line of text on an image, use 
multiple text boxes.
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To remove text added on an image

• Click the text box you want to remove, and then click Delete.

A d d i n g  a  b o r d e r  a r o u n d  a n  i m a g e

Using the Image Effects Border tool, you can add a solid border around an image and control its width, 
color, and comer roundness.

To add a border around an image

1. Select the desired image.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click ^3 (Image Effects) on the Image Toolbar.
3. On the toolbar, click lSl (Border).
4. In the Width box, enter the desired width of the border in pixels.
5. In the Roundness box, enter a number representing the degree of roundness of the border. A value 

of 100 produces a perfectly round border.
6. Click the Color box and select a color (p.233).
7. Click OK, and then click OK again to exit the Image Effects dialog box.
8. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image’s path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

9. Under Save format, select the desired image format (p. 138).
10. Click OK.

0  To specify a border around an image without modifying the image itself, use the Borders &
Background (p. 149) command on the Format menu. Note, however, that you cannot create rounded 
corners with this method.

A d d i n g  a  b e v e l e d - e d g e  e f f e c t

Using the Image Effects Bevel Effect tool, you can add a three-dimensional effect around the edges of an 
image, making it appear raised above the page background.
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To add a beveled-edge effect

1. Select the desired image.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click f t  (Image Effects) on the Image Toolbar.
3. On the toolbar, click ¿1 (Bevel Effect).
4. Click the Style box and select the desired shape of the beveled edges.
5. In the Width box, enter the desired width of the beveled edges in pixels.
6. In the Angle box, enter the desired angle of the apparent light source in degrees. A value of 0 

means the light is coming from the image’s right.
7. Click OK, and then click OK again to exit the Image Effects dialog box.
8. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image's path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

9. Under Save format, select the desired image format (p. 138).
10. Click OK.

A d d i n g  a  s h a d o w  t o  a n  i m a g e

Using the Image Effects Shadow tool, you can add a shadow effect to an image, making it appear to float 
above or under the page background.

To add a shadow to an image

1. Select the desired image.
2. Do one of the following to open the Image Effects dialog box:

o Right-click the image, point to Image, and then click Image Effects, 

o Click (Image Effects) on the Image Toolbar.

3. On the toolbar, click 3  (Shadow).
4. Click the Type box and select the desired shadow style:

o Outer Shadow makes the image appear to float above the background, with the light 
source positioned to the top and left.

o Inner Shadow makes the image appear to float under the background, with the light 
source positioned to the top and left.

o Outer Glow makes the image appear to float above the background, with the light source 
positioned directly above the image.
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o Inner Glow makes the image appear to float under the background, with the light source 
positioned directly above the image.

5. In the Offset X and Y boxes, enter the desired width of the shadow in pixels. (The Y box is disabled 
if a Glow shadow type is selected.)

6. Click the Color box and select the desired color of the shadow.
7. In the Blur box, enter a number representing the desired blurriness of the shadow. A value of 0 

produces a perfectly hard-edged shadow.
8. Click OK.
9. If you specified the shadow type as Outer Shadow or Outer Glow, click the BG color box and 

select the color that matches the background color of the document or other container where the 
image is located. (Use the eyedropper tool to copy the appropriate color from the document 
window.)

10. Click OK.
11. In the Save as box, enter the path and file name under which to save the modified image. Initially, 

the box contains the original image’s path and file name; if you want to replace the original image 
file, leave the path and file name unchanged.

12. Under Save format, select the desired image format (p.138).
13. Click OK.

S e t t i n g  a  t r a n s p a r e n t  c o l o r  o n  a n  i m a g e

You can choose one color in any image in a Web document and make that color transparent. When an 
image has a transparent color, things "under" the image—such as the page background—show through the 
transparent areas.

In the example below, both Santa Claus images have white backgrounds, but the one on the right has been 
modified so that pure white areas are transparent. You may notice that the alpine background image also 
shows through those parts of the second figure’s mustache and headgear that are pure white.

The figure on the right uses transparency
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When you set a transparent color on an image, Namo WebEditor creates a copy of it in GIF format (p.139), 
which is the most popular Web image format that supports transparency. If the original image is not GIF, 
Namo WebEditor will convert it to GIF when it creates the copy. To avoid deleting the original image file, 
you should specify a different name or path for the transparent copy.

To set a transparent color on an image

1. Click the image you want to make transparent.
2. Do one of the following:
3. Right-click the image, point to Image, and then click Set Transparent Color.

4. Click (Set Transparent Color) on the Image Toolbar.
5. Click an area of the image that is the color you want to make transparent.
6. In the Save as box, enter the path and name of the transparent GIF file to be created. (Leave the 

path and name unchanged if you want to replace the original image file.)
7. Confirm that the color shown in the Transparent color box is the one you intended to make 

transparent, and then click OK.

3  When you paste an image from another program, you can immediately set a transparent color on it. In 
the Paste Image File As dialog box, click the Transparent color box and select the color to be made 
transparent.

S l i c i n g  a n  i m a g e  i n t o  p i e c e s

When an image in a Web document is large, it can be useful to break it up into several pieces, like the 
pieces of a jigsaw puzzle. Slicing an image in this way has several benefits, including the following:

• Browsers can download several pieces of a sliced image at the same time, causing the whole 
image to load faster.

• Slicing an image gives you more flexibility when placing the image in a table (p. 182), since you 
can put pieces of the image into adjacent cells to suit your design requirements.

• You can create several variations of an image—for example, with different text components—by 
creating several versions of one piece of the image instead of editing the whole image.

• You can put hyperlinks on different parts of a sliced image without using an image map (p. 177). 

For an example of one way you can use image slicing, consider the table below.
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To move the text from the top cell "into" the image in the bottom cell, we can slice the image into pieces as 
shown below, leaving the middle area empty to accommodate the text.

''•—- a!>

4 4

After exporting the sliced image parts to an HTML table, we insert the text in the empty cell, as shown 
below.

You can slice images using Namo Image Slicer (p.534), a separate utility program that comes with Namo 
WebEditor. For more information, see Namo Image Slicer, p.534 or refer to Namo Image Slicer’s online 
help.

To slice an image into several pieces

1. Start Namo Image Slicer: On the Start menu, point to Programs, point to Namo Web Utilities, and 
then click Namo Image Slicer.
On the File menu, click New.

On the toolbar, click Oi (Import Image).
Locate the image File you want to slice, select it, and click Open.
Using the Slicer Tool, draw boxes to define the desired image pieces.
On the toolbar, click £D (Export to HTML).
In the File name box, type a name for the HTML document that will contain the table containing 
the image pieces, and click Save.
Switch back to Namo WebEditor and open the HTML file you saved in step 7.
On the Edit menu, click Select All, and then press Ctrl+C to copy the table containing the image 
pieces.

2.

3.
4.
5.
6. 
7.

9.
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10. Open or switch to the document into which you want to insert the sliced image.
11. Place the insertion point at the desired location and press Ctrl+V.

C h a n g i n g  a n  i m a g e ' s  f i l e  f o r m a t

You can convert a bitmapped image (p.139) from its original file format (p.l 39) to GIF, JPEG, PNG, or SIS 
format.

3  Jfyou convert a JPEG or PNG image with many colors (such as a photograph) into GIF or SIS format, 
the resulting image may appear grainy or show banding.

To change an image's format

1. Right-click the image to convert, point to Image, and then click Convert Image Format.
2. In the Save as box, enter the path and name for the converted image file. (Click Browse to select a 

folder.)
3. Under Format, select the desired file format and specify the desired options.
4. Click OK.

Related topics
Web image form ats.................................................................................................p. 139
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H y p e r l i n k s  a n d  b o o k m a r k s

Without a doubt, hyperlinks are the central reason the Web has become the huge success it is today. Thanks 
to hyperlinks (or just "links”), a Web user browsing one page or site can instantly "jump" to another page or 
site, just by clicking a word or an image. The power of hyperlinks to connect users to the information and 
resources they seek has made the Web the first truly universal communications network since the telephone 
system, and one that is arguably more powerful.

In  th i s  s e c t io n

About hyperlinks..................................................................................................... p. 165

Creating a hyperlink ............................................................................................... p. 168

Setting a link's target window or fram e...............................................................p. 170

Making a link open in a pop-up w indow ............................................................ p. 171

Setting a tooltip on a link........................................................................................p. 172

Assigning access keys to links...............................................................................p. 173

Setting hyperlink colors..........................................................................................p. 174

Changing the destination o f a hyperlink..............................................................p. 176

Removing a hyperlink............................................................................................. p. 176

Creating an image m ap ........................................................................................... p. 177

Opening a linked document in Edit mode........................................................... p. 178

About bookmarks..................................................................................................... p. 179

Creating a bookmark................................................................................................p. 179

Renaming and removing bookm arks................................................................... p. 180

Using bookmarks in hyperlinks............................................................................ p. 180

R e la te d  to p ic s

Creating a link bu tton ............................................................................................. p.299

Site structure and navigation..................................................................................p.355

Adding dynamic navigation bars and trees......................................................... p.365

Finding broken links................................................................................................p.409

Checking external links.......................................................................................... p .411

Changing hyperlinks and file names to lowercase............................................ p.413
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A b o u t  h y p e r l i n k s

Essentially, a hyperlink is a tag on a word, phrase, im age, or other page elem ent, that tells the W eb browser, 
"When the user clicks this, open X." X could be just about anything, including:

•  another location on the sam e page

•  another page on the sam e W eb site

•  a page on another W eb site

•  an im age or m ultim edia file

•  a dow nloadable program file

•  ... and so forth.

The tag for a hyperlink only needs to g ive  the browser one p iece o f  information: the URL o f  the destination  
resource. O ptionally, it can provide other information, such as the name o f  a frame or w in d ow  (p. 170) to 
open the destination in, or a b rief text m essage (p. 172) to display w hen the user holds the pointer over the 
link.

In this section
Link destination types......

Relative vs. absolute links

Related topics
About bookmarks.................................................................................................... p. 179

L i n k  d e s t i n a t i o n  t y p e s

The m ost fam iliar type o f  hyperlink is the type that links to a W eb page or site, such as 
!,http://w w w .exam ple.com n. But there are other kinds, as w ell. Various link types are distinguised b y  the 
protocol identifier that appears at the beginning o f  the URL. Som e com m on link types are listed b elow .

http

Hypertext Transfer Protocol. This is the usual link type for W eb resources— docum ents, im ages, 
and so forth.

h ttps

Hypertext Transfer Protocol Secure: The sam e as HTTP, but w ith the addition o f  Secure Sockets 
Layer (SSL), a protocol for transmitting sensitive material securely over the Internet.

p. 165 

p. 167
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ftp
File Transfer Protocol: Links that begin with "ftp://” are for files and directories on FTP servers 
(Internet file servers).

ire
Internet Relay Chat: Links to an IRC channel—a virtual meeting place where users "chat” by 
means of instant text messages. IRC links require additional software (an IRC client) to open.

news, nntp
Network News Transfer Protocol: Links to a newsgroup or article on a network news server, 

gopher
A less-sophisticated precursor of the Web, developed by the University of Minnesota. Although 
most Web browsers are able to display gopher documents, very few gopher servers still exist.

telnet
The telnet protocol allows users to access remote computers using a command line interface. It is 
typically used by administrators to access remote Unix servers. Telnet links require additional 
software (a telnet client) to open.

mailto
The protocol for e-mail links. Mailto links are not truly hyperlinks, since clicking a mailto link 
does not result in a connection to anything; it only tells the Web browser to create a new, blank e- 
mail message with the specified "to" address. For the same reason, there is no such thing as a 
mailto URL. Mailto links take the form "mz\\io\username@servername.domairi\

file
This type of link is used to point to a file on the local file system. In general, file links are only 
used temporarily, before a document is published to the Web, since users of remote computers 
cannot access files on your local file system. Namo WebEditor uses file links in temporary 
documents (documents that have not yet been saved) to point to images and other resource files, 
since the relative path to a resource is not known until the document is saved. When you save the 
document, Namo WebEditor offers to convert the file links to relative links based on the location 
of the document.

Related topics
Relative vs. absolute lin k s ......................................................................................p. 167
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R e l a t i v e  v s .  a b s o l u t e  l i n k s

A hyperlink that points to a Web document or resource may use either a relative URL or an absolute URL. 
The distinction has to do with how complete, or self-sufficient, the path pointing to the destination is.

Relative URLs

A relative URL consists of just a path that contains only enough information to locate a file in relation to 
the location of the document containing the URL. Using a relative link is like using your company’s internal 
mail system. If you need to send a memo to someone in your own department, you can just address it to the 
person’s name, such as "Betty Jones" (assuming there is just one Betty Jones in your department). To reach 
someone in another department, it might be sufficient to use the department name plus the person's name; 
for example, "Marketing/Betty Jones". You don’t have to specify a street address, city, state, ZIP code, and 
so forth, since the company mail system assumes that an address that doesn’t have these parts must refer to 
someone inside the company.

Similarly, a relative URL only needs to provide a file name, or a file name plus a directory path. The Web 
browser (or Namo WebEditor) assumes that such a URL must point to a file in the folder structure of the 
same site as the containing document, and it interprets the URL accordingly.

Here are some examples of relative URLs:

R elative  U R L  F ile  L ocation

example.html the same folder as the document
images/example.gif the "images" subfolder of the document’s folder
images/photos/alice.jpg the "photos" subfolder of the "images" subfolder of the document’s folder
../index.html the parent folder of the document's folder
../../example.css the parent folder of the parent folder of the document’s folder

Absolute URLs

Unlike a relative URL, an absolute URL does not depend on the location of the document containing it. To 
continue the analogy given above, using an abolute link is like mailing a letter with a full name and address 
through the national post. The name and address should uniquely identify the intended recipient, without 
ambiguity and without reference to the location of the sender.

Whereas relative URLs are always local (they always point to resources on the same site as the document 
containing the link), absolute URLs can be either local or global—they can point to resources anywhere on 
the Web.

A local absolute URL consists of just an absolute path to the resource. It starts with a slash ("/"), indicating 
that the path starts at the root (or top) level of the Web site’s folder hierarchy. Since the path starts at the 
root, it always points to the same file, regardless of where in the site's folder structure the document 
containing the link is.
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Here are some examples of local absolute URLs:

• /¡ndex.html
• /images/example.gif
• /products/webeditor/tour/tour 1 .asp

A global absolute URL—also called a full URL—is one that provides not just an absolute path, but also a 
site address. Thus, a global URL can point to a unique resource anywhere on the Internet. A global URL 
must start with the name of the protocol used to connect to the destination (such as ‘'http:”) followed by a 
double slash (”//”), the site address, and then the resource path. (If the resource path is not specified, the 
URL points to the root of the site, which may be represented by an index page at the root level.)

Here are some examples of global absolute URLs:

• http://www.example.com/products/index.html
• http://www.example.com/
• ftp://ftp.namo.com
• ftp://ftp.namo.com/public/webeditor_demo.exe

Notice that the second and third examples do not provide a path. In the case of the HTTP URL, the Web 
server will probably serve up the index page in the root folder of the site. In the FTP case, the FTP server 
will provide a listing of the server's root directory.

Related topics
Link destination types............................................................................................. p. 165

C r e a t i n g  a  h y p e r l i n k

Virtually any bit of content on a Web page can be turned into a hyperlink, including words, phrases, single 
characters, entire paragraphs, and images. No matter what the content is, the process of creating a hyperlink 
on it is always the same: first, select the content; second, specify the destination of the link—that is, what 
Web page, file, or other resource will be loaded by the browser when the link is clicked.

To create a hyperlink

1. Select the text or image you want to turn into a hyperlink.
2. Do one of the following:

o On the Insert menu, click Hyperlink,
o On the Standard Toolbar, click $  (Hyperlink).
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o Press F9.
3. In the URL box, enter the path or URL of the link's destination. (For example, 

"http://www.namo.conr or "photos.html". Do not include quotes. When entering a full URL, you 
must include the protocol string, such as "http:", and the double slash before the server name.) 
Alternatively, if the destination file is local, you can do one of the following instead of entering 
the path manually:

o Click (Browse) to select a file on the local file system.
o Click ^3 (Open Documents) to select among the documents that are currently open in 

Namo WebEditor.

o Click EX (Site) to select among the files that belong to the current local site. If no site is 
currently open, this button will be disabled.

o Click Cl (New Document) to create a new document and link to it.
4. If you are linking to a bookmark (p. 179), enter the bookmark name in the Bookmark box. (If the 

bookmark is in the current document, you can leave the URL box empty.)
5. Click OK.

lE) Yo u  cannot use the method described above to create a hyperlink on a Flash Button (p.265). To create a 
link on a Flash Button, double-click the Flash Button and enter the U RL in the Link box of the Flash 
Button Properties dialog box.

"mailto" hyperlinks

A special kind of hyperlink, the mailto link, is not really a hyperlink at all, because it does not point to an 
Internet resource. When you click a mailto link, your browser opens your default e-mail program and tells 
it to create a new message addressed to the address specified in the link. The link can also provide the 
message title.

To create a mailto link, do this:
1. Select the text or image you want to turn into a mailto link.
2. Do one of the following:

o On the Insert menu, click Hyperlink, 
o Click $  (Hyperlink Properties) on the Standard Toolbar, 
o Press F9.

3. Click £3 (Email).
4. In the Address box, enter the desired e-mail address (for example, "bobo@namo.com").
5. (optional) In the Subject box, enter the desired title for the message.
6. Click OK twice.

9  Use the Hyperlink Toolbar to create a hyperlink quickly. After selecting the desired content, click the 
U R L  box (the longest box) on the Hyperlink Toolbar, enter the desired URL, and press E n t e r .  If the
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Hyperlink Toolbar is not visible, you can reveal it by right-clicking the toolbar area and selecting 
Hyperlink Toolbar

When you type a URL in the document window, Narno WebEditor automatically creates a link with that 
URL on the URL. For example, if you type "www.namo.com", Namo WebEditor will create a link to 
http://www.namo.com. You can disable this behavior on the Edit(p.56) tab of the Preferences dialog 
box.

S e t t i n g  a  l i n k ' s  t a r g e t  w i n d o w  o r  f r a m e

Normally, when you click a link in a browser, the destination of that link (if it is something that can be 
displayed in a browser) opens in the same window or frame that displayed the document containing the link, 
replacing the original document. However, you can make the destination of a link open in a different 
window or frame from the one displaying the current document. You do this by specifying the link's target.

For example, if you set a link's target to "frame2", the browser will try to open the link's destination in the 
frame named "frame2". If there is no frame by that name, the browser will then try to open the link in the 
window named "frame2". If there is no window by that name, then the browser will open the link in a new 
window and name the window ”frame2".

A link's target can be the name of a window, the name of a frame, or one of these special keywords:

• Jblank: The link wilt be opened in a new, unnamed window.
• _parent: The link will be opened in the current frame's "parent", replacing the current frameset.

The parent is usually the browser window, but if the current frameset is being displayed inside one 
frame of another frameset, then the parent is the containing frame in the higher-level frameset.

• _self: The link will be opened in the current frame or window.
• _top: The link will be opened in the current window. If the window is divided into frames, the 

link's destination will replace the frames.

0  A window's name is not the same as its title, the words that appear in its title bar. If a window has a 
name, it is not visible to users, but the browser remembers it as long as the window is open. To create 
a browser window with a certain name, set the target of a hyperlink to the desired name. If you want 
the named window to be initially empty, set the link's URL to "about:blank".

3  In general there is no reason to set the target of a single hyperlink to a named window. However, if 
you have several hyperlinks that you would like to open in a separate window from the current 
document, but you don't want a new window to be opened for each link, you can set all of the links' 
targets to one window name. When the first link in the group is clicked, the browser will create a new

170 Hyperlinks and bookmarks

http://www.namo.com
http://www.namo.com


Chapter 4: Basic Page Content and Formatting

window and open the link in it. Then, when other links in the group are clicked, they will open in the 
same window.

To set a link's target

1. Double-click the link to open the Hyperlink Properties dialog box.
2. In the Target box, type the desired frame or window name, or click the triangle and select one of 

the keywords or frame names (if a frameset is open). If a frameset is currently open, you can also 
click [51 (Select Target Frame) to select a frame visually.

U You can also set a link's target using the Target box on the Hyperlink Toolbar. Type a window or frame 
name in the box or click the triangle and select one of the keywords or frame names.

Related topics
Setting a default target for hyperlinks................................................................. p.240

Setting a frame’s default target..............................................................................p. 107

Using fram es............................................................................................................ p. 101

Making a link open in a pop-up window.............................................................p. 171

M a k i n g  a  l i n k  o p e n  i n  a  p o p - u p  w i n d o w

You can set up a hyperlink so that Web browsers will open it in a new window with the position, size, and 
other properties that you specify. Such pop-up windows appear on top of the window that is displaying the 
current document. They are often smaller than most browser windows, and certain parts that are usually 
visible can be hidden, such as the menu and the toolbar.

You can specify the following properties for pop-up windows:

• name (useful when you want to reuse the same window)
• position relative to the top left comer of the screen
• width and height
• the visibility of its menu, toolbar, scroll bars, status bar
• resizability

To set a link to open in a pop-up window

1. Double-click the link to open the Hyperlink Properties dialog box.
2. Select the Open in new window check box, and then click Options.
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3. (optional) In the Window name box, enter the name you want the window to have. (You can have 
other pop-up links open in the same window by specifying the same name, or prevent other pop­
up links from using the same window by specifying a unique name.)

4. In the Left margin and Top margin boxes, enter the desired distance of the pop-up window from the 
screen's left and top edges, respectively, in pixels.

5. In the Width and Height boxes, enter the desired width and height of the window, in pixels.
6. Under Options, select the check boxes corresponding to the controls you want the window to 

display.
7. Click OK twice.

0  If you want a link to open in a new window, but you do not want to specify the window's size and other
properties, set the link's target (p. 170) to Jbfank and leave the Open in new window check box
unselected.

Related topics
Setting a link’s target window or fram e...............................................................p. 170

S e t t i n g  a  t o o l t i p  o n  a  l i n k

The optional title attribute of hyperlinks allows authors to "attach" a hidden piece of text to a link, 
generally containing a brief description of the link's destination. Recent browsers display this text as a 
tooltip when a user holds the mouse pointer over the link for a few seconds.

Lorem ipsum dolor sit amet

w[diedick for definition.

Exam ple o f a  tooltip fo r a hyperlink

To set a tooltip on a link

1. Double-click the link to open the Hyperlink Properties dialog box.
2. In the Tooltip box, enter the desired text of the tooltip.

Netscape 4.x and earlier do not support tooltips on links.
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OlW  If you set a tooltip on a link made from an image, and the image has alt text (p. 151), Internet Explorer 
does not display the link's tooltip when the mouse pointer is held over the image. Instead, it shows the 
image's alt text as a tooltip.

3  Other elements besides hyperlinks can have title attributes as well, and recent browsers will display 
those titles as tooltips, just as with links. To add a title attribute to any element, do this:

1. Place the insertion point in the desired element.
2. On the Tag Selector (p.40), right-click the element’s tag and then click View Source.
3. Inside the element's opening tag, insert t i  t l e = "", adding the desired tooltip text inside the 

quotes. For example, <span t it le = " h e l lo " > .
4. Click the Edit tab to return to Edit mode.

Related topics
Adding alternative text to an im age .......................................................p. 151

A s s i g n i n g  a c c e s s  k e y s  t o  l i n k s

Some users, such as blind people and people who browse the Web on a mobile phone, may find it difficult 
or impossible to navigate hyperlinks using a mouse. For such users, most browsers support navigating links 
using the Tab and Enter keys, but when a document has many links, this can be inconvenient.

By assigning access keys to hyperlinks, you can make it easier for users to navigate them without a pointing 
device. An access key is a single character—usually a number—that, when pressed in combination with the 
Alt key (or another, device-specific key that serves the same purpose), causes the browser to either activate 
or follow the associated link. For example, if a link has been assigned "2” as its access key, pressing Alt+2 
will cause the browser to activate or follow that link.

The digits 0 9 make good access keys, but you should avoid letters, since ordinary Windows browsers use 
several Alt+letter combinations as menu shortcuts. For mobile phone users, you can also use ”#’’ and as 
access keys, since these characters are always present on standard keypads.

When you assign an access key to a link, it's a good idea to add a note after the link to let users know about 
it. For example:

• News (press 1)
• Support (press 2)
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EJ Do not assign the same access key to more than one link.

To assign an access key to a link

1. Double-click the link to open the Hyperlink Properties dialog box.
2. In the Access key box, type the desired character, or click the triangle and select one from the 

drop-down menu.

S e t t i n g  h y p e r l i n k  c o l o r s

In modem visual browsers, a hyperlink can be displayed in any of three or four different colors at a given 
time. The normal color, blue by default, is used when a link has not yet been opened in the current browser 
session. A link’s color changes to the visited color, purple by default, once it has been opened. The active 
color, red by default, is used in different ways by different browsers: Internet Explorer uses it for the link 
that has ’’focus’’—that is, the link that will be opened when the user presses the Enter key; while Netscape 
uses it for a link that is in the process of being clicked. The hover color, which may or may not defined by 
default, is used for the link that is currently under the mouse pointer (without the mouse button being 
pressed).

S?  In Internet Explorer, the active color and the hover color are set by default to the same color (red). In 
Netscape 6+ and Mozilla 1.x, no hover color is defined by default; if you define one, that color will 
also be used as the active color. Netscape 4.x does not support the hover color.

You can override any or all of the default link colors at various levels:

• At the individual link level, you can set a single color for a specific link. The same color will be 
used regardless of the link's state (normal, visited, active, or hover).

• At the document level, you can specify different normal, visited, and active colors that affect all 
the links in a particular document. (However, you cannot specify a hover color at this level.)

• At the style sheet (p.212) level, you can specify different normal, visited, active, and hover colors 
that affect all the links in all the documents that use a particular style sheet.

0  If you specify link colors at both the document level and the style sheet level, the browser will give 
priority to the style sheet colors (assuming the browser supports style sheets). If you specify a single 
color for a specific link, it will override all colors specified at other levels.

To specify a single color for a specific link

1. Select the link. Do not, however, select any adjacent content.
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2. On the Formatting Toolbar, click the triangle on the A . * (Font Color) button and select a color 
(p.233).

To specify colors for all links in the current document

1. On the File menu, click Document Properties, and then click the Appearance tab.
2. To specify the normal link color, click the Hyperlinks color box and select a color (p.233).
3. To specify the visited link color, click the Visited links color box and select a color (p.233).
4. To specify the active link color, click the Active links color box and select a color (p.233).

To specify link colors in a style sheet

1. On the Format menu, click Define Styles.
2. Click L *  (Add).
3. Under Style type, click Other.
4. Click the triangle on the Name box and select one of the following:

o :link to define the normal link color 
o :visited to define the visited link color 
o ¡active to define the active link color 
o :hover to define the hover link color

5. Click OK.
6. Click the Font color box and select a color (p.233).
7. Repeat steps 2 6 for each link color you want to define.
8. (optional) If you want to save the style sheet externally so that you can use it with other 

documents, click (Save As External File), navigate to the desired folder, enter the desired file 
name, and click Save.

9. Click OK.

9  You can change the default normal visited, and active link colors for new documents on the Document 
Defaults tab of the Preferences dialog box.

Related topics
Selecting colors........................................................................................................p.233

Setting character-related properties......................................................................p .219

Using style sheets.................................................................................................... p .212
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C h a n g i n g  t h e  d e s t i n a t i o n  o f  a  h y p e r l i n k

There are several ways to change the destination (URL) of a hyperlink. The method varies somewhat 
depending on the type of content on which the link is based.

To change the URL of a text-based link

• Do one of the following:
o Double-click the link, enter the new URL, and press Enter.
o Place the insertion point inside the link, enter the new URL in the URL box on the 

Hyperlink Toolbar, and press Enter.
o Place the insertion point inside the link, enter the new URL in the URL box on the 

Inspector, and press Enter.

To change the URL of an image-based link

1. Select the image.
2. On the Standard Toolbar, click $  (Hyperlink), or press F9.
3. Enter the new URL and press Enter.

To change the URL of a Flash Button-based link

1. Double-click the Flash Button.
2. Enter the new URL in the Link box and press Enter.

R e m o v i n g  a  h y p e r l i n k

To remove a hyperlink on text or an image

1. If the link is text-based, place the insertion point in it. If it is image-based, select the image.

2. On the Standard Toolbar, click (Remove Hyperlink), or press Shift+F9.

9  To remove several nearby hyperlinks at once, select all the content surrounding them and then do step
2 above.

To remove a hyperlink from a Flash Button

1. Double-click the Flash Button.
2. Delete the contents of the Link box and press Enter.
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C r e a t i n g  a n  i m a g e  m a p

You can place several different hyperlinks on a single image. You do this by drawing hot zones on the 
image, each hot zone linking to a different URL. A collection of hot zones is called an image map. For 
example, the image below has an image map with five hot zones, one for each continent. Clicking each 
zone will take the user to a different Web page. (Normally, the lines demarcating hot zones are invisible, 
but they have been made visible in this example.)

An image map

Namo WebEditor lets you create hot zones by simply drawing them with the mouse. Hot zones can be 
rectangular, circular, or polygonal with any number of sides. Tools for drawing the various hot zone shapes 
can be accessed easily on either the Inspector or the Image Toolbar. (To reveal the Image Toolbar, right- 
click the toolbar area and click Image Toolbar.)

To create an image map

1. Select the image you want to create an image map on.
2. Click any of the following buttons on either the Inspector or the Image Toolbar:

o Q  (Draw Rectangular Hot Zone) 
o O  (Draw Circular Hot Zone) 
o O  (Draw Polygonal Hot Zone)

3. Draw a rectangle, circle, or polygon covering an area of the image that you want to make a link. 
(For a polygonal hot zone, click each point where you want to place a vertex, and then double­
click the last point to close the polygon.) When you are finished drawing the hot zone, the Create 
Hyperlink dialog box will appear.

4. Enter the desired URL for the hot zone and specify any other properties you want for the hyperlink, 
and then click OK.

5. Repeat steps 2 4 for each area of the image you want to make a link.
6. When you are finished drawing hot zones, press Esc to exit hot zone drawing mode.
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fcf You can use the same steps above to add a hot zone to an existing image map.

To move a hot zone

1. Click an image that has an image map.
2. Drag the desired hot zone to the desired location. (The mouse pointer will turn into the shape of a 

hand when it is over a hot zone.)

To resize or reshape a hot zone

1. Click an image that has an image map.
2. Click the desired hot zone. Resize handles will appear at the hot zone's comers or vertices. (For a 

circular hot zone, resize handles will appear at the comers of the circle's bounding box.)
3. Drag resize handles as necessary to change the hot zone's size and/or shape.

To change the URL or other properties of a hot zone

1. Click an image that has an image map.
2. Double-click the desired hot zone. The Hyperlink Properties dialog box will appear.
3. Edit the link properties as desired, and then click OK.

To remove a hot zone

1. Click an image that has an image map.
2. Click the desired hot zone and press Delete. (Note: you may need to click on another part of the 

image before the hot zone's outline disappears.)

O p e n i n g  a  l i n k e d  d o c u m e n t  i n  E d i t  m o d e

Namo WebEditor provides the ability to follow links in Edit mode. Thus, while you are editing one 
document, you can easily open another document that the first document contains a link to. To follow a link 
in Edit mode, click the link while holding down the Alt key. Alternatively, right-click the link and then 
click Open Hyperlink.

If the URL of the followed link is just a path to a local document (p. 167), Namo WebEditor will simply 
open the document. If, however, the URL is a full URL (p. 167) that points to a document on the Web,
Namo WebEditor will attempt to download a copy of the document from the Web. (This is the same as 
opening a document on the Web (p.60) by entering its URL in the Open dialog box and clicking Open 
URL.)
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Related topics
Opening documents................................................................................................. p.60

A b o u t  b o o k m a r k s

A bookmark is a tag that identifies a location, within a document, that is to serve as the destination of a 
hyperlink. For example, if a document has a bookmark named "3.html" on its third heading element, a 
hyperlink on the same page can refer to "#section_3", causing the Web browser to jump to that location on 
the page, scrolling the document if necessary. A hyperlink on another document can refer to the bookmark 
by appending the bookmark name to the URL—for example,
http://www.example.eom/index.html#section_3. When a user clicks the link, the browser will open the 
document and jump to the bookmark location.

Bookmarks are especially useful in long documents. For example, if you have a page that contains a long 
list of terms and definitions, you could put a unique bookmark on each term, and then use the bookmarks to 
link to individual terms from other documents, or from a term index and the top of the page. It is also 
common to insert a bookmark at the top of a long page, and then insert links to the top bookmark 
periodically throughout the page. This saves users the trouble of scrolling back to the top manually.

Bookmarks are not visible in a browser. In Namo WebEditor's Edit mode, the location of a bookmark is
indicated by the icon 1̂ 3 just before the bookmark. If the display of special tag marks (p.44) is disabled, 
bookmarks are completely invisible in Edit mode.

C r e a t i n g  a  b o o k m a r k

To create a bookmark

1. Either select some content on the line where you want the boomark, or just place the insertion 
point anywhere on that line.

2. On the Insert menu, click Bookmark; or press Ctrl+G.
3. In the Bookmark name box, type the desired name for the bookmark. If you selected text in step 1, 

the text will automatically appear in the box; you can edit it or replace it as you wish.
4. Click Add or press Enter, and then click Close or press Enter again.

In the document window, a bookmark icon ( O ) will appear where you inserted the bookmark, and, if you 
selected some content before creating the bookmark, that content will be shown with a dashed underline. If
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you can't see the icon/underline or you want to hide it, click □  (Show/Hide Special Tag Marks) on the 
Standard Toolbar.

W The Bookmarks dialog box is non-modal, so you can keep it open while you continue working in the 
document window. You can create several bookmarks one after another, and then close the dialog box 
when you are finished.

Related topics
Setting a bookmark as the destination o f  a hyperlink........................................p. 180

R e n a m i n g  a n d  r e m o v i n g  b o o k m a r k s

To rename a bookmark

1. Right-click the bookmark icon (1 ^ )  or the underlined content where the desired bookmark is, 
and then click Modify Bookmark. (Or just double-click the bookmark icon.)

2. In the Bookmark name box, edit the bookmark name as desired and press Enter.

To delete a bookmark

1. Right-click the bookmark icon (S 3  ) or the underlined content where the desired bookmark is, 
and then click Modify Bookmark. (Or just double-click the bookmark icon.)

2. Click Remove.

n
U You can rename or delete several bookmarks at once while the Bookmarks dialog box is open. Just 

select each bookmark you want to rename or remove in the Bookmarks list, and then rename or 
remove it.

U s i n g  b o o k m a r k s  i n  h y p e r l i n k s

To refer to a bookmark in the URL of a hyperlink, just append the character, followed by the bookmark 
name, at the end of the URL. For example, to link to the bookmark named "8.html" in the document 
"regulations.html”, you would use the URL regulations.html#section_8.

If you want to link to a bookmark in the same document as the link itself, just use "#" followed by the 
bookmark name as the URL. For example, #section_8.
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When you create a hyperlink using the Create Hyperlink dialog box, if you enter a path to a local 
document in the URL box, clicking the triangle on the Bookmark box will drop down a list of all the 
bookmarks that are in that document. You can just select a bookmark in the list instead of typing it in. 
(This only works ifNamo WebEditor can find the destination document on the local file system, so it 
will not work if the URL is non-local or the document does not exist locally.)
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T a b l e s

In HTML, a table is essentially a box divided into cells. Each cell is a container; its contents can include 
text, images, and other elements— even other tables.

Tables were originally intended for presenting textual information that is easiest to read in a row-and- 
column layout, such as baseball statistics. However, pioneering Web designers quickly discovered they 
could use tables to create multi-column page layouts that were otherwise impossible to achieve in HTML 
(before the introduction o f layers (p.l 11)). Although authors can now design complex page layouts with less 
effort using layers, the majority o f authors still prefer working with tables.

9  Using Namo WebEditor's layout box (p.91) feature, you can create a table for page layout by simply 
drawing container cells on a grid and then arranging them by dragging. Depending on your 
experience level, layout boxes can be easier and more intuitive than working with tables directly.

In this section
Creating a table....................................................................................p. 183
Selecting parts of a table....................................................................... p. 184
Resizing rows and columns...................................................................p. 185
Adding and removing rows and columns................................................ p. 188
Copying and moving cells.................................................................... p. 189
Deleting the contents of multiple cells.................................................... p. 190
Merging and splitting cells.................................................................... p. 191
Aligning content in cells....................................................................... p. 192
Specifying cell spacing and padding.......................................................p. 192
Controlling the appearance of table and cell borders................................p. 194
Specifying other table and cell properties............................................... p.201
Centering or right-aligning a table..........................................................p.205
Making other content flow around a table...............................................p.205
Splitting and joining tables................................................................... p.206
Sorting and transposing tables............................................................... p.207
Converting between paragraphs and tables..............................................p.208

Related topics
Using a table for layout......................................................................... p.99
Using layout boxes.............................................................................. p.91
Table cell rollover................................................................................ p.303
Importing Excel spreadsheets................................................................p.480
Creating charts from table data.............................................................. p.484

182 Tables



Chapter 4: Basic Page Content and Formatting

C r e a t i n g  a  t a b l e

There are three ways to create a table in Namo WebEditor:

• Using the Create Table button on the Standard Toolbar

• Using the Draw Table command and "drawing” a table with the mouse

• Using the New Table command and specifying numbers of rows and columns in the Table 
Properties dialog box

To create a table using the Create Table button
1. Place the insertion point where you want to insert the table.

2. On the Standard Toolbar, click ®  (Create Table).
3. Drag the mouse down and to the right until the highlighted cells on the miniature table match the 

number o f rows and columns you want in the table.
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3x4
Creating a table using the Create Table button

El When you create a table using the Create Table button, Namo WebEditor automatically sets column 
widths so that each column is the same width and the whole table stretches across the current width of 
the document window. Table width is not specified, so the columns can automatically shrink when the 
document or browser window is made narrower.

To "draw” a table
1. Place the insertion point at the beginning of the line above which you want to insert a table.
2. Press Enter to create a new, empty paragraph.
3. On the Table menu, click Draw Table. The mouse pointer will turn into a pencil— indicating table 

drawing mode— and the Table Toolbar will appear.
4. Click on the empty paragraph and drag the mouse until the dashed rectangle is the size and shape 

you want for the table.
5. Click inside the border o f the new table and draw lines to divide the table into rows and columns.

6. When you are finished drawing the table, press Esc or click ^  (Escape Table Drawing Mode) on 
the Table Toolbar.
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EI When you "draw" a table, Namo WebEditor automatically sets column widths and row heights to 
reflect the positions of the borders you draw. Table width is not specified, so the columns can 
automatically shrink when the document or browser window is made narrower.

13 You cannot "draw" a table inside another table.

To create a table through the Table Properties dialog box
1. Place the insertion point where you want to insert the table.
2. On the Table menu, click New Table.
3. In the Rows and Columns boxes, enter the desired numbers of rows and columns for the new table.
4. (optional) Enter the desired width and/or height o f  the table in the Width and/or Height boxes.
5. Click OK.

ED When you create a table using the Table P rope rties dialog box and you do not specify the table width, 
Namo WebEditor automatically sets column widths so that each column is the same width and the 
whole table stretches across the current width of the document window. Table width is not 
automatically specified, so the columns can automatically shrink when the document or browser 
window is made narrower. Conversely, if you do specify the table width, column widths are not 
automatically specified.

Related topics
Resizing rows and columns...................................................................p. 185

S e l e c t i n g  p a r t s  o f  a  t a b l e

To select a single cell
• Do one o f the following:

o Click inside the cell while holding down the Ctrl key.
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o  R ight-click  inside the cell and click  S e lect Cell.

To select several adjacent cells
•  Do one o f  the follow ing:

o Click inside the first cell and drag the mouse pointer to the last cell.
o Click inside the first cell and then click inside the last cell while holding down the Shift 

key.

To select several non-adjacent cells
•  Click inside each cell w hile hold ing dow n the Ctrl key.

To select an entire row
• Click the left border of the row's first cell. (The mouse pointer should look like - f  before you 

click.)

To select an entire column
• Click the top border o f the column's first cell. (The mouse pointer should look like 4- before you 

click.)

To select an entire table
•  R ight-click inside the table and click  S e lect Table.

To deselect a cell
•  Click inside the cell w hile holding dow n the Ctrl key.

R e s i z i n g  r o w s  a n d  c o l u m n s

Depending on how you create a table (p. 183), Namo WebEditor may automatically set column widths and 
row heights to certain values. You can change row heights and column widths in two ways: by dragging 
borders with the mouse or by specifying heights and widths using numerical values. You can also set the 
overall height or width o f a table using numerical values.

Resizing rows and columns using the mouse
To resize a column, drag its right border left or right. (The mouse pointer should look like Mb while you 
drag.) Note that when you resize any column except for the last column in a table, the next column's width 
also changes to keep the table's overall width the same. If you want to resize a column without affecting
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other columns (but letting the table's overall width change), hold down the Ctrl key while you drag the 
column border.

♦
To resize a row, drag its bottom border up or down. (The mouse pointer should look like n r  while you 
drag.) Note that when you resize a row, other rows stay the same height, and the table's overall height 
changes. If you want to resize a row without changing the table's overall height (but letting the next row's 
height change), hold down the Ctrl key while you drag the row border.

You can also resize an entire table while keeping the relative widths o f its columns (or the relative heights 
of its rows) constant. To do so, drag the table's right (or bottom) border while holding down the Ctrl key.

9  When you use a layout grid (p.43) and/or layout guides (p.43), and the Snap option is turned onf the 
borders of rows and columns will "snap" to guides and gridlines as you drag them.

Specifying row heights and column widths using numbers
You can set the height of a row or the width o f a column numerically, either in pixels or as a percentage o f 
the table's height (or width). You can also set the overall width and/or height o f a table, either in pixels or 
as a percentage o f the available space.

To specify row height using numbers
1. Select the row you want to resize.
2. On the Inspector, enter a number o f pixels or a percentage value in the Height box and press Enter.

To specify column width using numbers
1. Select the column you want to resize.
2. On the Inspector, enter a number o f pixels or a percentage value in the Width box and press Enter.

To specify table width and/or height using numbers
1. Right-click inside the table and click Table Properties.
2. In the Width box and/or the Height box, enter a number and then click either pixels or %.

To equalize column widths or row heights
1. Select the columns or rows you want to make the same width or height. (The columns or rows 

must be adjacent.)
2. On the Table menu, point to Cell Sizing, and click either Equalize Cell Widths or Equalize Cell 

Heights.

To clear all specified heights or widths in a table
1. Place the insertion point inside the table.
2. On the Table menu, point to Cell Sizing, and click either Clear All Width Attributes or Clear All 

Height Attributes.
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IE l The w id th  o r  h e ig h t a ttr ib u te s  o f  a l l  c e lls  a n d  th e  ta b le  i t s e l f  w i l l  b e  c le a re d .

Notes about row and column sizing
• Browsers respect specified column widths whenever possible. Specified row heights, on the other 

hand, are always disregarded when necessary to fit cell contents.

• You can specify the widths of some columns in a table and leave those o f other columns 
unspecified. Any column without a specified width will be sized automatically, depending on its 
contents, within the available space.

• You can use a combination of pixel values and percentages when specifying column widths or row 
heights in the same table. In such cases, the overall width or height o f the table (as long as it is not 
specified) will be based on the pixel values.

• If you specify all column widths in percentages, and the percentages do not add up to 100%, the 
columns will be sized according to the ratios between their percentage values. The same holds true 
for rows and row heights.

• To set the width o f a column or the height o f a row, you only need to set the width or height o f one 
cell in that column or row. If different cells in the same column or row have different specified 
sizes, the largest cell determines the effective column width or row height.

• Because o f  conflicts or limitations, the effective sizes o f cells will often not match their specified 
sizes. If you want to change the specified sizes to match the effective sizes, on the Table menu, 
point to Cell Sizing, and click Apply Apparent Cell Sizes.

How specified row or column sizes interact with specified table sizes
When you set column widths in pixels and also specify the overall table width, the specified values may 
conflict with each other: that is, the sum of the column widths may not equal the specified table width. The 
same is true o f row heights and overall table height. The following rules govern how modem browsers 
resolve conflicting cell and table sizes:

• If the sum of the column widths is not equal to the specified table width, the column widths are 
automatically adjusted to fit the specified table width. The proportions between column widths 
remain constant.

• If the sum o f the row heights is less than the specified table height, the row heights are 
automatically adjusted to fit the specified table height. The proportions between row heights 
remain constant.

• If the sum o f the row heights is greater than the specified table height, the table height is 
automatically adjusted to accommodate the specified row heights.

Related topics
Selecting parts o f a table............................................................................................ p. 184
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A d d i n g  a n d  r e m o v i n g  r o w s  a n d  c o l u m n s

To add a row at the bottom of a table
1. Place the insertion point in the last cell o f the table.
2. Press Tab.

To insert rows
1. Place the insertion point somewhere in the table.
2. Do one o f the following:

o On the Table menu, click Insert Rows or Columns.
-4 V-

o On the Table Toolbar, click Jr. (Insert Rows/Columns).
3. Click Insert rows.
4. In the Number of rows box, enter the number o f rows to insert.
5. Under Insert position, specify whether to insert the row(s) above or below the current row.
6. Click OK.

To insert columns
1. Place the insertion point somewhere in the table.
2. Do one o f the following:

o On the Table menu, click Insert Rows or Columns.

o On the Table Toolbar, click i t  (Insert Rows/Columns).
3. Click Insert columns.
4. In the Number of columns box, enter the number of columns to insert.
5. Under Insert position, specify whether to insert the column(s) to the left or the right of the current 

column.
6. Click OK.

To delete rows or columns
1. Place the insertion point inside the first row or column you want to delete.
2. Do one o f the following:

o On the Table menu, click Delete Rows or Columns.

o On the Table Toolbar, click (Delete Rows/Columns).
3. Specify whether to delete rows or columns and how many to delete.
4. Click OK.

9  Alternatively, just select the rows or columns to delete and press S h i f t + D e l e t e .
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GD When you insert a row or column, the new cells inherit the attributes—such as alignment and
background color—of the corresponding cells in the row or column that contained the insertion point. 
However; any text you insert in the new cells does not inherit the attributes of text in the adjacent cells.

Related topics
Selecting parts of a table...................................................................... p. 184

C o p y i n g  a n d  m o v i n g  c e l l s

To copy and insert rows or columns
1. Select the rows or columns you want to copy.
2. Press Ctrl+C.
3. Place the insertion point in another row or column.
4. Press Ctrl+V.
5. If you are copying rows, click Insert above or Insert below, depending on where you want to insert 

the copied rows. If you are copying columns, click Insert left or Insert right, depending on where 
you want to insert the copied columns.

6. Click OK.

To copy the contents of a block of cells to another block of cells
1. Select the block o f cells whose contents you want to copy. (The selection must be a rectangular 

block o f  cells.)
2. Press Ctrl+C.
3. Place the insertion point in the first cell o f the destination block.
4. Press Ctrl+V.
5. Click Paste contents only and then click OK.

E l  W hen p a s t in g  th e  c o n te n ts  o f  a  b lo c k  o f  c e lls  to  a n o th e r  b lo c k  o f  c e lls , the  ta r g e t  b lo c k  m u st h a v e  a t  
le a s t  a s  m a n y  ro w s  a n d  c o lu m n s a s  th e  so u rc e  b lock .

To move rows or columns
1. Select the rows or columns you want to move.
2. Do one o f the following:

o Drag the rows or columns on top o f another row or column.
o Press Ctrl+X, place the insertion point in another row or column, and then press Ctrl+V.
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3. If you are moving rows, click Insert above or Insert below, depending on where you want to insert 
the rows you are moving. If you are moving columns, click Insert left or Insert right, depending on 
where you want to insert the columns you are moving.

4. Click OK.

To copy or move a block of cells into another cell as a child table
1. Select the block o f cells you want to copy. (The selection must be a rectangular block of cells.)
2. Do one of the following:

o To copy the cells, press Ctrl+C.
o To move the cells, press Ctrl+X.

3. Place the insertion point in another cell.
4. Press Ctrl+V.
5. Click Insert as a child table and then click OK.

To create a new table by copying cells from an existing table
1. Select the block o f cells you want to copy. (The selection must be a rectangular block o f cells.)
2. Press Ctrl+C.
3. Place the insertion point outside the table.
4. Press Ctrl+V.

Related topics
Selecting parts of a table....................................................................... p. 184

Namo WebEditor 6 User Manual

D e l e t i n g  t h e  c o n t e n t s  o f  m u l t i p l e  c e l l s

To delete the contents of multiple cells
1. Select the cells whose contents you want to delete.
2. Do one o f the following:

o On the Table menu, click Delete Contents,
o Press Del.

Related topics
Selecting parts of a table....................................................................... p. 184

190 Tables



Chapter 4: Basic Page Content and Formatting

M e r g i n g  a n d  s p l i t t i n g  c e l l s

Merging cells means combining two or more table cells into one. Splitting a cell means dividing it into two 
or more cells. You can merge and split cells using either menu/toolbar commands or the Table Pencil and 
Table Eraser tools.

To split cells
1. Select the cells you want to split.
2. Do one o f the following:

o On the Table menu, click Split Cell, 

o On the Table Toolbar, click ES (Split Cell).
3. Specify whether to split the cells into rows or columns and how many rows or columns to split 

each cell into.
4. Click OK.

To split cells using the Table Pencil tool
1. Do one o f the following:

o On the Table menu, click Draw Table.

o On the Table Toolbar, click ^  (Table Pencil).
2. Draw lines where you want to split cells.

3. When finished, press Esc or click ^ (Escape Table Drawing Mode) on the Table Toolbar.

To merge cells
1. Select two or more cells to merge.
2. Do one o f the following:

o On the Table menu, click Merge Cells,

o On the Table Toolbar, click H  (Merge Cells).

03  The cells to be merged must comprise a rectangular block.

To merge cells using the Table Eraser tool

1. On the Table Toolbar, click ( ?  (Table Eraser).
2. Drag the eraser across one or more borders between cells.

Related topics
Selecting parts of a table...................................................................... p. 184
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A l i g n i n g  c o n t e n t  i n  c e l l s

By default, the contents o f a table cell are left-aligned and vertically centered within the cell. You can 
change a cell’s alignment settings on the Inspector.

To set the horizontal alignment of the contents of cells
1. Select the cells whose content you want to align.
2. On the Inspector, click the H alignment box and select Left, Right, or Center.

To set the vertical alignment of the contents of cells
1. Select the cells whose content you want to align.
2. On the Inspector, click the V alignment box and select Top, Middle, Bottom, or Baseline.

IP  In theory, if one cell in a row has its vertical alignment set to Baseline, the content of all other cells in 
the same row should start at the same vertical position as that of the cell whose vertical alignment is 
set to Baseline. In practice, however, most browsers treat Baseline alignment the same as Top 
alignment.

E) You can override the specified horizontal alignment of a cell on a paragraph-by-paragraph basis by 
setting a different alignment (p.22l) for individual paragraphs in the cell.

Related topics
Selecting parts of a table....................................................................... p. 184
Centering or right-aligning a table on the page........................................ p.205
Setting paragraph alignment..................................................................p.221

S p e c i f y i n g  c e l l  s p a c i n g  a n d  p a d d i n g

Cell spacing is space between cells in a table. Cell padding is space between the border o f a cell and its 
contents. You can specify a single cell padding value for a whole table, or you can specify a padding 
amount independently for each side o f an individual cell. If you do both, individual cell padding values 
override the table-wide value. Cell spacing, on the other hand, can only be set for a whole table.

Some examples o f different spacing and padding values are shown below:

192 Tables



Chapter 4: Basic Page Content and Formatting

¡helio ¡hello 

[hëïïô ¡hëïïô

Spacing = 10; 
Padding = 0

hello hello

hello hello

hello |hello

hello ¡hello

Spacing = I; 
Padding = 10

Spacing = 5; 
Padding = 0; 

first cell's padding = 10

To set cell spacing and padding for a whole table
1. Right-click the table and click Table Properties.
2. In the Cell padding box, enter a number o f pixels.
3. In the Cell spacing box, enter a number o f pixels.
4. Click OK.

To specify padding amounts for selected cells
1. Select the cells for which you want to specify padding amounts.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the cell side for which you want to set the padding. To select 

multiple sides at once, click each while holding down the Ctrl key. (See the examples below.) To 
select all four sides, click Select All. To deselect all sides, click in the middle o f the box. By 
default, all four sides are selected.

C lic k  w h ile  hold ing dow n C tr l to  
selcct m u ltip le  sides.

4. Enter a number in the Padding box and then click the unit box next to it and select a unit. I f  you do 
not specify a unit (p.231), the value will be interpreted as pixels.

5. Repeat steps 3 and 4 if  you want to set a different padding value for another side.
6. Click OK.

a If you set a table’s cell spacing to 0, the borders of adjacent cells will overlap.
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Related topics
Selecting parts of a table................................................................ p. 184

C o n t r o l l i n g  t h e  a p p e a r a n c e  o f  t a b l e  a n d  c e l l  b o r d e r s

In an HTML table, each cell can have a visible border on any of its four sides, as can the table as a whole. 
If you do not specify otherwise, most browsers draw cell borders as 1-pixel lines that are dark gray on the 
top and left sides, and light gray on the bottom and right sides. Similarly, by default, most browsers draw 
table borders as 1-pixel lines that are light gray on the top and left sides, and dark gray on the bottom and 
right sides. (The exact colors depend on the browser and the user's operating system settings.) Most 
browsers also display, by default, a small amount of white space between cells. While this cell spacing 
(p. 192) may appear to be part of or related to the cell borders, it is actually separate and independent.

Below is a 3x3 table with default borders and cell spacing, as rendered by Internet Explorer 6 on a typical 
Windows XP computer:

s a m p le s a m p le s a m p le

s a m p le s a m p le s a m p le

s a m p le s a m p le s a m p le

By zooming in on one cell, we can more easily distinguish its borders from those of neighboring cells, and 
also see the two different colors that, in combination with the small space between cells, makes the borders 
appear "raised", like raised lettering on a book cover.

I l

s a m p l e

“ I------------------------------ r

With Namo WebEditor, you can easily change the style, color, and width of cell and table borders. If you 
wish, you can specify different border settings independently for each side of a cell. You can also apply a
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single color (or pair of light and dark colors), style, or width at once to all the borders of a cell, group of 
cells, or table.

In this section
Applying border presets to an entire table.......................................... p. 195
Specifying one or two border colors for an entire table.........................p. 196
Specifying one or two border colors for selected cells.......................... p. 196
Specifying border style, color, and width for a table or block of cells...... p. 197
Specifying border style, color, and width for individual cells................. p. 199
Managing conflicting cell borders.................................................... p.200

A p p l y i n g  b o r d e r  p r e s e t s  t o  a n  e n t i r e  t a b l e

The simplest way to change the appearance of the borders in a table is to use a border preset. When you 
apply a border preset, Namo WebEditor changes several border-related attributes of an entire table at once, 
and also removes any border-related attributes that were previously applied to individual cells. The four 
available border presets are described below.

Sets the table's border width to 1 pixel; removes all other border-related HTML 
attributes from the table; and removes all border-related CSS properties from all 
cells. Also resets the table’s cell spacing and padding (p. 192).

Normal

sample sample

sample sample

Thin
Sets the table's border width to 1 pixel, dark border color to white, light border 
color to black, and cell spacing (p. 192) to 0. Removes all border-related CSS 
properties from the table and all cells. Also resets the table’s cell padding 
(p. 192).

Thick
Sets the table’s border width to 1 pixel, dark border color and light border color 
both to black, and cell spacing (p. 192) to 0. Removes all other border-related 
HTML attributes and CSS properties from the table and all cells. Also resets the 
table’s cell padding (p.192).

sample sample

sample sample

sample sample

sample sample
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H id e

feampleV^pld ^ets ta^̂ e’s ce^ spacing and padding both to 0. Removes all border-related
r.........r......... :....HTML attributes and CSS properties from the table and all cells. (If no border
¡samples ampld attributes are specified, browsers hide table borders.)

To apply a border preset to a table
• On the Table menu, point to Borders, and then click one of the commands: Normal, Thin, Thick, 

and Hide.

0  If you have specified a border color or pair of colors for any cell (p. 196) using HTML attributes, 
applying a border preset to the table will not remove the cell border color (s). Also, if you have 
specified any border-related CSS properties for the table itself applying a border preset will not 
remove those properties.

S p e c i f y i n g  o n e  o r  t w o  b o r d e r  c o l o r s  f o r  a n  e n t i r e  t a b l e

To specify a single border color for a whole table
1. Right-click inside the table and click Table Properties.
2. Under Borders, click the Color box and select a color (p.233).

To specify light and dark border colors for a whole table
1. Right-click inside the table and click Table Properties.
2. Under Borders, click the Light border box and select a color. Then, click the Dark border box and 

select a color (p.233).

E ? Light and dark border colors are only supported by Internet Explorer.

To reset a border color to the default color
1. Right-click inside the table and click Table Properties.
2. Under Borders, click one of the color boxes and, on the Color Palette (p.233), click Default.

S p e c i f y i n g  o n e  o r  t w o  b o r d e r  c o l o r s  f o r  s e l e c t e d  c e l l s

To specify a single border color for one or more cells
1. Select the desired cells.
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2. On the Inspector, click the Border color box and select a color (p.233).

To specify light and dark border colors for one or more cells
1. Select the desired cells.
2. Right-click one of the cells and click Cell Properties.
3. Under Borders, click the Light border box and select a color. Then, click the Dark border box and 

select a color (p.233).

HD Light and dark border colors are only supported by Internet Explorer.

To reset a border color for one or more cells
1. Select the desired cells.
2. Right-click one of the cells and click Cell Properties.
3. Under Borders, click one of the color boxes and, on the Color Palette (p.233), click Default. 

Related topics
Selecting parts of a table................................................................p. 184

S p e c i f y i n g  b o r d e r  s t y l e ,  c o l o r ,  a n d  w i d t h  f o r  a  t a b l e  o r  b l o c k  

o f  c e l l s

You can control the style, color, and width of borders for a whole table or a block of cells using the Table 
Borders dialog box. The border properties you select in this dialog box apply to all the selected cells as a 
unit. For example, you could select a block of cells in the middle of a table and apply a distinct set of 
border properties to it as a block. In the example below, the middle block of four cells uses double outer 
borders and dashed inner borders, while the rest of the table uses single, solid borders.

sample sample sample sample

sample sample i sample sample

sample sample • sample sample

sample sample sample sample
B order properties applied to a cell block

To specify complete border properties for a whole table or a block of cells
1. Do one of the following:
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o If you want to apply border properties to an entire table, place the insertion point inside 
the table.

o If you want to apply border properties to a block of cells, select the desired cells.
2. On the Table menu, point to Borders, and click Advanced.
3. In the border selection box, click to select the border for which you want to specify properties. To 

select multiple borders, click each while holding down the Ctrl key. (See the illustrations below.) 
You can also use the buttons under the selection box to select various groups of borders.

Click a b o rd e r to select i t  C lick ano ther bo rd e r while holding
down the C trl key to also select it.

C lick an intersection  to select two Double-click anyw here to  select or 
borders. deselect all borders.

4. Do any or all of the following:
o Click the Style box and select the desired border style. (If you select None, the border is 

hidden.)
o Click the Color box and select a color (p.233). 
o Enter a number in the Width box and select a unit in the unit box.

5. Repeat steps 3 and 4 for each border or set of borders you want to change.
6. Click OK.

When you use the Table Borders dialog box with a particular table for the first time, Namo WebEditor 
sets the table's cell spacing (p.192) to 0. Also, if you use it to specify the borders of only part of a table, 
the rest of the table will be automatically changed to use solid, black, 1-pixel borders.
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о Namo WebEditor uses CSS properties to apply settings in the Table Borders dialog box. Please note 
that various browsers may support these CSS properties differently or not at all.

Related topics
Selecting parts o f a tab le . .p.184

S p e c i f y i n g  b o r d e r  s t y l e ,  c o l o r ,  a n d  w i d t h  f o r  i n d i v i d u a l  c e l l s

You can control the style, color, and width of the border on each side of a cell independently, as in the 
example below, in which the middle cell uses a different border style and color on each side:

s a m p le  s a m p le s a m p le
1

s a m p le  i
1
i s a m p le  'I s a m p le

s a m p le s a m p le sa m p le

Exam ple of independent cell borders

To specify complete border properties for one or more individual cells
1. Select the desired cell(s). If you select more than one cell, the same border properties will be 

applied to each of them.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the cell border you want to change. To select multiple borders at 

once, click each while holding down the Ctrl key. (See the examples below.) To select all four 
borders, click Select All. To deselect all borders, click in the middle of the box. By default, all four 
borders are selected.

Click while holding dow n C trl to 
select m ultiple borders.

4. Do any or all o f the following:
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o Click the Style box and select the desired border style. (If you select None, the border is 
hidden.)

o Click the Color box and select a color (p.233). 
o Enter a number in the Width box and select a unit in the unit box.

5. Repeat steps 3 and 4 for each border or set of borders you want to change.
6. Click OK.

Namo WebEditor uses CSS properties to apply border settings in the Style dialog box. Please note that 
various browsers may support these CSS properties differently or not at all.

Related topics
Selecting parts of a table................................................................ p. 184

M a n a g i n g  c o n f l i c t i n g  c e l l  b o r d e r s

When a table’s cell spacing (p.192) is set to 0, two borders of adjacent cells can conflict, because they both 
take up the same space. When this happens, browsers use a complicated set of rules to decide which of the 
overlapping borders will dominate. Unfortunately, since these rules are not well documented, it is difficult 
to predict how border conflicts will be resolved.

In both of the examples below, all borders except for those of the bottom right cell are specified as solid, 
gray, 3-pixel borders. The bottom right cells in both examples have double black borders on all sides, but 
the one in the second example has 4-pixel borders instead of 3-pixel. Because of this difference, the borders 
of the bottom right cell in the second example ’'win", while those in the first example "lose".

sa m p le s a m p le  | s a m p le s a m p le

s a m p le s a m p le sa m p le s a m p le

Double borders "lose" Double bo rders "w in"

To avoid an undesired outcome when adjacent borders conflict, you sometimes need to forcibly hide one of 
the conflicting borders. Alternatively, if you want all cell borders to be visible even when cell spacing is 0, 
you can use the border-collapse CSS property on the table to prevent border overlapping.

To hide one or more borders of a cell
1. Select the cell. (Click it while holding down the Ctrl key.)
2. On the Format menu, click Borders & Background.
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3. In the border selection box, select the cell border you want to change. To select multiple borders at 
once, click each while holding down the Ctrl key. (See the examples below.)

Y
! !

-I
i

*

I
I

Click a border to select it. Click while holding down Ctrl to
select multiple borders.

4. Click the Style box and select None.
5. Click OK.

To prevent overlapping cell borders when cell spacing is set to 0
1. Place the insertion point just before the table. (The <table> tag should be highlighted on the Tag 

Selector.)
2. Click the HTML tab to switch to HTML mode.
3. Examine the <table> tag on the highlighted line and do one of the following:

o If the tag contains the inline style declaration s ty le =  "border- 
c o l la p s e : c o lla p se ; ", change it to s ty le =  "border- 
c o l la p s e : s e p a r a te ; ".

o Otherwise, insert s ty le =  " b o rd e r-c o lla p se : s e p a r a te ;" into the <table> tag.
4. Return to Edit mode to see the effect of the change.

S p e c i f y i n g  o t h e r  t a b l e  a n d  c e l l  p r o p e r t i e s

Various miscellaneous properties of tables and cells can be managed in the Table Properties dialog box or, 
often, on the Inspector.

In this section
Adding a caption to a table....................................

Using background colors and images in a table 

Using table header c e lls ........................................

p.202

p.202

p.204
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Controlling text wrapping in a tab le ........................................................................p.204

A d d i n g  a  c a p t i o n  t o  a  t a b l e

Any table can have a caption—a sentence or phrase that provides some information about the table, such as 
a description of its contents. Although you could use an ordinary paragraph for the same purpose, a true 
caption may be more convenient since it is actually part of the table and thus always stays with it. If you 
delete the table, the caption is also deleted.

To add a caption
1. Place the insertion point in a table.
2. On the Table menu, point to Caption, and then click Insert Caption.
3. Type the caption.

To change the position of a caption
1. Right-click a table that has a caption and click Table Properties.
2. Under Layout, click the Table caption box and select the desired caption position.
3. Click OK.

To delete a caption
1. Place the insertion point in a table that has a caption.
2. On the Table menu, point to Caption, and then click Delete Caption.

When you choose Left or R ight for the caption position, Internet Explorer and Namo WebEditor display 
the caption on top of the table with left or right alignment. Netscape 6.x and 7.x display the caption on 
the left or right side of the table. Netscape Navigator 4.x displays the caption centered on top of the 
table.

U s i n g  b a c k g r o u n d  c o l o r s  a n d  i m a g e s  i n  a  t a b l e

Each cell in a table can have its own background color or image, as can the table as a whole. You can also 
apply a background color (but not an image) to a particular row. Cell backgrounds override row 
backgrounds, which in turn override table backgrounds. On the same element, a background image 
overrides a background color.

Netscape Navigator 4.x does not correctly support table background images. If a table background 
image is specified', it is applied to each cell separately.
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1. Right-click the table and click Table Properties.
2. Under Background, do one o f the following:

o In the Image box, enter the path or URL of an image File. You can also click 'A (Browse)
to find and select an image file from your local file system; click (Clip Art) to select an
image from the clip art library; or click 2^  (Site) to select from a list of image files 
belonging to the current local site (if one is open).

o Click the Color box and select a color (p.233).
3. Click OK.

To apply a background color or image to a cell or cells
1. Select the desired cell(s).
2. Right-click one of the selected cells and click Cell Properties.
3. Under Background, do one o f the following:

o In the Image box, enter the path or URL of an image file. You can also click ^  (Browse)
to find and select an image file from your local file system; click &  (Clip Art) to select an
image from the clip art library; or click (Site) to select from a list o f image files 
belonging to the current local site (if one is open).

o Click the Color box and select a color (p.233).
4. Click OK.

L-J If you apply a background image to multiple cells, the image is applied separately to each cell; it does 
not span the group of cells.

To apply a background color to a row
1. Right-click the row, click Table Properties, and then click the Row tab.
2. Under Background, click the Color box and select a color (p.233).
3. Click OK.

To remove a background color or image on a table, cell, or row
1. Right-click the table, cell, or row and click Table Properties.
2. If you are removing a row background color, click the Row tab.
3. Under Background, do one or both o f  the following, as appropriate:

o Delete the path or URL in the Image box. 
o Click the Color box and then click Default.

4. Click OK.

To apply a background color or im age to  a tab le
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Related topics
Selecting parts of a table........................................................................... p. 184

U s i n g  t a b l e  h e a d e r  c e l l s

A special kind o f table cell is called a header cell. Text in header cells is automatically formatted with 
center alignment and bold type. Header cells are typically used as headings at the tops o f columns, but any 
cell can be made a header cell.

To specify cells as header cells
1. Select the cells you want to be header cells.
2. On the Inspector, select the Header check box.

To turn header cells into ordinary cells
1. Select the headers cells.
2. On the Inspector, deselect the Header check box.

Related topics
Selecting parts of a table............................................................................p. 184

C o n t r o l l i n g  t e x t  w r a p p i n g  i n  a  t a b l e

Ordinarily, text in a table is automatically "wrapped" (broken into multiple lines) by browsers so that the 
width o f the table does not exceed the width o f the browser window. However, there may be instances 
when you do not want text in a particular cell or set of cells to be automatically wrapped, even if keeping 
the text on one line would require the table to be wider than the window. For example, the cells in the first 
column o f a table may contain labels that you want always to appear on a single line, regardless o f the size 
of the browser window.

In such cases, you can specify that a cell be excluded from automatic text wrapping. If a cell has the 
nowrap attribute, browsers will always try to keep each paragraph in the cell on a single line. If necessary, 
cells in other columns will be made narrower, even if they have specified widths. If other columns can be 
shrunk no further, the browser will make the table wider, without regard to the width of the window.

0  If a cell has a specified width in pixels, text in the cell will be wrapped if necessary to respect the 
specified width even if the ttowrap attribute has been set.
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To prevent text wrapping in selected cells
1. Select the desired cell(s).
2. On the Inspector, select the No wrap check box.

Gil The effect of using the nowrap attribute is not apparent in Edit mode. To view the effect o f nowrap, 
switch to Preview mode.

C e n t e r i n g  o r  r i g h t - a l i g n i n g  a  t a b l e

If a table does not fill the available horizontal space, it will be aligned by default on the left o f  the parent 
container. However, you can specify that it be centered or right-aligned, instead.

To center or right-align a table
1. Right-click the table and click Table Properties.
2. Under Layout, click the Alignment box and select Right or Center.

M a k i n g  o t h e r  c o n t e n t  f l o w  a r o u n d  a  t a b l e

If a table does not horizontally fill its parent container, you can make it "float”, causing content following 
the table to flow around the table on one side.

Sj D:\work\wescratch\noname1 .html

Lorem ipsum dolor 
sed, malesuada in, 
accumsan non, pos 

hendrerit malesuada uma. Nam laorei 
consequat ipsum magna a orci. Maec

Example of a floating table

To make following content flow around a table
1. Right-click the table and click Table Properties.

lorem ipsum

ipsum lorem
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2. Under Layout, click the Alignment box and select Left (floating) or Right (floating), depending on 
whether you want following content to flow around it on the right or the left.

To adjust the space between a floating table and adjacent content
1. Right-click the table and click Table Properties.
2. Click the Style button and then click Borders & Background.
3. In the border selection box, select the side on which you want to adjust the table margin. To select 

multiple sides at once, click each while holding down the Ctrl key. (See the examples below.)

V

* “  *  L *

i  r
A______________

Click while holding down Ctrl to 
select multiple sides.

4. Enter a number in the Margin box and then click the unit box next to it and select a unit. If you do 
not specify a unit (p.231), the value will be interpreted as pixels.

5. Click OK, and then click OK again to close the Table Properties dialog box.

S p l i t t i n g  a n d  j o i n i n g  t a b l e s

To split a table into two tables
1. Place the insertion point in the row below which you want to split the table.
2. On the Table menu, point to Convert, and then click Split Table.

Do not split a table at a row that contains part o f a cell that spans two or more rows, as the results are 
unpredictable.

To join two adjacent tables
1. Place the insertion point in the first table.
2. On the Table menu, point to Convert, and then click Merge Tables.
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E3 The tables to be joined must have the same number of columns, and there must be no other content 
between them (including empty paragraphs). If the column widths of the two tables are different, the 
column widths of the first table will be applied to the joined table.

S o r t i n g  a n d  t r a n s p o s i n g  t a b l e s

Rows (or columns) in a table can be sorted in ascending or descending order according to the data in up to 
three columns (or rows). Cell data can be evaluated as numbers or as strings of characters. See the 
examples below.

Name Age
Joe Smith 26
Joe Smith 17
Alan Alcove 51
Christy Maer 9
Helen Haunt 101

Original

Name Age
Alan Alcove 51
Christy Maer 9
Helen Haunt 101
Joe Smith 26
Joe Smith 17

Sorted by column 1

Name Age
Alan Alcove 51
Christy Maer 9
Helen Haunt 101
Joe Smith 17
Joe Smith 26

Sorted by column 1 
then by column 2

Name Age
Christy Maer 9
Joe Smith 17
Joe Smith 26
Alan Alcove 51
Helen Haunt 101

Sorted by column 2 
as number

Name Age
Helen Haunt | 101
Joe Smith 17
Joe Smith 26
Alan Alcove 51
Christy Maer 9

Sorted by column 2 
as string

A table can also be transposed, swapping rows for columns and vice versa as in the following example:

Color Sign HMH John Mary
John Green Gemini [Color Green Taupe
Mary Taupe Aries i Sign Gemini Aries

Original Transposed
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To sort a table or part of a table
1. Place the insertion point in the table to be sorted or select the cells to be sorted.
2. On the Table menu, click Sort.
3. If you want to sort columns, click Sort left to right under Options. To sort rows, leave the option 

deselected.
4. Under Sort by, select the column (or row) according to which the rows (or columns) will be sorted; 

specify whether to evaluate the cell contents as strings or as numbers; and specify whether to order 
the rows (or columns) in ascending or descending order.

5. (optional) If the column (or row) you selected under Sort by contains some cells that have the 
same contents, select another column (or row) as the second sort criterion under then by and 
specify its sort options. You can also specify a third column (or row) to sort by.

6. Under Options, select the desired options:
o To sort only selected cells, select Sort selected cells only.
o To rearrange only the contents of cells without affecting the cells' properties, such as 

alignment and background color, select Sort contents only.
o To exclude the first or last row in the table or selection from being sorted, select Exclude 

the first selected row or Exclude the last selected row.
7. Click OK.

(HD You cannot so r t a  tab le  that con tains an y m erged  cells.

To transpose a table
1. Place the insertion point in the table to be transposed.
2. On the Table menu, point to Convert, and then click Transpose Table.

C o n v e r t i n g  b e t w e e n  p a r a g r a p h s  a n d  t a b l e s

You can convert a block of text consisting of words, sentences, or paragraphs into a table. You specify the 
number of columns and the delimiter(s) that will determine how the content is divided among cells.

You can also convert a table into a series of paragraphs. The table will be scanned from left to right and 
then top to bottom, and the contents of each cell will become a separate paragraph.

To convert a block of text into a table
1. Select the desired block of text.
2. On the Table menu, point to Convert, and then click Text to Table.
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3. In the Columns box, enter the desired number of columns for the table. (The Rows box will 
display the number of rows the table will have, based on the selected text and the selected 
delimiter. You cannot specify the number of rows.)

4. Under Delimiter, click the appropriate option depending on how you want to divide the selected 
text among cells:

o To put each paragraph into its own cell, click Paragraph breaks.
o To put each paragraph or part of a paragraph following a line break into its own cell, 

click Line breaks and paragraph breaks.
o To put each word into its own cell, click Spaces. (You can also use multiple spaces as 

delimiters by entering a value of 2 or higher in the box.)
o To put the whole selection into a single cell, click No delimiters.
o To use another delimiter or multiple delimiters, click Other and type the desired 

delimiter(s) in the box.
5. Click OK.

To convert a table into paragraphs
1. Place the insertion point inside the desired table.
2. On the Table menu, point to Convert, and then click Table to Text.
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F o r m a t t i n g  c o n t e n t

Generally speaking, in the context of Web authoring, formatting is the act of modifying the appearance of 
textual content in some way. (Although you can also modify the appearance of images and other non­
textual content, most people do not call that formatting.)

Every text element in HTML has a default appearance, which is how it looks if you don't apply any specific 
formatting to it. For example, most Web browsers display ordinary paragraphs in a medium-sized serif font, 
with left alignment, and with top and bottom margins. (The exact default appearance of any particular 
element depends on the browser, but it is based on commonly-accepted norms. Some browsers allow users 
to set up their own default styles for various elements.) To override an element's default appearance, you 
can format it in various ways—for instance, by changing its font or alignment.

In this section
About formatting and styles...................................................................p.210
Applying a single-instance format......................................................... p.212
Using style sheets................................................................................ p.212
Setting character-related properties........................................................p.219
Setting paragraph alignment, indentation, and line height.........................p.221
Setting margins, padding, and borders.................................................... p.222
Setting background colors and images.................................................... p.225
Using the Formatting panel................................................................... p.227
Understanding measurement units..........................................................p.231
Selecting colors.................................................................................... p.233
Copying and pasting formatting............................................................. p.235

A b o u t  f o r m a t t i n g  a n d  s t y l e s

Broadly speaking, there are two techniques that Web authors use to format content. Both techniques are 
familiar from popular word-processing programs.

Single-instance formatting
In the first technique, formatting is directly applied to a particular piece of content (such as a paragraph, a 
sentence, or a word). You select the content you want to format, and then you use commands in toolbars or 
menus to change, for example, its font, text size, margins, or borders. We can call this technique "single­
instance" formatting, because the formatting is applied to a single instance of some content. Of course, you
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might apply the exact same formatting to more than one piece of content, but then you have to select and 
format each in turn, repeating your actions for each piece.

Styles
The second technique is far more powerful. In this technique, you define a style—a collection of 
appearance properties and values. Once defined, you can apply a style to any piece of content by simply 
selecting the style from a menu. Alternatively, you can define a style that is automatically applied to all 
instances of a particular type of element.

For example, if you are writing an online book, you might define a style for block quotes that appear at the 
beginning of each chapter. You could specify that these paragraphs be indented two centimeters on both 
sides, use an italic font, and have taller than normal line spacing. Having defined the style, you can apply it 
to a paragraph by selecting the style from the Style menu on the Formatting Toolbar. As another example, 
you could define a style for all bulleted lists, specifying that they use square bullets and bold text; then your 
style would be applied automatically to all bulleted lists.

Styles are contained in a style sheet (p.212). An internal style sheet is one that is part of a document—the 
style sheet exists in the <head> section of the document's HTML source, and it can only be used by that 
document. An external style sheet, on the other hand, exists as a separate text file. Any document can link 
(p.215) to an external style sheet, making the styles defined in it available to the document. Linking to an 
external style sheet is an extremely powerful technique, since you can alter the formatting of a whole set of 
documents that are linked to the same style sheet by just editing one file.

Single-instance formatting and styles both have their uses, and you can use both techniques in the same 
document—even on the same piece of content. With a few exceptions, any format can be applied using 
either technique. Use styles when you want to apply the same formatting to many or all instances of an 
element. Use a single-instance format when you need to override default formatting for one piece of 
content or to override an applied style for one instance of a content class.

The distinction between single-instance formatting and formatting using styles is only partially related 
to the distinction between HTML formatting and CSS formatting. Although styles use only CSS 
properties (not appearance-related HTML elements or attributes), single-instance formats may use 
HTML elements and attributes, CSS properties, or a combination of both. If a single-instance format 
uses CSS properties, those properties are applied using an inline declaration.

Related topics
Applying a single-instance format.........................................................p.212
Using style sheets................................................................................ p.212

Formatting content 211



Ñamo WebEditor 6 User Manual

A p p l y i n g  a  s i n g l e - i n s t a n c e  f o r m a t

A single-instance format is a format that is applied to a single piece of content, rather than one that is (or 
can be) applied repeatedly to many pieces of content through the use of a style (p.210). Examples of single­
instance formats include:

• making a word or a phrase bold
• setting the alignment of a paragraph to ’’center"
• changing a list item to use a square bullet and italic text

To apply a single-instance format
1. Select the content you want to format. You can select a block element (such as a paragraph or a 

table cell), several block elements, or part of a block element (such as a letter, a word, or a 
sentence).

2. Do one or more of the following:
o On the Format menu, click any of Font, Paragraph, Borders & Background, or List, 

depending on the type of formatting you want to apply.
o Click a button on the Formatting Toolbar.
o Click a button or modify a value on the Inspector.

0  If you want to apply the same formats to many pieces of content, it is better to define a style (p.213). You 
can then apply the style to any similar piece of content by selecting the style from a menu, or the style 
can be applied automatically to every instance of the same element.

Related topics
Setting character-related properties........................................................p.219
Setting paragraph alignment, indentation, and line height.........................p.221
Setting margins, padding, and borders....................................................p.222
Setting background colors and images....................................................p.225
Using style sheets................................................................................ p.212

U s i n g  s t y l e  s h e e t s

A style sheet is a collection of styles (p.210) (also called ’’style rules’’, or just ’’rules"). Style sheets can be 
internal or external An internal style sheet is one that is part of a document—the style sheet exists in the 
<head> section of the document’s HTML source, and it can only be used by that document. An external
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style sheet, on the other hand, exists as a separate text file. Any document can link (p.215) to an external 
style sheet, making the styles defined in it available to the document.

To create an internal style sheet for the current document, you define (p.213) one or more styles. You can 
then apply (p.215) the styles you have defined from the Formatting Toolbar or the Inspector (or they may be 
applied automatically to all elements of specified types). You can also save (p.218) the style sheet as an 
external file for use with other documents.

In this section
Defining a style................................................................................... p.213
Applying a class style..........................................................................p.215
Assigning an ID to an element.............................................................. p.216
Linking to an external style sheet................. ........................................ p.216
Saving an internal style sheet as an external style sheet........................... p.218
Editing an external style sheet............................................................... p.218

D e f i n i n g  a  s t y l e

Before you can apply a style to something, you need to define it. There are two steps in defining a style:

1 . Specify the style’s selector—that is, the element type, class, or ID that the style will apply to. (See 
the descriptions of style types below.)

2. Specify the properties affected by the style, and the values for those properties.

Types of styles ♦
It is useful to identify three kinds of styles, distinguished by the type of selector they use:

• Element styles use an element type as the selector; thus they apply to all instances of a specific 
element type (for example, all paragraphs).

• Class styles come in two varieties:
o Universal class styles use a class name by itself as the selector; thus they apply to any 

element that belongs to the named class (for example, any element of class "funny").
o Element-specific class styles use an element type and a class name as the selector; thus 

they apply to instances of a specific element type that belong to the named class (for 
example, paragraphs of class "callout").

•  ID styles use an ID as the selector; thus they apply only to the element that has the specified ID 
(p.216) (for example, the paragraph whose ID is "intro").

To define an element style
1. On the Format menu, click Define Style.
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2. Click &  (Add).
3. Click the Element box, select an element type, and then click OK.
4. In the Character (p.219), Paragraph (p.221), and Borders (p.222) & Background (p.225) tabs, 

specify values for the properties you want the style to affect, and then click OK.

To define a universal class style
1. On the Format menu, click Define Style.

2. Click Li (Add).
3. In the Name box, type the class name for the style, and then click OK.
4. In the Character (p.219), Paragraph (p.22i), and Borders (p.222) & Background (p.225) tabs, 

specify values for the properties you want the style to affect, and then click OK.

To define an element-specific class style
1. On the Format menu, click Define Style.

2. Click [& (Add).
3. Click the Element box and select an element type.
4. In the Name box, type the class name for the style, and then click OK.
5. In the Character (p.219), Paragraph (p.22i), and Borders (p.222) & Background (p.225) tabs, 

specify values for the properties you want the style to affect, and then click OK.

To define an ID style
1. On the Format menu, click Define Style.

2. Click (Add).
3. Under Style type, click ID.
4. In the Name box, type the element ID that you want the style to apply to, and then click OK.
5. In the Character (p.219), Paragraph (p.22i), and Borders (p.222) & Background (p.225) tabs, 

specify values for the properties you want the style to affect, and then click OK.

[D It is possible to define a universal class style and an element-specific class style that both use the same 
class name—for example, tr.mystyle,f and "p.mystyle". In such cases, the element-specific style takes 
precedence for the specified element type. To understand how browsers resolve other overlapping or 
conflicting style rules, please refer to Cascading and Inheritance in the online CSS reference.

Related topics
Setting character-related properties........................................................p.219
Setting paragraph alignment, indentation, and line height.........................p.221
Setting margins, padding, and borders....................................................p.222
Setting background colors and images....................................................p.225
Applying a class style...........................................................................p.215
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Assigning an ID  to an element.................................................................................. p.216

A p p l y i n g  a  c l a s s  s t y l e

How you apply a class style to an element depends on what the element is.

If the element is one of these... Apply a class style by doing this:

paragraph 
heading 
list item
preformatted block
address
term
definition

1. Place the insertion point inside the element.
2. Do one of the following:

o On the Formatting Toolbar, click the Style box 
and select a style.

o On the Inspector, click the Class box and select a 
style.

0  Note that if you have defined any element-specific class styles, 
only those that match the current element will appear in the 
Style or Class menu.

any other kind of element 1. Select the element. (If the element cannot be selected 
directly in the document window, use the Tag Selector to 
select it.)

2. On the Format menu, click Class.
3. In the Class box, select a style.

part of a block element 
(such as a word or a 
phrase)

1. Select the word, phrase, or other element fragment.
2. On the Formatting Toolbar, click the Style box and select a 

style.

0  Although you can apply any universal style to an element fragment or an inline element, some o f the 
style's properties may be ignored by browsers because those properties apply only to whole block 
elements. For example, if  a style specifies 20-pixel margins on all sides, and you apply the style to a 
paragraph fragment, the fragment will have 20-pixel margins on its left and right sides but not above 
and below. The exact behavior o f such block-oriented properties when applied to an element fragment 
depends on the browser

0  Some block-oriented style properties do not display correctly in Edit mode when applied to an inline 
element or element fragment. To view these properties, switch to Preview mode.

Related topics
Defining a style. .p.213
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A s s i g n i n g  a n  I D  t o  a n  e l e m e n t

Any element in a document can be assigned a unique ID. Although element IDs can be used in a variety of 
ways, the two most common uses are:

• Referring to an element by its ID in a script (p.288)
• Automatically applying a distinctive style to one element by defining an ID style (p.213)

How you assign an ID to an element depends on what the element is.

If the element is a... Assign it a unique ID by doing this:
• paragraph
• heading
• list item
• preformatted block
• address
• term
• definition

1. Place the insertion point inside the element.
2. On the Format menu, click Class.
3. In the ID box, type a unique ID.

• any other kind of 
element

1. Select the element. (If the element cannot be directly selected in 
the document window, use the Tag Selector to select it.)

2. On the Format menu, click Class.
3. In the ID box, type a unique ID.

An ID  must begin with a letter and may contain letters, numbers, hyphens, underscores, colons, and 
periods.

Related topics
Defining a style....................................................................................p.213

L i n k i n g  t o  a n  e x t e r n a l  s t y l e  s h e e t

Instead of, or in addition to, creating an style sheet in a particular document, you can create a link in the 
document to an external style sheet file. When you do this, all the styles in the external style sheet become 
available to use in the document, just as if they were defined internally. By linking several documents to 
the same external style sheet, you can control the styles used in them by editing just the style sheet file.

It is possible to create links to multiple external style sheets in the same document, if necessary.
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An external style sheet file is a plain text document with a .css file name extension. You can create (p.218) 
an external style sheet in a text editor such as Notepad, or you can save (p.218) an internal style sheet that 
you have created as an external file.

To link to an external style sheet
1. On the Format menu, click External Style Sheets.

2. Click ^  (Add External File).
3. Find and select the desired external style sheet (it must have a .css extension) and then click Open.
4. Repeat steps 2 and 3 if you want to link to additional style sheet files, and then click OK.

I f  you link to an external style sheet, make sure to include the style sheet file when you publish the 
document to the Web. I f  your document is part of a local site, Namo WebEditor takes care of this for 
you.

Be aware that if a document contains internal style rules and also links to an external style sheet, or if it 
links to more than one external style sheet, it is possible that some rules will have identical selectors and 
therefore conflict with each other. In such cases, standards-compliant browsers choose the rule that is 
defined last. If you create an external style sheet link after creating an internal style sheet, then the rules in 
the external style sheet are considered to come after those in the internal style sheet. If you create links to 
multiple external sheets, the rules in the style sheet to which you linked last are considered to come last. 
However, you can change the order of external style sheet links (see below).

To understand how browsers resolve overlapping style rules, please refer to Cascading and Inheritance in 
the online CSS reference.

To change the order of external style sheet links
1. On the Format menu, click External Style Sheet.
2. In the External style sheets list box, select a style sheet.
3. Click a (Up) or ▼ (Down).
4. Repeat steps 2 and 3 until the style sheet links are in the desired order, and then click OK.

To remove an external style sheet link
1. On the Format menu, click External Style Sheet.
2. In the External style sheets list box, select a style sheet.
3. Click O  (Remove) and then click OK.

Related topics
Saving an internal style sheet as an external style sheet 
Editing an external style sheet...................................

Chapter 4: Basic Page Content and Formatting
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S a v i n g  a n  i n t e r n a l  s t y l e  s h e e t  a s  a n  e x t e r n a l  s t y l e  s h e e t

If you save an internal style sheet as an external style sheet file, you can create links in other documents to 
the style sheet, making its styles available in the other documents.

0  Saving an internal style sheet as an external file does not automatically create a link to the external 
style sheet file. Also, once you save an internal style sheet as an external style sheet, any changes you 
make in the internal style sheet do not affect the external style sheet.

To save an internal style sheet as an external style sheet
1. On the Format menu, click Define Styles.
2. Click fcfi (Save As External File).
3. Navigate to the folder where you want to save the external style sheet, enter a file name, and then 

click Save.

Related topics
Linking to an external style sheet.......................................................... p.216
Editing an external style sheet...............................................................p.218

E d i t i n g  a n  e x t e r n a l  s t y l e  s h e e t

An external style sheet is a plain text file with a .css file name extension. Since it is plain text, you can edit 
it in any text editor, such as Notepad. You cannot edit an external style sheet in Namo WebEditor.

An external style sheet contains one or more style rules. Each rule consists of a selector followed by one or 
more declarations within curly braces. An example is shown below:

property name values

r S  -------------------- ^f ------------------"s
blockquote { fo n t : bold 18pt “Times N ew  Roman” }

'------v------ ' ^ ---------------------v ' ---------------------'
selector dedaration

A sample style rule for blockquote elements

For more information about the syntax of style rules, please refer to “CSS Syntax” in the online CSS 
reference.
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While an explanation of cascading style sheets is outside the scope of this guide, Namo WebEditor's online 
CSS reference includes full descriptions of all of the visual-oriented properties of Cascading Style Sheets 
Level 2 (CSS 2). The reference can help you understand how CSS rules are constructed, as well as what 
kinds of values can be used with each property.

To edit an external style sheet
1. On the Format menu, click External Style Sheet.
2. In the External style sheets list box, select a style sheet.
3. Click &  (Edit Contents). The style sheet file will be opened in Notepad.

S e t t i n g  c h a r a c t e r - r e l a t e d  p r o p e r t i e s

Character-related formatting includes such properties as font, font size, font style, font decoration, and so 
forth. You can directly change the character properties of a text selection, or you can include character 
properties in a style (p.210) that you apply to elements or element fragments.

To change the character formatting of selected text
1. Select the text you want to format.
2. On the Format menu, click Font.
3. Specify values for the properties you want to apply to the text. (See the property descriptions 

below.)

9  To quickly change the fo n t, size, color, o r background color o f  selected text, use the Inspector 
or the Form atting Toolbar.

To include character properties in a style
1. On the Format menu, click Define Styles.
2. In the Style list, select the style you want to modify. (Or create (p.213) a new style.)
3. Click the Character tab and specify values for the properties you want to include in the style. (See 

the property descriptions below.)

General properties

Font Specifies the font family.
Size Specifies the font size. If you do not specify a unit (p.231), pixels are used.
Weight Specifies the thickness of characters. A numeric value sets the font weight on a scale from

100 (lightest) to 900 (darkest). 400 is equivalent to "normal"; 700 is equivalent to "bold".
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Style
Font color 
Bg color

Decoration

Underline
Upperline
Strikethrough
Blinking
None

Specifies the font style: normal, italic, or oblique.
Specifies the text color. Click the box and select a color (p.233). 
Specifies the background color. Click the box and select a color (p.233).

The text will be displayed with an underline.
The text will be displayed with an overline.
The text will be displayed with a line through the center.
The text will blink periodically. (Netscape only)
Clears all text decoration. This is useful when you want to override text decoration 
specified in a style.

Spacing

Letter

Word

Specifies the amount of space between characters. If you do not specify a unit (p.231), pixels 
used.
Specifies the amount of space between words. If you do not specify a unit (p.231), pixels are

Additional character formats (only in Font dialog box)
If you are directly formatting selected text (that is, you are not defining a style), several more properties are 
available when you click the More button in the Character Styles dialog box.

Citation Marks the text as a citation; displayed in italics by most browsers.
Code Marks the text as a code sample; displayed in a monospaced font by most browsers.
Keyboard Marks the text as text to be entered by the user; displayed in a monospaced font by most 

browsers.
Blinking Makes the text blink periodically. (Netscape only)
Definition Marks the text as the defining instance of a term; displayed in italics by most browsers.
Sample Marks the text as sample output from a computer program; displayed in a monospaced font

by most browsers.
Strong Marks the text as strongly emphasized; displayed in a bold font by most browsers.
Emphasis Marks the text as emphasized; displayed in italics by most browsers.
Variable Marks the text as a variable; displayed in italics by most browsers.

Related topics
Selecting colors.................................................................................... p.233
Setting paragraph alignment, indentation, and line height.........................p.221
Setting margins, padding, and borders....................................................p.222
Setting background colors and images.................................................... p.225

220 Formatting content



Chapter 4: Basic Page Content and Formatting

Defining a style............................................................................................................. p.213

S e t t i n g  p a r a g r a p h  a l i g n m e n t ,  i n d e n t a t i o n ,  a n d  l i n e  

h e i g h t

You can directly change the alignment, indentation and/or line height of a particular paragraph, or you can 
include these paragraph-related properties in a style (p.210) that you apply to some or all paragraphs. These 
properties also affect other block elements, including headings, list items, and preformatted blocks.

To directly set the alignment of a paragraph
1. Place the insertion point in the desired paragraph.
2. Do one of the following:

o On the Inspector, click the Alignment box and choose an alignment setting.
o On the Formatting Toolbar, click (Align Left), l i  (Align Center), or S  (Align Right).
o On the Format menu, click Paragraph, click Text alignment, and then choose an 

alignment setting.

£3 The J u s t i f y  alignment setting, which distibutes the words in each line of a paragraph so that both sides 
are even, is only available when you use the third method listed above.

To directly set the indentation of a paragraph
1. Place the insertion point in the desired paragraph.
2. On the Format menu, click Paragraph.
3. Under Indentation, enter the desired amount in either or both of the Left and Right boxes for left 

and right indentation, respectively. If you do not specify a unit (p.231), pixels will be used.
4. If you want the first line of the paragraph to use a different indentation amount, enter the desired 

amount in the First line box.

^  To quickly change only the left indentation of a paragraph, click ( i n c r e a s e  I n d e n t )  or £1 
( D e c r e a s e  i n d e n t )  on the Formatting Toolbar.

To directly set the line height of a paragraph
1. Place the insertion point in the desired paragraph.
2. On the Format menu, click Paragraph.
3. Under Spacing, do one of the following:

o Click the Presets box and select a preset:
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■ Normal sets the line height to the default value determined by the browser
■ Tight sets the line height to the default and the top and bottom margins to zero
■ 150% sets the line height to 150% of the paragraph’s font size
■ 200% sets the line height to twice the paragraph’s font size

o Enter a number in the Line height box. If you do not specify a unit (p.231), the value will 
be interpreted as a multiple of the paragraph’s font size.

4. If you want to specify the top and bottom margins for the paragraph, enter values in the Before and 
After boxes.

0  Specifying B e f o r e  and A f t e r  values has the same effect as specifying top and bottom margin (p.222) 
values.

To specify alignment, indentation, and line height in a style
1. On the Format menu, click Define Styles.
2. In the Styles list, select the style you want to modify. (Or create (p.213) a new style.)
3. Click the Paragraph tab and specify values for the properties you want to include in the style. (See 

the instructions above for each type of paragraph property.)

Related topics
Setting character-related properties........................................................p.219
Setting margins, padding, and borders....................................................p.222
Setting background colors and images....................................................p.225
Defining a style.................................................................................... p.213

S e t t i n g  m a r g i n s ,  p a d d i n g ,  a n d  b o r d e r s

Margins, padding, and borders are properties that you can modify for any element, and also for parts of 
elements, such as words and sentences. All of these properties can be specified differently for each side of 
an element.

• Borders are lines surrounding an element. Borders come in various styles, widths (thicknesses), 
and colors.

• Margins are empty space surrounding an element. Margins increase the distance between an 
element and its neighbors. If an element has a visible border, its margins take up space outside the 
border.

• Padding is empty space between an element’s contents and its borders.

The relationships among margins, padding, and borders can be visualized through a floating box example:
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Lorem ipsum dolor sit 
amet, consectetur 
adipisicing elit, sed do 
eiusmod tempor 
incididunt ut iabore et 
dolore magna aliqua. Ut 
enim ad minim veniam, 
quis nostrud exerdtation 
ullamco laboris nisi ut 

aliquip ex ea commodo consequat. Duis aute irnre dolor in 
reprehenderit in voluptate velit esse cillum dolore eu fugiat 
nulla pariatur. Excepteur sint occaecat cupidatat non 
proident, sunt in culpa qui officia deserunt mollit anim id est 
laborum.
The relationships among margins, padding, and borders

You can directly change the margins, padding, and borders of a particular paragraph, heading, or list item. 
You can also include these properties in a style (p.210) that you apply to any element.

You cannot directly modify margins, padding, or borders for elements other than paragraphs, headings, 
list items, and preformatted blocks. To modify these properties for another type o f element, include the 
properties in a style and apply (p.215) the style to the element

To directly set a paragraph's margins and/or padding
1. Place the insertion point in the desired paragraph.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the side for which you want to set the margin and/or padding.

To select multiple sides at once, click each while holding down the Ctrl key. (See the examples 
below.) To select all four sides, click Select All. To deselect all sides, click in the middle of the 
box. By default, all four sides are selected.

1  r
A______________

Click while holding down Ctrl to 
select multiple sides.

4. To set the margin, enter a number in the Margin box and then click the unit box next to it and 
select a unit. If you do not specify a unit (p.231), the value will be interpreted as pixels.

This floating box has a 
10-pixel border, 15- 
pixel padding on all 
sides, and a 20-pixel 
right margin.
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5. To set the padding, enter a number in the Padding box and then click the unit box next to it and 
select a unit. If you do not specify a unit (p.23I), the value will be interpreted as pixels.

6. Repeat steps 3 through 5 if you want to set a different margin and/or padding value for another 
side.

7. Click OK.

To directly set a paragraph's borders
1. Place the insertion point in the desired paragraph.
2. On the Format menu, click Borders & Background.
3. In the border selection box, select the side for which you want to set the border. To select multiple 

sides at once, click each while holding down the Ctrl key. (See the examples below.) To select all 
four sides, click Select All. To deselect all sides, click in the middle of the box. By default, all four 
sides are selected.

V
_J L_

“1 r
A

Click a side to select it. Click while holding down Ctrl to
select multiple sides.

4. Click the Style box and select a border style.
5. Click the Color box and select a color (p.233).
6. In the Width box, enter a number and then click the unit box next to it and select a unit. If you do 

not specify a unit (p.231), the value will be interpreted as pixels.
7. Repeat steps 3 through 6 if you want to set a different border for another side.
8. Click OK.

To include margin, padding, and border settings in a style
1. On the Format menu, click Define Styles.
2. In the Styles list, select the style you want to modify. (Or create (p.213) a new style.)
3. Click the Borders & Background tab and specify values for the properties you want to include in 

the style. (See the instructions above for each type of property.)

O You can set margins, padding, and borders all at the same time by specifying settings for each property 
before closing the Style dialog box.
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Related topics
Setting character-related properties...............................
Setting paragraph alignment, indentation, and line height
Setting background colors and images..........................
Defining a style...........................................................
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p.219
p.221
p.225
p.213

S e t t i n g  b a c k g r o u n d  c o l o r s  a n d  i m a g e s

Any element can have a background color or image. For some elements, you can set these properties 
directly. You can also include these properties in a style (p.210) that you apply to any element.

To set a background color or image on a paragraph, heading, or list item
1. Place the insertion point in the desired paragraph.
2. On the Format menu, click Borders & Background.
3. Under Background, do one of the following:

o Click the Color box and select a color.
o Enter the path or URL to an image file in the Image box. To select a file on the local file 

system, click Browse. To specify options for the background image, click Options.
4. Click OK.

0  When you set a background color on a paragraph or similar element, the background fills the entire 
space between the left and right sides o f the element's parent container (such as a table cell or the 
browser window), even if  the element's content only takes up part of the space. To avoid this, select the 
text o f the element and set the background color on the selection.

To set a background color on a text selection
1. Select the desired text.
2. Do one of the following:

o On the Formatting Toolbar, click H"!  ̂(Text Background Color) and select a color (p.233). 
o On the Inspector, click the BG color box and select a color (p.233).

To set a background color or image on a table, row, or cell
1. Place the insertion point in the desired table, row, or cell.
2. On the Tag Selector, do one of the following:

o Click <table> to select the table 
o Click <tr> to select the row
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o Click <td> to select the cell
3. On the Inspector, do one of the following:

o To set the background color, click the Background or Background Color box and select a 
color (p.233).

o To set the background image, enter the path or URL of an image file in the Background 
box. To select a file on the local file system, click (Browse).

To set a background color or image on a layer or floating box
1. Double-click the layer or floating box's outline.
2. Under Background, do one of the following:

o Click the Color box and select a color (p.233).
o Enter the path or URL to an image file in the Image box. To select a file on the local file 

system, click ^  (Browse).
3. Click OK.

To set the document's background color or image
1. On the File menu, click Document Properties.
2. Do one of the following:

o Under Colors, click the Background box and select a color (p.233). 
o Under Background image, enter the path or URL to an image file. To select a file on the 

local file system, click Q  (Browse).
3. Click OK.

To specify a background color or image in a style
1. On the Format menu, click Define Styles.
2. In the Styles list, select the style you want to modify. (Or create (p.213) a new style.)
3. Click the Borders & Background tab.
4. Under Background, do one of the following:

o Click the Color box and select a color (p.233).
o Enter the path or URL to an image file in the Image box. To select a file on the local file 

system, click Browse. To specify options for the background image, click Options.

Related topics
Selecting colors.................................................................................... p.233
Setting character-related properties........................................................p.219
Setting paragraph alignment, indentation, and line height.........................p.221
Setting margins, padding, and borders....................................................p.222
Defining a style.................................................................................... p.213
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U s i n g  t h e  F o r m a t t i n g  p a n e l

The Formatting panel is one of the tool panels on the right side of Namo WebEditor's main window. The 
Formatting panel lists the six heading levels, the normal paragraph style, and any universal styles and list 
styles that have been defined in the document or in a linked style sheet. Clicking a heading level converts 
the current paragraph or paragraph-like element to a heading. Clicking a style applies that style to the 
current paragraph, paragraph-like element, or selection.

To reveal the Formatting panel: on the View menu, point to Panels, and then click Formatting.

You can use the Formatting panel to:

• Quickly apply a universal style or a list style to selected content
• Quickly change a paragraph or paragraph-like element to a heading
• Quickly change a styled paragraph or paragraph-like element to a normal paragraph
• Add a new universal style (optionally based on the formatting of the current paragraph or 

selection)
• Add a new list style
• Modify or delete a universal or list style
• Modify the style of a heading level
• Quickly remove a style applied to the current paragraph or selection

3  The F orm a tting  panel only lists heading levels and universal styles. It does not list element styles, 
element-specific class styles, or ID styles. For information on using these kinds of styles, see Using 
style sheets, p.2I2.

In this section
Applying a style or heading level with the Formatting panel....................p.228
Removing a style applied with the Formatting panel...............................p.228
Adding, editing, or removing a style in the Formatting panel...................p.229
Modifying the default style of a heading level........................................p.231

Related topics
Using style sheets................................................................................ p.212
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A p p l y i n g  a  s t y l e  o r  h e a d i n g  l e v e l  w i t h  t h e  F o r m a t t i n g  p a n e l

To change a paragraph into a heading
1. Place the insertion point in the paragraph or paragraph-like element you want to change into a 

heading.
2. Click the desired heading level (HI H6) on the Formatting panel.

To apply a style to an entire paragraph
1. Place the insertion point in the paragraph or paragraph-like element you want to change.
2. Click the desired style on the Formatting panel.

To apply a style to a text selection
1. Select the text you want to change.
2. Click the desired style on the Formatting panel.

To reset a paragraph to the default paragraph style
1. Place the insertion point in the paragraph or paragraph-like element you want to reset.
2. Click Normal on the Formatting panel.

CD When you apply the Normal style, Namo WebEditor removes the class (p.213) assignment (if any) from 
the current text block I f  the text block is a heading, a list item, or a preformatted text block, applying 
the Normal style also converts it into a normal paragraph. Applying the Normal style does not remove 
any single-instance formats (p.210) that were applied to the text block.

O  If you apply a heading level or the Normal style to a list item in the middle o f a list, the list will be split 
into two parts, one before and one after the affected item.

R e m o v i n g  a  s t y l e  a p p l i e d  w i t h  t h e  F o r m a t t i n g  p a n e l

To remove a style from a paragraph
1. Place the insertion point in the paragraph or paragraph-like element from which you want to 

remove a style.
2. Click Clear Formatting on the Formatting panel.

To remove a style from a text selection
1. Select the text from which you want to remove a style.
2. Click Clear Formatting on the Formatting panel.
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s i  The C l e a r  F o r m a t t i n g  command on the F o r m a t t i n g  panel works by removing the class (p.213)
assignment (if any) from the current text block or selection. I f the text block is a heading, a list item, or 
a preformatted text block, the C l e a r  F o r m a t t i n g  command also converts it into a normal paragraph.
The command does not remove any single-instance formats (p.210) that were applied to the text block 
or selection.

A d d i n g ,  e d i t i n g ,  o r  r e m o v i n g  a  s t y l e  i n  t h e  F o r m a t t i n g  p a n e l

You can use the buttons at the bottom of the Formatting panel to add, modify, or remove universal styles 
and list styles.

To add a universal style

1. On the Formatting panel, click L i  (Add).
2. In the Name box, type a name for the new style.
3. Under Type, select General, and then click Define Style.
4. Specify the desired properties for the new style and then click OK. For information about setting 

style properties, see the following topics:
o Setting character-related properties, p.219
o Setting paragraph alignment, indentation, and line height, p.221
o Setting margins, padding, and borders, p.222
o Setting background colors and images, p.225

To add a universal style based on an existing universal style
1. Place the insertion point in a paragraph to which a universal style has been applied.
2. On the Formatting panel, click A  (Add From).
3. In the Name box, type a name for the new style.
4. Under Type, select General, and then click Define Style.
5. Specify the desired properties for the new style and then click OK. (The properties of the existing 

style will have been copied to the new style.) For information about setting style properties, see 
the following topics:

o Setting character-related properties, p.219 
o Setting paragraph alignment, indentation, and line height, p.221 
o Setting margins, padding, and borders, p.222 
o Setting background colors and images, p.225

To add a list style

1. On the Formatting panel, click L* (Add).
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2. In the Name box, type a name for the new style.
3. Under Type, select List, and then click Define Style.
4. Click the Type button corresponding to the desired list type.
5. Do one of the following:

o If you selected Bullet or Number list type, click the Style box and select the desired bullet 
or number style.

o If you selected Image list type, in the Image path box, enter the path or URL to the image 
file you want to use as the list marker.

6. If you wish, specify the Left, Right, and/or First line margins for list items.
7. Click OK.

To modify a style in the Formatting panel
1. Point to the style you want to change in the Formatting panel, click the triangle, and then click 

Modify.
2. Click Define Style.
3. Make the desired changes to the style and then click OK. For information about setting style 

properties, see the following sections:
o Setting character-related properties, p.219
o Setting paragraph alignment, indentation, and line height, p.221
o Setting margins, padding, and borders, p.222
o Setting background colors and images, p.225

To rename a style in the Formatting panel
1. Point to the style you want to rename in the Formatting panel, click the triangle, and then click 

Modify.
2. In the Name box, type the new name, and then click OK.

To remove a style in the Formatting panel
• Point to the style you want to remove in the Formatting panel, click the triangle, and then click 

Delete.

0  Styles defined in an external style sheet cannot be modified or removed using the commands in the 
Formatting panel To modify or remove an externally-defined style, edit the external style sheet. (Click

to open the list o f linked style sheets, select the style sheet, and then click to edit it in your 
default text editor.)

uJ You cannot remove the Normal style or any o f the heading levels.
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Setting character-related properties........................................................p.219
Setting paragraph alignment, indentation, and line height........................p.221
Setting margins, padding, and borders................................................... p.222
Setting background colors and images................................................... p.225

Related topics

M o d i f y i n g  t h e  d e f a u l t  s t y l e  o f  a  h e a d i n g  l e v e l

To modify the default style of a heading level
1. Point to the heading level you want to change in the Formatting panel, click the triangle, and then 

click Modify.
2. Click Define Style.
3. Make the desired changes to the style and then click OK. For information about setting style 

properties, see the following topics:
o Setting character-related properties, p.219
o Setting paragraph alignment, indentation, and line height, p.221
o Setting margins, padding, and borders, p.222
o Setting background colors and images, p.225

To reset the default style of a heading level
1. Point to the heading level you want to reset in the Formatting panel, click the triangle, and then 

click Reset.

U n d e r s t a n d i n g  m e a s u r e m e n t  u n i t s

In many cases, when you enter a number as the value of an attribute or property—for example, font size— 
you are given the choice of what unit to use. The units you can use in Namo WebEditor are described 
below.

3  It is usually not necessary to specify a unit, even when the choice is given. I f you do not specify a unit, 
the default unit will be used. The default unit depends on the property or attribute being modified, but 
most often it is pixels.
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Common length units
These units are used in cascading style sheet (CSS) properties that take a length value, such as margins and
borders. For more information, please refer to CSS Value Types in 1

[Unit [Abbr. Meaning
inches in inches
points Pt 1/72 of an inch
picas pc 12 points
cm cm centimeters
mm mm millimeters
pixels px pixels (units of screen resolution)
em em a unit equal to the current font size
ex ex a unit equal to the "x-height" of the current font
% % percentage of base value*

♦The base value for a % value depends on the property being modified. For font sizes, the base value is the 
calculated font size of the parent element.

Special font size values
These unitless values are used only for font sizes.

Unit Notes
1-7 Size on a scale from 1 (smallest) to 7 (largest). The exact size corresponding to each number 

depends on the browser, but "3" usually corresponds to 12pt.
xx-small
x-small
small
medium
large
x-large
xx-large

The exact size corresponding to each keyword depends on the browser.

smaller
larger

Sets the font size one ’’step" smaller or larger than the font size of the parent element. The size 
of each step depends on the browser.
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S e l e c t i n g  c o l o r s

Using the Color Palette
Any time you need to specify a color in Namo WebEditor, the primary interface is the Color Palette.

jOOFFOO Д  J  lime f  
В  Default

Custom Colors__________________
¡""¡""TTBB r u  I I I I I I | I 1 1
1 II 1 11 1 n  h  1 1 1  m
Recent Colors

i i m i m i m f
The Color Palette

Using the Color Palette is easy: just click a color. To restore the default color for the current item or 
property, click Default.

If the color you need is not on the palette, try one of these features:

Color Picker button
Click to open the Color Picker (p.234). In the Color Picker, you can select any 24-bit RGB color or 
define additional custom colors.

Eyedropper
Drag the eyedropper to any visible part of the screen to "pick up" the color underneath the pointer. 

Hex box
Enter a hexadecimal color code in the box at the top left comer of the palette and press Enter.
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j  Color Set menu
Click and select a color set. (The default color set is Web-Safe Colors.) You can also add more 
color sets to this menu from the Color Sets (p.47) tab of the Resource Manager. Click Manage 
Color Sets to do so.

Custom Colors

This area shows the custom colors you have defined. To add more custom colors, click to open 
the Color Picker (p.234).

Recent Colors
This area shows the colors you have used recently.

Using the Color Picker
Use the Color Picker to select any 24-bit color.

Color Picker

HJ.ML |mr00 Njme; >eÍ3W Cota Dieppe«: 

fied [255^ Hue: |iô ^  ^  H
£ieert 2S5 -ÿj ¿ahiaócn |255 -t-j 
Elue: |0 ¿ j BwWne« |2S5 -j-j

m O ■■MuBMSKQ ■■■!>■■: - ■ - •

Custom Cok«
: B T i T v n  ri  

[ I I í I ¡ í ¡ i ' iT'i ,

The Color Picker

The Color Picker provides six ways to select or specify a color:
• HSB palette: Drag the slider on the vertical bar to select a hue, and then click inside the large 

gradient box to select a saturation and brightness level.
• Color palette: Click a color in the horizontal palette.
• Hex color code: Enter a hexadecimal color code in the HTML box.
• RGB values: Enter RGB values in the Red, Green, and Blue boxes.
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• HSB values: Enter HSB values in the Hue, Saturation, and Brightness boxes.
• Eyedropper: Drag the eyedropper to any visible part of the screen to "pick up" the color 

underneath the pointer.

In addition, you can add any color to the palette of custom colors that is part of the Color Palette (p.233). To 
add a custom color:

1. Click one of the 36 custom color slots under Custom Colors.
2. Select or specify the color you want to save as a custom color.
3. Click Add to Custom Colors.

9  I f  you have already selected the color you want, clicking a custom color slot will replace your 
color with the color already in that slot. To avoid this, after selecting your color, press the 
Tab key until the keyboardfocus is in the slot area, and then press the arrow keys to select the 
desired slot. Then, click Add to Custom Colors.
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C o p y i n g  a n d  p a s t i n g  f o r m a t t i n g

You can use the clipboard to copy formatting from one element to another element. Items you can copy and 
paste include character formatting, paragraph formatting, image attributes, table properties, cell properties, 
hyperlinks, bookmarks, and chart properties.

To copy and paste formatting
1. Place the insertion point in the paragraph, word, table, or table cell, or select the image, whose 

formatting you want to copy.
2. On the Edit menu, click Copy Format, or press Shift+F2.
3. Select the types of properties you want to copy, and click OK.
4. Place the insertion point in the paragraph, table, or table cell, or select the text or image, to which 

you want to copy the formatting.
5. On the Edit menu, click Paste Format, or press F2.

0  When pasting a background color into a table, Namo WebEditor will prompt you to specify whether to 
apply the background color to the whole table, the current cell, or the whole document.

Formatting content 235



Ñamo WebEditor 6 User Manual

D o c u m e n t  p r o p e r t i e s

Every Web document has certain properties that apply not to individual elements but to the document as a 
whole. These properties include the document’s title, its default colors, meta tags, and so forth. In Namo 
WebEditor, you can view and modify these properties in the Document Properties dialog box: on the File 
menu, click Document Properties.

In this section
Setting a document's title...................................................................... p.236
Specifying keywords and other meta data............................................... p.237
Specifying a character set..................................................................... p.238
Setting a document's base location......................................................... p.239
Setting a default target for hyperlinks.....................................................p.240
Setting default document colors............................................................. p.241
Setting document scrollbar colors.......................................................... p.242
Setting a document background image................................................... p.243
Setting document margins..................................................................... p.243
Adding page transitions........................................................................ p.244
Adding a background sound..................................................................p.245
Setting up an automatic refresh or redirect..............................................p.246
Specifying a cache expiration date......................................................... p.247
Adding PICS labels to a document.........................................................p.247
Adding custom meta tags...................................................................... p.248

S e t t i n g  a  d o c u m e n t ' s  t i t l e

A document’s title is the word or phrase that appears in the title bar of a browser window when the 
document is viewed. Besides giving users a hint about what they are viewing, the title is also used by Web 
search engines to identify a document in search results, and it is used by browsers when a user creates a 
bookmark or ’’favorite” for a document. Therefore, it's a good idea to give each document a meaningful title.

To set a document's title
1. On the File menu, click Document Properties, and then click the General tab.
2. In the Title box, type the desired title.
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I f  you don't specify a title for a document before saving it for the first time, Namo WebEditor 
automatically generates one based on the first line of text in the document. You can change the 
generated title in the Title box o f the Save As dialog box.

S p e c i f y i n g  k e y w o r d s  a n d  o t h e r  m e t a  d a t a

In addition to the title, you can add several other bits of information to a document that may be useful for 
Web search engines or your own site management practices. If you specify this meta data, Namo 
WebEditor puts it in meta tags in a document's header. Meta tags are not normally visible in browsers, but 
they can be used by other software to help categorize and manage documents. The basic meta tags 
supported by Namo WebEditor include:

Keywords
Keywords can be used by search engines to help categorize documents according to content. For 
example, if you are creating a document about dinosaurs, adding the keyword "dinosaurs" can help 
a search engine add your document to the "dinosaurs" category of a Web directory. You can enter 
multiple keywords separated by commas.

Author
The "author" meta tag is used to provide the name of the person or organization that authored the 
document.

Classification
This meta tag can be used in a variety of ways by you or your organization. For example, if a 
company wants to categorize its intranet documents according to function, it could put a keyword 
like "product_data" or "personnel" in the "classification" meta tag of each document.

Description
The "description" meta tag can be used to provide a brief description of the contents of the 
document.

To specify keywords or other meta data
1. On the File menu, click Document Properties, and then click the General tab.
2. Enter appropriate meta data in any or all of the Author, Classification, Description, and Keywords 

boxes.
3. Click OK.
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Searching meta data
Once you have added meta data to several documents, you can search that meta data using Namo 
WebEditor's global find and replace (p.406) command or a search program. If you want to make sure that 
your search only matches words in a particular meta tag, use the following syntax in your search string:

meta nam e="name" content -'keyword'

where name is the type of meta tag you want to search and keyword is the word or phrase you want to find. 
For example, to find all the documents in a site or a folder that have an "author" meta tag with the content 
"John Smith", you would use the following search string:

metaname-'author" content="John Smith"

Related topics
Adding custom meta tags......................................................................p.248
Finding and replacing text throughout a site............................................p.406

S p e c i f y i n g  a  c h a r a c t e r  s e t

A character set is a table of mappings from numerical codes to text characters. As you probably know, 
computers represent text using a distinct numeric code for each character, be it a letter, a numeral, a 
punctuation mark, or something else. However, there are many ways to map characters to codes. For 
example, in ISO-8859-1—the standard Internet character set for computers running the U.S. English 
version of Windows, also known as Western European (ISO)—the decimal code 92 represents a backslash 
("\"), but in the EUC-KR character set, it represents the Korean currency symbol (W ).

Because of the international nature of the Web, the character set in which a document is viewed by a 
particular user may not be the same as the character set in which it was written. If you live in the United 
States and compose in English, your documents probably use some variant of ASCII, such as ISO-8859-1. 
But if your document is viewed by a user in Korea using the Korean version of Windows, her browser 
probably expects the document to use a Korean character set. This can result in some characters not 
appearing correctly on the user's screen.

To avoid this problem as much as possible, it's a good idea to specify the character set that a document uses. 
Doing so tells browsers to display your document in that character set. If you don't specify a character set, 
browsers will usually display your document in the default character set specified by the user, which may 
be very different from the character set the document was authored in.

Note that specifying a character set doesn't actually change the character codes in a document. It just tells 
browsers how they should interpret those codes.
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1. On the File menu, click Document Properties, and then click the General tab.
2. Do one of the following:

o Click the left Character set box and select a character set by its title (for example, 
Western European (ISO)). The right box will show the code name of the selected 
character set. The value User-defined means "Do not specify a character set.”

o Click the right Character set box and select a character set by its code name (for example, 
iso-8859-1). You can only select an item in this box if the selection in the left box is 
User-defined, and only a few character sets can be selected this way.

£D I f  you compose documents in a non-Western European language, such as Korean, users who do not 
have fonts installed on their computers that are compatible with the fonts you use in your documents 
will not be able to view your documents correctly, even if you correctly specify the character set.

Related topics
Changing character sets throughout a site.............................................. p.412

To specify a character set for a document

S e t t i n g  a  d o c u m e n t ' s  b a s e  U R L

If a document contains relative hyperlinks (p. 167), Web browsers by default interpret those links as being 
relative to the location of the document in the site's folder hierarchy. For example, if the document located 
at http://www.namo.com/products/index.html contains a link to an image file using the relative path 
"images/example.gif', then browsers will expand the URL to the image file as
http://www.namo.com/products/images/example.gif, since they will take "images" to be a subfolder of the 
folder containing the document, which is "products".

You can change the way browsers interpret relative links in a document by specifying a base URL for the 
document. If you specify a base URL, browsers will ignore the location of the document in the site 
structure and instead interpret relative links in relation to the specified URL. Following the example given 
above, if the base URL of the index.html document is set to "http://www.namo.com/", then browsers will 
expand the relative link "images/example.gif' to http://www.namo.com/images/example.gif.

When specifying a base URL, you must provide a full Internet URL, such as "http://wwvv.example.com/", 
"http://www.example.com/photos/", or "http://www.example.com/photos/index.html". Partial URLs, such 
as "/photos", wil be ignored by browsers. Some browsers let you omit the leading "http://" from a base 
URL, but other browsers do not, so it’s a good idea to always include it. If the URL includes a folder path 
after the site name (but no file name), make sure to include a final slash at the end.
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To set a document's base URL
1. On the File menu, click Document Properties, and then click the General tab.
2. In the Base URL box, type the desired base URL.

Related topics
About hyperlinks................................................................................. p. 165

Namo WebEditor 6 User Manual

S e t t i n g  a  d e f a u l t  t a r g e t  f o r  h y p e r l i n k s

When you create a hyperlink, you can specify that its destination be opened in a particular window or frame. 
This window or frame is called the link’s target (p. 170). But it is also possible to set a default target for all 
the links in a document. If you do so, any link that does not have its own specified target will open in the 
target specified for the document.

To set a default target for the hyperlinks in a document
1. On the File menu, click Document Properties, and then click the General tab.
2. In the Default target box, type the name of a window or frame.

Four special targets can be selected if you click the triangle on the Default target box:

_blank Links will open in a new window.
^parent If the current document is part of a frameset (p. 101), its links will open in the frameset’s parent 

container, replacing the frameset. The parent is usually the browser window, but if the frameset 
is being displayed in a frame of another frameset, then the parent is the containing frame in the 
higher-level frameset.

_self Links will open in the current window (or frame, if the document is part of a frameset).
_top Links will open in the current window (replacing the frameset, if the document is part of a 

frameset).

To override the default target for a specific hyperlink
1. Double-click the hyperlink.
2. In the Target box, enter the name of a window or frame. To select a frame visually, click 

(Select Target Frame).

B  Y°u can onty set *he default target to a particular window if the window has a name. In general, only 
windows that are created by scripts have names. Therefore, only a window created by a script can be a 
default target. One way to create a named window to use as a default target is to use a script that
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creates a new window as soon as the current document is opened. You can do this using the Script 
Wizard's Pop-up window script.

Related topics
Setting a link's target window or frame.................................................. p. 170
About frames and framesets..................................................................p. 101
Setting a frame’s default target..............................................................p. 107

S e t t i n g  d e f a u l t  d o c u m e n t  c o l o r s

In the Appearance tab of the Document Properties dialog box, you can specify certain colors that apply to
an entire document:

Label Description Default
Background The color of the document’s background white
Text The default color of text black
Hyperlinks The default color of normal hyperlinks blue
Visited links The default color of visited hyperlinks purple
Active links The default color of the active hyperlink red

To change the background color, default text color, or default hyperlink colors of a document
1. On the File menu, click Document Properties, and then click the Appearance tab.
2. For each color you want to specify, do one of the following:

o Enter a hexadecimal color code, 
o Click the color box and select a color (p.233).

To copy the background color, default text color, and default hyperlink colors from another 
document

1. On the File menu, click Document Properties, and then click the Appearance tab.
2. Click the Copy Colors From button.
3. Find and select the document you want to copy colors from, and then click Open. (You can also 

enter a URL in the URL box and click Open URL.)

Related topics
Setting document scrollbar colors......................................................... p.242
Setting a document background image...................................................p.243
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Selecting colors..................... .p.233

S e t t i n g  d o c u m e n t  s c r o l l b a r  c o l o r s

Internet Explorer 5.5 and later versions support the ability to specify the colors used in document scrollbars 
and text boxes in forms. You can set these colors in the Scrollbar Colors dialog box. A total of eight 
different colors (one base color and seven colors for various parts of the scrollbar) can be specified, 
although you don't have to specify all of them.

Base color

3D light color 
Arrow color 
Dark shadow color 
Highlight color 
Face color

Shadow color 
Track color

Specifies a single color for most parts of the scrollbar. Specifying a color for any 
part overrides the base color for that part.
The outer highlight color of the scrollbar box and arrows
The color of the small triangles in the scrollbar arrows
The outer shadow color of the scrollbar box and arrows
The inner highlight color of the scrollbar box and arrows
The main color of the scrollbar box and arrows; also sets the color of the track if not 
separately specified
The inner shadow color of the scrollbar box and arrows 
The color of the scrollbar track

To set a document's scrollbar colors
1. On the Format menu, click Scrollbar Colors.
2. For each color you want to specify, click the corresponding color box and select a color (p.233).

The Preview box displays a preview of your selected colors. The Component box highlights the scrollbar 
part whose color you are modifying.

^  Scrollbar colors are only supported by Internet Explorer 5.5 or later. Other browsers will ignore the 
specified colors.

0  I f you specify at least one scrollbar color, the new-styie scrollbars used by Internet Explorer on 
Windows XP computers will revert to the pre- Windows XP style.

Related topics
Setting default document colors............................................................. p.241
Setting a document background image................................................... p.243
Selecting colors.................................................................................... p.233
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S e t t i n g  a  d o c u m e n t  b a c k g r o u n d  i m a g e

A document can have a background image—an image that lies "under" the document’s content. A 
background image repeats to fill the document, no matter how large the window in which the document is 
open is.

To set a background image on a document
1. On the File menu, click Document Properties, and then click the Appearance tab.
2. In the Background image box, type the path or URL to an image file, or do one of the following:

o Click ^  (Browse) to find and select an image file from your local file system.
o Click (Clip Art) to select an image from the clip art library.
o Click (Site) to select from a list of image files belonging to the current local site (if 

one is open).

Ü Alternatively, you can set a document background image by using the background-image cascading 
style sheets property on the <body> element o f a document. This method provides greater flexibility, 
since you can use the property in combination with the background-attachment, background-position, 
and background-repeat properties to control the background image's scrolling, starting position, and 
repetition characteristics.

Related topics
Setting default document colors............................................................ p.241

S e t t i n g  d o c u m e n t  m a r g i n s

A document's margins are the blank space between its content and the left and top edges of the window. In 
most documents, the size of these margins is not specified, so browsers use their own default margins. 
However, you can specify the size in pixels of the left and top margins in the Styles tab of the Document 
Properties dialog box.

To set a document's left and top margins
1. On the File menu, click Document Properties, and then click the Styles tab.
2. Under Margins, enter a number of pixels in either or both of the Left and Top boxes to specify the 

left and top margin, respectively.
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Alternatively, you can set a document’s margins by using the margin properties of cascading style sheets on 
the document's <body> element. This approach is more flexible, because you can specify the length unit for 
the margin size and specify margins also for the right and bottom edges of the document.

To set a document's margins using a style

1. On the File menu, click Document Properties, and then click the Styles tab.
2. Click the Add Style to <BODY> Tag button.
3. Click the Borders & Background tab.
4. Enter margin sizes for each side for which you want to specify a margin. (See Setting margins, 

padding and borders, p.222.)
5. Click OK twice.

Related topics

Setting margins, padding and borders............................................................... p.222

A d d i n g  p a g e  t r a n s i t i o n s

Internet Explorer supports a feature called page transitions. A page transition is a visual effect that occurs 
when a user enters or leaves a document or site, similar to the transition effects sometimes seen between 
scenes in movies and videos. Available effects include "wipes", "blinds", and so forth.

There are four distinct events, or triggers, that you can specify to initiate a page transition:

• Page Entry: When the user enters (opens) the document
• Page Exit: When the user leaves the document (by going to another document or closing the 

window)
• Site Entry: When the user enters the document from another site (but not from another page on 

the same site)
• Site Exit: When the user leaves the document and goes to another site

These events are not mutually exclusive, so (for example) you could specify one transition effect that 
occurs when a user enters the document and another effect that occurs when a user leaves the document. If 
one document specifies an exit transition and another document, linked from the first document, specifies a 
different entry transition, the entry transition takes precedence when a user clicks the link.

To add a page transition to a document

1. On the File menu, click Document Properties, and then click the Styles tab.
2. Under Page transitions, click the Event box and select the trigger for the transition effect.
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3. Click the Effect box and select the desired effect.
4. In the Duration box, enter the number of seconds you want the transition to take.
5. If you want to add a transition effect for another event, click Apply and then repeat steps 2 through

4.
6. Click OK.

To remove a page transition

1. On the File menu, click Document Properties, and then click the Styles tab.
2. Under Page transitions, click the Event box and select an event for which a transition effect was 

previously specified.
3. Click the Effect box and select None.

ÜÜ Page transitions are only supported by Internet Explorer 4.0 and later.

A d d i n g  a  b a c k g r o u n d  s o u n d

Internet Explorer supports the ability to play an audio file—"in the background”, so to speak—when a 
document is opened. The supported audio file types are: WAVE (.wav), MIDI (.mid), AIFF 
(.aif, .aifc, .aiff), and AU (.au, .snd). You can specify how many times the sound should repeat, or that it 
should repeat endlessly.

To add a background sound to a document

1. On the File menu, click Document Properties, and then click the Styles tab.
2. Under Background sound, enter the path or URL to an audio file in the Path box. Click Browse to 

browse for a file on your local file system.
3. In the Repeat box, enter the number of times the sound should play, or select Repeat forever.
4. If you want to listen to the sound file you specified, click ►. To stop playing the sound, click ■.
5. Click OK.

§  Background sounds are only supported by Internet Explorer.
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S e t t i n g  u p  a n  a u t o m a t i c  r e f r e s h  o r  r e d i r e c t

For some kinds of time-sensitive documents, it might be desirable to instruct browsers to automatically 
reload a document at regular intervals. For example, if you have a document that displays local weather 
information collected from a frequently updated data source, you might want browsers to auto-refresh the 
page every ten minutes, saving users the effort of clicking the Refresh button.

In other cases, after a browser loads a document, you might want it to automatically load {redirect the user 
to) a different document, possibly after a brief delay. An example is the common situation in which an 
author or webmaster has moved a document to a new location, but some users might still use links or 
"bookmarks" that point to the old location. In such cases, you might want to put a temporary document in 
the old location; the temporary document can advise users to update their links or bookmarks and then have 
the browser automatically jump to the new location.

You can set up either action in the Advanced tab of the Document Properties dialog box.

To set up an automatic refresh interval

1. On the File menu, click Document Properties, and then click the Advanced tab.
2. Under Auto refresh/redirect, in the URL box, enter the name of the current document. (Do not 

leave the box empty.)
3. In the Delay time box, enter the number of seconds between refreshes. (For example, enter "300" 

for a 5-minute interval.)
4. Click OK.

9  If there is a possibility that the document will be renamed later, enter a space instead o f the 
file name in the URL box.

To set up an automatic redirect

1. On the File menu, click Document Properties, and then click the Advanced tab.
2. Under Auto refresh/redirect, in the URL box, enter the path or URL of the document you want the 

browser to redirect to.
3. In the Delay time box, enter the number of seconds the browser should delay before loading the 

other document.
4. Click OK.

Related topics

Adding custom meta tags....................................................................................p.248
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S p e c i f y i n g  a  c a c h e  e x p i r a t i o n  d a t e

Most Web browsers cache local copies of visited documents on the user’s hard drive. If the user revisits a 
Web page she has visited before, the browser may display the local copy, which can be much faster than 
fetching the document from the Web. In general, browsers display cached copies if they have determined 
(perhaps by examining the modification date) that the original document has not changed since the copy 
was created.

However, for some time-sensitive documents, you may want browsers to always retrieve a particular page 
from the Web server, overriding their cache policies. In other cases, you may want browsers not to use 
cached copies of a document after a certain date and time has passed. To override browser's cache policies 
and force them to retrieve a particular document from the Web, you can specify a cache expiration date for 
the document. This date can be in the past, which causes browsers to never use cached copies of the 
document.

To specify a cache expiration date for a document

1. On the File menu, click Document Properties, and then click the Advanced tab.
2. In the Expires on box under Cache expiration, enter the date after which browsers should not use 

cached copies of the document. (Click Sample Date to see the correct date/time format.)

Related topics

Adding custom meta tags...................................................................................p.248

A d d i n g  P I C S  l a b e l s  t o  a  d o c u m e n t

The Platform for Internet Content Selection (PICS) is a system for labeling Web documents with respect to 
their content. It was originally developed as a standardized method that could be used by Internet filtering 
products or Web browsers to identify and filter out content that users deem inappropriate for their children. 
The PICS system depends on Web authors or webmasters labeling their own documents according to some 
formalized rating or classification system. One example of such a rating system is the one developed by the 
Internet Content Rating Association. The ICRA Web site features a PICS label generator that you can use 
to generate a PICS label for a site or page, based on your answers to some content-related questions. Once 
you have a PICS label, you can easily insert it into a document using Namo WebEditor. (To apply a PICS 
label to an entire site, add it to the site's index page.)

To add PICS labels to a document

1. On the File menu, click Document Properties, and then click the Advanced tab.
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2. In the Labels box under Platform for Internet Content Selection (PICS), type or paste each PICS 
label. Separate multiple labels with carriage returns (press Enter).

3. Click OK.

Sejoong Namo Interactive does not recommend or endorse any particular content rating system.

A d d i n g  c u s t o m  m e t a  t a g s

In addition to the common types of meta data that you can specify in the General and Advanced tabs of the
Document Properties dialog box, you can add other meta tags through the Custom META Tags tab of the
same dialog box. There are two kinds of meta tags you can add to a document:

HTTP header equivalents (<meta http-equiv>)
This type of meta tag is used to provide some special instruction to the browser. For example, the 
meta h t tp -e q u iv = " e x p ir e s " tag gives the browser an expiration date for its cached copy of 
a document; if a browser respects this tag, it will reload the document from the server instead of 
displaying a cached copy. HTTP header equivalent meta tags are so called because they perform 
the same function as corresponding HTTP headers provided by some Web servers.

User metadata (<meta name>)
This type of meta tag is used to contain any author-defined meta data for any purpose. There are 
some common forms that are widely recognized, such as meta name=" keyw ords" (used by 
search engines to help categorize documents), but authors are free to add any kind of meta data 
they wish.

To add or modify a custom meta tag

1. On the File menu, click Document Properties, and then click the Custom META Tags tab.
2. Depending on the type of meta tag you want to add or modify, click the Add button or the Modify 

button under HTTP header equivalents or under User metadata.
3. In the Name box, enter the desired http-equiv or name value for the meta tag.
4. In the Content box, enter the desired content value, and then click OK.
5. If you want to add another meta tag, repeat steps 2 through 4.
6. Click OK.

To remove a custom meta tag

1. On the File menu, click Document Properties, and then click the Custom META Tags tab.
2. Select the meta tag you want to remove and click Remove.
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EJ The list boxes in the Custom META Tags tab also display any meta tags that have been added through 
the Genera! and Advanced tabs, in addtion to any custom tags you have added. Most o f  these meta tags 
can be edited in this tab.

Related topics

Specifying keywords and other meta data....................................................... p.237
Setting up an automatic refresh or redirect...................................................... p.246
Specifying a cache expiration date........................... ....................................... p.247





5  S p i c i n g  U p  Y o u r  S i t e

In this section, we’ll go beyond the basics of page content and learn how to enhance Web sites with 
multimedia, JavaScript effects, online user forums, and more.

In this section

Adding multimedia objects............................................................................... p.252
Using Smart Clipart........................................................................................... p.258
Using Flash Buttons........................................................................................... p.265
Using themes....................................................................................................... p.270
Creating photo albums.......................................................................................p.281
Adding JavaScript effects................................................................................. p.288
Adding interactive features............................................................................... p.323
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A d d i n g  m u l t i m e d i a  o b j e c t s
Namo WebEditor 6 makes it easier than ever to insert videos, audio recordings, Flash animations, and other 
multimedia objects into your Web documents. With the Media Wizard, you can add a video or audio file to 
any document and have it play right on the page using Windows Media Player, QuickTime, or RealOne 
Player, in just a few simple steps.

In this section

Inserting video and audio files.................................
Inserting Flash and Shockwave objects..................
Inserting other ActiveX, applet, or plug-in objects

I n s e r t i n g  v i d e o  a n d  a u d i o  f i l e s

Use the Media Wizard to insert a video or audio file into the current document. The Media Wizard supports 
the following browser controls and plugins for playing multimedia content:

• Windows Media Player
• QuickTime Player
• RealOne Player (RealPlayer)

To insert a video or audio file

1. On the Insert menu, point to Media and then click Media Wizard.
2. Under Step 1: Select media file, enter the path or URL of the media file you want to insert, or click

^  (Browse) to find and select a media file from your local file system. Once you specify a media 
file, the Media Wizard will automatically select the appropriate player based on the file’s extension.

3. Click Next.
4. Specify the options and settings you want the player to use. (See the explanations below.)
5. Click Finish.

B i  When using the Media Wizard, you cannot select the player to use, even if the specified media file's 
format is supported by more than one player To use a player other than the one autoselected by the 
Media Wizard: on the Insert menu, point to Media, and then click the command corresponding to the 
player you want to use.

.p.252

.p.255

.p.256
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These options apply to all media objects. All of these settings are optional—you can leave them blank or 
accept the default values.

ID
If you plan to use the media object in a script, enter an ID by which the object will be referred.
The ID must begin with a letter and contain only letters, digits, hyphens, underscores, and periods.

Width and Height
Enter numbers to specify the width and height of the player either in pixels or as a percentage of 
the size of the parent container.

Horizontal spacing and Vertical spacing
You can specify the size of the margins on the sides (horizontal spacing) and/or above and below 
(vertical spacing) the media object, in pixels.

Alignment
You can specify how the media object will be aligned with respect to adjacent content. The 
alignment options are the same as those for images; see Setting an image's alignment, p. 148 for 
examples. The default alignment is Bottom.

Play and screen options for Windows Media Player

These options are available for media objects that will be played with the Windows Media Player control. 

Auto start
The media clip will begin playing as soon as the browser has finished downloading it.

Show tracker
The player will show a slider that allows the user to jump to a point in the media clip. (Note: the 
tracker will not be visible if the Show controls option is not selected.)

Show controls
The player will show controls for controlling the progress and sound volume of the media clip. 

Show goto bar
The player will show a drop-down menu displaying a list of markers in the media file, if any have 
been defined. The user can select a marker to jump to the corresponding position in the media clip.

G e n e r a l  o p t i o n s
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Show info
The player will show a panel containing information about the media clip, such as its name, author, 
and copyright notice.

Show status bar
The player will show a bar displaying status information.

Auto size
The player will automatically adjust its size to fit the media clip.

Play and screen options for QuickTime

These options are available for media objects that will be played with the QuickTime plugin.

Auto start
The media clip will begin playing as soon as the browser has finished downloading it.

Loop
The media clip will play again from the beginning when its end is reached.

Show controls
The player will show controls for controlling the progress and sound volume of the media clip. 

Scale

• Stretch to fit: The media clip will be stretched to fit the specified dimensions of the player.
• Keep aspect: The media clip will be scaled proportionally to fit the specified height of the 

player, preserving its original aspect ratio.

Play and screen options for RealOne Player

These options are available for media objects that will be played with the RealOne (or RealPlayer) plugin. 

Auto start
The media clip will begin playing as soon as the browser has finished downloading it.

Loop
The media clip will play again from the beginning when its end is reached.

Center (auto size)
The player will automatically adjust its size to fit the media clip.
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Main aspect
The media clip will be scaled proportionally to fit the specified height of the player, preserving its 
original aspect ratio.

Controls
Click to select the controls you want the player to show.

I n s e r t i n g  F l a s h  a n d  S h o c k w a v e  o b j e c t s

To insert a Flash or Shockwave object in the current document

1. On the Insert menu, point to Media and then click Flash or Shockwave, depending on the type of 
object you want to insert.

2. Locate and select the desired Flash or Shockwave file on your local file system and click Open, or 
enter the URL of a Flash or Shockwave file on the Internet in the URL to open box and click Open 
URL

3. (optional) If you will use the object in a script, type an ID for the object in the ID box.
4. (optional) If you want to show the object in a size other than its original size, specify the desired 

size in the Width and Height boxes under Size and spacing. You can enter sizes in pixels or as a 
percentage of the parent container's size.

5. (optional) Specify the margins on the sides and/or above and below the object in the Horizontal 
spacing and Vertical spacing boxes.

6. Under Alignment, click the box and select the desired alignment of the object with respect to 
adjacent content. (See Setting an image's alignment, p. 148 for examples of the alignment options.) 
The default alignment is Bottom.

7. (optional) If you need to change any of the object's parameters, click the Parameters button, edit 
the parameters, and click OK.

8. Click OK.

Notes

• To be able to see Flash or Shockwave objects in Preview mode, your computer must have the 
appropriate player installed. You can download the Flash and Shockwave players from 
Macromedia's download page.

• Most Flash objects (those with .swf extensions) are shown in Edit mode as the first frame of the 
animation. However, Flash objects that have a .fla extension are represented by dashed rectangles 
in Edit mode.

• Shockwave objects are represented by dashed rectangles in Edit mode.
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I n s e r t i n g  o t h e r  A c t i v e X ,  a p p l e t ,  o r  p l u g - i n  o b j e c t s

If you have a media file that is not supported by Windows Media Player, QuickTime, or RealPlayer, but 
you know an ActiveX control that supports it, you can still insert the media file into a Web document. 
Similarly, you can insert any media file that is supported by a Netscape-style browser plug-in. You can 
insert Java applets, as well.

To insert an ActiveX object

1. On the Insert menu, point to Object and then click ActiveX Control.
2. In the Class ID box, enter the classid attribute for the object, or click the triangle and select from 

the list of ActiveX controls installed on your computer.
3. (optional) If you will use the object in a script, type an ID for the object in the ID box.
4. (optional) If you want to show the object in a size other than its original size, specify the desired 

size in the Width and Height boxes under Size and spacing. You can enter sizes in pixels or as a 
percentage of the parent container’s size.

5. (optional) Specify the margins on the sides and/or above and below the object in the Horizontal 
spacing and Vertical spacing boxes.

6. If you are inserting a media clip, click Parameters, enter the path or URL of the media clip in the 
appropriate field (for example, Source) and click OK. Also click Parameters if you need to specify 
any other object parameters.

7. Click OK.

To insert a plug-in object

1. On the Insert menu, point to Object and then click Plug-In.
2. In the Path box, enter the path or URL of the media file. You can click Browse to locate and select 

a media file on your local file system.
3. (optional) In the Alt text box, enter a brief description or notice to be displayed in the browser if 

the supporting plug-in is not installed.
4. (optional) In the Plug-in home box, enter the URL of a Web page from which users can download 

the plug-in if they do not have it.
5. (optional) If you want to show the object in a size other than its original size, specify the desired 

size in the Width and Height boxes under Size and spacing. You can enter sizes in pixels or as a 
percentage of the parent container’s size.

6. (optional) Specify the margins on the sides and/or above and below the object in the Horizontal 
spacing and Vertical spacing boxes.

7. Under Alignment, click the box and select the desired alignment of the object with respect to 
adjacent content. (See Setting an image's alignment, p. 148 for examples of the alignment options.) 
The default alignment is Bottom.

8. Click OK.
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To insert a Java applet

1. On the Insert menu, point to Object and then click Java Applet.
2. In the Code box, enter the name of the applet's class file, or click Browse to locate and select a 

class file on your local file system.
3. In the Codebase box, enter the path or URL of the folder that contains the class file. (If you select 

a file using the Browse button, the codebase is entered automatically.)
4. (optional) In the Alt text box, enter a brief description or notice to be displayed in the browser if 

the supporting plug-in is not installed.
5. (optional) If you want to show the object in a size other than its original size, specify the desired 

size in the Width and Height boxes under Size and spacing. You can enter sizes in pixels or as a 
percentage of the parent container's size.

6. (optional) Specify the margins on the sides and/or above and below the object in the Horizontal 
spacing and Vertical spacing boxes.

7. Under Alignment, click the box and select the desired alignment of the object with respect to 
adjacent content. (See Setting an image’s alignment, p. 148 for examples of the alignment options.) 
The default alignment is Bottom.

8. (optional) If you need to change any of the applet's parameters, click the Parameters button, edit 
the parameters, and click OK.

9. Click OK.

Notes

• Most ActiveX, plug-in, and applet objects are represented by dashed rectangles in Edit mode.
• To edit the properties of an object, double-click the dashed rectangle. To resize the object, click 

the rectangle once to select it, and then drag its resize handles.
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U s i n g  S m a r t  C l i p A r t
Namo WebEditor comes with a library of ready-to-use Smart ClipArt images that you can insert into your 
Web documents. Being vector-based (p. 139), Smart ClipArt images are different from ordinary, bitmapped 
images—such as GIF and JPEG images—because you can resize them without loss of sharpness and edit 
them, right inside Namo WebEditor, in an object-oriented fashion. For example, you can add a text object 
to any Smart ClipArt image, and then change or remove the text later without needing to restore the 
original, unedited image. Smart ClipArt images use the TNG format, Namo WebEditor’s own vector-based 
image format.

When you insert a Smart ClipArt image into a Web document, Namo WebEditor automatically creates a 
bitmapped version of the image in GIF format, so that it can be viewed in any visual browser without 
installing additional software. At the same time, the original vector-based image data is inserted into 
document’s HTML source code, so that you can later edit the image without reinserting it. When you resize 
or edit the Smart ClipArt image, Namo WebEditor recreates another bitmapped version on the fly.

If Namo WebCanvas is installed on your computer, you can edit a Smart ClipArt image within Namo 
WebEditor by double-clicking it. You can also use Namo WebCanvas to create your own Smart ClipArt 
images from scratch.

In this section

Inserting a Smart ClipArt image....................................................................... p.258
Modifying Smart Clip.........................................................................................p.259
Converting a Smart Clip.....................................................................................p.263
Converting a Smart ClipArt image to an ordinary image............................... p.263
Managing Smart Clip..........................................................................................p.263

Related Topics

Web image formats............................................................................................. p. 139

I n s e r t i n g  a  S m a r t  C l i p A r t  i m a g e

To insert a Smart ClipArt image

1. Place the insertion point where you want to insert the image.
2. On the Insert menu, click Smart ClipArt. (Or click the Smart ClipArt button on the Shortcut Bar.)
3. Select a folder in the folder list on the left side of the Resource Manager.
4. Select the desired image and click OK.
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When you insert a Smart ClipArt image, Namo WebEditor saves a bitmapped version of the image in a 
temporary folder. It is the bitmapped version, not the original Smart ClipArt (TNG) image, that is actually 
shown in the document window or a browser. Later, when you save the document, Namo WebEditor moves 
the bitmapped image to the "images" subfolder of the document's folder. (If an "images" folder does not 
exist, it is created automatically.) When you publish the document, make sure to upload the "images" 
subfolder to the remote site, along with the document.

You can change the default path for Smart Clip Art-derived bitmapped images by specifying a different path 
in Namo WebEditor Preferences. The path is always relative to whatever folder the document is saved in. 
For example, if you specify the default path as "../images", the bitmap images will be saved in the "images" 
subfolder of parent folder of the document folder.

To change the default path for Smart ClipArt-derived bitmap images

1. On the Tools menu, click Preferences, and then click the Save tab.
2. In the Save Smart ClipArt, equation, and chart images in folder box, type the desired path (relative 

to the document folder).

If you change the default path for Smart ClipArt images, Namo WebEditor will automatically move 
already-inserted images to the new path the next time you save a document that includes Smart ClipArt.

M o d i f y i n g  S m a r t  C l i p A r t  i m a g e s

You can edit a Smart ClipArt image right inside Namo WebEditor using the Smart ClipArt Editor, a 
simplified version of the standalone Namo WebCanvas image editor that is included with some versions of 
Namo WebEditor 6. To open the Smart ClipArt Editor, just double-click a Smart ClipArt image in a 
document. When you are finished editing the image, click OK.

The subsections below describe a few basic editing tasks you can perform in the Smart ClipArt Editor. 
However, since the editor includes much of the functionality of the full Namo WebCanvas program, a 
complete description of its capabilities is beyond the scope of this document. For more information about 
what you can do with the Smart ClipArt Editor, please refer to the Help window in Namo WebCanvas.

The Smart ClipArt Editor is not available if you do not have Namo WebCanvas installed. If Namo 
WebCanvas was not included in your Namo WebEditor 6 package, it must be purchased separately 
and installed to enable the Smart ClipArt Editor.

In this section

Changing colors in a Smart ClipArt image.........
Adding or editing text in a Smart ClipArt image
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Changing the exporting area of a Smart ClipArt image..................................p.262

C h a n g i n g  c o l o r s  i n  a  S m a r t  C l ip A r t  i m a g e

To change the color of an object in the image

1. Double-click the Smart ClipArt image in the document window.
2. On the side toolbar, click ^ (Direct Selection Tool).
3. Select the desired object by clicking it. (If it is difficult to select directly, you can also select it in 

the Layers panel.) The path of the selected object will appear in thin blue lines.

4. On the Paint panel, click the triangle on either the Fill button or the Stroke button (depending on 
which part of the object you want to change) and select a new color. If the color you want is not on
the palette, click El (the palette menu) and select another palette, or click ©  and select a color in 
the Color Picker.

Paint I Stroke I Transform | Effect | Text |

Fit

Stroke:

I (0.000,138.000]

5. Click OK to save the edited image.
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l“l If an object's stroke is not at least 1 pixel wide, any color you give it will not be visible. To change an 
object's stroke width, click the Stroke tab and enter a value in the Width box.

To change the image's background color

Most Smart ClipArt images have a transparent white background. This works well when they are used in a 
Web document that also has a white background. But if a document has a colored background, the image 
may not match well. In such cases, you should change the Smart ClipArt image’s background color to 
match that of the document.

1. Double-click the Smart ClipArt image in the document window.
2. Right-click the image editing area and click Canvas Properties.
3. Click the Color box and select the new background color. If the color you want is not on the

palette, click El (the palette menu) and select another palette, or click and select a color in the 
Color Picker.

4. If you want the background color to be transparent (so that the document’s background shows 
through it), select the Transparent check box.

5. Click OK.
6. Click OK again to save the edited image.

A d d i n g  o r  e d i t i n g  t e x t  i n  a  S m a r t  C l ip A r t  i m a g e

Adding text to, or modifying existing text in, a Smart ClipArt image is easy. You can edit the text itself and 
change its font, size, style, direction, and other properties.

To edit an existing text object in a Smart ClipArt image

1. Double-click the Smart ClipArt image in the document window.
2. Select the text object by clicking it. (If it is difficult to select directly, you can also select it in the 

Layers panel.)
3. On the Text panel, edit or change the properties of the text object as desired.
4. Click OK to save the edited image.

add text to a Smart ClipArt image

1. Double-click the Smart ClipArt image in the document window.
2. On the side toolbar, click A  (Text Tool).
3. Click anywhere in the image editing area.
4. In the Text box, type the desired text, and then configure the text properties—font, size, direction, 

and so forth—as desired.
5. Click OK.
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6. On the side toolbar, click ^ (Selection Tool).
7. Drag the text object to the desired position on the image. You can also resize it by dragging its 

resize handles.
8. Click OK to save the edited image.

When entering text, you can insert a line break by pressing Ctrl+Enter.

C h a n g i n g  t h e  e x p o r t  a r e a  o f  a  S m a r t  C l ip A r t  i m a g e

One of the strengths of the Smart ClipArt image format is that you can choose which part of an image is 
visible in the Web document by modifying its export area. The export area is a rectangular region that 
determines what part of the image will be saved in bitmapped format for display in the document. Each 
Smart ClipArt image that comes with Namo WebEditor has a predefined export area, and you can modify

To specify the export area of a Smart ClipArt

1. Double-click the Smart ClipArt image in the document window.

2. On the side toolbar, click (Export Area Tool).
3. Do one of the following to define the export area:

o Draw a box around the part of the image you want to be visible,
o Click anywhere on the image editing area. In the Export Area dialog box, specify the 

desired Size and Position of the export area in numbers, and then click OK.
4. If necessary, adjust the export area by dragging the resize handles on the dashed blue rectangle.
5. Click OK to save the image with the new export area.

Namo WebEditor can automatically set the export area to the minimum size that includes every object 
in the image. To set the export area automatically, right-click anywhere on the image editing area and 
click Auto Export Area.
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C o n v e r t i n g  a  S m a r t  C l i p A r t  i m a g e  t o  a n  o r d i n a r y  

i m a g e

When you insert a Smart ClipArt image into a Web document, Namo WebEditor saves the original image 
data in the document itself, so that you can always edit the image later without needing to open another file. 
As a result, the file sizes of documents containing Smart ClipArt images can be significantly larger than 
those of similar documents that only use bitmapped images (which are always stored separately). If you 
need to minimize the file size of a document that includes Smart ClipArt images, and you do not plan to 
edit the images in the future, you can save space by converting the images to ordinary, bitmapped images.

To convert a Smart ClipArt image to a bitmapped image

1. Right-click the image, point to Image, and then click Convert to Standard Image.
2. Click Yes to confirm converting the image.
3. In the File name box, enter the desired file name for the bitmapped image.
4. Click the Save as type box and select the desired bitmap image format: GIF, JPEG, or PNG.
5. Click Save.

9  I f  the Smart ClipArt image has a transparent background color, select GIFformat for the conversion. 
The other formats do not support transparency.

0  Once you convert a Smart ClipArt image to an ordinary bitmapped image, you cannot edit it with the 
Smart ClipArt Editor.

M a n a g i n g  S m a r t  C l i p A r t

The Smart ClipArt library is managed through the Resource Manager (p.45). To open the Resource 
Manager: on the Window menu, click Resource Manager.

You can perform the same types of management tasks with Smart ClipArt images as you can with other 
resources, including:

• Moving images from one category (folder) to another
• Deleting unwanted images
• Adding new images, such as those you create with WebCanvas
• Adding images from a zip archive
• Copying images to a zip archive and optionally e-mailing the archive to another person
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(See The Resource Manager, p.45 for information on general resource management tasks.)

In addition, you can permanently modify an image in the library, or modify an image and save it as a new 
image.

To permanently modify a Smart ClipArt image in the library

1. Open the Resource Manager. (On the Window menu, click Resource Manager.)
2. Right-click the image you want to modify and then click Modify.
3. Edit the image as desired. (See Modifying Smart ClipArt images, p.262.)
4. Click OK.

To modify a Smart ClipArt image in the library and save it as a new image

1. Open the Resource Manager. (On the Window menu, click Resource Manager.)
2. Right-click the image you want to modify and then click Modify As New.
3. Edit the image as desired. (See Modifying Smart ClipArt images, p.262.)
4. Click OK.

A modified copy of the original image will appear in the Resource Manager, in the same folder as the 
original.

0  You cannot edit Smart ClipArt images if you do not have Namo IVebCanvas installed on your computer. 
IfNamo WebCanvas was not included in your Namo WebEditor 6package, it must be purchased 
separately and installed to enable the Smart ClipArt Editor.

Related topics

The Resource M anager........................................................................................... p.45
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U s i n g  F l a s h  B u t t o n s
Flash Buttons are brief, looping Flash animations that are meant to be used as navigation buttons, banners, 
or other design elements on Web pages. Unlike ordinary Flash files, Flash Buttons have a static text 
component that you can edit directly in Namo WebEditor. A variety of predesigned Flash Buttons are 
included with Namo WebEditor in the resource library, accessible through the Resource Manager (p.45).

You can use Flash Buttons as standalone buttons and design elements, and also in dynamic navigation bars 
(p.365) and dynamic banners (p.375).

Besides using the Flash Buttons that come with Namo WebEditor, you can add your own Flash files (ones 
you create yourself or that you download from the Web) to the library, so you can insert them conveniently 
into your Web documents.

In this section

Inserting a Flash B utton......................................................................................... p.265

Editing the text o f a Flash Button......................................................................... p.266

Resizing a Flash B u tton ......................................................................................... p.266

Changing the background color o f a Flash B utton........................................... p.267

Creating a hyperlink on a Flash B utton...............................................................p.268

Importing Flash files into the Flash Button lib rary .......................................... p.268

Related topics

Insert a dynamic navigation b a r ............................................................................p .371

Adding dynamic page banners..............................................................................p.375

I n s e r t i n g  a  F l a s h  B u t t o n

To insert a Flash Button

1. Place the insertion point where you want to insert the Flash Button.
2. On the Insert menu, click Flash Button. The Resource Manager window will open.
3. Select a folder in the left pane, select a Flash Button in the right pane, and then click OK.
4. Edit the contents of the Text box as desired. (This is the static text that will appear on the Flash 

Button.)
5. (optional) Select the desired font and font size for the static text.
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6. (optional) Using the Offset X and Y boxes, specify the desired position of the text relative to its 
default position, in pixels.

7. (optional) Edit the URL in the Link box as desired. (See Creating a hyperlink on a Flash Button, 
p.268.)

8. Click OK.

Q  You can also insert a Flash Button by dragging it to the document window from the Resource Manager.

Namo WebEditor 6 User Manual

E d i t i n g  t h e  t e x t  o f  F l a s h  B u t t o n

To edit or format the text of a Flash Button

1. Double-click the Flash Button.
2. Under Text, do any or all of the following:

o In the Text box, edit the text as desired, 
o Click the Font box and select the desired font, 
o In the Size box, enter the desired font size (in points).
o In the Offset X and Y boxes, enter the horizontal and vertical offsets, respectively, of the 

text from its default position (in pixels).
3. Click OK.

o  The preview area at the top of the Flash Button Properties dialog box displays the effect of any 
changes you make, so you can try different settings before closing the dialog box.

0  You cannot edit or format text in other Flash files through the Flash Button Properties dialog box.

R e s i z i n g  a  F l a s h  B u t t o n

To resize a Flash Button

1. Click the Flash Button to select it.
2. Drag any of the resize handles at the comers and sides of the button.

266 Using Flash Buttons



Chapter 5: Spicing Up Your Site

button text

Resizing a Flash B utton

Note that the foreground portion of a Flash Button always maintains its proportions (aspect ratio) when you 
resize the button. If you change the button’s proportions, only its background area changes shape.

171x54

C h a n g i n g  t h e  b a c k g r o u n d  c o l o r  o f  a  F l a s h  B u t t o n

Each Flash Button has a white background by default. This is usually appropriate when the document 
background is also white, but if the document background is another color, a pattern, or an image, the Flash 
Button will not blend well with it. In such cases, you can solve the problem by changing the background 
color of the Flash Button or by making its background transparent. The examples below illustrate the effect 
of making a Flash Button's background transparent when the document background is gray.

] ®  S i n

Jjj^  button ^
* button J p

W hite
background

T ran sp aren t
background

To change the background color of a Flash Button

1. Double-click the Flash Button.
2. Under Appearance, do one of the following:

o Click the Background box and select a color (p.233). (To quickly match the document 
background, use the eyedropper tool ^ .) 

o Select the Transparent check box.
3. Click OK.

1=1 The borders of some Flash Buttons may look ragged when you make their background color
transparent. This may result from the way the buttons were made. In such cases, set the background 
color to the same color as the document's background instead of making it transparent.
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O 'w  Transparent Flash Button backgrounds are supported by Internet Explorer 4+ and Netscape <5+.

C r e a t i n g  a  h y p e r l i n k  o n  a  F l a s h  B u t t o n

Unlike with an ordinary image, you cannot create a hyperlink on a Flash Button using the Insert Hyperlink 
command. Instead, you enter a URL in the Flash Button Properties dialog box.

To create or edit a hyperlink on a standalone Flash Button

1. Double-click the Flash Button.
2. Under Hyperlink, type the desired URL in the Link box, or do one of the following:

o Click Q  (Browse) to find and select a document on your local file system.
o Click (Open Documents) to select one of the documents that are currently open in 

Namo WebEditor.

o Click ©» (Site) to select from a list of documents belonging to the current local site (if 
one is open).

3. (optional) If you want the link to open in another window or frame than the one containing the 
Flash Button, enter the name of the desired window or frame in the Target box. (See Setting a 
link’s target window or frame, p. 170.)

4. Click OK.

0  IVhen you use Flash Buttons in a dynamic navigation bar, you do not need to manually assign a link to 
each button, because the button’s links are determined by the structure of the site tree and the 
properties of the navigation bar itself Any hyperlink assigned to a Flash Button in a dynamic 
navigation bar or dynamic banner through the Flash Button Properties dialog box will be ignored.

Related topics

About hyperlinks..................................................................................................... p. 165

I m p o r t i n g  F l a s h  f i l e s  i n t o  t h e  F l a s h  B u t t o n  l i b r a r y

If you have Flash (*.swf) files on your local file system that you have either created yourself or 
downloaded from the Web, you can add them to Namo WebEditor’s Flash Button library. Then, you can 
insert them into your documents as easily as you can the Flash Buttons that come with Namo WebEditor.
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To import Flash files into the Flash Button library

1. On the Window menu, click Resource Manager, and then click the Flash Buttons tab.
2. On the left pane, select the folder into which to import the Flash files.
3. Click the Import button at the bottom of the window.
4. Select one or more Flash files (files with a .swf extension) and click Open.

The newly imported Flash files will appear in the right pane of the Resource Manager window. You can 
now insert them into your documents as you can the included Flash Buttons.

y  You can also drag Flash files from Windows Explorer into the right pane of the Resource Manager 
window. (Make sure to click the Flash Buttons tab first.)

3  You cannot edit or format text in imported Flash files through the Flash Button Properties dialog box.
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U s i n g  t h e m e s
Designing a good-looking Web site is no easy task. Fortunately, even the most aesthetically-challenged 
author can build a great-looking site with the help of Namo WebEditor's themes.

In this section

About them es..............

Applying a them e.......

Creating a new theme 

Editing a them e...........

A b o u t  t h e m e s

A theme is a collection of styles (p.210) and objects (graphic design elements, such as bullets, buttons, and 
banners) that combine to create a harmonious look. When you apply a theme to a document, the theme's 
styles are added to the document's own style sheet, and the theme's objects become available for use in the 
document.

Namo WebEditor 6 comes with approximately two hundred predesigned themes. You can use them as they 
are, or edit (p.276) and customize them as you see fit. You can even create (p.276) completely new themes 
from scratch. To browse the themes that come with Namo WebEditor, open the Resource Manager (on the 
Window menu, click Resource Manager) and click the Themes tab.

In this section

What’s in a them e?.............................................

Files that are added when you apply a theme

W h a t ' s  i n  a  t h e m e ?

Every theme includes a set of style definitions (p.212) and a set of objects, which are images that are 
intended for use as design and navigational elements and that have a consistent "look".

Styles included in a theme

The table below lists the default styles that every theme includes; the properties that each style defines by 
default; and the types of elements the styles apply to.

.p.270

.p.272

.p.270

.p.273

.p.276

.p.276
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Style name 
Document 
Heading 1 
Heading 2 
List 1

List 2

Table

Cell

Header Cell

Normal Hyperlink 
Visited Hyperlink 
Active Hyperlink 
Hover Hyperlink

;Default properties
font-family, color, background-color 
font-family, font-size, color 
font-family, font-size, color 
font-family, font-size, color

font-family, font-size, color

border-top-color, border-right-color, border- 
bottom-color, border-left-color
border-top-color, border-right-color, border- 
bottom-color, border-left-color
border-top-color, border-right-color, border- 
bottom-color, border-left-color, background-color
color, text-decoration
color
color
color

[Applies to
the entire document
all level-one headings (p. 129)
all level-two headings (p. 129)
paragraphs of class (p.215) 
’’namo-list"
paragraphs of class (p.215) 
"namo-sublist"
tables (p. 182) of class (p.215) 
’’namo-table"
ordinary cells in tables of 
class (p.215) ,fnamo-table"
header cells (p.204) in tables of 
class (p.215) "namo-table"
normal (p. 174) hyperlinks
visited (p. 174) hyperlinks
active (p. 174) hyperlinks
hover (p. 174) hyperlinks

To view the properties of these styles for a specific theme, do the following:
1. On the Window menu, click Resource Manager, and then click the Themes tab.
2. Select the desired theme and click the Theme Properties button (at the bottom of the window).
3. Select the style whose properties you want to view.
4. View the properties of the selected style in each of the Character, Paragraph, and Borders & 

Background tabs.

In addition to the styles listed above, each theme has two styles that do not appear in the style list for the 
theme as shown in the Theme Properties dialog box. These styles, when applied to list items (p. 129), cause 
the list items to use image bullets.

When you edit (p.276) a theme, you are not limited to the styles and properties that are defined by default. 
You can add other properties for the existing styles, and you can add new styles as well. For example, you 
could change the Heading 1 style of a theme to include the margin-top property if you wanted level-one 
headings to have more (or less) top margin. And you could add another style to define the appearance of 
level-three headings, using h3 as the style’s selector.

Theme objects

The table below lists the objects (images) that every theme includes and describes their intended uses.
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Object name 
Banner

Intended use
Dynamic banners (p.375) or static banners

Horizontal Button buttons in horizontal dynamic navigation bars (p.365) 
Vertical Button buttons in vertical dynamic navigation bars (p.365)
Bullet 1 
Bullet 2 
Cool Icon 
Hot Icon 
New Icon 
Home Icon 
Up Icon 
Prev Icon 
Next Icon 
Horizontal Line 
Background

bullet for list items (p.129) of class (p.215) "namo-listl"
bullet for list items (p.129) of class (p.215) "namo-list2"
for highlighting "cool" content
for highlighting "hot" content
for highlighting "new" content
graphical link to site’s home page
graphical link to document's parent
graphical link to document’s previous sibling
graphical link to document’s following sibling
graphical version of a horizontal rule (p.75)
the document's background image

E l The Horizontal Button, Vertical Button, and Background objects cannot be inserted (p.274) into a 
document in the same way as the other theme objects. The button objects can only be used in dynamic 
navigation bars (p.365) that you insert in a document that is part of a local site. The Background object 
is automatically applied to a document when you apply a theme (p.275).

When you edit (p.276) a theme, you can replace any of its default objects with other images of your 
choosing. Also, some objects, being Smart ClipArt (p.258) images, can be edited with the Smart ClipArt 
Editor (p.259).

Related topics

Inserting theme objects............................................................................................p.274

Applying styles from a them e................................................................................ p.275

About formatting and styles....................................................................................p .210

Site structure and navigation.................................................................................. p.355

When you apply a theme to a document or local site that did not previously have a theme, you should be 
aware that Namo WebEditor copies certain image files to the document/site folder or a subfolder, as 
follows:
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• The theme's background image file is copied to the site folder, or, if the site folder contains an 
"images” subfolder, it is copied to that subfolder.

• Image files corresponding to most theme objects (p.271) you insert into the site's documents are 
likewise copied to the site folder, or, if the site folder contains an "images" subfolder, it is copied 
to that subfolder.

• Image files corresponding to the buttons in any dynamic navigation bars (p.365) in the site's 
documents are copied to a new "nav" subfolder of the site folder.

• Image files corresponding to any dynamic banners (p.375) in the site’s documents are likewise 
copied to a new "nav" subfolder of the site folder.

When applying a theme to a standalone document

• The theme's background image file is copied to the document folder, or, if the document folder 
contains an "images" subfolder, it is copied to that subfolder.

• If you insert any theme objects (p.271) into the document, you must decide the location of the 
corresponding image files at the time you save the document. (The Resource File Handling dialog 
box will prompt you to choose how to handle the image files.)

When you publish a site or document that uses a theme, make sure to upload the theme image files along 
with the document or the rest of the site files. Otherwise, the theme will not display correctly in a user's 
browser. (If you use the Quick Publish (p.392) command to publish an entire site, Namo WebEditor takes 
care of uploading these files for you.)

When applying a theme to documents in a local site

A p p l y i n g  a  t h e m e

To use a theme in a document or set of documents, you need to apply it. You can apply a theme to any of 
the following document sets:

• Just the current document
• All open documents
• Every document in the current local site
• The current document and its child documents, if any, in the site tree of the current local site

Before applying a theme, you must save all the documents to be affected. Namo WebEditor will prompt 
you to save the document(s) if necessary.

To apply a theme

1. On the Format menu, click Theme.
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2. In the folder list, select a theme category, and then select a theme in the selection area. (To get a 
better view of the selected theme, double-click it.)

3. When you are satisfied with your selection, click OK.
4. Specify what set of documents you want to apply the theme to, and then click OK.

CE) You cannot undo applying a theme. Once you apply a theme, you cannot return the document or site to 
a themeless state without manually deleting theme files and editing the document's source code. I f  you 
change a document or site's theme and you want to go back to the old theme, you need to reapply the 
old theme.

0  When you add a new document (p.347) to a site to which you have applied a theme, the new document 
does not automatically use the theme. You must explicitly apply the theme to the new document.

In this section

Inserting theme objects...........

Applying styles from a theme

I n s e r t i n g  t h e m e  o b j e c t s

Once a theme has been applied to a document, you can easily insert most types of theme objects (p.271) into 
the document using the Theme Object submenu of the Insert menu. On the Insert menu, click Theme Object, 
and select the desired theme object from the submenu.

In most themes, objects are ordinary, bitmapped images, and you can modify them in the same ways as 
other bitmapped images. (See the Images, p. 137 section for more information.) However, objects in vector- 
based themes (the themes in the Vector category) use Smart ClipArt (p.258) images. As with other Smart 
ClipArt images, you can edit these objects using the Smart ClipArt Editor. (Double-click the object to edit 
it.)

If you insert a Banner theme object, it will initially have the text "Banner text" on it. To change the text, 
double-click the banner and enter the desired text.

0  The Horizontal Button, Vertical Button, and Background objects cannot be inserted into a document 
using the Insert Theme Object commands. The button objects can only be used in dynamic navigation 
bars (p.365) that you insert in a document that is part of a local site. The Background object is 
automatically applied to a document when you apply a theme (p.275).

The Smart ClipArt Editor is not available if you do not have Namo WebCanvas installed. IfNamo 
WebCanvas was not included in your Namo WebEditor 6 package, it must be purchased separately 
and installed to enable the Smart ClipArt Editor.

.p.274

.p.275
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Related topics

Files that are added when you apply a them e.................................................... p.272

A p p l y i n g  s t y l e s  f r o m  a  t h e m e

When you apply a theme to a document, some of its styles (p.270) are applied automatically to the 
document's content, while others—the List and Table styles—can be applied manually when desired.

Styles that are applied automatically

The styles that are automatically applied include:

• the Document style, which affects the font, text color, and background color of the whole 
document

• the Heading 1 and Heading 2 styles, which affect the font, size, and color of all level-one and 
level-two headings (p. 129), respectively

• the Hyperlink styles, which affect the color of hyperlinks 

Applying a list style from the current theme

There are actually two kinds of "list" styles in each theme. Styles of the first type are actually paragraph 
styles and can only be applied to ordinary paragraphs. They affect the font, size, and color of the paragraph. 
To apply one of these "list" styles:

1. Place the insertion point in the paragraph to which you want to apply the list style. If you wish to 
apply the style to several consecutive paragraphs, select them.

2. On the Formatting Toolbar, click the Style box and select namo-list or namo-sublist.

Styles of the second "list" type are actual list-item styles and can only be applied to list items. They cause 
the list item to have an image bullet, using either the Bullet 1 or the Bullet 2 theme object (p.271). To apply 
one of these list styles:

1. Select the desired list items. (Do not simply place the insertion point in the list item.)
2. On the Insert menu, point to Theme Object, and then click Apply Theme To List 1 or Apply Theme 

To List 2.

Applying the current theme's table style to a table

Each theme has one table style. If you apply the style to a table (p. 182), it affects the border and background 
colors of the entire table. To apply the table style:

1. Place the insertion point inside the table to which you want to apply the style.
2. On the Insert menu, point to Theme Object, and then click Apply Theme To Table.
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Related topics

Styles included in a them e......................................................................................p.270

Formatting content................................................................................................... p.210

C r e a t i n g  a  n e w  t h e m e

Namo WebEditor includes a basic theme template from which you can create an entirely new theme. You 
can then apply (p.273) your new theme to a document or a site exactly as you would one of the themes that 
come with Namo WebEditor.

To create a new theme

1. On the Window menu, click Resource Manager, and then click the Theme tab.
2. (optional) Create a new theme folder by doing the following:

1. Right-click an existing folder in the folder list (such as the top-level Themes folder) and 
then click New Folder. The new folder will be created inside the selected folder.

2. Rename the new folder by right-clicking it and clicking Rename.
3. Right-click the folder in which you want to put the new theme, and then click New Theme.
4. Type a name for the new theme and click OK.

The newly-created theme will contain the default styles (p.270) and objects (p.271) that all themes have, but 
these styles and objects will be "empty”: no properties will have been specified for the styles, and no image 
files specified for the objects. To finish creating the new style, you need to edit (p.276) it and define the 
properties and image files for its styles and objects, respectively.

Related topics

Editing a theme.................................................................................... p.276

E d i t i n g  a  t h e m e

You can edit, or modify, a theme in the following ways:

• you can change the character, paragraph, border, or background-related properties of any of its 
styles (p.270)

• you can add new styles
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• you can replace the image file of any theme object (p.271) with another image file
• you can edit the Banner and Button objects, which are Smart ClipArt (p.258) images, using the 

Smart ClipArt Editor
• if the theme is vector-based (as are the themes in the Vector category), you can edit any of its 

objects using the Smart ClipArt Editor

Once you edit a theme, you cannot reset it to its original state without reinstalling Namo WebEditor. 
Therefore, before editing a theme, it is advisable to make a copy (p.48) of the theme, and then edit the 
copy.

When you edit a theme, Namo WebEditor does not automatically update documents that use the theme. 
To apply the changes to the documents, you must reapply (p.273) the theme.

0  The Smart ClipArt Editor is not available if you do not have Namo WebCanvas installed. I f  Namo 
WebCanvas was not included in your Namo WebEditor 6 package, it must be purchased separately 
and installed to enable the Smart ClipArt Editor.

In this section

Editing a theme's sty les.......................................................................................... p.277

Adding styles to a them e........................................................................................p.278

Replacing theme ob jects........................................................................................p.279

Editing theme objects..............................................................................................p.280

Related topics

What’s in a them e?.................................................................................................. p.270
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E d i t i n g  a  t h e m e ' s  s t y l e s

You can modify the properties of any of the styles (p.270) defined in a theme. Editing a theme style is the 
much the same as editing an ordinary style (p.210), except that you do it in the Theme Properties dialog 
box rather than the Styles dialog box.

For a list of names and descriptions of the default theme styles, refer to Styles included in a theme, p.270.

To edit styles in a theme

1. On the Window menu, click Resource Manager, and then click the Theme tab.
2. Select the theme you want to edit and then click the Theme Properties button (at the bottom of the 

window).
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3. For each style you want to edit, do the following:
1. Select the style in the style list.
2. In each of the Character, Paragraph, and Borders & Background tabs, modify the desired 

properties.
4. When finished, click OK.

For information about specifying style properties, see the following topics:
• Setting character-related properties, p.219
• Setting paragraph alignment, indentation, and line height, p.221
• Setting margins, padding, and borders, p.222
• Setting background colors and images, p.225

Related topics

Using style sheets................................................................................ p.212

A d d i n g  s t y l e s  t o  a  t h e m e

By adding a style (p.210) to a theme, you make that style available to all documents to which you apply the 
theme in the future.

To add a style to a theme

1. On the Window menu, click Resource Manager, and then click the Theme tab.
2. Select the theme you want to edit and then click the Theme Properties button (at the bottom of the 

window).
3. Click the Add button under the style list.
4. Do one of the following, depending on the type of style you want to create. (See Defining a style, 

p.213 for explanations of the various style types.)
o To create an element style, click the Tag box and select the desired element type. Do not 

enter anything in the Name box.
o To create a universal class style, enter the desired class name in the Name box. Leave the 

Tag box set to (none).
o To create an element-specific class style, click the Tag box and select the desired element 

type, and then enter the desired class name in the Name box.
5. Click OK.
6. In each of the Character, Paragraph, and Borders & Background tabs, specify the desired 

properties for the style.
7. When finished, click OK, or click Apply if you plan to add another style right away.
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• Setting character-related properties, p.219
• Setting paragraph alignment, indentation, and line height, p.221
• Setting margins, padding, and borders, p.222
• Setting background colors and images, p.225

Related topics

Defining a style........................................................................................ p.213

R e p l a c i n g  t h e m e  o b j e c t s

You can replace any theme object (p.271) in a theme with another image of your choosing. When replacing
a theme object, keep in mind the following guidelines:

• The Banner, Horizontal Button, and Vertical Button objects in all themes are Smart ClipArt (p.258) 
images. You can only replace one of these with another Smart ClipArt image.

• Other objects in non-vector-based themes (all themes except those in the Vector category) are 
bitmapped images. You can replace any of them with another bitmapped image (GIF, JPEG, or 
PNG), or with a Smart ClipArt image.

• All objects in vector-based themes (all themes in the Vector category) are Smart ClipArt images. 
You can only replace one of these with another Smart ClipArt image.

• When replacing a Banner or Button object, make sure the replacement image is wide enough to 
contain the longest document title you plan to use in your site, at the font size used by banners or 
navigation bar buttons, respectively.

To replace a theme object

1. On the Window menu, click Resource Manager, and then click the Theme tab.
2. Select the theme you want to edit and then click the Theme Properties button (at the bottom of the 

window).
3. In the style list, select the object you want to replace.
4. Click Import Image.
5. Locate and select the desired replacement image, and then click Open.
6. Click OK, or click Apply if you plan to replace another object right away.

Related topics

Editing theme objects.........................................................................................p.280

For information about specifying style properties, see the following topics:
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E d i t i n g  t h e m e  o b j e c t s

The Banner, Horizontal Button, and Vertical Button objects (p.271) of all themes, and all the objects of 
vector-based themes, are Smart ClipArt (p.258) images. (The vector-based themes are the ones in the Vector 
category.) This means you can edit them using the Smart ClipArt Editor (p.259).

To edit a Smart Clipart-based theme otyect

1. On the Window menu, click Resource Manager, and then click the Theme tab.
2. Select the theme you want to edit and then click the Theme Properties button (at the bottom of the 

window).
3. In the style list, select the object you want to edit. (Unless the theme is vector-based, note that only 

the Banner object and the two Button objects are editable.)
4. Click Edit Image.
5. In the Smart ClipArt Editor, make the desired changes, and then click OK.

0  The Smart ClipArt Editor is not available if you do not have Namo WebCanvas installed. I f  Namo 
WebCanvas was not included in your Namo WebEditor 6package, it must be purchased separately 
and installed to enable the Smart ClipArt Editor.

Related topics

Modifying Smart ClipArt images..................................................................... p.259
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C r e a t i n g  p h o t o  a l b u m s
One of the most exciting uses of the Web is as a medium for sharing favorite photographs with family, 
friends, and others. With its built-in Photo Album Wizard, Namo WebEditor makes creating online photo 
albums as easy as possible. Just give it a list of image files and choose a few display settings, and the 
wizard takes care of creating thumbnails, organizing them in a table, and creating links to the original, full- 
size images. You can choose how both the thumbnails and the original images are displayed (in the same 
window or separate windows, and so forth).

In this section

Using the Photo Album W izard....
Understanding photo album styles 
Advanced photo album settings....

Related topics

Images.................................................................................................................. p. 137

U s i n g  t h e  P h o t o  A l b u m  W i z a r d

Use the Photo Album Wizard to insert a gallery of thumbnail images in the current document that link to 
the full-size images that you specify. After you specify the image files to be included and a few display 
options, the wizard automatically generates thumbnail images with links to the original images and places 
the thumbnails in a table on the current page. Depending on your choice of photo album style, the wizard 
may also generate a separate document to hold each original image.

To start the Photo Album Wizard

1. Open or create the document in which you want to insert the thumbnail gallery, and then save the 
document.

2. Place the insertion point where you want the gallery to appear.
3. On the Tools menu, click Photo Album Wizard.

The Photo Album Wizard has three or four easy steps, depending on the style of photo album you choose. 
The steps are described below.

p.281
p.283
p.285
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Step 1: Selecting image files

In this step, you create a list of the image files you want to include in the photo album. You can add images
to the list either individually or by selecting entire folders full of images.

• To add individual image files, click Add Files. In the Open dialog box, navigate to the folder 
containing the desired image file(s), select the desired image file(s), and then click Open. (To 
select multiple sequential image files, click the first image file, and then click the last image file 
while holding down the Shift key. To select multiple non-sequential image files, click each while 
holding down the Ctrl key.)

• To add all the image files in a folder, click Add Folder. In the Browse For Folder dialog box, 
select the desired folder. If you want to include images in subfolders of the selected folder, click 
Include subfolders. Then, click OK.

• To remove some of the image files from the list, select them and click Remove Selected. To 
remove all image files from the list and start over, click Remove All.

When finished adding image files, click Next.

Step 2: Selecting a photo album style

In this step, you choose a photo album style and configure a few settings specific to the selected style. For
information about the various styles available, see Understanding photo album styles, p.283.

Step 3: Specifying thumbnail options

(This step is skipped if you selected the Gallery (p.284) style in Step 2.) In this step, you specify appearance
options for the thumbnails. Check the Preview area to see the effect of any changes you make.

• Under Border style, select the desired border style for the thumbnails.
• Under Size, specify either a uniform width and height (in pixels) for all thumbnails, or a 

percentage of each original image's size. If you select Uniform size and the Constrain proportions 
check box is selected, the size of the thumbnails will depend on whichever of width and height 
you specify last, while the other number is ignored.

• Depending on the border style you selected and whether the current document has a non-white 
background, you may need to change the thumbnail background color from the default white.
Click the Color box and select a color (p.233).

• If you want to add a drop shadow to the selected border style, select Create drop shadow and 
specify the shadow’s color, offsets, and amount of blur. (Note that some border styles enable a 
drop shadow by default.)

When finished specifying thumbnail options, click Next.
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In this step, you specify options relating to the table (p. 182) that will contain the thumbnails (or the full-size 
images if you selected the Gallery (p.284) style in Step 2). Check the preview area at the bottom of the 
dialog box to see the effect of any changes you make.

• Under Table size, in the Number of columns box, enter the desired number of columns for the table. 
(The number of rows is determined automatically depending on the number of images.) Optionally, 
you can also specify the table's width and height in pixels or as a percentage of the available space. 
Note that if you set the table's width or height smaller than the size required to display the 
thumbnails, the specified size will be ignored.

• (optional) Under Cell border style, click the Preset box and choose a preset style for the cell 
borders, or specify the border thickness (in pixels) in the Thickness box. (For information about 
table borders, see Controlling the appearance of table and cell borders, p. 194.)

• (optional) Under Cell border colors, specify the color(s) of the cell borders. (For information about 
table borders, see Controlling the appearance of table and cell borders, p. 194.)

• (optional) Under Table background, in the Bg image box, enter the path or URL of a background 
image for the table, or click the Bg color box and select a background color (p.233) for the table. 
(For information about table borders, see Using background colors and images in a table, p.202.)

When finished specifying layout options, click Finish.

9  You can always modify the properties of the thumbnail table after completing the wizard, in the same
ways as with any other table.

Related topics

Understanding photo album styles
Advanced photo album settings....

S t e p  4 :  S p e c i f y i n g  l a y o u t  o p t i o n s

U n d e r s t a n d i n g  p h o t o  a l b u m  s t y l e s

The Photo Album Wizard can create a photo album in any of five distinct styles. The choice of style affects 
how your full-size images will be displayed in the browser. The available styles and their specific options 
are described below.

Slide Show

The wizard inserts a table of thumbnails into the current document. When the user clicks a thumbnail, the 
corresponding full-size image is loaded into the current window or frame (p. 101), replacing the current 
document, or is opened in another named window or frame. If the Add navigation links option is selected (as

p.283
p.285
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it is by default), Previous/Up/Next links appear below the full-size image; the user can click a link to load 
the next or previous image in the photo album or go back to the thumbnails.

By default, the full-size images load in the same window or frame as the thumbnail document. However, by 
entering a window or frame name in the Target box, you can make the full-size images load in a different 
window or frame. (For more information about targets, see Setting a link's target window or frame, p. 170.)

If the Auto advance interval check box is selected, each full-size image will be replaced by its successor 
after the specified number of seconds.

Individual Image Windows

The wizard inserts a table of thumbnails into the current document. When the user clicks a thumbnail, the 
corresponding full-size image is opened in a pop-up window. If the user then clicks another thumbnail 
without closing the pop-up window, the other full-size image is opened in another pop-up window, leaving 
the first pop-up window unaffected. Each pop-up window is sized to fit the image it displays.

Using the check boxes, you can control whether such controls as the menu bar and scroll bars are visible or 
hidden in the pop-up windows.

One Image Window

The wizard inserts a table of thumbnails into the current document. When the user clicks a thumbnail, the 
corresponding full-size image is opened in a pop-up window. If the user then clicks another thumbnail 
without closing the pop-up window, the other full-size image is opened in the same pop-up window, 
replacing the first image.

Using the check boxes, you can specify whether such controls as the menu bar and scroll bars are visible or 
hidden in the pop-up windows. Use the Width and Height boxes to specify the initial size of the pop-up 
window in pixels. (You may want to set the window size large enough to fit the largest image in the photo 
album.)

Multi-View

The wizard inserts a table of thumbnails and, below it, the first full-size image, into the current document. 
When the user clicks a thumbnail, the corresponding full-size image replaces the one being displayed at the 
time.

This style has no settings to configure.

Gallery

The wizard inserts a table containing the original, full-size images themselves into the current document.
No thumbnails are generated.

This style has no settings to configure.
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A d v a n c e d  p h o t o  a l b u m  s e t t i n g s

At any step of the Photo Album Wizard, you can click the Advanced Settings button to configure advanced 
settings for the photo album. The Advanced Settings dialog box has two tabs: Save and Captions.

Save options

The Save tab exposes settings affecting how the wizard handles the three types of files it uses or creates: 

Original images
Normally, the Photo Album Wizard does not make copies of the original images you specify in 
Step 1. Each thumbnail links back to its corresponding original image, wherever it may be. If the 
original image is located on a different drive or network folder from the current document, the link 
will contain a file-type (p. 166) URL referencing an absolute path on the local file system, and the 
link will not work when the document is published to the Web.

To avoid such problems, you can tell the wizard to copy the original images to the same folder as 
the document, or to another folder in or ’’near" the document’s folder. Then, the thumbnails will 
link to the "nearby" copies of the original images, using relative paths. As long as you make sure 
to upload the copied images to your remote site along with the document, the thumbnail links will 
work correctly.

To have the wizard copy the original images, select Save copies and then, in the Save in box, 
specify the folder into which to copy the images. You must specify an absolute, file-system path, 
such as "C:\projects\current\images". (To select or create a folder, click the Browse button.)

Thumbnail images
Normally, when the Photo Album Wizard creates and saves thumbnail previews of your original 
images, it follows these default rules:

• thumbnails are saved in the same folder as the current document
• thumbnails are saved in the same graphic file format as the original images
• thumbnail image file names are created by copying the original image file names and 

appending "_tm" to each

You can change any of these behaviors for the current photo album.

• To save thumbnails in a different folder, enter the desired folder path in the Save in box. You 
can use either an absolute, file-system path, such as "C:\projects\current\thumbs", or a relative 
path, such as "thumbs/". (To select or create a folder, click the Browse button.)

• To specify the file format for thumbnails, click the File format box and select GIF, JPEG, or 
PNG.
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• To change the file name suffix for thumbnails, enter the desired suffix in the box next to the 
suffix check box.

• To use a file name prefix instead of a suffix, deselect the suffix check box, select the prefix 
check box, and enter the desired prefix.

HTML documents
If you select the Slide Show (p.283) photo album style in Step 2 of the Photo Album Wizard and 
enable the Add navigation links option, the Photo Album Wizard will generate an HTML document 
for each full-size image in the photo album. (This is necessary because of the navigation links the 
Slide Show style uses.) Normally, the wizard saves these generated documents in the same folder 
as the current document, and generates each document’s file name by appending ”_view” to the 
file name of the full-size image it displays. However, you can change either of these behaviors.

• To save the generated documents in a different folder, enter the desired folder path in the 
Save in box. You can use either an absolute, file-system path, such as 
’’C:\projects\current\photoviews”, or a relative path, such as ’’photoviews/”. (To select or 
create a folder, click the Browse button.)

• To change the file name suffix for the generated documents, enter the desired suffix in the box 
next to the suffix check box.

• To use a file name prefix instead of a suffix, deselect the suffix check box, select the prefix 
check box, and enter the desired prefix.

Caption options

The Captions tab exposes settings related to captions for the thumbnails generated by the Photo Album 
Wizard. Normally, the wizard does not create captions. If you want captions, select the Use captions check 
box.

Click the Position box and specify where you want the captions to be placed. Captions can be placed below, 
above, or to either side of each thumbnail.

The contents of the Caption info box determine what information about the corresponding full-size image 
each caption will contain. Each available piece of information is represented by a code, such as & f for the 
image’s file name. You can string any number of these codes together in the Caption info box to construct 
the caption. The available pieces of information and their codes are as follows:

&f image file name
&e image file name extension
&w image dimensions
&S image file size
&d image file creation date
&n image sequence number (the position of the image in the photo album)
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You can insert static text, such as spaces and punctuation marks, anywhere among the codes. One 
additional code, &b, inserts a line break in the caption.

For example, the comment definition:

Scf.Sce ScdScbScVj

will produce a caption like this:

mountains.jpg 12/23/2003 
1600x1200

Instead of typing the codes, you can click the ... button next to the Caption info box and select codes from 
the drop-down menu.

Related topics

About hyperlinks................................................................................................. p. 165
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A d d i n g  J a v a S c r i p t  e f f e c t s
In the beginning, the kinds of things Web authors could do inside a Web page were quite limited. There 
was content—the words and images that make up a document; and there was markup—the HTML tags that 
tell Web browsers how to present the content. As the Web grew and Web authors started wanting to do 
more with their pages, it became obvious that something was missing: a way to make Web pages dynamic.

A dynamic Web page is one that can change in some way after it is opened in a browser. For example, a 
dynamic page might have a menu in which clicking an item reveals a submenu of links that were 
previously hidden. There is no way to create such a menu with pure HTML, since HTML provides no way 
for authors to instruct browsers to change something in a document in response to user actions (such as 
clicking a menu item). What is needed is the ability to program the browser—to tell it something like, "If 
event Stakes place, then do 7." JavaScript provides this capability.

JavaScript is a scripting language designed for the Web. A script is a program that is stored as plain text 
and is "run" by a host program, such as a Web browser. Scripts written in JavaScript can be included 
directly within Web documents. When a browser that supports JavaScript opens a document containing a 
script, it loads the script into memory and executes it either right away or later, in response to some event. 
Although other Web-oriented scripting languages exist (most notably VB Script), JavaScript is the most 
widely supported by browsers and operating systems.

These are just a few of the kinds of dynamic effects that JavaScript makes possible in Web pages:

• Replacing an image with another image when the user moves the pointer over it
• Revealing or hiding a block of content when the user clicks a button
• Displaying a message (dialog) box when the user clicks a hyperlink
• Moving an image along a predefined path
• Causing an image or text to follow the pointer as the user moves the mouse

Fortunately, you don’t have to know how to program in JavaScript to be able to add useful scripts to your 
documents. Namo WebEditor provides three ways to add scripted effects without writing scripts.

The Script Wizard
The Script Wizard provides an easy, step-by-step interface for adding twenty of the most popular 
JavaScript effects to your page, from image rollovers to expanding menus.

Actions and events
Through the Actions window, you can "attach" any of eighty built-in scripts ("actions") to various 
kinds of page elements and specify the event that triggers the action. The built-in actions include 
applying an alpha effect, flipping a layer, inserting text, and many more.
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A timeline is a predefined sequence of movements and other changes (such as becoming hidden or 
visible) that apply to one or more layers (p.l 11) over a period of time. In other words, a timeline is 
a way to animate page content. Timelines are created in the Timeline window.

Timelines

In this section

Using the Script Wizard................................................................................p.289
Working with actions and events.................................................................p.304
Creating timelines.........................................................................................p.316

U s i n g  t h e  S c r i p t  W i z a r d

Use the Script Wizard to easily add a JavaScript effect to the current document. The wizard includes twenty 
effects, ranging from simple image rollovers to expanding, customizable navigation menus.

To start the Script Wizard, do one of the following:

• On the Insert menu, point to Script, and then click Script Wizard.

• On the Main Toolbar, click (Insert Script Wizard Effect).

In this section

Script Wizard: Text menu............................................................................ p.290
Script Wizard: Drop-down menu.................................................................p.291
Script Wizard: Expanding navigation menu................................................ p.291
Script Wizard: Background fade in/out........................................................p.292
Script Wizard: Wipe effect........................................................................... p.293
Script Wizard: Floating layer....................................................................... p.293
Script Wizard: Sliding layer......................................................................... p.294
Script Wizard: Mouse trails.......................................................................... p.295
Script Wizard: Marquee............................................................................... p.295
Script Wizard: Scrolling text in a box..........................................................p.296
Script Wizard: Scrolling text in the status bar............................................. p.297
Script Wizard: Image rollover...................................................................... p.297
Script Wizard: Animation effect..................................................................p.298
Script Wizard: Link button........................................................................... p.299
Script Wizard: Banner rotation....................................................................p.300
Script Wizard: Pop-up window....................................................................p.301
Script Wizard: Pop-up window cookie.........................................................p.301
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Script Wizard: Clock.................................................................................... p.302
Script Wizard: Access information...............................................................p.303
Script Wizard: Cell rollover.......................................................................... p.303

S c r i p t  W i z a r d :  T e x t  m e n u

Text Menu is a menu where you select and click a word to move to a specific address (URL). Text menu is 
created in a layer, and the size of the layer you see in the Edit window will be the size of the entire text 
menu. You can also apply effects to the Text Menu to make it dynamic.

To create a text menu

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select a Script, select Text Menu from the Menus and Navigation folder. Click Next.
3. In the Target layer drop-down menu, select the layer to insert the text menu in. You can either 

select an existing layer or create a new layer. To put the text menu it a new layer, select New from 
the Target layer drop-down menu.

4. To add a new item in the text menu, press Add.
5. In the Menu Item Settings dialog box, specify the Item name and the Link URL, then click OK.
6. Click Next. The Format Menu dialog box will appear.
7. Specify Background, Border color, Font, Font color, then click Next.
8. In the Menu Action dialog box, choose the Action type, and then click Finish.

W To modify the existing text menu, right-click the layer containing the text menu to open the shortcut 
menu. Select Script Wizard Properties. You can also change the order of the items in the Text Menu 
dialog box by clicking Up/Down

y  The text menu items are not visible in the Edit window, and only the layer will be shown. You can 
preview the text menu in the preview window.

y  In case you inserted the text menu in the existing layer, the background color set in the Layer
Properties dialog box will not be displayed. To change the text menu background, right-click to open 
the shortcut menu, and then select Script Wizard Properties.
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S c r i p t  W i z a r d :  D r o p - d o w n  m e n u

If you click an item in the drop-down menu, the relevant URL will open. The drop-down menu is very 
useful when there is not much space for menu items.

Create drop-down menu

To create drop-down menu, specify drop-down menu items and the target frame to open linked pages in.

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Drop-down menu in Menus and Navigation. Click Next.
3. To add a drop-down menu, press Add.
4. In the Menu Item Settings dialog box, specify Item name and Link URL, and then click OK.
5. Specify Target to show the linked pages in. If you don't use any frame, then set it for

'_self (default). If you want the linked pages to open in the new window, then set it for '_blank\
6. In Height, specify how many rows of the menu will be shown. If you set it for '1', then the drop­

down button will appear. If you set it for '2' or more, then the scrollbar will appear.

Error! Objects cannot be created from Error! Objects cannot be created from
editing field codes. editing field codes.

H eight = T  H eight = '2 '

7. Click Finish.

y  I f you double-click the drop-down menu, or Form Element Properties in the shortcut menu, then Drop­
down Menu Properties dialog box will appear. Here, you can add/remove/modify menu items..

3  In the Drop-down Menu Properties dialog box, you can also specify the style, and select Allow multiple 
selections.

S c r i p t  W i z a r d :  E x p a n d i n g  n a v i g a t i o n  m e n u

When you click an item of the main menu, it will spread out a sub-menu below it. If you click again, it will 
do the opposite. When you click an item of the sub-menu, it will open the relevant URL. To create an 
expanding navigation menu, specify the items of the expanding navigation menu, and set the style. After all 
this precedure, an expanding navigation menu will be inserted into the document.
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Create expanding navigation menu

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard in the 
standard toolbar.

2. In the list, select Expanding Navigation Menu in the Menus and Navigation. Click Next.
3. To add menu items to the menu, press Add.
4. In the Menu Item Settings dialog box, specify the Item name, Link URL and Target. Click OK.
5. To add sub-items, select an upper item, press Add, and then repeat step 4.
6. After settings, press Next.
7. Specify Font, Size and Color, and then press Finish. If you want the item to change its color when 

the mouse pointer is over it, select Use rollover effect and set the Highlight color.

9

9

To modify or remove the expanding navigation menu, open the shortcut menu, select Script Wizard 
Properties.

To change the position and size o f the expanding navigation menu, open the shortcut menu, select 
Layer Properties, and modify the position and size o f  the layer. Or you can directly adjust the handle 
o f the layer.

y  The expanding navigation menu is not visible in the Edit window. Only the layer which contains the 
menu is visible. You can preview the expanding navigation menu in the preview window or the web 
browser.

S c r i p t  W i z a r d :  B a c k g r o u n d  f a d e  i n / o u t

When you open the document or move to another one, the background color of the document will change.
You can also adjust the speed of the background color change. With this effect, you can give various
changes to the document.

Apply background fade in/out effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Background fade in/out in Transitions. Click Next.
3. In the Apply effect, decide when to change the background. Select Enable fade effect.
4. In the Remote site information, set the Starting/Ending color. In the Number of steps, decide how 

many steps will take to change the background color. The larger the number is, the more slowly 
and gently the effect will take place.

5. Press Finish.
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Remove background fade in/out effect

1. Open the document which the effect is being applied to in the Edit window.

2. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

3. In the list, select Background fade in/out in Transitions. Click Next.
4. Deselect Enable fade effect, and Press Finish.

S c r i p t  W i z a r d :  W i p e  e f f e c t

The screen or the layer will be wiped off a colored covering to reveal the contents. Using the Wipe effect, 
you can give a different feeling to the screen, or emphasize a layer. To apply Wipe effect to the layer, the 
layer must be inserted in advance.

Apply Wipe effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Wipe effect in Transitions. Click Next.
3. Decide whether you will apply the effect to the Entire window or the Layer. In case you select the 

Layer, select the layer to apply the effect to in the Layer box.
4. Looking at the result in the Preview, select the Wipe effect type and Wipe color.
5. Press Finish.

Remove Wipe effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard in the 
standard toolbar.

2. In the list, select Wipe effect in Transitions. Click Next.
3. Select No wipe effect.
4. Press Finish.

S c r i p t  W i z a r d :  F l o a t i n g  l a y e r

When the user scrolls the document in a browser, the affected layer floats at the same position. If you apply 
this effect to the layer which contains the menu, the visiters can save their efforts to scroll back to see the 
menu again. To apply Floating layer effect, the layer must be inserted in advance.

Adding JavaScript effects 293



Ñamo WebEditor 6 User Manual

Apply floating layer effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Floating layer in Layer Effects. Click Next.
3. Select the Target layer to apply floating effect to.
4. Specify where the layer should be floating at. If you click Float at current position, the position of 

the layer will be fixed at the current position.
5. Press Finish.

Remove floating layer effect

1. Select the layer which has the effect. Open the shortcut menu, and select Script Wizard Properties.
2. Select No floating layer, and then press Finish.

S c r i p t  W i z a r d :  S l i d i n g  l a y e r

When you place your mouse pointer on the edge of a hiding layer, the layer slides into the screen. You can 
put away the contents of the layer ouf of the screen, and withdraw it whenever you want. To apply the 
Sliding layer effect, the layer must be inserted in advance.

Apply sliding layer effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Sliding layer in Layer Effects. Click Next.
3. Select the Target layer, and specify Slide layer poisiton and Sliding speed. The larger the Sliding 

speed number is, the faster it slides in.
4. Press Finish.

W In case you select Original positionfor the Slide layer position, you must place the layer on the top or 
the left of the screen in advance.

Remove sliding effect

1. Select the layer which has the effect. Open the shortcut menu, and select Script Wizard Properties.
2. In the Sliding layer dialog box, select No sliding effect, and then press Finish.
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S c r i p t  W i z a r d :  M o u s e  t r a i l s

The layer trails the mouse pointer. In the preview window or web browser, the image or text inserted in the 
layer will trail the mouse pointer. To apply Mouse trail effect, you must insert the layer containing an 
image or text in advance.

Apply mouse trail effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Mouse trails in Layer Effects. Click Next.
3. From the drop-down menu, select the target layer (the layer must be inserted in advance). Press 

Add to add the layer to the list.
4. Press Finish.

9  If you add two or more layers to the list, several layers will trail the mouse pointer. You can change the 
order of the layer by pressing Up/Down, or you can remove the layer out of the list by pressing 
Remove.

Remove mouse trail effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Mouse trails in Layer Effects. Click Next.
3. Press Remove Script, and then Finish.

S c r i p t  W i z a r d :  M a r q u e e

The text or image in a layer will scroll in the way you like. The starting point of this effect will be where 
the layer is located at. Therefore to change the starting point, change the position of the layer. To apply the 
marquee effect, you must insert the layer containing an image or text in advance.

Apply marquee effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the list, select Marquee in the Scrollers. Click Next.
3. Select the Target layer, and then specify the Scroll direction.
4. Specify the scrolling type in the Behavior.
5. Specify the scrolling speed in the Scroll stride. The larger the number is the faster it will scroll.
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6. Specify the repeat interval of scrolling in the Scroll delay.
7. Specify the length of the scrolling in the Visible length. To adjust the visible lengh of scrolling to

DQ
be identical with the size of the layer, click Fit to Layer

8. Specify how many times the scrolling will repeat in the Repetitions.
9. Click Finish.

9  When you select Bidirectional in the Behavior, you should set the Visible length bigger than the layer 
size. In case you select Unidirectional scroll, if you set the Repetitions as it will repeat infinitely. In 
case you select Sequential scroll, the scrolling object will disappear when it finishes repeating as 
specified.

Remove marquee effect

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard &  in the 
standard toolbar.

2. In the dialog box, select No effect in the Scroll direction.
3. Click Finish.

S c r i p t  W i z a r d :  S c r o l l i n g  t e x t  in  a  b o x

The scrolling text moves from right to left within an one-line text box repeatedly. The scrolling text keeps
moving by specific periods.

Insert a scrolling text box

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select Script, select Scrolling Text in a Box from the Scrollers folder, then click Next.
3. Specify Form name and Form field name. You can use only the English alphabet, digits and 

underscores (_) for the name. The name must start with an alphabet.
4. Enter text in the Scrolling text, then specify Scrolling period. The larger number the Scrolling period 

has, the slower the scrolling text moves.
5. Click Finish.

9  To adjust the length of the text box that contains the scrolling text, select the text box, then drag the left
or right handle.
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1. Double-click the one-line text box, or right-click to open the shortcut menu, and then select 
Scrolling Text in a Box.

2. Modify the Scrolling text, and Click Finish.

M o d i f y  s c r o l l i n g  t e x t  b o x

S c r i p t  W i z a r d :  S c r o l l i n g  t e x t  i n  t h e  s t a t u s  b a r

The scrolling text moves from right to left on the status bar of the web browser repeatedly.

Insert scrolling text in the status bar

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard from 
the standard toolbar.

2. In the Select Script, select Scrolling text in the status bar from the Scrollers folder, then click Next.
3. Fill in Text 1, Text 2 and Text 3. The inserted texts will move on the status bar.
4. Click Finish.

Remove the effect

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select Script, select Scrolling text in the status bar from the Scrollers folder, then click Next.
3. Press Remove Script. Click Finish.

S c r i p t  W i z a r d :  I m a g e  r o l l o v e r

When you bring the mouse pointer over a rollover image, it will be replaced by another image. If you move 
the mouse pointer off the image, the first image will be restored. Therefore, you need two images to make a 
rollover image.

Create an image rollover

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select Script, select Image Rollover from the Rollover Effects folder, then click Next.
3. Enter the Name of the rollover image. You can use only the English alphabet and digits for the 

Name.
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4. Set First image path and Second image path respectively. You can preview the rollover effect in 
the Preview window.

5. Click Finish.

You can also insert a hyperlink in the rollover image in the Image Rollover dialog box. Press Hyperlink 
to open the Hyperlink Properties dialog box, and then set the hyperlink to the rollover image.

Modify an image rollover

1. Double-click the rollover image, or right-click to open the shortcut menu, and then select Image 
Properties.

2. Select the Rollover tab.
3. Modify Second image path, then click OK.

Remove an image rollover

1. Double-click the rollover image, or right-click to open the shortcut menu, and then select Image 
Properties.

2. Select the Rollover tab. Press Remove Rollover.
3. Click OK.

S c r i p t  W i z a r d :  A n i m a t i o n  e f f e c t

Images, texts and layers can have animation effects. When you don't use the layer, the whole paragraph 
where the cursor is placed will have the effect.

Apply animation effect

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select Script, select Animation effect from the Other folder, then click Next.
3. Enter Animation layer name. The name must begin with an alphabet, and cannot have a space in 

itself.
4. Looking at the Preview window, specify Starting position and Trace type.
5. Specify Starting condition, Total steps and Delay. The larger number the Total steps has, the 

slower the animation will be.
6. In the Internet Explorer section, specify Zoom text. If you select Word by word, the word will 

move individually. This effect is supported by Internet Explorer.
7. Click OK.
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ilO Beside the layer which has the animation effect, the Script Wizard [§] special tag mark will appear. 

bD The animation will stop where the layer is located at currently.

GD The whole paragraph where the cursor is placed will have the effect. Therefore, to apply animation 
effect to a certain part only, you have to use the layer. Even when you break the line by pressing Shift- 
Enter, the new line still belongs to the paragraph, therefore will be affected by the effect.

Remove animation effect

1. Select the layer which has the animation effect, and right-click to open the shortcut menu, and then 
select Script Wizard Properties.

2. Select No animation. Click Finish.

9  In case it is not the layer that you want to remove the effect from, but text or an image itself do step 1-
2 o f "Apply animation effects ", and then select No animation

O  The animation effect works properly in Internet Explorer 4.0 (and higher version) and Netscape 4.0 
(and higher version).

S c r i p t  W i z a r d :  L in k  b u t t o n

When you click a Link Button, you will move to a previous/next page or a specific URL. You can simply 
insert "Forward/Back” buttons in the web document.

Create a link button

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard from 
the standard toolbar.

2. In the Select a script, select Link Button from the Other folder. Click Next.
3. Enter Button label.
4. Specify the Destination(URL/Forward/Back). You can insert "Forward/Back" buttons as those of 

the web browsers. In case you select URL, you can select the target frame.
5. Click Finish.

9  In case the linked page has no frame, set the target frame value as '_self.

9  You can set the style o f the link button. Right-click the link button to open the shortcut menu, select 
Form Element Properties, and then click Style.
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Modify a link button

1. Double-click the link button. Or right-click the link button to open the shortcut menu, and select 
Link Button.

2. In the Link Button dialog box, modify Button label and Destination, and then click Finish.

S c r i p t  W i z a r d :  B a n n e r  r o t a t i o n

A banner can rotate images. The banner displays the title of the document or advertises a website. When
you click the banner, you will move to relevant page. To make a banner rotation, two or more images are
needed.

Create a banner rotation

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select a Script, select Banner Rotation from the Other folder. Click Next
3. Press Add. In the Banner Rotation Item Settings dialog box, specify the path of the Image and 

Link URL of the page to link. If needed, set the target frame, and click OK.
4. To add more images, repeat Step 3.
5. Specify Rotation period of the banner rotation. The larger the number is, the later the next image 

will appear.
6. Click Finish.

9  In case the linked page has no frame, set the target frame value as self .

Modify a banner rotation

1. Select the image which has the rotation effect. In the shortcut menu, select Script Wizard 
Properties.

2. Select the item to modify in the list. Click Modify. By clicking Up/Down, you can change the 
rotation order. You click Remove to remove the item.

3. Click Finish.

Remove the rotation effect

1. Select the image which has the rotation effect. In the shortcut menu, select Script Wizard 
Properties.

2. Press Remove Script. Click Finish.
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S c r i p t  W i z a r d :  P o p - u p  w i n d o w

When you open a document, or click an image, a new window may pop up. Usually, these pop-up windows 
are used to show an announcement when you open the first page.

Insert a pop-up window

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard ^  from 
the standard toolbar.

2. In the Select a Script, select Pop-Up Window from the Other folder. Click Next.
3. Specify Target window name. You can use only the English alphabet, digits and underscores (_) 

for the name. The name must begin with an alphabet.
4. Enter URL for the pop-up window.
5. Specify the Position and Size of the pop-up window.
6. In the Options section, select the item you want (Show toolbar, Show menu, Resizable, Show 

scroll bar, Show status bar).
7. Click Finish. Check if the pop-up window works properly in the preview window.

Remove the pop-up window

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.

2. In the Select Script, select Pop-Up Window from the Other folder. Click Next.
3. Press Remove Script, and click Finish.

Related topics

Script Wizard: Pop-up window cookie......................................................... p.301

S c r i p t  W i z a r d :  P o p - u p  w i n d o w  c o o k i e

A pop-up window can perform 'Do not open this window again today' function by using ’’Cookie". If you 
apply the pop-up window control Cookie, a form field and a check box will be inserted where the cursor is 
located. If the visitor select the check box in the web browser, the pop-up window will not appear again for 
a day.

Apply Cookie

1. In the Edit window, open the document being used for the pop-up window.

2. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard &  from 
the standard toolbar.
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9

3. In the Select a Script, select Pop-Up Window Cookie from the Other folder. Click Next.
4. In the Window name field, enter the name of the pop-up window to apply Cookie to. The name 

should be identical with the one you entered in the Script Wizard Pop-Up Window.
5. In the Home URL field, enter the relative URL of 'index.html' of the website. For example, You 

may set a pop-up window (new.html) to appear when the visitor opens 'index.html’, and publish 
those two documents to the website, 'http://www.namo.com'. If the absolute URL of'index.html1 is 
'http://www.namo.com/index.htmr, then enter 7\ If the absolute URL of'index.html' is 
'http://www.namo.com/bbs/index.htmr, then enter ’/bbs' in the Home URL field.

6. Click Finish to insert the check box where the cursor is located. Type a sentence, 'Do not open this 
window today', beside the check box.

Save the document, and check if  the function works properly. When you select the check box, the pop
up window will disappear

El To see the result, you must publish those documents first.

Related topics

Script Wizard: Pop-up window.....................................................................p.301

S c r i p t  W i z a r d :  C l o c k

You can create a clock that indicates current time and date. The clock appears as text and digits in an one- 
line text box.

Create a clock

1. On the Insert menu, point to Script, and then click Script Wizard, or select Script Wizard from 
the standard toolbar.

2. In the Select Script, select Clock from the Other folder, then click Next.
3. Specify Form name and Form field name. You can use only the English alphabet, digits and 

underscores (_) for the name. The name must start with an alphabet.
4. In the Time format list, select the kind you want.
5. Click Finish. You can preview the clock in the preview window.

9  To adjust the length o f  the text box that contains the clock, select the text box, then drag the left or right 
handle from side to side. To modify the name or the kind o f the clock, right-click to open the shortcut 
menu, and then select Clock.
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The time o f the clock is based on the system time set by the computer. Therefore, if  you change the 
system time, the clock time will also be changed. For this reason, the time o f the clock displayed in the 
web browser may differ depending on the computer.

S c r i p t  W i z a r d :  A c c e s s  i n f o r m a t i o n

When the visitor comes to the website, the script asks the visitor’s name, or show last modification date and 
time, the visitors IP address, host name, etc. In case of asking the visitor's name, the script shows the 
prompt window where the visitor enter his/her name. Those information will appear in the one-line text box 
in the document.

Insert Access information

1. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard in the 
standard toolbar.

2. In the list, select Acess information in Other, and then click Next.
3. Specify the Form name and Form field name. The name can consist of English alphabets, numbers 

and underscores (_). The name must begin with the English alphabet.
4. Select Information type.
5. Click Finish.

El To modify the access information, select Access information from the shortcut menu. 

Visitor's IP address and Host name appears only in Netscape.

S c r i p t  W i z a r d :  C e l l  r o l l o v e r

If you bring the mouse pointer over a cell, the cell color and style will change. If you bring the mouse 
pointer off the cell, the original appearance will be restored. In case you create a layout for a document by 
using the layout box, you can easily apply the rollover effect to the area you want to. To apply the rollover 
effect to a cell, you must select the cell first.

Apply the rollover effect to a table cell

1. Place your cursor inside the cell to apply the rollover effect to.

2. On the Insert menu, point to Script, and then click Script Wizard, or click Script Wizard ^  in the 
standard toolbar.

3. In the list, select Cell rollover in Rollover Effects. Click Next.
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4. Press Add to open Style Name dialog box, and enter the style name in the Name field.
5. In the Style dialog box, specify the cell style such as font, background color, style, etc.
6. From the Rollover style list, select the new style name, and then preview the result in the Preview 

window.
7. Click Finish.

9  You can preview cell rollover effect in the preview window or in the web browser.

9  You can also modify the effect by using the shortcut menu. In the shortcut menu, select Cell Properties, 
and then Script Wizard

Modify the table cell rollover effect

1. In the shortcut menu, select Cell Properties.
2. Press Script Wizard.
3. Press Add to add a new rollover style, or Edit to edit an existing rollover style. Click Finish.

9  In the Rollover styles list, i f  you select (none), the rollover effect of the relevant cell will be removed.

W o r k i n g  w i t h  a c t i o n s  a n d  e v e n t s

An action is a script that is executed as the result of some event, such as the user's clicking an image or the 
document's being opened by a browser. Actions are "attached” to events that occur with respect to certain 
kinds of page elements. For example, an action that reveals a hidden paragraph might be attached to a 
"mouse over" event on an image: when a user moves the pointer over the image, the action is executed and 
the hidden paragraph is revealed.

You can attach more than one action to the same event on a given element. For example, clicking an image 
can reveal a hidden paragraph and set a timeline (p.316) in motion, at the same time. Similarly, you can 
attach actions to multiple events on an element. For example, the popular "rollover” effect involves having 
one action occur when the mouse pointer enters the boundaries of an element, and another, opposing action 
occur when the pointer exits those boundaries.

Namo WebEditor includes over 80 built-in actions (p.306) and supports 17 event types (p.305).

The Actions panel is where you attach actions to events on page elements (or the whole document). If any 
actions are already associated with the current element, they are listed in the window. To show the Actions 
panel: on the View menu, point to Panels, and click Actions (or press Alt+7).
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List of supported events..................................................................................... p.305
List of built-in actions............................................................. ...........................p.306
Attaching actions to events on elements.......................................................... p.314
Attaching actions to events on a document..................................................... p.315
Using the Script Manager................................................................................... p.316

I n  t h i s  s e c t i o n

L i s t  o f  s u p p o r t e d  e v e n t s

Event Occurs when... [Applies to
OnClick the user clicks an element any element
OnDblClick the user double-clicks an element any element
OnMouseDown the user presses the mouse button while the pointer is over an 

element (but before she releases the mouse button)
any element

OnMouseUp the user releases the mouse button while the pointer is over an 
element

any element

OnMouseOver the user moves the pointer into an element's boundaries any element
OnMouseOut the user moves the pointer outside an element's boundaries any element
OnFocus a form field receives focus (becomes the target of key presses) 

or the document window is made active
form fields, 
documents

OnBlur a form field loses focus or the document window is made 
inactive

form fields, 
documents

OnSelect the user selects text in a form field text form fields
OnChange the user edits text in a form field or changes the selection in a 

form menu
text form fields, 
form menus

OnKeyPress the user presses a key while the insertion point is in a form field 
or a hyperlink has focus

text form fields, 
hyperlinks

OnKeyDown the user completes the down stroke of a key while the insertion 
point is in a form field or a hyperlink has focus

text form fields, 
hyperlinks

OnKeyUp the user completes the up stroke of a key while the insertion 
point is in a form field or a hyperlink has focus

text form fields, 
hyperlinks

OnLoad the browser finishes loading the document or an image documents, images
OnUnload the user leaves the document documents
OnAbort the user cancels loading the document or an image documents, images
On Error the browser encounters an error while loading the document or 

an image
documents, images

On Resize the user resizes the document window documents
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Event Occurs when...
OnScroll the user scrolls the document window
OnFrameM the nth frame of a timeline is reached

Applies to
documents 
timeline frames

Related topics
List of built-in actions.......................................................................... p.306
Working with actions and events...........................................................p.304

List o f built-in actions

Image-related actions

Action
Preload Image 

Replace Image 

Resize Image 

Restore Image 

Set Background 
Image

Description
Preloads an image file that is 
not initially displayed
Replaces a named image with 
another image
Changes the display size of a 
named image
Restores an original image after 
being replaced
Sets or changes the document's 
background image

Notes
Use to avoid a delay when a script inserts an 
image after the document has been loaded.
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Action Description Notes
Clip Layer Restricts the visible portion of Takes four length parameters in pixel units, measured

a layer from the initial top left comer of the layer:

• Top: the offset of the top edge of the visible 
portion of the layer from its initial top edge

• Left: the offset of the left edge of the visible 
portion of the layer from its initial left edge

• Right: the offset of the right edge of the visible 
portion of the layer from its initial left edge

• Bottom: the offset of the bottom edge of the 
visible portion of the layer from its initial top 
edge

Layer-related actions

Glide Layer

Hide Layer 
Move Layer by

Move Layer to

Replace 
Contents of 
Layer
Resize Layer

Set
Background 
Color of Layer
Set
Background 
Image of Layer

Causes a layer to "glide” from 
a starting position to a final 
position

Hides a layer
Moves a layer by the 
specified number of pixels 
from its initial position, 
horizontally and/or vertically
Moves a layer to the specified 
position, measured in pixels 
from the top left comer of the 
page
Replaces the initial contents 
of a layer with the specified 
text
Changes the size of a layer

Sets or changes a layer's 
background color

Sets or changes a layer's 
background image

The smaller the value of the Speed parameter, the 
faster the motion (0 is fastest). This value is relative; 
the actual speed depends on the browser and the 
computer. The Step parameter means the number of 
pixels the layer moves with each step.

Negative values cause the layer to be moved toward 
the left and/or top.

Negative values are allowed.

The replacement contents must be text only.

If the specified size would make the layer too small to 
fit its contents, the layer will be auto-sized to fit its 
contents.
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Action Description
Set Z-lndex Sets or changes a layer's Z- 

index (p. 115)
Show Layer Reveals a hidden layer
Show Layer as Causes a layer containing the
Tooltip specified text to "pop up" at

the specified offset from the 
mouse pointer’s location

Wipe Layer Causes a layer to seem to 
"grow" from the specified 
starting coordinates to the 
specified ending coordinates

Notes

Can be used to create a "tooltip" for a page element.
Requires an existing layer, which can be initially
empty and hidden.

Takes eight length parameters in pixel units,
measured from the initial top left comer of the layer:

• Starting top: the offset of the top edge of the 
visible portion of the layer from its initial top 
edge at the beginning of the wipe

• Starting left: the offset of the left edge of the 
visible portion of the layer from its initial left 
edge at the beginning of the wipe

• Starting right: the offset of the right edge of the 
visible portion of the layer from its initial left 
edge at the beginning of the wipe

• Starting bottom: the offset of the bottom edge of 
the visible portion of the layer from its initial top 
edge at the beginning of the wipe

• Ending top: the offset of the top edge of the 
visible portion of the layer from its initial top 
edge at the end of the wipe

• Ending left: the offset of the left edge of the 
visible portion of the layer from its initial left 
edge at the end of the wipe

• Ending right: the offset of the right edge of the 
visible portion of the layer from its initial left 
edge at the end of the wipe

• Ending bottom: the offset of the bottom edge of 
the visible portion of the layer from its initial top 
edge at the end of the wipe

Form-related actions

Action Description Notes
Move Focus to Moves the focus to the specified field Generally used with an

onBlur event on another field
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Action
Reset Form Field
Select Text in 
Form Field
Validate E-mail 
Address

Validate Field 
Contains Number

Description
Clears the contents of the specified text field 
Selects the entire contents of the specified text field

Displays a message box with the specified message 
if the specified text field does not contain a valid e- 
mail address
Displays a message box with the specified message 
if the specified text field does not contain a number

Validate Field Not 
Empty

Displays a message box with the specified message 
if the specified text field is empty

Validate Length Displays a message box with the specified message
Not Exceeded

Validate No Field 
Empty

if the contents of the specified text field exceed the 
specified length
Displays a message box with the specified message 
if any text field in the specified form is empty 
(including hidden fields)

Document/window-related actions 

Action Description
Close Window Causes the browser to close the current window

Disable Shortcut 
Menu

Expand Window

Flash Message in 
Status Bar
Fly Message in 
Status Bar
Move Window in 
Circles

Open Two URLs

Disables the shortcut (right-click) menu for the 
current window and displays a message box with the 
specified text
Causes the window to grow from the specified 
starting size to the specified final size, from the center 
out
Displays a flashing message in the status bar

Displays a message in the status bar in which 
characters "fly” in, one at a time
Causes the window to move in circles the specified 
number of times and then come to rest at the specified 
offset from the top left comer of the screen
Simultaneously opens the first URL in the current 
window and the second URL in a new window

Notes

Generally used with an 
onBlur event on the specified 
text field
Generally used with an 
onBlur event on the specified 
text field
Generally used with an 
onBlur event on the specified 
text field
Generally used with an 
onBlur event on the specified 
text field
Generally used with an 
onClick event on a submit 
button

Notes
The browser may ask the 
user to confirm closing the 
window.
The message box is not 
optional.

The final size must be 
larger than the starting 
size.
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[Action
Open URL After 
Delay
Open URL in Full­
screen Window

Open URL in New 
Window
Open URL with 
Message

Open URL
Periodically 
Refresh Window
Print Document
Refresh Window
Resize Window 
by

Resize Window to

[Description
Opens the specified URL in the current window after 
the specified delay time
Causes the browser to open a URL in a new, full­
screen window without a title bar, menu bar, toolbars, 
or status bar
Opens the specified URL in a new window with the 
specified options
Opens the specified URL in the current window after 
the user closes a message box containing the specified 
text
Opens the specified URL in the current window
Reloads the current document at the specified 
intervals
Opens the Print dialog box for the current document
Reloads the current document once
Reduces or enlarges the current window by the 
specified number of pixels, horizontally and/or 
vertically
Resizes the current window to the specified size

Scroll Window

Set Background 
Color
Shake Window

Show Last
Update
Timestamp
Show Message 
Box
Show Message in 
New Window
Show Message in 
Status Bar
Test Browser

Scrolls the window up or down by the specified 
number of pixels
Sets or changes the document's background color

Causes the window to "shake" (move rapidly up, 
down, left, and right) the specified number of times
Replaces the contents of a layer with the last update 
date and time of the current document

Opens a message window (dialog box) containing the 
specified text
Opens a new window displaying the specified text 
with the specified options
Displays a static message in the status bar

Causes the browser to load one of two specified URLs 
depending on whether the browser is Internet 
Explorer or Netscape

[Notes

Use with caution; users 
may have difficulty 
closing the new window.

Both horizontal and 
vertical size must be 
specified.

Requires an existing layer, 
which can be initially 
empty and hidden.
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Action
Test for Plugin

Test Operating 
System

Test Screen 
Resolution
Wipe Message in 
Status Bar

Causes the browser to load one of two specified URLs 
depending on whether the specified plugin is installed
Causes the browser to load one of three specified 
URLs depending on whether the user’s operating 
system is Windows, Mac OS, or Linux
Causes the browser to load one of two specified URLs 
depending on the user’s screen resolution
Displays a message in the status bar that ’’wipes" back 
and forth repeatedly

[Description Notes

Frame-related actions

Action
Break Out of Frame

Open URL in Whole 
Window
Open URLs in Three 
Frames
Open URLs in Two 
Frames

[Description
Causes the current document, if it is in a frame, to take over the 
whole window
Opens the specified URL in the whole window, replacing any 
frameset
Opens a specified URL in each of three specified frames 

Opens a specified URL in each of two specified frames

jNotes
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Visual effects

Action
Apply Alpha 
Effect

Description
Applies an alpha transparency 
gradient to the contents of a layer

Notes
Takes six numerical parameters:

Start opacity: the opacity level at the 
beginning of the gradient 
Finish opacity: the opacity level at the end of 
the gradient
Start X: the distance in pixels from the left 
edge of the layer to the beginning of the 
gradient
Start Y: the distance in pixels from the top 
edge of the layer to the beginning of the 
gradient
Finish X: the distance in pixels from the left 
edge of the layer to the end of the gradient 
Finish Y: the distance in pixels from the top 
edge of the layer to the end of the gradient

Apply Blur Applies a blur effect to the contents
Effect of a layer

Parameters:

• Blur radius: higher values increase the 
"blurriness” of the effect

• Shadow opacity: specifies the degree of 
opacity or translucency of the layer contents 
when the Make shadow option is selected

Apply Glow 
Effect
Apply Shadow

Apply Hard 
Shadow
Apply Mask 
Effect

Apply Motion 
Blur

Makes the contents of a layer 
appear to "glow"
Applies a soft-edged shadow to the 
contents of a layer
Applies a hard-edged shadow to 
the contents of a layer
Fills transparent areas in a layer 
with the specified color and makes 
opaque areas transparent
Applies a "motion blur" effect to 
the contents of a layer

If the Make shadow option is selected, all 
opaque parts of the layer will be changed to a 
medium gray tone.
The Strength parameter controls the size of the 
glow.

The Strength parameter controls the length of the 
"trails".
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Apply Wave Applies a sine wave distortion to 
Effect the contents of a layer along the

vertical axis

Action Description Notes
Parameters:

Cycles: the number of cycles in the wave 
Phase: the point in the cycle at which the 
wave begins
Amplitude: the horizontal difference 
between the peaks and troughs of the wave, 
in pixels
Lighting strength: the difference in 
brightness between the peaks and troughs of 
the wave; set to ”0” to leave original colors 
unmodified

Apply X-ray 
Effect
Change Colors 
to Grays
Flip Horizontal

Flip Vertical

Invert Colors

Make Color 
Transparent
Remove Visual 
Effect

If you select the Combine option, the wave- 
distorted contents will be superimposed on the 
original contents instead of replacing them.

Converts the contents of a layer to 
a negative black & white image
Replaces all colors in the contents 
of a layer with gray tones
Flips the contents of a layer 
horizontally
Flips the contents of a layer 
vertically
Changes each color in the contents 
of a layer to its inverse
Makes one color in the contents of 
a layer transparent
Restores the contents of a layer to 
their original appearance after a 
visual effect has been applied

El The visual effect actions all require that the affected content be contained in an existing layer.

p i The visual effect actions require Internet Explorer 5.5 or later.
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Other actions

jAction Description Notes
Call Causes the specified Use this action to run your own custom script functions.
Function JavaScript function to be 

executed
Enable Enables Netscape’s <blink>
BLINK Tag tag to work in Internet

Explorer, causing contents 
to blink.

Hide H ides the elem ent w hose The elem ent to be hidden must have an ID attribute (p.216).
Element ID you  specify

Jump to Causes the specified The Max repetitions parameter specifies the maximum
Timeline timeline to jump to the number of times the same event will trigger this action. This
Frame specified frame can be especially useful when the event that triggers this

action is an onFrame event on a frame after the specified 
’’jump to’’ frame.

Pause Pauses the video or audio in
WMP the specified Windows
Object Media Player object
Play Starts the specified timeline 
Timeline
Play WMP Plays the video or audio in
Object the specified Windows 

Media Player object
Show R eveals the hidden elem ent The elem ent to be revealed must have an ID attribute
Element w hose ID you  specify  (p.216).

Stop Stops the specified timeline
Timeline if it is playing
Stop WMP Stops the video or audio in 
Object the specified Windows

Media Player object

Related topics
List of supported events........................................................................ p.305
Working with actions and events........................................................... p.304

Attaching actions to events on elements

You can attach an action to an event involving any of the following types of elements:
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•  hyperlinks

•  bookmarks

•  im ages

•  layers

•  form controls

To attach an action to an event on an element
1. Select the desired elem ent. ( I f  the elem ent is a hyperlink or bookmark, you  can just p lace the 

insertion point within it.)

2. On the Actions panel, c lick  ù(Add).
3. In the Action Properties dialog box, select the desired Event and Action.

4. Specify the Parameters for the selected  action.

5. C lick OK.

9  Although you cannot directly attach an action to an ordinary piece of text, you can create a bookmark 
(p. 179) on the desired text and attach an action to the bookmark.

Related topics
Attaching actions to events on a document.............................................p.315
Attaching actions to a timeline.............................................................. p.321

Attaching actions to events on a document

You can attach an action to an event involving a document as a whole, such as the document's being loaded 
by a browser.

To attach an action to an event on the current document
1. Make sure no element is selected and the insertion point is not within a hyperlink or bookmark.
2. On the Actions panel, click Add ü .
3. In the Action Properties dialog box, select the desired Event and Action.
4. Specify the Parameters for the selected action.
5. Click OK.

Related topics
Attaching actions to events on elements................................................ p.314
Attaching actions to a timeline.............................................................. p.321
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Using the Script Manager

The Script Manager provides a convenient way to add, remove, or modify any action attached to any 
element in the current document. You can also use it to see which elements have Script Wizard effects 
associated with them, and to remove those effects. To open the Script Manager window, on the Window 
menu, click Script Manager.

The left pane of the window displays a hierarchical list of all the elements in the current document to which 
actions or Script Wizard effects can be attached, starting with the document itself. Note that a parent 
element, such as a form, may appear in the list even though you cannot attach actions to it; it is there 
because one or more of its child elements can have actions attached.

If an element in the list actually has an attached action, a small red circle appears on the top right comer of 
its icon. If it is associated with a Script Wizard effect, a small red letter "S" appears on the bottom right 
comer of its icon.

The top and bottom panes on the right side of the window list the actions and Script Wizard effects, 
respectively, that are attached to the element currently selected in the element list.

You can attach a new action to an element in the element list by selecting it and clicking Add. This has the 
same effect as selecting the element in the document window and clicking Add on the Actions panel. 
Similarly, you can edit or remove an attached action by selecting it in the action list and clicking Modify or 
Remove.

Finally, you can remove an attached Script Wizard effect by selecting it in the effect list and clicking 
Remove.

C r e a t i n g  t i m e l i n e s

A n important aspect o f  layers (p.l 11) is that you can position them  freely anywhere on a page. U sing  
JavaScript, it is even  p ossib le to change the position of a layer after the page has been opened in a browser. 
T im elines take advantage o f  this fact. B y  creating a timeline, you  describe a sequence o f  positional changes, 
affecting one or more layers, that the browser w ill execute at som e point after loading the page. Y ou can set 
a tim eline to start autom atically w hen  the browser has fin ished loading the page, or the tim eline can be 
started by  a script action (p.304) attached to som e event (such as clicking a specific im age).

A timeline consists of a sequence offrames, like the frames of a movie. When a browser "plays" a timeline, 
it steps through each frame from first to last, one after another, at a certain speed. Each frame describes the 
state of one or more layers at a point in time. The state of a layer includes its position, size, visibility, and 
z-index.
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A timeline contains one or more sprites arranged in time, like notes in a musical score. Each sprite controls 
the motion or changing state of one layer across a certain number of frames.

Tim eline ; V« • :'v IC7|
timeünel ▼ 14 i  |T  

1 5 10 15
A

В ► |15 fp§ [7 £u*o start 

20 25 30 35 40 ^

2 p  layer2-----
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An example timeline 'with four sprites

The example timeline pictured above contains four sprites (the lavender bars), named after the layers they 
control. As you can see, sprites can overlap—meaning that two or more layers are in motion or changing 
state at the same time. Two sprites can control the same layer, but then they cannot overlap.

Each sprite has at least two keyframes—frames at which the position/state of the associated layer is 
explicitly specified by you. Keyframes are indicated by large white dots on the sprite. The first and last 
frames of a sprite must be keyframes. You can add more keyframes anywhere in the sprite. In the frames 
between keyframes, the position/state of the layer is interpolated by Namo WebEditor. This fact lets you 
create a smooth animation by defining the position/state of a layer at just two points in time and letting 
Namo WebEditor take care of the in-between frames.

In addition to controlling the position/state o f  one or more layers over time, a tim eline can trigger actions 
(p.304) at specific frames. For exam ple, when a tim eline reaches the twentieth frame, it can trigger an action 
that causes the browser to start another tim eline or reveal a hidden elem ent.

In this section
Creating and editing timelines............................................................... p.318
Starting and stopping timelines............................................................. p.320
Attaching actions to a timeline.............................................................. p.321

Related topics
Using layers........................................................................................p.l 11
Working with actions and events.......................................................... p.304
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Creating and editing timelines

Creating a timeline involves creating and arranging sprites on the Timeline panel. Each sprite controls the 
motion and/or changing state of one layer across a certain number of frames of the timeline.

There are two basic methods of creating a sprite. We can call these the ’’drag method" and the "record 
method". Which one you should use depends on the nature of the animation you want to create:

• When you want a layer to move in straight lines between relatively few keyframes, or the motions 
of the layer must be tightly controlled, or you want the layer to not move at all but other aspects of 
its state to change over time, use the drag method.

• When you want a layer to move fluidly through a complex path, or you want to create a sprite 
quickly and the exact position of the layer at any given time is not important, use the record 
method.

To create a sprite with the "drag" method
1. If the Timeline panel is not visible, press Alt+4 to reveal it.
2. Select the layer you want to control by clicking its outline.
3. Drag the layer by its handle into the Timeline panel. As the mouse pointer enters the panel, a 

sprite (lavender bar) should appear on the timeline. Release the mouse button when the sprite is in 
the desired position.

4. Click the initial keyframe on the sprite (the white dot at the sprite’s left end).
5. In the document window, drag the layer to the position you want it to be in at the beginning of the 

animation. If necessary, double-click the layer's handle or outline and specify the exact position 
and other properties you want the layer to have at the beginning of the animation.

6. Click the final keyframe on the sprite (the white dot at the sprite's right end).
7. In the document window, drag the layer to the position you want it to be in at the end of the 

animation. When you release the mouse button, you should see a straight black line in the 
document window running between the layer's initial position and its final position, indicating the 
path it will take when the sprite plays. If necessary, double-click the layer's handle or outline and 
specify the exact position and other properties you want the layer to have at the end of the 
animation.

8. If necessary, create additional keyframes (p.319) as desired and adjust (p.319) the layer's 
position/state at each, as described below.

9. To preview the sprite, make sure the Auto start check box on the Timeline panel is selected, and 
then switch to Preview mode.

To create a sprite with the "record" method
1. If the Timeline panel is not visible, press Alt+4 to reveal it.
2. Select the layer you want to control by clicking its outline.
3. Right-click inside the Timeline panel and click Record Path of Layer.
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4. In the document window, drag the layer through the path you want it to take, moving the mouse as 
smoothly as possible. As you drag, a series of asterisks will appear behind the mouse pointer, 
tracing its motion. When you release the mouse button, a black line representing the recorded path 
of the layer will appear in the document window, and a finished sprite will appear on the timeline.

5. If necessary, adjust (p.319) the layer's position at specific keyframes or add/remove keyframes 
(p.319), as described below.

6. To preview the sprite, make sure the Auto start check box on the Timeline panel is selected, and 
then switch to Preview mode.

To adjust a layer's position/state at a point on the timeline
1. Click the keyframe at which you want to adjust the layer's position and/or state. (Position and state 

can only be specified at a keyframe. If there is no keyframe at the point on the timeline where you 
want to specify these properties, you must add a keyframe (p.319).)

2. Do any of the following, depending on what property of the layer you want to adjust:
o To adjust the layer's position, first drag the layer to roughly the desired position. Then, if 

necessary, fine-tune the position by using the arrow keys on your keyboard to move the 
layer one pixel at a time, or by double-clicking the layer's handle and specifying the exact 
position relative to the document's top left comer, in pixels.

o To adjust the layer's size, drag any of its resize handles. If necessary, double-click the 
layer's handle and specify its exact width and height in pixels.

o To change the layer's visibility, z-index, or other properties, double-click the layer's 
handle.

Adding, moving, and removing keyframes

• To add a keyframe, click the point on the sprite where you want the new keyframe, and then right- 
click anywhere in the panel and click Insert Keyframe. Then, drag the layer to the desired position 
and/or set the layer's properties as desired for that point in the timeline.

• To move a keyframe, click the white dot representing it on the sprite and drag it left or right. The 
position of a keyframe determines when the layer reaches the position or state defined for that 
keyframe. Moving the beginning or ending keyframe of a sprite makes the sprite longer or shorter. 
You cannot move a keyframe beyond an adjacent keyframe.

• To remove a keyframe, click the white dot representing it, and then right-click anywhere in the 
panel and click Remove Keyframe. You cannot remove the beginning or ending keyframes of a 
sprite.

Moving sprites in time and space

• To move a sprite in time, so that it starts at a different point in the timeline, drag it left or right on 
the timeline.

• You can also move a sprite to a different row on the timeline. Sprites on different rows can 
overlap, while sprites on the same row cannot. (However, note that two sprites that control the 
same layer can never overlap.)
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• To move a sprite in space, so that the entire path of the layer controlled by the sprite is offset from 
the original path, do the following:

1. In the Timeline panel, click the desired sprite at any frame that is not a keyframe.
2. In the document window, drag the layer in the direction and to the distance you want the 

path to be offset. When you release the mouse button, the black line representing the path 
will reappear at the new position.

3. If necessary, fine-tune the path's position by double-click the layer's handle or outline and 
specifying its exact position at that point.

• To remove a sprite, select it by clicking anywhere on it, and then press Delete.

Working with multiple timelines

One document can have multiple timelines, any of which can begin playing at the same time or at different 
times. For example, an action attached to a frame (p.321) in one timeline can start another timeline when the 
first timeline reaches that frame.

• To add a timeline, right-click anywhere on the Timeline panel and click Add Timeline. The new 
timeline will be named "timelineA’", where X  is the next available integer.

• To change the timeline being shown on the Timeline panel, click the combo box at the top left 
comer of the panel and select a timeline.

• To rename a timeline, select it, edit its name in the combo box, and press Enter.
• To delete a timeline, select it, right-click anywhere on the Timeline panel, and click Delete 

Timeline.

Related topics
Using layers........................................................................................ p. 111

Starting and stopping timelines

A  tim eline on ly  starts playing when som e event (p.305), such as the user clicking a particular im age in the 
document, triggers a script that starts the tim eline. I f  you want a tim eline to start playing as soon as the 
document has been loaded, you can use an O nL oad  event attached to the document itself. Selecting the 
Auto start check box on the Timeline panel does this for you. I f  you want a tim eline to be started by som e 
other event, you can use a P lay T im elin e  action and trigger it with, for exam ple, an O nC lick  event 
attached to a button im age.

Once a tim eline is started, it w ill play through to its end unless stopped by a script. If started again by  
another event, the tim eline w ill resume at the point where it was stopped.

Y ou can choose to have a tim eline play just once or repeat endlessly.
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To make a timeline start when the document loads

• On the Timeline panel, select the desired timeline (if there is more than one) and then select the 
Auto start check box.

To make another event start a timeline
1. Select the hyperlink, image, form control, or other element to which to attach the action that starts 

the timeline.
2. On the Actions panel, click Li (Add). (To reveal the Actions panel, press Alt+7.)
3. Click the Event box and select the event you want to start the timeline.
4. Click the Action box and select Play Timeline.
5. Under Parameters, click the Timeline box and select the desired timeline.
6. Click OK.

To make an event stop a timeline
1. Select the hyperlink, image, form control, or other element to which to attach the action that stops 

the timeline.
2. On the Actions panel, click L* (Add). (To reveal the Actions panel, press Alt+7.)
3. Click the Event box and select the event you want to stop the timeline.
4. Click the Action box and select Stop Timeline.
5. Under Parameters, click the Timeline box and select the desired timeline.
6. Click OK.

To make a timeline repeat indefinitely

• On the Timeline panel, select the desired timeline (if there is more than one) and then select the 
Repeat check box.

Attaching actions to a tim eline

Each frame in a tim eline can have an action  (p.304) attached to it. For exam ple, the twentieth frame in a 
tim eline m ight have an attached action that opens a new  browser w indow ; when the tim eline reaches that 
frame, an OnFrame20 event occurs and the action is executed.

To attach an action to a timeline frame
1. On the Timeline panel, click the column representing the desired frame.
2. On the Actions panel, click Ct* (Add). (To reveal the Actions panel, press Alt+7.)
3. Click the Action box and select the desired action.
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4. Under Parameters, specify values for any parameters the action may require, and then click OK.
5. If you wish to attach another action to the same frame, repeat steps 2 through 4.

To remove an action attached to a timeline
1. On the Timeline panel, click the column representing the frame that has the action you want to 

remove.

1. On the Actions panel, select the action to remove, and then click 0 (Remove). (To reveal the 
Actions panel, press Alt+7.)

Related topics
List of built-in actions.......................................................................... p.306

Namo WebEditor 6 User Manual
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A d d i n g  i n t e r a c t i v e  f e a t u r e s

The Web is not a one-way street. From the beginning, it was designed to support interactive, two-way 
communication between Web sites and Web users. The simplest and most common example o f interaction 
on the Web is the ever-popular ’’search box”: a simple form in which users type in a word or phrase o f  
interest and click a Search button, thereby telling a Web server to perform a search for the entered 
keywords. But interactivity on the Web can go much further than that. An example is the Web-based online 
forum, a virtual meeting ground where users with common interests post messages on various topics and 
read messages others have posted.

The common element in virtually all Web-based interaction is the form. A form is an area on a Web page 
that contains text boxes and other input controls by which a user can enter information to be passed to a 
script or program on the Web server. With Namo WebEditor, you can create and edit even complex forms 
easily, using the Form Toolbar and form-related dialog boxes. Namo WebEditor also includes several 
ready-to-use, form-related scripts you can use to do things like check whether a text box contains a valid e- 
mail address before the user submits a form.

If you use Namo WebBoard to create a Web-based forum, you can use Namo WebEditor to edit WebBoard 
’’skins” as easily as editing ordinary HTML documents. (A skin is a set o f WebBoard document templates 
that define the visual style o f WebBoard forum pages. By editing skin documents, you can customize a 
forum's appearance or even create an entirely new look for your forum.) Namo WebEditor also includes 
commands to insert a forum view into a document or a forum page into the current local site, making it as 
easy as possible to integrate a forum into your site.

In this section
Adding a forum to your site 
Creating Web forms..........

A d d i n g  a  f o r u m  t o  y o u r  s i t e

Although you cannot use Namo WebEditor to create a Web-based forum, Namo WebEditor makes it easy 
to incorporate an existing forum into a Web document or site. If you use Namo WebBoard Manager on the 
same computer, Namo WebEditor will even retrieve the list o f Namo WebBoard servers and forums 
automatically, so you don’t have to enter a forum URL manually.

The Insert Forum command inserts an inline frame (p.416) into the current document and sets the URL of 
the inline frame to that o f the specified Namo WebBoard or other forum. The use o f an inline frame makes 
it possible to place other content around the forum view without having to edit the forum documents

p.323
p.325
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themselves. For instance, you could insert a top-of-page banner and a side navigation bar around the inline 
frame.

You can also use the Site Manager to insert a forum node (p.362) into a local site. A forum node is a Web 
document that contains an inline frame displaying a forum.

y  If you want your forum pages to load in the entire window, rather than in an inline frame, do not use 
the Insert Forum command. Instead, simply place one or more links to the forum's main page on 
appropriate pages in your site.

To insert a forum into the current document
1. Place the insertion point where you want the forum to appear.
2. On the Insert menu, click Forum.
3. If the forum was created with Namo WebBoard and you are using Namo WebBoard Manager on 

the same computer as Namo WebEditor, do the following:
1. Click Namo WebBoard forum.
2. Click the Server box and select the desired Namo WebBoard server.
3. Click the Forum box and select the desired forum. (The type of the selected forum will be 

shown in the Type box.)
4. Otherwise, do the following:

1. Click Other forum.
2. In the Name box, enter a name for the inline frame that will contain the forum. (This 

name will not appear in the document, but you can use it to refer to the inline frame if 
you plan to use the inline frame as a target (p. 170) for hyperlinks.)

3. In the URL box, enter the URL of the forum's main page or any other desired page.
5. Click OK.

To insert a forum node into the current local site
1. Switch to the Site Manager window.
2. In the Site Tree pane, select the node under which you want to create the forum node. (The forum 

node will be a child o f the selected node.)
3. On the Insert menu, click New Forum.
4. If the forum was created with Namo WebBoard and you are using Namo WebBoard Manager on 

the same computer as Namo WebEditor, do the following:
1. Click Namo WebBoard forum.
2. Click the Server box and select the desired Namo WebBoard server.
3. Click the Forum box and select the desired forum. (The type of the selected forum will be 

shown in the Type box.)
5. Otherwise, do the following:

1. Click Other forum.
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2. In the Name box, enter a name for the forum node. (This will also be the name of the 
inline frame that displays the forum in the document.)

3. In the URL box, enter the URL of the forum's main page or any other desired page.
6. Click OK.
7. Enter the desired file name for the new document that will display the forum.

ED IfNarno WebBoard Manager is not installed on your computer\ or no Namo WebBoard servers have 
been defined’ you will not be able to select Namo WebBoard forum  in the In se rt Forum  dialog box. For 
information about how to define a Namo WebBoard server, please refer to the Help window of Namo 
WebBoard Manager.

Related topics
Inline frames.......................................................................................p.416
Adding forum nodes.............................................................................p.362

C r e a t i n g  W e b  f o r m s

In Web documents, forms provide a means for users to submit information o f some sort that is then 
processed by a Web server in some way. A form consists o f a collection o f controls (p.327), such as text 
boxes, drop-down menus, and buttons, through which users enter information. Usually, one button serves 
as a '’submit1' button, which the user clicks to have the browser submit the information to the server. More 
specifically, the form data—which consists o f both the information entered by the user and the identify ing 
names o f the form controls— is passed to a form handler, a server program or script that takes the form data 
as input and acts upon it in according to the intentions o f the web developer. The form handler is specified 
in the form's action (p.333) attribute (p.333).

Example of a Web form
As an example, consider a form on a search page, like the simple form below, which consists of a drop­
down menu, a one-line text box, and a submit button:

Search in:
Error! Objects cannot be 
created from editing field 
codes.

For:
Error! Objects cannot be 
created from editing field 
codes.

Error! Objects cannot be 
created from editing field 
codes.

Each control on a form has a name and a value. Names are assigned by the author, while values are 
provided by the user (either directly, as when the user enters something in a text box; or indirectly, as when

Adding interactive features 325



Ñamo WebEditor 6 User Manual

the user selects an item in a drop-down menu or clicks a button). In the search form above, the name of the 
drop-down menu might be "area"; that o f the text box, "query"; and that o f the button, "button".

When the user selects a search area, enters a search term, and clicks the button, the browser sends the form 
data to the form handler, which for example might be http://deepsearch.namo.com/cgi-bin/mclient.cgi. The 
form data consists o f one name/value pair for each control in the form. If the user has selected "Support" in 
the menu and entered "WebEditor" in the text box, the form data would be as follows:

a r e a  = s u p p o r t  
q u e r y  = W e b E d i to r  
b u t t o n  = S e a r c h

In this example, the program mclient.cgi then takes the query term and performs a search for that term on 
the documents in the specified area. When the search is complete, mclient.cgi generates an HTML 
document whose content is the list of search results, and the server returns this response document to the 
browser.

Steps to create a form
To create a Web form in Namo WebEditor, you simply insert one or more form controls in a document. 
You do not need to explicitly insert the <form> tag itself, since Namo WebEditor, by default, automatically 
inserts <form> tags around the controls you insert. In Edit mode, if  the display o f special tag marks (p.44) is 
enabled, the form will be surrounded by a dashed outline, as in the example below. (To toggle the display 
o f special tag marks, click Show/Hide Special Tag Marks 113 on the Standard Toolbar.)

[=  Search | I
| (♦ Search for all words I
| C Search for any word |

I____________________________________I
A  dashed outline surrounds a fo rm  in  E d it  m ode

To ensure that a new form control belongs to the right form, make sure to insert it within the form's dashed 
outline.

After inserting the form controls, make sure to specify the form's action (p.337) in the Form Properties 
dialog box.

y  Even if you have no script or program available on the Web server to handle a form, you can still make 
use offorms on your Web site by designating an e-mail address as the form handler. If you enter a 
mailto (p.166) link (p.166) such as "mailto:bob@namo.com" as the form's action, most modern 
browsers will send the form data to the specified e-mail address. So, for instance, you could create a 
form to receive feedback from your users, and the form would be useful even if you have no form 
handler on the server. Note: if  you use a mailto action, you should also set the form's method attribute 
(p.334) to POST:
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Inserting and editing form controls........................................................p.327
Specifying a form's action and other properties...................................... p.333
Creating a form in a table..................................................................... p.337

In this section

Inserting and editing form controls

Types of form controls

One-Line Text Box
Lets users enter brief text, such as a name or one line o f a street address. If the user leaves the text 
box empty, its name will still be sent to the form handler, but without a value. Text boxes o f  the 
special password subtype displays asterisks in place o f the typed characters.

Examples: username

File Browser
Same as a one-line text box, but with a ’’Browse" button attached. If the user clicks the Browse 
button, he or she can select a file on the local file system, and its absolute path will be 
automatically entered in the text box. (The user can still type arbitrary text in the box, however.) 
Useful for forms where the user is asked to specify a file to be uploaded to a server.

Example: ______________________ | Browse~

Scrolling Text Box
Lets users enter long text with multiple paragraphs, such as a comment or the body o f an e-mail 
message. If the user leaves the text box empty, its name will still be sent to the form handler, but 
without a value. You can specify the number o f lines the text box will display at a time.

Example: Error! Objects cannot be created from editing field codes.

Check Box
Lets users answer a yes/no question by checking or unchecking a box. If the user does not check 
the box, no name or value will be sent to the form handler. You can control whether the check box 
is initially checked or unchecked.
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Examples: 0  Send me spam.
□  Send me ham.

Radio Button
Lets users select one choice from two or more mutually exclusive choices. Radio buttons should 
always exist in groups o f at least two. When the user selects a button, the button that was 
previously selected becomes deselected. Each button in the same group should have the same 
name. You can control whether each radio button is initially selected or not, but only one button in 
a group should be initially selected.

Examples: ©  Send me spam.
O Leave me alone.

Drop-Down Menu or List Box
Lets users select one item or, optionally, multiple items from a list presented as either a drop-down 
menu or a list box. For each item the user selects, the name of the control and the value o f the item 
will be sent to the form handler. If the user selects no item, no name or value will be sent. You can 
specify the height o f the control (in rows) and whether multiple selections are allowed. Setting the 
height to 1 produces a drop-down menu; setting it to 2 or greater produces a list box.

Examples: Error! Objects cannot be created Error! Objects cannot be created
from editing field codes. from editing field codes.

Push Button
A standard button that performs some action when clicked. The appearance o f  a push button 
depends on the browser and the operating system; generally, it looks the same as a button in a 
dialog box. There are three kinds o f push buttons:

• submit: Sends the form data to the form handler.
• reset: Clears the form, returning it to its initial state.
• general: No predefined function. To make a general button do something, you need to attach a 

script action (p.304) to it.

Examples: | Send E-mail |

Image Control
An image that acts as a submit button, sending the form data to the form handler when clicked. 
Included in the form data are the x and y  coordinates o f  the point the user clicked on the image. 
Thus, the form handler could do different things depending on where the user clicked on the image.

Reset Form
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Example: e nter sea rch term  ©

Hidden Field
Provides a way to include information in the form data while keeping it invisible to users. The 
name and value of the hidden field are always included in the form data, even though the user 
cannot interact with the hidden field. Among other things, a hidden field could be used to provide 
the form handler with the URL of the page from which the form data was sent (and the form 
handler could do something different depending on that information). In Edit mode, hidden fields 
are indicated with this icon: [§L (If you cannot see hidden field icons, click □  (Show/Hide 
Special Tag Marks) on the Standard Toolbar.)

To insert a one-line text box
1. Place the insertion point where you want the one-line text box.
2. Do one of the following:

o On the Insert menu, point to Form, and then click One-Line Text Box. 
o On the Form Toolbar, click W  (Insert One-Line Text Box).

3. (optional) Modify the default settings as desired:
o In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 

use the same name as any other control on the form.
o In the Initial value box, enter the text that will initially appear in the box.
o In the Width in characters box, enter the width of the box in characters.
o In the Maximum input length box, enter the maximum number of characters that will be 

accepted.
o Set Input type to Password if the text box will be used for password entry. (Typed 

characters will be displayed as asterisks.)
4. Click OK.

To insert a file browser
1. Place the insertion point where you want the file browser.
2. Do one of the following:

o On the Insert menu, point to Form, and then click File Browser, 
o On the Form Toolbar, click f t  (Insert File Browser).

3. (optional) Modify the default settings as desired:
o In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 

use the same name as any other control on the form.
o In the Width box, enter the width of the box in characters.

4. Click OK.
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To insert a scrolling text box
1. Place the insertion point where you want the scrolling text box.
2. Do one of the following:

o On the Insert menu, point to Form, and then click Scrolling Text Box. 
o On the Form Toolbar, click (Insert Scrolling Text Box).

3. (optional) Modify the default settings as desired:
o In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 

use the same name as any other control on the form.
o In the Initial value box, enter the text that will initially appear in the box.
o In the Width box, enter the width of the box in characters.
o In the Number of lines box, enter the height of the box in rows of text.

4. Click OK.

To change the scroll bars on a scrolling text box
1. After inserting a scrolling text box, double-click it.
2. Click Scroll Bar.
3. Specify the scroll bar colors as described in Setting document scrollbar colors, p.242.
4. Click OK twice.

To insert a check box
1. Place the insertion point where you want the check box.
2. Do one of the following:

o On the Insert menu, point to Form, and then click Check Box. 
o On the Form Toolbar, click I* (Insert Check Box).

3. (optional) Modify the default settings as desired:
o In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 

use the same name as any other control on the form.
o In the Value box, enter the value that will be sent to the form handler if the user checks 

the box. (If you do not specify a value, the browser will send "On”.)
o Set Initial state to Checked if you want the check box to be initially checked.

4. Click OK.
5. Type a label for the check box.

To insert a radio button group

• Repeat the steps below for each radio button in the group:
1. Place the insertion point where you want the radio button.
2. On the Form Toolbar, click P' (Insert Radio Button).
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3. Make sure the name in the Name box is the same as that of every other button in the 
group, and different from that of any other control on the form.

4. In the Value box, enter the value that you want associated with the current button.
5. Set Initial state to Selected or Not selected. (Only one button in the group should be 

initially selected.)
6. Click OK.
7. Type a label for the button.

To insert a drop-down menu or list box
1. Place the insertion point where you want the drop-down menu or list box.
2. Do one of the following:

o On the Insert menu, point to Form, and then click Drop-Down Menu, 
o On the Form Toolbar, click H3 (Insert Drop-Down Menu).

3. (optional) In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 
use the same name as any other control on the form.

4. Repeat the steps below for each item you want in the menu or list.
1. Click Add.
2. In the Name box, enter the name of the item as you want it to appear in the menu or list.
3. In the Value box, enter the value that you want associated with the item.
4. If you want the item to be initially selected, select the Selected check box.
5. Click OK.

5. In the Height box, enter the desired height of the control in rows. If you enter 1, the control will 
display as a drop-down menu; if you enter 2 or greater, it will appear as a list box in which the 
specified number of rows is visible at a time.

6. If you want the user to be able to select more than one item, select the Allow multiple selections 
check box.

7. Click OK.

To insert a push button
1. Place the insertion point where you want the push button.
2. Do one of the following:

o On the Insert menu, point to Form, and then click Push Button, 
o On the Form Toolbar, click (□ (Insert Push Button).

3. (optional) In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 
use the same name as any other control on the form.

4. In the Value box, enter the value associated with the button. The value also serves as the button’s 
label (the text that appears on the button).

5. Set the Button type to:
o Submit, for a button that sends the form data to the form handler
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o Reset, for a button that clears the form, resetting it to its initial state
o  General, i f  you intend to attach a script action (p.304) to the button and only want the 

button to trigger that action.

6. Click OK.

To insert an image control
1. Place the insertion point where you want the image control.
2. Do one of the following:

o  On the Insert menu, point to Form, and then click  Im age Control, 

o  On the Form Toolbar, click  1̂ 3 (insert Image Control).

3. (optional) In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 
use the same name as any other control on the form.

4. In the Image box, type the path or URL to an image file, or do one of the following:
o Click (Browse) to find and select an image file on your local file system, 
o Click &  (Clip Art) to select an image from the clip art library.
o Click &  (Site) to select from a list of image files belonging to the current local site (if 

one is open).
5. (optional) Under Size and Layout, specify the image properties as desired. (The options are the 

same as those available when inserting an ordinary image; see Images, p. 137 for more 
information.)

6. Click OK.

To insert a hidden field
1. Place the insertion point where you want the hidden field. (Since it is hidden, its location does not 

matter, as long as it is within the form.)
2. Do one of the following:

o On the Insert menu, point to Form, and then click Hidden Field, 
o On the Form Toolbar, click (Insert Hidden Field).

3. (optional) In the Name box, edit or replace the default name assigned by Namo WebEditor. Do not 
use the same name as any other control on the form.

4. In the Value box, enter the value to be sent to the form handler.
5. Click OK.

To edit a form control

• Double-click the form control.
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You can control many aspects of the appearance of most form controls. For example, you can change the 
character formatting (font, text color, and so forth) of a one-line text box, or the border properties of a 
button. To change the appearance of a form control, do this:

1. Double-click the form control.
2. Click the Style button and then click:

o Character, to change character-related properties, such as font
o Paragraph, to change paragraph-level properties, such as text alignment, line height, and 

so forth
o Borders & Background, to change the control's borders, margins, padding, and 

background color or image.

For more information about using style properties, see the following topics:

• Setting character-related properties, p.219
• Setting paragraph alignment, indentation, and line height, p.221
• Setting margins, padding, and borders, p.222
• Setting background colors and images, p.225

Note that not all control types are affected by a given style property. For instance, specifying the font for a 
check box or radio button has no effect, since those controls cannot contain text. (You can, of course, apply 
a style to a check box's label as you can to any other text, but the label is separate from the check box.)

Changing the appearance of a form control

Specifying a form 's action and other properties

The most important part of a form is not visible to users: it is the form’s action attribute, which specifies the 
URL of the form handler—the script or program on the Web server to which the form data is passed and 
which acts on the form data.

In all, each form has five attributes that you may need to specify values for, listed below. Only action must 
be specified; the other four are optional.

Action
The URL of the form handler. This is the only required attribute. If you do not specify an action, 
nothing will happen when a user clicks the submit button.

Name
The name of the form. This is only important if you plan to refer to the form in a script (p.288). 
Unlike the names of form controls, the name of the form itself is not sent to the form handler.
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Target
The window or frame in which the document returned by the form handler will open. The default 
value is _self, meaning the response document will open in the same window or frame as the 
document containing the form. By changing the target, you can have the response document open 
in a new window, a specific named window, or a specific frame. The target types you can specify 
are the same as those for hyperlinks. (For more information about targets, see Setting a link’s 
target window or frame, p. 170.)

Method
The method of sending the form data to the form handler. There are two possible values: GET and 
POST.

If the method is set to GET, the browser will send the form data by appending it to the URL of the 
form handler; for example, ”http://www.namo.com/search.php?area=support&query=WebEditor". 
If the method is set to POST, the browser will send the form data as an HTTP POST request.

GET is the default method. The main advantage of the GET method is that, since the form data is 
included in the form handler’s URL, users can bookmark the URL to make it easier to send the 
same request to the form handler in the future. For example, the user could bookmark the search 
URL in the paragraph above; each time the user uses the bookmark, the search engine would 
respond to the same query. However, the GET method is limited in that it does not support non- 
ASCII form data, and the amount of form data that it can send is limited by the maximum URL 
length supported by the user's browser. The POST method does not have these limitations, so you 
should use it whenever users might enter non-ASCII characters (such as Chinese ideograms) in the 
form, or if the form data might be larger than 100 characters. You should also select POST if the 
form includes a file browser control (p.327).

Encoding type
The content type used to encode the form data when it is sent to the server. The default value is 
"application/x-www-form-urlencoded”. Generally, you should not change this unless the form 
includes a file browser control (p.327), in which case set the encoding type to ’’multipart/form- 
data” and also set the method to POST.

9  I f  yo u  en ter a  mailto (p.166) link (p.166) such a s  "m a ilto :bob@ n am o .com " as the action  an d  s e t the  
m eth od  to POST, m ost m odern b row sers  w ill sen d  the fo rm  da ta  to the e-m ail address in the link. This 
can b e  a conven ien t w ay to v iew  sa m p le  ou tpu t fro m  a  fo rm  f o r  testin g  pu rposes.

9  I f  you  a re  design ing  a fo rm  that does n o t sen d  inform ation to  a se rve r  bu t in stead  p ro v id e s  da ta  f o r  a  
clien t-side scr ip t (p.288), y o u  do  n o t n eed  to spec ify  a  value f o r  the action  attribute.

To specify a form's action and other properties
1. Right-click anywhere on the form (within the dashed outline) and then click Form Properties.
2. In the Action box, enter the URL of the form handler.
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3. (optional) Specify any other properties as desired:
o In the Form name box, edit or replace the default name assigned by Namo WebEditor.
o In the Target box, enter the name of the response document’s target window or frame 

(p. 170); or click the triangle and select from a list of special targets.
o Click the Method box and select the desired transmission method for the form data. (If 

you do not specify a method, GET will be used.)
o In the Encoding type box, enter an alternative encoding type for the form data only if 

necessary. If the form includes a file browser control, enter "multipart/form-data". In 
most other cases, you should leave this box blank.

4. Click OK.

Changing a form's style properties
You can apply various style properties to a form as a whole. For instance, you can change its background 
color, apply a background image, change its alignment on the page, and so forth. To modify a form's style 
properties, do this:

1. Right-click anywhere on the form (within the dashed outline) and then click Form Properties.
2. Click the Style button and then click:

o Character, to change character-related properties, such as font
o Paragraph, to change paragraph-level properties, such as text alignment, line height, and 

so forth
o Borders & Background, to change the form's borders, margins, padding, and background 

color or image.

For more information about using style properties, see the following topics:

• Setting character-related properties, p.219
• Setting paragraph alignment, indentation, and line height, p.221
• Setting margins, padding, and borders, p.222
• Setting background colors and images, p.225

Note that any style properties you apply to a form are applied only to the form itself; they are not 
"inherited" by the form controls within it. To change the appearance of the form controls, you need to edit 
their style properties (p.333) individually.

Using script actions w ith form controls

Namo WebEditor's collection of ready-to-use script actions (p.304) includes several form-related script 
actions to perform such tasks as checking whether a specific field contains a numerical value or whether 
there are any empty fields, before sending form data to a form handler. You can associate these script
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actions with events such as exiting a text box or clicking a submit button. The available form-related script 
actions are as follows:

Script Action 
Move Focus to

Reset Form Field

Select Text in 
Form Field
Validate E-mail 
Address

Validate Field 
Contains Number
Validate Field Not 
Empty
Validate Length 
Not Exceeded
Validate No Field 
Empty

Description
Moves the keyboard focus to a specific form 
control.
Clears the contents of a specific text box.

Selects the contents of a specific text box.

Displays a pop-up message if the contents of 
a specific text box are not a valid e-mail 
address.
Displays a pop-up message if the contents of 
a specific text box are not a number.
Displays a pop-up message if a specific text 
box is empty.
Displays a pop-up message if the contents of 
a specific text box exceed a specified length.
Displays a pop-up message if any text box in 
the form is empty.

Can be attached to
text boxes, hidden fields

text boxes, drop-down menus, list 
boxes
all controls except hidden fields and 
file browsers
one-line text boxes

one-line text boxes

one-line text boxes

one-line text boxes

one-line text boxes, check boxes, 
radio buttons, push buttons, image 
controls

To attach a script action to a form control
1. Select the desired form control.
2. On the Actions panel, click (Add). (If the Actions panel is hidden, press Alt+7.)
3. Click the Action box and select the desired action.
4. C lick the Event box and select the event (p.305) that should trigger the action.

5. Under Parameters, confirm that the correct form is selected in the Form name box, and specify 
other parameters as required.

6. Click OK.

To modify or remove a script action
1. Select the form control to which the script action is attached.
2. On the Actions panel, double-click the script action you want to modify, or select it and click 3  

(Remove).

Related topics
W orking w ith  actions and events...................................................................................p .304
List o f  supported events.................................................................................................... p.305
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Creating a form in a table

To help lay out a form neatly, it is convenient to insert form controls and labels in the cells of a table. By 
doing so, you can ensure that controls and labels are nicely aligned with each other. Normally, however, if 
you insert form controls in table cells, Namo WebEditor will create a separate form inside each cell. This is 
usually not desirable, since the form controls will not be in the same form with each other.

To avoid this problem and ensure that all the form controls in a table exist in the same form, follow the 
steps below when creating a form in a table:

1. Create a table with enough rows and columns to accommodate all the form controls you want. 
(You can add more rows or columns later, if necessary.)

2. On the Insert menu, point to Form, and then click Insert With Form Tags to disable automatic 
<form> tag creation. (When disabled, no check mark appears next to the menu command.)

3. Insert the desired form controls and text labels in the desired table cells.
4. When you are finished inserting form controls, leave the insertion point inside the table.
5. On the Format menu, click Form.
6. Specify desired values for the form’s properties and click OK, or just click OK if you plan to 

specify the properties later.

If the display of special tag marks (p.44) is enabled, you should now see a dashed outline around the entire 
table, indicating the presence of a form.

0  When you  crea te  a fo rm  in a  tab le  u sing the m ethod d escr ib ed  a bove , N am o W ebEditor som etim es  
inserts an em pty pa ra g ra p h  inside th e  fo rm , be low  the table. You can sa fe ly  de le te  this em pty  
paragraph . To a vo id  inserting  the em p ty  paragraph  in the f ir s t  p lace , se lec t an y ce ll in the tab le  before  
step  5.
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6 Working With Sites
When you create a Web site, you first create a set of Web documents and related resource files on your 
computer, and then publish (upload) them to a Web server. Technically speaking, the Web site consists of 
the copies of your files on the Web server—not the original files on your local file system, since these are 
not available on the Web.

There are two ways of managing these local files. First, you can manage them as you would any other set 
of files on your hard drive, using a file manager such as Windows Explorer. However, a more powerful 
way to manage them is to create a lo ca l s ite  in Namo WebEditor to contain the local files. This approach 
has several advantages.

In Namo WebEditor, a lo ca l s ite  is a managed collection of Web documents, folders, and resource files on 
the local file system that you intend to publish as a Web site. A local site gathers local files into a cohesive 
whole and lets you manage them as a whole, with Namo WebEditor's Site Manager.

There are five major advantages of creating and using a local site, as opposed to simply keeping all your 
local files in a folder and managing them with Windows Explorer:

• If you rename a file or folder that is part of a local site, Namo WebEditor can automatically update 
any links that refer to it.

• A local site can have a site tree (p.355), m aking it possib le to use dynam ic navigation bars (p.365) 
in your docum ents.

•  Y ou  can m anage shared resources (such as im age files) in a site library (p.377).

•  Y ou  can use Q uick Publish (p.392) to publish the entire local site, or any part o f  it, in one step.

• If you work as part of a team on the same site, you can use source control (p.379) to prevent 
conflicts that can arise when multiple people edit the same document.

Creating a local site is easy. Y ou  can create one w hen you  start building a W eb site, or you can put an 
existing collection  o f  files into a local site. I f  you create a site using the Site W izard (p.344), N am o  
W ebEditor creates a local site autom atically.

GD When y o u  crea te  a lo ca l s ite , N am o W ebE ditor adds a sp ec ia l f i le  nam ed site.wejand a sp ec ia l fo ld e r  
n am ed _  we_info5 in the lo ca l site's top -leve l fo ld e r . These spec ia l item s s to re  s ite  inform ation a n d  
in ternal resources. B y defau lt, these item s a re  not v is ib le  in the Site M anager, although y o u  can se e  
them  in W indows E xp lorer. D o  not d e le te  these item s unless yo u  w ant to de le te  the lo ca l site.
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In this section
Planning a site....................................................................................................................... p.341
Creating a local s ite ............................................................................................................ p .344
Im porting an existing s ite .................................................................................................p .350
Site structure and navigation............................................................................................p .355
Using the site lib rary ...........................................................................................................p.377
Collaborating on a s ite .......................................................................................................p.379
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P l a n n i n g  a  s i t e

Before you start building a Web site, you should take some time to think about how it will be organized, 
both with respect to the file system and with respect to the logical relationships between documents.

In this section
Planning a site's folder structure..
Planning a site's logical structure

P l a n n i n g  a  s i t e ' s  f o l d e r  s t r u c t u r e

Although it is possible to put every file of a site in a single folder, it usually makes more sense to group 
related files in subfolders within a top-level folder. There are many approaches to grouping site files. The 
examples below show two possible strategies:

Example A
Desktop 

¿ G  My Documents

company 
| ¿1 G) products

j □  activesquare 
L”{£) images 

! $  ( 3  handstory
I 51 webedtor

I I |H£) services 
|-"E3 store 

support
T w o  m ethods o f o rgan iz ing  files in  fo lders

In Example A, files are organized according to site areas. For example, all the files for the Products area of 
the site go into the ’’products" folder, where they are further divided into subfolders according to specific 
products. Each folder might also have an "images" subfolder to contain image files.

In Example B, files are organized according to type. All HTML files go into the top-level "My Web Site" 
folder. CSS files, image files, JavaScript files, and other resource files go into subfolders for each resource 
file type.

Example B
Desktop

0  ‘Q  My Documents
j è - Q
j i j-£2) css
1 j j~-£a images

| ! multimedia 
| !H 3  scripts

My Web Site

p.341
p.342
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The organizational strategy you choose depends largely on the kind o f Web site you are creating and its 
size. For relatively small sites with no clearly defined areas, something like Example B can be convenient, 
since it limits the number of folders you have to manage. For large corporate sites, the folder organization 
is likely to be more like Example A, but far more complicated, since documents might be further organized 
by corporate division, international regions, and so forth.

Keep in mind that the folder structure o f a site need not have any relationship to its logical structure— the 
hierarchy o f "parent” and "child" pages. For example, the product description page for Namo WebEditor 
might logically be considered a "child" o f the products index page, but the document does not need to 
reside in a subfolder o f the products folder.

Related topics
Planning a site's logical structure........................................................... p.342

P l a n n i n g  a  s i t e ' s  l o g i c a l  s t r u c t u r e

The logical structure o f a site is the map o f relationships among the documents in the site. It is the 
hierarchy o f "parent" and "child" documents. A site's logical structure can be visualized as a tree, like a 
family tree, although when describing Web sites the tree is commonly shown inverted, with its root at the 
top and branches and leaves below. A site’s home (index) page is at the topmost level. Immediately below it 
are the home page’s immediate "children"; in the case o f a company site, these could be the index pages for 
Products, Services, Support, and so forth. In turn, each o f these first-level children might have its own 
children, and so on.

[Home!

y
I-------------------------------------- n ----------------------------------- 1

Products Services Support

? ?  ________ f
i----------------------1 i---------------1 i--------

SiperWidge Molestra Consulting Dentistry Knowledge Base Updates Cortact Info

? ? ?¡— j— j j— — j | ,
Wo Demo H o  Demo Rocket Science Telepathy

Ï
Customer Quotes

Logical structure of a hypothetical small business site

Deciding on the logical structure o f a site means deciding how to organize its documents into groupings 
and relationships that make sense to you and to your users. There are many ways to organize a site, and it is 
not always obvious which of two alternatives is best. Should there be two branches, one for Products and
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another for Services, or should both be combined in one branch? Should Updates fall under Support, or 
should there be a separate Updates page under each product?

Of course, you can always put links in one document to any other document, regardless of their relative 
locations in the site tree. However, many sites can be organized into "natural" groupings: for instance, 
product pages naturally fall into a "Products" category. When deciding what the children o f a particular 
document should be, ask yourself what the most important links in that page will be. In most cases, the 
children o f that document should be the pages those primary links point to.

The site tree and dynamic navigation bars
In the case of an ordinary Web site, the site tree is a theoretical construct. It doesn't exist anywhere but in 
the mind of the developer, or perhaps in a planning document. But when you use a local site in Namo 
WebEditor, you can explicitly build a site tree for your site. This site tree serves a concrete purpose: its 
structure determines the destinations of the links in any dynamic navigation bars (p.365) you put in your 
documents.

Unlike an ordinary hyperlink, which always points to the same document (by its path and file name) 
regardless o f where the document is in the site tree, a link in a dynamic navigation bar points to whatever 
document is in a specific place in the tree. If you replace that document with another document (that has a 
different path and/or file name), Namo WebEditor automatically updates the link to point to the new file. 
For example, you might have a dynamic navigation bar in which the links point to the children of the 
current document. If you replace one o f the child documents— let's say you replace superwidge.htm! with 
humunga.html—Namo WebEditor will automatically change the link pointing to superwidge.html so that it 
now points to humunga.html. Namo WebEditor similarly updates dynamic navigation bars when you add or 
remove documents in the site tree.

Dynamic navigation bars are powerful tools. If you plan and build your site tree with care, they can relieve 
much o f the burden o f updating links when you change the structure o f your site.

Related topics
Planning a site’s folder structure............................................................ p.341
Site structure and navigation.................................................................p.355
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C r e a t i n g  a  l o c a l  s i t e

There are two ways to create a new local site that is not based on an existing site.

•  If you are new to Web authoring or want to get a basic site up and running in the minimum time, 
use the Site Wizard (p.344). In just a few steps you will have a ready-to-customize site based on 
the structural template and visual theme o f your choice. The wizard constructs a complete set o f  
themed pages for you; all you have to do is fill them in with your own content. In addition, the 
wizard builds a structural tree (p.355) for the site and places dynamic navigation bars (p.365) on 
each page. You can, o f course, add your own pages or remove ones you don’t need at any time.

• If you need complete control over a new site from beginning to end, use the New Site command to 
create an empty local site (p.346), and then fill it with new or existing documents.

In this section
Creating a site with the Site Wizard....................................................... p.344
Creating an empty local site.................................................................. p.346
Adding files and folders to a local site....................................................p.347
Moving and removing files and folders on a local site............................. p.348
Saving a local site as a site template.......................................................p.349

Related topics
Importing an existing site..................................................................... p.350

C r e a t i n g  a  s i t e  w i t h  t h e  S i t e  W i z a r d

Use Namo WebEditor's Site Wizard to create a ready-to-customize Web site in just seconds, using your 
choice o f structural template and visual theme. The wizard generates a complete local site, including 
HTML documents, predesigned graphics, navigation bars, and a complete site tree (p.355). Once you finish 
the wizard, all you need to do is fill in the content placeholders on each page with your own text, replace 
the placeholder images with your own images, and then publish (p.387) your site to the Web.

When (and when not) to use the Site Wizard
You should consider using the Site Wizard any time you need to get a basic site up and running on the Web 
with the minimum investment o f time and effort. You might be a novice Web author who wants to quickly 
create a place to share information and images with family and friends, or a small business owner with no 
Web authoring experience who needs to "hang a shingle" in cyberspace as soon as possible. Since the
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wizard takes care o f design, layout, and site structure for you, you can focus on content and get the job 
done faster.

While the Site Wizard is a great tool for building a Web site quickly and easily, it has various limitations 
that you should consider before deciding to use it. If any of the following conditions applies, you’ll 
probably be better off building a site from scratch (p.346):

• You need to build a large and/or complex site. The site templates used by the wizard contain from 
7 to 16 pages. Although you can add as many pages as you want later, the simple structure o f  the 
wizard’s templates may not easily support large numbers o f pages. Rather than radically modifying 
the structure o f a wizard-generated site, it probably makes more sense to build your own site 
structure from the ground up.

• You need precise control over page layout. Pages created by the Site Wizard use table-based 
layouts that cannot be modified within the wizard and may be difficult to modify afterwards.

• Your site needs to have a unique graphic design. Although the Site Wizard lets you choose from 
200 visual themes suitable for a variety o f  purposes, no predesigned theme can substitute for a 
truly unique visual design. If you already have, or plan to create, your own graphic design 
elements to use on your site, it can be easier to start the site from scratch rather than replacing a 
theme’s built-in graphics.

Using the Site Wizard
To launch the Site Wizard: on the Shortcut Bar, click Site Wizard.

Step 1: Template
Choose a site template from the list on the left. The site template determines the mix o f  pages that 
will initially make up the site, as well as the relationships among them. The template's site tree is 
shown in the preview area. You can edit the structure o f the new site by moving nodes in the site 
tree and using the buttons below it.

Click Next to proceed to the next step.

Step 2: Theme
Choose a visual theme from the list on the left. Your choice o f theme will determine the visual 
style o f your site. Themes include both text styles and graphical elements, such as buttons, banners, 
and backgrounds. To preview the site with the selected theme applied, click Site Preview. Click 
OK to return to the Site Wizard.

Click Next to proceed to the next step.

Step3: Information
Fill in the boxes with the requested information: a title for your new site, your name, your e-mail 
address, and your copyright notice. The site title and author name will not appear anywhere except 
in the Site Manager, but the e-mail address and copyright notice will appear on every page.
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In the Save site in box, enter the path o f  the folder in which you want to store the new local site. 
(Click Browse to browse for a folder or to create a new one.)

Click Next to proceed to the next step.

Step 4: Publishing
If you have already defined the remote site (p.388) to which you intend to publish the new local 
site, select it in the box on the left. Otherwise, you can click New to define a remote site now, or 
just ignore this step and define a remote site (p.388) later.

Click Finish to exit the Site Wizard.

The wizard will take a moment to generate the new local site, and then the site will be opened in the Site 
Manager.

Related topics
Creating a local site with the Site Wizard............................................... p.80

C r e a t i n g  a n  e m p t y  l o c a l  s i t e

If the Site Wizard does not suit your requirements, you can create an empty local site and build it up with 
your own documents, new or existing.

To create an empty local site
1. Do one o f the following:

o On the File menu in the main window, point to Site, and then click New Site, 
o On the File menu in the Site Manager, click New Site.

2. In the Site title and Author boxes, enter a name for the site and your name, respectively. (This 
information will not appear on the Web site.)

3. Click Create empty site, and then enter the path o f the folder in which you want to store the site's 
files. (You can c lick ... to browse for a folder or to create a new one.)

4. Click OK.

The Site Manager window will come to the front, with the new local site open and ready to accept new (or 
existing) documents.

Related topics
Adding files and folders to a local site....................................................p.347
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A d d i n g  f i l e s  a n d  f o l d e r s  t o  a  l o c a l  s i t e

The Site Manager’s Site F iles pane lists the files and folders belonging to the current local site. It's also 
where you add files and folders to the site.

Site Files 91 <
Name / Si... Date Modified !

Namos Steak Hous...
B"P~) ¡mages
EfrPl nav

-Q iabouthtm ii 9KB 1/14/2004 9:25
board html 5KB 11/4/20033:01

““[ J  index, html 6KB 11/4/200311:2'

menuhtml 15KB 1/15/200410:4
music, mid 1KB 10/7/200310:4

~  H i cph hfml 17KR
l>:

The Site Files pane of the Site Manager

To add a new (blank) document
1.

2.
3.
4.

In the Site F iles pane of the Site Manager, select the folder in which you want to add a new 
document. To add a new document at the site's top (root) level, select the site icon at the top o f the 
file list.
On the Insert menu, click New Document.
Select a document template and click OK.
Type the file name you want to use for the new document.

^  You can also add a new document to a local site by creating it in Namo WebEditor's main window and 
then saving it in the site's folder.

To add an existing document from outside the local site

• Drag the document from Windows Explorer to the Site F iles pane o f the Site Manager and drop it 
on the folder in which you want to put it. To add the document at the site's top (root) level, drop it 
on the site icon at the top o f the file list.

To add a new (empty) folder
1. In the Site Files pane o f the Site Manager, select the folder in which you want to add a new folder. 

To add a new folder at the site's top (root) level, select the site icon at the top o f the file list.
2. On the Insert menu, click New Folder.
3. Type the name you want to use for the new folder.
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To add an existing folder (and all its contents) from outside the local site

•  Drag the docum ent from W indow s Explorer to the S ite Files pane o f  the S ite M anager and drop it 
on the folder in w hich you want to put it. To add the docum ent at the site's top (root) level, drop it 
on the site icon  at the top o f  the file  list.

0  D ocum ents yo u  a d d  to a  loca l site  through the S ite F iles p a n e  are  n o t au tom atica lly  a d d ed  to  the s ite  
tree. F or inform ation abou t adding  docum ents to a  s ite  tree, see  A dding  docum en t nodes, p .3 5 7 .

0  When you  a d d  a n ew  docum ent to a site  to  which yo u  have a p p lied  a them e (p.270), the new  docum ent 
does not au tom atica lly  use the theme. You m ust explicitly  a p p ly  the them e (p.273) to the new  docum ent.

M o v i n g  a n d  r e m o v i n g  f i l e s  a n d  f o l d e r s  o n  a  l o c a l  s i t e

To move a file or folder
1. In the S ite  F iles pane o f  the Site M anager, drag the file or folder you want to m ove and drop it on  

the folder in w hich you  want to put it. To m ove the file or folder to the site's top (root) level, drag 
it to the site icon  at the top o f  the file  list.

2 . N am o W ebEditor w ill ask whether you w ant to update any URLs that reference the m oved file  or 
folder. C lick Y es.

0  To m ove m u ltip le  items, se lec t them firs t, an d  then d ra g  any o f  them to the d es ired  location.

To remove files or folders
1. In the S ite  F iles pane o f  the Site M anager, select the files and/or folders you want to rem ove, and 

then press D e le te .

2. N am o W ebEditor w ill ask you to confirm  deleting the selected  items. C lick Y es.

0  When yo u  rem ove a docum ent o r  fo ld e r  that is p a r t  o f  the s i te ’s s ite  tree, N am o W ebE ditor converts the  
docum ent o r  fo ld e r  n ode to a tem porary node. You shou ld  de le te  (p.362) this tem porary  node i f  yo u  do  
not p la n  to p u t an o th er docum ent o r  fo ld e r  in its  p lace .
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S a v i n g  a  l o c a l  s i t e  a s  a  s i t e  t e m p l a t e

Y ou can save a local site as a site tem plate and then use the tem plate in the future w hen you create a site 
using the Site Wizard (p.344).

To save the current local site as a site template
1. Switch to the Site Manager.

2. On the File m enu, c lick  S a v e  a s  Site Template.

3. Enter a name for the tem plate and click  OK.

Once you have saved a site tem plate, your tem plate w ill appear in the tem plates list, below  the factory 
tem plates, in the first step o f  the Site W izard.
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I m p o r t i n g  a n d  e x p o r t i n g  s i t e s

Y ou can create a local site from an existing site that was created without N am o W ebEditor. H ow  you  do 
this depends on w here the site’s files are.

•  I f  you  have a copy o f  the site files in one folder on your local file  system , you can sim ply use the 
New Site com m and to create a new  local site in that folder. N am o W ebEditor w ill autom atically 
add all the files in the folder and its subfolders to the new  local site.

•  I f  you  do not have a copy o f  the site on your local file  system , but the site is on the W eb, you  can 
dow nload the W eb site to your local file  system  and then create a new  local site in the dow nload  
folder.

Y ou can also export an existing local site to a zip archive and then import the archived site as a local site on  
another computer.

0  When yo u  im port a  s ite  that w as n ot crea ted  in N am o W ebEditor, the s ite  tree  f o r  the s ite  w ill in itia lly  
b e  em pty.

In this section
Importing a site from the local file system.............................................. p.350
Importing a site from the Web...............................................................p.351
Exporting and importing a local site to/from a zip archive........................p.353

I m p o r t i n g  a  s i t e  f r o m  t h e  l o c a l  f i l e  s y s t e m

To import a site from the local file system
1. M ake sure all the site files (docum ents and resource files) are in a single folder or in subfolders o f  

a single folder. If necessary, m ove them into a new  folder.

2. D o one o f  the follow ing:

o  In N am o W ebEditor’s main w indow , on the File menu, point to Site, and then click  New 
Site.

o  In the Site M anager w indow , on the File m enu, click  New Site.

3. In the Site title and Author boxes, enter a name for the site and your name, respectively. (This 
information w ill not appear on the W eb site.)

4. C lick Import existing files in a folder, and then enter the path o f  the folder containing the existing  
site files. (Y ou  can click ... to brow se for a folder.)
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5. Under Create site tree using th e se  file types, specify  the types o f  files for w hich N am o W ebEditor  
w ill create nodes in the site tree for the new  site.

o  Select D ocum ents to create nodes for HTM L docum ents and other W eb files, such as 
stylesheets and scripts. T his is the recom m ended setting.

o  Select Image files to create nodes for GIF, JPG, and PNG  im ages.

o  Select All files to create nodes for all files, regardless o f  type.

6. C lick OK.

N am o W ebEditor w ill now  create the n ew  local site and autom atically build a site tree based on the 
subfolder structure o f  the specified  folder and the selected file types.

Related topics
Importing a site from the Web 
Site structure and navigation...

I m p o r t i n g  a  s i t e  f r o m  t h e  W e b

To import a site from the Web
1. D o one o f  the follow ing:

o  In N am o W ebEditor's m ain w indow , on the File menu, point to Site, and then c lick  New  
Site.

o  In the Site M anager w in d ow , on the File menu, click  N ew  Site.

2. In the S ite title and Author boxes, enter a name for the site and your name, respectively. (T his  
information w ill not appear on  the W eb site.)

3. C lick Import existing files in a folder, and then click  6 9  (Import from W eb).

4. C lick Add.

5. In the URL to import from box, enter the U RL o f  the W eb site to import.

6. In the Store in folder box, enter the path o f  the local folder in w hich to save the imported site.

7 . M odify import options as desired (see  below  for details), and then click OK.

8. C lick Start to begin  dow nloading the W eb site.

9. W hen N am o W ebEditor has fin ished  dow nloading the site, click  C lose.

10. Under Create site tree using th e s e  file types, specify the types o f  files for w hich N am o W ebEditor 
w ill create nodes in the site tree for the new  site.

o  Select D ocum ents to  create nodes for HTML docum ents and other Web files, such  as 
stylesheets and scripts. T his is the recomm ended setting.

o  Select Image files to create nodes for GIF, JPG, and PNG  im ages.

p.351
p.355
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o  Select All files to create nodes for all files, regardless o f  type.

11. C lick OK.

N am o W ebEditor w ill n ow  create the new  local site and autom atically build a site tree based on the folder 
structure o f  the dow nloaded site and the selected file types.

The Import S ettings d ialog box contains a number o f  options to control the process o f  importing a W eb site. 
These are explained b elow .

Import Settings General

Download images from this site
Clear this check  box to prevent dow nloading im age files from the specified W eb site.

Download images from other sites
M any sites d isp lay im ages that are actually stored on other sites. Select this check box to a llow  
dow nloading these im age files.

Don't follow external links
N orm ally, N am o W ebEditor ignores links to docum ents on other W eb sites w hen importing a site. 
Select this check  box to force N am o W ebEditor to fo llow  external links and dow nload pages from  
other sites.

Depth
This setting controls the depth to w hich N am o W ebEditor w ill fo llow  links w hen importing a site. 
I f  set to 1, N am o W ebEditor w ill dow nload the docum ent at the specified  URL and all the 
docum ents to w hich  links in the first docum ent point, but no more. I f  set to 2, N am o W ebEditor 
w ill also dow nload the docum ents to w hich links in all the "level 1" docum ents point; and so forth. 
The m axim um  setting is 100. The default setting o f  10 should be sufficient to dow nload m ost W eb  
sites in their entirety.

Download all files / Skip previously imported files
This pair o f  options controls whether N am o W ebEditor w ill re-dow nload files that have already 
been dow nloaded (and that still exist in the dow nload folder).

Import Settings Authentication

Account information
This area is for entering a user ID and password needed to access a site that requires login. P lease  
note that N am o W ebEditor’s site import feature supports only basic HTTP authentication, not the 
more sophisticated forms o f  authentication supported by som e W eb servers.
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Maximum individual file size
I f  this check box is selected, N am o W ebEditor w ill not dow nload any file that exceed s the 
m axim um  size you specify.

Maximum total file size
I f  this check  box is selected, N am o W ebEditor w ill stop dow nloading files once the total size you  
specify  has been reached.

Maximum number of files to import
I f  this check box is selected, N am o W ebEditor w ill stop dow nloading files once the total number 
you sp ecify  has been reached.

Do not change links
N orm ally, w hen im porting a W eb site, N am o W ebEditor converts any full URL links (to pages or 
resources in the sam e site) into relative links. For exam ple, i f  you are importing the page at 
http://w w w .exam ple.com /index.htm l, and it contains a link to
"http://w w w .exam ple.com /im age.gif', N am o W ebEditor w ill normally change the link to  
" im age.g if1 in the dow nloaded copy o f  the file. To prevent changing links, select th is check  box.

Include/exclude file types
This set o f  options controls the file  types N am o W ebEditor w ill download: all file  types, on ly  the 
file  types you  specify , or all file  types except the ones you specify. To add a file type to be 
included or excluded, type its extension in the Extension box and click Add.

Related topics
Importing a site from the local file system............................................. p.350

Import Settings Advanced

E x p o r t i n g  a n d  i m p o r t i n g  a  l o c a l  s i t e  t o / f r o m  a  z i p  

a r c h i v e

A t tim es, you m ay need to copy or m ove a local site to another computer— either yours or that o f  another 
person. A lthough you can do so using the file  copying/m oving functions o f  W indow s, it can be easier and 
more convenient to use the com m ands built into N am o W ebEditor to do the job. W hen you export a local 
site, N am o W ebEditor autom atically packages all its files into a com pressed zip archive, so you  on ly  need  
to send or copy one file to the other computer. Then you or the other person can use the Site M anager to 
autom atically unpack the zip archive and save the local site on the second computer.
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To export a local site to a zip archive
1. I f  the site to be exported is not open, open it and sw itch to the Site Manager.

2. On the File m enu, click  Export Site.

3 . N avigate to the folder where you want to save the zip archive, specify  a file name, and click  S ave .

To import a local site from a zip archive
1. Open the S ite Manager: on the Window menu, click Site Manager.
2. On the File m enu, click  Import Site.

3. Enter the path o f  the zip archive to import from, or click  Browse to locate and select a zip archive.

4. In the Save site to box, enter the path o f  the folder in w hich to save the local site, or click Browse 
to locate and select a folder. (N ote that the site w ill be saved into a new  subfolder o f  the specified  
folder.)

5. C lick OK.
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S i t e  s t r u c t u r e  a n d  n a v i g a t i o n

W hen you create a local site in N am o W ebEditor, the s ite  tree  plays an important role: it forms the b asis o f  
all dynam ic navigation bars in the site. The site tree is an explicit representation o f  the logical relationships 
am ong the docum ents o f  the site— the hierarchy o f  parent and child docum ents. B elow  is an exam ple tree 
for a very small site:

A small site tree

Each square represents a node in the tree. A t the ro o t (the top o f  the inverted tree) is the node representing  
the site itself. A ny node can have zero or more ch ildren . Typically, the site node has exactly one child: the 
hom e (index) page o f  the site. In the exam ple above, the hom e page has three children, tw o o f  w hich have 
children o f  their ow n . Except for the site node, each node has exactly one paren t. N odes that have the same 
parent are called s ib lin g s .

The purpose o f  the site tree is to define the relationships betw een docum ents— to define "what goes where". 
This is useful as a visual aid in thinking about the site, but more importantly, it lets you create dynam ic 
navigation bars that respond to changes in the site's organization.

W hen you create a dynam ic navigation bar, you don't specify  w hich docum ents it links to. Instead, y o u  
specify  a re la tion sh ip  betw een the current docum ent and the linked documents. For exam ple, you can  
create a navigation bar that links to the children  o f  the current docum ent. I f  the current docum ent is the 
hom e page in the exam ple g iven  above (the page titled "Dark Matter”), then the navigation bar w ill link to 
the pages "About M e", "My Poems", and "My Stories". But i f  another docum ent is added as a  child o f  the 
hom e page— say, "My Photos"— N am o W ebEditor w ill autom atically update the navigation bar to include
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a link to the new  child . I f  a child  docum ent is deleted, N am o W ebEditor w ill autom atically rem ove its link  
from the navigation bar.

In this section
Building the site tree.............................................................................p.356
Adding dynamic navigation bars and trees..............................................p.365
Adding page banners............................................................................p.375

B u i l d i n g  t h e  s i t e  t r e e

W hen you create a new  local site (w ithout using the Site W izard), its site tree is  initially empty except for 
one node, representing the site itself. B uilding the tree m eans adding nodes and arranging them to reflect 
the structure you w ant for the site.

There are six  kinds o f  nodes that can be in a site tree:

•  D ocu m en t n od es represent ordinary docum ents that are part o f  the local site.

•  E xternal L in k  n odes represent U R L s that are external to the current site.

•  S h ortcu t n odes are "virtual" nodes. A  shortcut node links to a document node elsew here in the 
site tree. Shortcut nodes are useful w hen  you want a single document to appear in more than one 
place in the tree.

•  T em p orary  nodes are placeholders. U se  a temporary node to occupy a position in the site tree 
that you intend to fill later w ith a real node.

•  F oru m  n o d es are a special type o f  docum ent node. A  forum node represents a docum ent that 
contains an inline frame (p.416) displaying a forum v iew  (p.323).

•  F o ld er  n od es are special nodes that represent subfolders o f  the site's root folder. Folder nodes are 
created autom atically by N am o W ebEditor w hen you create a local site in an existing folder that 
contains subfolders. Y ou cannot create a folder node manually. Folder nodes are never included in 
dynam ic navigation bars.

In this section
Adding document nodes....................................................................... p.357
Adding external nodes.......................................................................... p.358
Adding shortcut nodes.......................................................................... p.358
Adding temporary nodes....................................................................... p.360
Adding forum nodes.............................................................................p.362
Moving, copying, and removing nodes................................................... p.362
About folder nodes...............................................................................p.363

356 Site structure and navigation



Saving an image of a site tree.

Chapter 6: Working With Sites

p.365

Adding document nodes

A  docum ent node  represents a docum ent that belongs to the local site. Y ou  can add a docum ent node for an 
existing docum ent in the site, or you can create a new  docum ent and add it to the site tree in one step.

Each document in a site can only be represented by at most one document node. If you want a document to 
be represented by multiple nodes in different locations in the site tree, create a document node at the 
"natural" position in the tree and then create shortcut nodes (p.358) at the other positions.

To add a node for an existing document
1. Switch to the Site Manager.

2 . In the site tree, select the ex isting node under w hich you want to add the docum ent node. (T he new  
node w ill be a child o f  the selected  node.)

3. Press the Insert key, or, on Insert m enu, click  Insert Into Site Tree.

4 . C lick the Type box and select either HTML docum ent ( i f  you  are adding a node for an HTM L  
document) or Dynamic docum ent ( i f  you are adding a node for an A SP, PHP, or JSP docum ent).

5. In the file  list, select the desired docum ent, and then click  OK.

9  You can a lso  a d d  a  docum ent node b y  dragg in g  a  docum ent fro m  the Site Files p a n e  on to  an existing  
node.

Ü3 I f  yo u  add  a node f o r  a  docum en t th a t is  a lready  represen ted  b y  a  docum ent node in the s i te  tree, the 
new  node w ill be c rea ted  a s  a sh ortcu t node (p.358).

To add a node for a new, empty document
1. Switch to the Site Manager.

2 . In the site tree, select the ex isting node under w hich you want to add the docum ent node. (T he new  
node w ill be a child o f  the selected  node.)

3. On the Insert menu, c lick  one o f  the follow ing: New HTML File, New A SP File, N ew  JSP  File, or 
New PHP File, depending on the type o f  docum ent you want to create.

4 . Type the desired file  name and click  OK.

5. Type the desired navigation nam e for the new  docum ent and press Enter.

The new document will be saved in the site's root folder.
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To add a node for a new document based on a template
1. Sw itch to the S ite Manager.

2. In the site tree, select the existing node under w hich you want to add the docum ent node. (The new  
node w ill be a child  o f  the selected node.)

3. On the Insert m enu, click  New Document.

4 . Select the desired docum ent tem plate and click  OK.

5. Type the desired file  nam e and click  OK.

6. Type the desired navigation name for the new  docum ent and press Enter.

The new  docum ent w ill be saved in the site’s root folder.

ED When you add a new document to a site to which you have applied a theme (p.270), the new document 
does not automatically use the theme. You must explicitly apply the theme (p.273) to the new document.
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Adding external nodes

A n external node represents a docum ent that is external to the current site. U sually this m eans a docum ent 
on another W eb site, although an external node could also represent a document on the local file  system  but 
w hich exists outside o f  the site’s root folder.

To add an external node
1. Sw itch to the Site Manager.

2. In the site tree, select the existing node under w hich you want to add the external node. (The new  
node w ill be a child  o f  the selected node.)

3. On the Insert m enu, click  N ew  External Link.

4. In the URL b ox, type the U RL o f  the external document. Y ou can enter either a full Internet URL  
or a path to a local file.

5. In the Navigation nam e box, type the desired navigation name for the external node.

6. C lick OK.

Adding shortcut nodes

A shortcut node represents a local docum ent that is already represented by a document node (p.357) in the 
site tree. Shortcut nodes are useful w hen you want the same docum ent to appear in more than one location  
in the site tree, thus a llow ing  it to be included in navigation bars that link to different levels o f  the tree.
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For example, consider the simplified site tree below:

S u p p o r t

B-

I f  there is a ch ild-level dynam ic navigation bar on the "Home" page, it w ill contain links to "Products" and 
"Support". And i f  there is another ch ild -level navigation bar on the "Support" page, it w ill link to "Forum" 
and "FAQ". But suppose w e want to include the "FAQ" page in the hom e page's navigation bar, as w ell. 
N orm ally, this w ould  not be possib le, since a dynam ic navigation bar can on ly  contain links to nodes on a 
single level o f  the site tree. H ow ever, i f  w e create a shortcut node to the "FAQ" page at the hom e page's 
child level, as in the exam ple tree below , the "FAQ" page w ill then be included on the hom e page's ch ild - 
level navigation bar.

P r o d u c t s
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To add a shortcut node
1. Switch to the Site Manager.
2. In the site tree, select the document node for which you want to create a shortcut node.
3. On the Insert menu, click New Shortcut Node. The shortcut node will be created as a child of the 

selected document node.
4. Type the desired navigation name for the shortcut node and press Enter. (A shortcut node can 

have a different navigation name from the original node.)
5. Drag the shortcut node to the desired location in the site tree. (See Moving, copying, and removing 

nodes, p.362.)

(El You can only create a shortcut node for a document or forum node. Other types of nodes (external and
temporary) can be simply copied from one location in the site tree to another.

Adding temporary nodes

A temporary node is an "empty" node in the site tree. It does not represent any document, but, like other 
nodes, it can have child nodes. A temporary node can appear in a navigation bar or navigation tree, but the 
button or text will not be linked to anything.

There are two uses of temporary nodes:
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•  Y ou can use a temporary node as a placeholder at a location in the site tree where you  plan to  
insert a '’real" node later. This lets you  finish building the site tree even i f  som e o f  the site's 
docum ents do not exist yet. W hen you  are ready, you can convert the temporary node to a 
docum ent or external node using the Convert Temporary N ode comm and.

•  I f  you use dynamic navigation trees (p.367) in your docum ents, you  can use a temporary node as a 
"virtual parent" for a set o f  docum ents that you  want to appear as children in the navigation tree, 
w ithout having to have a "real" parent document.

To add a temporary node
1. Sw itch to the Site Manager.

2. In the site tree, select the existing node under w hich you want to add the temporary node. (T he  
n ew  node w ill be a child o f  the selected  node.)

3. On the Insert menu, click  New Temporary Node.

4. T ype the desired navigation nam e for the temporary node and press Enter.

To convert a temporary node into a document node
1. Sw itch to the Site Manager.

2. In the site tree, select the temporary node.

3. On the Edit menu, click Convert Temporary Node.

4. D o  one o f  the follow ing:

o  I f  you want to convert the temporary node to a node for an existing docum ent, c lick  
(B row se), select a docum ent, and then click  Open.

o  I f  you want to convert the temporary node to a node for a new  document, click  Cl (N ew), 
select a docum ent tem plate, click  OK, type the desired file name, and then click  OK.

5. In the Navigation nam e box, edit the node’s navigation name as desired.

6. C lick OK.

To convert a temporary node into an external node
1. Sw itch to the Site Manager.

2. In the site tree, select the tem porary node.

3. On the Edit menu, click Convert Temporary Node.

4. N ext to N ode type, click External link.

5. In the URL box, type the U R L  o f  the external document.

6. In the Navigation nam e box, edit the node’s navigation nam e as desired.

7. C lick OK.
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Adding forum nodes

A forum node is a special kind of document node. It represents a document that contains an inline frame 
(p.416) displaying a forum view (p.323). When you create a forum node, you specify a Namo WebBoard or 
other forum to display, and then Namo WebEditor creates a new document and inserts in it an inline frame 
linked to the specified forum automatically. In all other respects, a forum node works the same as an 
ordinary document node. (Creating a forum node is simply a shortcut to creating a document node and then 
manually inserting (p.323) a forum view in the document.)

To add a forum node
1. Switch to the Site Manager.
2. In the site tree, select the existing node under which you want to add the forum node. (The new 

node will be a child of the selected node.)
3. On the Insert menu, click New Forum.
4. If the forum you want to display was created with Namo WebBoard and you are using Namo 

WebBoard Manager on the same computer as Namo WebEditor, do the following:
1. Click Namo WebBoard forum.
2. Click the Server box and select the desired Namo WebBoard server.
3. Click the Forum box and select the desired forum. (The type of the selected forum will be 

shown in the Type box.)
5. Otherwise, do the following:

1. Click Other forum.
2. In the Name box, enter a name for the forum node. (This will also be the name of the 

inline frame that displays the forum in the document.)
3. In the URL box, enter the URL of the forum's main page (or any other desired page).

6. Click OK.
7. Type the desired file name for the new document and press Enter.

Related topics
Adding a forum to your site 
Inline frames......................
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Moving, copying, and removing nodes

Moving, copying, and removing nodes are all operations that change the navigational structure of a site. 
These operations do not have any physical effect on the files that make up the site.

.p.323

.p.416
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To move a node

• Drag the node to the desired location in the site tree. If the selected node has any child nodes, the 
child nodes will move with it.

To copy a node

• Drag the node to the desired location in the site tree while holding down the Ctrl key. If the 
selected node has any child nodes, the child nodes will be copied with it.

u  Copying a document node will create a shortcut node (p.358) at the new location.

To remove a node
1. Select the desired node and press the Delete key.
2. Click Yes.

«aw«.
L J  Removing a document node does not delete the document it represents.

To hide a node in dynamic navigation bars
You can cause a node to not appear in any dynamic navigation bars that would ordinarily include it, 
without removing the node from the site tree.

1. Select the node you want to hide.
2. On the Edit menu, click Enable Navigation.

To unhide the node, repeat the command.

About folder nodes

A folder node is a special kind of node that is only created when you create a local site in an existing folder 
that contains subfolders. In such a case, each subfolder will be represented by a folder node at the 
appropriate level in the site tree, and any documents in the subfolder become child nodes of the folder node. 
Folder nodes never appear in dynamic navigation bars, and you cannot create folder nodes manually.

For example, say you have a small collection of documents that you want to turn into a local site, and the 
documents are arranged in a folder and two subfolders as below:
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Q a c m e  
&f~) photos 
| pQahtml
I b.html

B 'C l  stories 
j~ [^  c.html 
' - [ J  dhtml 

index, html

When you create a local site in the acme folder, Namo WebEditor will automatically create the following 
site tree (shown here in vertical, small-node view):

- [ ^ in d e x .h t m l  

•{7. p h o t  o s  0 -------- !
'• •Q b .h tm l

r Q  c .h t m l
•{ s t o r i e s  B ------1

L* [^ d .h tm l

In this example, photos and stories are folder nodes. The HTML documents (a.html, b.html, and so forth) 
in the corresponding subfolders are represented as child nodes of the folder nodes.

If you were to insert a parent-level dynamic navigation bar in a.html, the bar would contain only a link to 
index.html. It would not contain links to the photos and stories folders, because folder nodes never appear 
in dynamic navigation bars.

You may be wondering why Namo WebEditor creates folder nodes at all, since folder nodes cannot 
participate in dynamic navigation bars. The answer is simply that it does so as a convenience to authors. By 
creating a node for each subfolder and child nodes for each document in the subfolder, Namo WebEditor 
can ensure that every document in the collection is represented by a node in a predictable location in the 
site tree. You can then drag the document nodes to the desired locations in the tree and remove the folder 
nodes. This is easier than adding the documents to the site tree manually.

In the example above, if a.html is the "main" document in the photos folder, you could drag it "up” in the 
tree so that it is on the same level as index.html; and then drag b.html to a.html so that it becomes a child 
node of a.html. Finally, you could remove the photos node.

¿^Acme E-
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¿^Acme □* • Q a .h t m l  B ---------- [ ^ b .h t m l

c .h t m l
{ J j s t o r i e s  B ------j

Q  d .h tm l

in d ex .h tm l

In short, you can think of folder nodes as temporary parents for nodes representing documents in subfolders 
when you create a local site in an existing folder hierarchy. Since folder nodes play no part in the 
navigational structure of the site, you should move their child nodes to the appropriate locations in the site 
tree and then remove the folder nodes from the tree.

Saving an image of a site tree

Sometimes, it can be useful to save an image of a site tree, such as for documentation purposes or when 
giving a presentation about a proposed site structure. You can use a built-in command in the Site Manager 
to do so. Unlike a standalone screen capture utility, the built-in command always captures the entire tree, 
even if the tree is too big to fit in the Site Manager window. You can save a site tree image in BMP, GIF, 
JPEG, or PNG format.

To save an image of the current site tree
1. Switch to the Site Manager.
2. On the Tools menu, click Save Site Tree as Image File.
3. Navigate to the folder where you want to save the image, and type the desired file name in the File 

name box. (You do not need to type an extension.)
4. Click the Save as type box, select the desired image file format, and then click Save.

A d d i n g  d y n a m i c  n a v i g a t i o n  b a r s  a n d  t r e e s

About dynamic navigation bars

A dynamic navigation bar is a set of dynamic links that point to nodes in the site tree of a local site. Such 
links are not fixed to particular documents; their URLs change if you change the site tree, for example by 
moving (p.362) a node out and replacing it with another node. Also, a dynamic navigation bar does not have 
a fixed number of links. The number of links changes if you add or remove nodes in the set of nodes to 
which the bar links.
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When you insert a dynamic navigation bar in a document, you specify a set of nodes to which the bar will 
contain links. For example, a dynamic navigation bar might link to the child nodes of the current document, 
or to the document’s parent node and its siblings.

To illustrate, suppose a site has the following navigational structure (site tree):

Q  Acme Widgets, Inc.
B

_  I
[¿Home

Q  Products Q  Support
1=1 _______ g _______

[¿WebEditor [¿HandStory [¿Forum [¿FAQ [¿Contacts

If the Forum page contains a parent-level dynamic navigation bar, the bar will contain links to Products 
and Support—the page’s parent and the parent's siblings. The bar might look like this:

|| Products

If the Forum page contains a sibling-level dynamic navigation bar, the bar will contain links to Forum, 
FAQ, and Contacts—but not to WebEditor and HandStory, because those nodes, while on the same level 
as Forum, do not share the same parent with that node. The bar might look like this:

:jj FAQ

11 Contacts

Now, suppose we add another document as a child node of Support—titled, for example, Knowledge 
Base:

Û  Support
i_______ ?  ______ ____________ !

[¿Forum [¿FAQ [¿Contacts Q  Knowledge Base

Then, the sibling-level dynamic navigation bar on the Forum page will automatically change to include the 
new node:
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Dynamic navigation bars can be either horizontally or vertically oriented. You also have a choice of using 
plain text, Smart ClipArt (p.258) buttons, or Flash Buttons (p.265) for the links in dynamic navigation bars.

About dynamic navigation trees

Dynamic navigation trees are similar to dynamic navigation bars; they too are sets o f dynamic links that 
point to nodes in a site tree. Instead o f being o f a row or column o f links, however, a dynamic navigation 
tree is a hierarchical menu of links that the user can expand and collapse, like the folder tree in Windows 
Explorer. The image below shows an example:

v  Home 

> P r o d u c ts  

^  S u p p o r t  

Forum  

FAQ

U e b E d ito r  FAQ 

HandS t o r  AQ 

C o n t a c t s

Another difference between dynamic navigation bars and dynamic navigation trees is the method of  
specifying the set o f  nodes the navigation tree will link to. Rather than specifying a set such as the child 
nodes o f the current document, you specify any set o f siblings, or the home page node by itself, to be the 
top-level link(s) in the navigation tree. All o f their child nodes are automatically included in the navigation 
tree.

Navigation trees are always vertically oriented. You can specify such formatting properties as the font, font 
size, and colors of the links.

0  Since dynamic navigation bars and trees contain dynamic links to nodes in a site tree, rather than fixed 
links to documents, you can only insert a dynamic navigation bar or tree in a document that is part of 
a local site, and then only if  you have built a site tree (p.356) for the site.
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Where do the labels of the links in dynamic navigation bars and trees come from?

The labels of the links in dynamic navigation bars and trees, such as "Products” and "Support" in the 
examples above, come from the navigation names of the corresponding nodes in the site tree. Navigation 
names are not the same as document titles (what appears in the title bar of a browser when the document is 
viewed). You assign each node a navigation name in the Site Manager, usually when you add (p.356) the 
node. To change a node’s navigation name, do the following:

1. Switch to the Site Manager.
2. Select the node whose name you want to change.
3. Press F2 (or, on the Edit menu, click Rename).
4 . Type the new name and press E n te r.

When are dynamic navigation bars and trees updated?

When you make changes to the site tree, dynamic navigation bars and trees in any of the site’s documents 
that are currently open in Namo WebEditor are immediately updated. If a document is not open when you 
change the site tree, it will be automatically updated the next time you open it. You can also manually force 
all dynamic navigation bars and trees in all site documents to be updated with a Site Manager command: on 
the Tools menu, click Update Navigation Bars.

Namo WebEditor cannot update dynamic navigation bars and trees in documents on a remote site. When 
documents in the local site are affected by changes in the site tree, you should re-publish (p.387) the 
affected documents to the remote site so that the copies there have up-to-date navigation bars and/or trees.

In this section

Types of dynamic navigation bars.................................................................... p.368
Inserting and configuring a dynamic navigation bar....................................... p.371
Inserting................................................................................................................p.373 and configuring p.371 a
dynamic navigation tree......................................................................................p.373

Related topics

Building the site tree..........
Hyperlinks and bookmarks

Types of dynamic navigation bars

Dynamic navigation bar types are distinguished by their node sets—the sets of nodes in the site tree to 
which the navigation bar contains links. The various types are listed below, along with descriptions of their 
node sets and examples.

.p.356 

.p. 164

368 Site structure and navigation



Chapter 6: Working With Sites

The examples are based on the following hypothetical site tree and assume that the current document (the 
document containing the example navigation bar) is the one entitled 2,1.2.

M)j Site

p .  I
[¿H om e

B

Û1
□

0,2  Ü 3
0

□  1.1 Û 1.2  Û2.1 Ü Z 2  Ü 2.3  
0

Ci 21 ■b .2.1:2
E

Q z i.3
□

Q  2.1.21 Q  2.1.22 Q2.1.2.3 Q  21.3.1 
Example site tree for navigation bar examples

Type: Main level 
Node set: the child nodes of the site's main index page 
Example: i  ̂ 2 ^

Type: 
Node set: 
Example:

Parent level
the parent of the current document and the parent's siblings

2.1 T 22 2.3

Type: Siblings 
Node set: the siblings of the current document 
Example: £.1 \

2A2

2.1.3

Type: Children 
Node set: the child nodes of the current document
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Example:

Type: 
Node set: 
Example:

Type: 
Node set: 
Example:

Note:

Type: 
Node set:

Example:

Note:

Type: 
Node set:

Example:

Note:

Type: 
Node set: 
Example:

Note:

f 2.1.2.1  

2Ä 2 2

2.1.2.3

Path from home
the current document itself and all its direct ancestors
Home > 2 > 2 > 2 . 1 . 2

Previous/Next
the siblings immediately preceding and following the current document 

[Previous] [Next]
The links in this type of navigation bar are always labelled ’’Previous" and "Next". If the 
current document does not have a preceding sibling, the "Previous" link is not included; if it 
does not have a following sibling, "Next" is not included.

Previous/Up/Next
the siblings immediately preceding and following the current document, and the document's 
parent
[Previous] [Up] [Next]
The links in this type of navigation bar are always labelled "Previous", "Up", and "Next”. If the 
current document does not have a preceding sibling, the ’’Previous" link is not included; if it 
does not have a following sibling, "Next" is not included.

Previous/Home/Next
the siblings immediately preceding and following the current document, and the site’s main 
index page

[Previous] [Home] [Next]
The links in this type of navigation bar are always labelled "Previous", "Home", and "Next". If 
the current document does not have a preceding sibling, the "Previous" link is not included; if 
it does not have a following sibling, "Next" is not included.

Parent
just the parent of the current document

W
The single link in a parent-type navigation bar is always labelled "Up".

370 Site structure and navigation



Chapter 6: Working With Sites

Type: Home
Node set: just the site’s main index page

Example: H o m e  )

Note: The single link in a home-type navigation bar is always labelled ’’Home”.

Type: Page num ber links
Node set: the siblings of the current document
Example: [1] [2] [3]

Note: Each link in the bar has a numeric label based on the sequence number of its corresponding 
node in the set of siblings o f the current document.

Type: 
Node set: 
Example:

Note:

User-defined
an arbitrary set of sibling nodes

1.1 12

You can specify any set o f sibling nodes as the node set of a user-defined navigation bar, even 
a set of nodes that are "unrelated’’ to the current document (except through the root node). A 
user-defined node set must be a single, complete set of sibling nodes.

Inserting and configuring a dynamic navigation bar

To insert a dynamic navigation bar in the current document

1. Place the insertion point where you want the navigation bar.
2. On the Insert menu, point to Navigation , and then c lick  Navigation Bar.
3. In the N avigation bar type list, select the type (p.368) of navigation bar you want. (Look at the Site  

tree preview to confirm that the selected node set is correct.)
o If you selected U s e r -d e f in e d  (p.371) as the bar type, click a node in the Site  tree preview. 

The selected node and its siblings will be the node set of the navigation bar.
4. Specify the desired options for the navigation bar as described below (p.372).
5. Click OK.

Site structure and navigation 371



Ñamo WebEditor 6 User Manual

Dynamic navigation bar options

L in k  s ty le
You can choose between text links and button image links. For button links, you can choose any 
Smart ClipArt (p.258) image or Flash Button (p.265) in the resource library. See Selecting a 
navigation bar button image, p.373 below.

For text links, you can specify the separators between links, the line height (for vertical navigation 
bars), and the words for Previous, Next, Up, and Home links. You can also specify the maximum 
number of numbered page links for a page num ber links (p.371)-type navigation bar. To specify 
these options, click the ... button next to the Text option under Link style.

Orientation
You can choose horizontal or vertical orientation.

In c lu d e  h o m e  p a g e
If the selected navigation bar type is U ser-defined, M ain  level, Parent level, Siblings, or C hildren, 
you can force the navigation bar to include a link to the site’s home or main index page by 
selecting this option. The home page link will be the first link in the bar.

S h o w  p o p u p  s u b m e n u s
If you select this option, each link in the navigation bar to a node that has children will show a 
pop-up menu o f links to that node’s child nodes. You can customize the appearance of the pop-up 
submenu by clicking the ... button next to the option. This option is not available if the link style is 
set to Flash Button.

S h o w  s u b le v e ls
For vertical navigation bars only, selecting this option will cause the navigation bar to show a 
second set of links, under the link to the current document's ancestor (if the link exists), to the 
ancestor’s children. These ancestor’s-child links are always text links, even if the bar’s link style is 
Sm art C lipArt or Flash Button. You can customize the appearance of the ancestor’s-child links by 
clicking the ... button next to the option.

Target
Specifies the target window or frame (p. 170) in which the navigation bar’s links will open, except 
for the Home link (if any), which will open in the target specified in the H om e target option.

H o m e  ta rg e t
Specifies the target window or frame (p. 170) in which the Home link will open, if the navigation 
bar has one.
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For a dynamic navigation bar that uses button images for its links, you can specify an image of your 
choosing or just use the default image. The default image is selected as follows:

• If the links style of a dynamic navigation bar is set to Smart ClipArt and the current document has a 
theme (p.270) applied to it, the default button image is the Horizontal Button (p.271) or the Vertical 
Button (p.27I) that belongs to the theme, depending on the bar's orientation.

• If the link style is set to Smart ClipArt and the document has no theme, the default button image is 
a generic Smart ClipArt button.

• If the link style is set to Flash Button, the default button image is a generic Flash Button button.

To specify a different button image, do the following:

1. In the N av ig ation  Bar P ro p ertie s  dialog box, click the ... button next to either S m art C lipArt or 
Flash Button, depending on which type of image you want to use.

2. Click Select.
3. In the left pane, select an image category.
4. In the right pane, select the desired image, and then click OK.
5. (optional) If you want to modify the image, click Modify and edit the image. (See Modifying Smart 

ClipArt images, p.259, or Using Flash Buttons, p.265, for more information.)
6. Click OK.

To modify an existing dynamic navigation bar

• Double-click the navigation bar, edit its settings, and click OK.

0  To change the font, font size, or other text properties o f the buttons in a dynamic navigation bar that 
uses button images, you must edit the Smart ClipArt or Flash Button image the bar uses.

Related topics

Types of dynamic navigation bars................................................................p.368
Modifying Smart ClipArt images.................................................................p.259
Using Flash Buttons..................................................................................... p.265

Selecting a navigation bar button image

Inserting and configuring a dynamic navigation tree

To insert a dynamic navigation tree in the current document

1. Place the insertion point where you want the navigation tree.
2. On the Insert menu, point to Navigation, and then click Navigation T re e .
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3. In the Site tree box, select one of the nodes that you want to be at the top level of the navigation 
tree. The selected node’s siblings, if any, will be automatically selected. (The top level of a 
navigation tree must always consist o f a single, complete set of sibling nodes.)

4. (optional) Specify the Text, Bullets, and Target settings as described below (p.374).
5. Click OK.

Namo WebEditor will insert a layer (p.l 11) containing the dynamic navigation tree at the insertion point. If 
the display of special tag marks (p.44) is enabled, you will see the layer’s outline and a navigation tree icon
l&! in the layer's lower right comer. (If special tag marks are not displayed, you can reveal them by clicking 
£ 3  (S h o w /H id e  Special Tag  M arks ) on the Standard Toolbar.)

The layer will appear to be empty, because the navigation tree is actually created dynamically using 
JavaScript when the document is viewed in a browser. To preview the navigation tree, switch to Preview 
mode.

You can move the navigation tree to any position on the page by dragging the layer outline. (See Creating 
and positioning a layer, p.l 12.)

If some of the nodes included in the navigation tree have very long navigation names, the corresponding 
links may be too long to fit the default width of the containing layer. In such cases, unless you make the 
layer wider, the links will "wrap” to two or more lines. But since the height of each link is fixed, this will 
produce undesirable results. Switch to Preview mode to see if this is happening; if it does, you should 
widen the layer by dragging its left-middle resize handle. (See Resizing a layer, p.l 14.)

You can also modify other properties of the layer. Right-click the layer's outline and then click Layer 
Properties. See Using layers, p.l 11 for information about layer properties.

Dynamic navigation tree settings

T e x t
Select the desired font, font size, normal font color, and highlight font color for the navigation tree. 
(The highlight color appears when the user moves the mouse pointer over a link in the navigation 
tree.)

B u lle ts
You can change the images used for the triangles that expand and collapse a parent node in the 
navigation tree. The triangle uses two images, one for when a node is collapsed, and the other for 
when it is expanded. You can change these independently. To specify an image, do any of the 
following:

• Click « a  (Browse) to find and select an image file on your local file system.
• Click (Clip Art) to select an image from the clip art library.
• Click (Site) to select from a list of image files belonging to the current local site.
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T a rg e t
Specifies the target window or frame (p. 170) in which the navigation tree's links will open.

To modify an existing dynamic navigation tree

• Double-click the outline of the containing layer, edit the navigation tree's settings, and click OK.

Related topics

Using layers............................................................................................. p.l 11
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A d d i n g  d y n a m i c  p a g e  b a n n e r s

About dynamic page banners

A dynamic page banner is a page banner (that is, a banner, usually at the top of a page, that announces the 
page's title) in which the title is dynamically updated by Namo WebEditor when you change the navigation 
name of the document containing the banner. For instance, if you change the navigation name of a 
document containing a dynamic banner from "Our Mission" to "Our Vision", the title on the banner will 
automatically change accordingly.

To insert a dynamic page banner in the current document

1. Place the insertion point where you want the banner.
2. On the Insert menu, point to N avigation , and then click Banner.
3. The Label box will display the current navigation name of the document. If you want to change it, 

edit the contents of the box.
4. Select the banner style as described below (p.375).
5. Click OK.

¡ 3  Since a dynamic banner gets its text from the document's navigation name, you can only insert a 
dynamic banner in a document that is a node in a site tree.

Dynamic banner styles

You can choose between a text banner and an image-based banner.

For a text banner, you can specify the characters, if any, that surround the title on either end. By default, the 
beginning and ending characters are the square brackets "[" and respectively. To change them, click 
the ... button next to the Text option and then edit the contents of the boxes marked 1 and 6 under 
Separators.
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For an image-based banner, you can choose any Smart ClipArt (p.258) image or Flash Button (p.265) in the 
resource library. If you do not select an image, a default image will be used as follows:

• If the banner style is set to S m art ClipArt and the current document has a theme (p.270) applied to it, 
the default image is the Banner (p.271) image that belongs to the theme.

• If the banner style is set to Sm art C lipArt and the document has no theme, the default image is a 
generic Smart ClipArt banner.

• If the banner style is set to Flash Button, the default image is a generic Flash Button banner.

To specify a different image, do the following:
1. In the B an n e r P ro p e rtie s  dialog box, click the ... button next to either Sm art ClipArt or Flash  

Button, depending on which type of image you want to use.
2. Click Select.
3. In the left pane, select an image category.
4. In the right pane, select the desired image, and then click OK.
5. (optional) If you want to modify the image, click M odify and edit the image. (See Modifying Smart 

ClipArt images, p.259, or Using Flash Buttons, p.265, for more information.)
6. Click OK.

To modify an existing dynamic page banner

• Double-click the baner, edit its settings, and click OK.
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Using the site library
When you are working on a local site, the Site Library panel (shown by default at the bottom right comer 
of the main window) displays lists of various types of assets, such as hyperlinks, images, and shared 
content blocks (p.420), that exist in the local site. You can insert a site asset into the current document by 
dragging it from the Site Library panel to the document window. This makes it as easy as possible to insert 
items that you might use many times throughout a site.

J ( 3  Site Library _

a  #  o [ li~ Q  l  tg
Name '  | See | Date... I Folder | State

audio, gif 1KB 2001/07/.. . D:\work\wes... j
Q  about_html_$ma... 6KB 2003/10/.. . D:\work\wes... 1
Q  org_nth_artnou.. 1KB 2001/07/.. . D:\work\wes...
Q  org_nth_artnou... 1KB 2001/07/.. . D:\work\wes...
Q  org_nth.artnou... 1KB 2001/07/.. . D:\work\wes... j 1
Q  org_nth_bannef... 1KB 2001/07/.. . DAwork\wes...
Q  orgLnth.btackJ-.. 1KB 2001/07/.. . D:\work\wes...

org_n(h_b!ack_t.. 1KB 2001/07/.. . D:\work\wes...
Q  orgLnth_black_l.. 1KB 2001/07/.. . D:\work\wes...
Q  orjLnth.defau!L. 1KB 2001/07/.. . D:\work\wes...
Q  org_nth_grace_... 1KB 2001/07/.. . D:\work\wes...
[¿J orgLnth_grace_... 1KB 2001/07/.. . DAworkVwes... y ,

The Site Library panel (image list)

The panel has seven buttons above the file list, which are used to select the type of asset to be listed.

Button Asset type
HTML documents

& Hyperlinks
s j Shared content blocks (NSC files)
ü Images (bitmapped and Smart ClipArt)

0 Flash files
ÏL Style sheets (CSS files)
m Dynamic documents (ASP/PHP/JSP)

Things you can do with the Site Library panel

The following operations can be done to any asset type except hyperlinks.

• To insert an asset (except style sheet files) into the current document, do one of the following: 
o drag the asset into the document window and click Insert File or Im age  
o right-click the asset and click Insert
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• To open an asset, double-click it. Documents and shared content blocks will open in Namo 
WebEditor, while other types of files will open in their own default programs. (The default 
programs for opening various file types can be set through the Folder Options icon in the 
Windows Control Panel.)

• To rename or delete an asset, right-click it and click R enam e or Delete.

• To view an asset in a browser, right-click it and click View with [browser name].

Working with hyperlinks in the Site Library panel

The Site Library panel displays hyperlinks differently from other asset types, and available operations are 
somewhat different as well. When the panel lists links, instead of displaying file names, sizes, modification 
dates, and so forth, as for other asset types, it displays the following information:

• in the Name column: the URL of the link
• in the Document(s) column: the path (relative to the site’s root) and filename of every document 

that contains the link
• in the Type column: whether the link points to a site document ("internal”) or a Web URL 

("external")

Actually, it may be more accurate to say the panel lists unique URLs, rather than links. If the current site 
contains, for example, ten links to Sejoong Namo Interactive’s home page in five documents, the URL 
http://www.namo.com/ will only appear once in the list of links, but the entry in the Document(s) column 
for that URL will show the pathnames of five documents.

As with other assets, you can insert a link into the current document by dragging it to the document 
window or right-clicking it and clicking Insert.

Double-clicking a link in the list opens the Hyperlink Properties dialog box, so you can change the URL. If 
you do so, every link in the site that points to the old URL will be automatically updated to point to the new 
URL.

Related topics

The tool panels............................................................................. p.38
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Collaborating on a site
When you work on a large-scale website with other members of a team, it can be difficult to keep track of 
who is editing what. As a result, "collisions” can occur when two people try to edit the same document at 
the same time: when the document is saved, changes made by one or both authors may be lost. To help 
avoid such problems, Namo WebEditor can directly interface with a source control system that keeps track 
of documents being edited and prevents collisions from happening.

Namo WebEditor supports two different source control systems: Microsoft Visual SourceSafe, and 
WebDAV. The same source control-related commands in Namo WebEditor are used for either system. The 
only difference in the way Namo WebEditor interfaces with SourceSafe vs. WebDAV is how you specify a 
source control server to connect to.

Requirements for using source control

In order to use Namo WebEditor's source control features, you and your computer must meet the following 
requirements.

for SourceSafe

• Microsoft Visual SourceSafe client software installed on your computer
• a username and password for a SourceSafe database

for WebDAV

• a username and password for a WebDAV server

Also note that Namo WebEditor's source control features are only available when you work with a local 
site (a collection of files managed with the Site Manager).

In this section

Source control basics.................................................................... p.380
Connecting to a source control server............................................... p.381
Adding files to source control......................................................... p.382
Checking files out and back in........................................................ p.383
Retrieving the latest versions of files................................................ p.384
Removing files from source control..................................................p.385
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S o u r c e  c o n t r o l  b a s i c s

When you collaborate with other people on documents that are under source control, the workflow is 
different from when you work alone with documents that belong exclusively to you. The basic ideas in 
source control are as follows:

• There is a set of "master" documents and resource files, somewhere in a database or folder that all 
the collaborators have (secure) access to. These master files are considered the definitive versions 
of the documents—they may even be the actual published documents on the Web server.

• When an author needs to edit a document, he or she does not edit the master copy. Instead, the 
author checks the document out—that is, he or she copies the master document to the local 
computer and, at the same time, locks the master copy so that it cannot be replaced by another 
author. Then, the author edits the local copy. When the author is finished editing, he or she checks 
the document back in to the source control database, replacing the master copy with the edited 
local copy and, at the same time, removing the lock on the master copy.

This process ensures that, at any given time, only one author can update a master document, thus avoiding 
the situation where two or more authors save "overlapping" versions of the same document to the central 
repository and lose their changes.

Preparing to use source control

The following tasks must be performed before your team can start editing source-controlled documents:
1. If the documents to be edited collaboratively are not already part of a local site, create (p.344) a 

local site on a client computer and then add (p.347) the desired documents to it.
2. Connect (p.381) to the source control server and add (p.382) every file in the local site to the source 

control project or folder.
3. Every other author on the team must now obtain a copy of the site files, so that he or she can open 

the local site on his or her own computer. However, at this point, the other authors will not be able 
to use Namo WebEditor to retrieve the site files, because the command is not available until the 
local site is open. To get around this paradox, the other authors must obtain the files another way. 
Here are some alternatives:

o Use a standalone source control client program on each client computer to download the 
files from the source control server. (For SourceSafe, use Visual SourceSafe Explorer. 
For WebDAV, several open source and commercial clients may be found on the 
WebDAV Projects web page.)

o If the source control server is also a file server on the local area network, simply copy the 
site files from the server to each client computer using Windows.

o On the client computer that was used to create the local site, use the Site Manager’s 
Export Site (p.353) command to save the site files in a zip archive. Distribute the zip 
archive to each team member (through email or any other method). On each client 
computer, use the Site Manager's Import Site (p.353) command to unpack the site to a 
local folder.
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The following outlines the tasks involved whenever you need to edit a source-controlled document:
1. Connect (p.381) to the source control server, if you are not already connected.
2. Check out (p.383) the documents to be edited.
3. Edit the documents.
4. Check the documents back into (p.383) the source control server.

Overview of source-controlled workflow

C o n n e c t i n g  t o  a  s o u r c e  c o n t r o l  s e r v e r

To connect to a SourceSafe server

1. If the source-controlled local site is not already open, open it now. (On the File menu, point to Site, 
and then click Open Site.)

2. Switch to the Site Manager.
3. On the Source Control menu, click Connect to Source Control Server.
4. Click the Source control type box and select VSS.
5. Enter your SourceSafe user name and password in the appropriate boxes.
6. Click Browse.
7. Under Available databases, select the desired SourceSafe database and click OK. (If the desired 

database is not listed, click Add, locate the desired database, select it, and click O pen.)
8. Click OK.
9. In the project tree, select the desired project, and then click OK.

t? You can create a new project on the SourceSafe server by clicking New Project in the S elect Source 
C ontro l P ro je c t dialog box.

To connect to a WebDAV server

1. If the source-controlled local site is not already open, open it now. (On the File menu, point to Site, 
and then click Open Site.)

2. Switch to the Site Manager.
3. On the Source Control menu, click Connect to Source Control Server.
4. Click the Source control type box and select WebDAV.
5. Click Browse.
6. Under Available databases, select the desired WebDAV profile and click OK. If the desired profile 

is not listed, click Add and do the following:
1. E n te r a nam e fo r the W e b D A V  p ro file .
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2. E n te r the U R L  o f  the W e b D A V  folder.

3. E n te r y o u r  u se r nam e, p a ssw o rld , and e -m a il address.

4. C l i c k  O K .

7. C l ic k  O K .

O n c e  y o u  are co n n e cted  to the so u rce  co n tro l server, N a m o  W e b E d ito r w il l  co m p a re  the list o f  f ile s  in  the 

lo c a l site w ith  the lis t  o f  f ile s  in  the S o u rce S a fe  p ro ject. I f  a n y  file s  in  the lo c a l site are not fo u n d  in  the 

S o u rce S a fe  p ro ject, the Add Files to Source Control d ia lo g  b o x  w il l  appear. I f  yo u  w ant to add file s  to 

so u rce  co n tro l n o w , sele ct them  and c l ic k  O K . O th erw ise, c l ic k  Cancel.

To disconnect from the source control server

• O n  the S o u rc e  C o n tro l m enu, c l ic k  D isco n n e ct.

0  When you disconnect from the server, Namo WebEditor will ask whether you want to use the same 
source control server the next time you connect. I f  you click Yes, the next time you use the Connect to  
Source C ontrol Server command, Namo WebEditor will connect immediately without prompting you to 
choose a server.
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A d d i n g  f i l e s  t o  s o u r c e  c o n t r o l

B e fo re  y o u r team  c a n  start c h e c k in g  file s  out o f  the so urce co n tro l database fo r ed iting, the entire site the 

team  is  w o rk in g  on  m u st be added (u p lo a d e d ) to the so u rce  co n tro l p ro je ct o r  fo ld er. D u rin g  the co u rse  o f  

the project, y o u  m a y  need to add m ore file s  p e rio d ic a lly , as w e ll. A d d in g  file s  to so u rce  co n tro l m akes them  

a v a ila b le  fo r y o u  o r o th er team  m em bers to c h e c k  them  out fo r editing.

To add site files to source control

1. S w itch  to the Site M a n a g e r and co n n ect (p.381) to the so u rce  co n tro l server.

2. In  the Site F ile s  pane, select the file s  to be added to so u rce  co n tro l. (N o te that a n y  d e sire d  file s  in  

su b fo ld e rs  m u st be e x p lic it ly  selected. S ele ctin g  the fo ld e r it s e lf  w il l  not w o rk .)

3. O n  the S o u rc e  C o n tro l m enu, c l ic k  A dd  to S o u rc e  Control.

4. C o n firm  that the d e sire d  file s  are selected in  the file  list. T o  e x clu d e  an y file  in  the list fro m  b e in g  

added, d e se le ct it.

5. C l ic k  O K .

W h e n  the file s  h ave s u c c e s s fu lly  been added to so u rce  control, a p a d lo c k  ic o n  l&  w il l  ap pear in  the S o u rc e  

Control co lu m n  o f  the Site F ile s  list fo r  each f ile  that is  u n d er so u rce  co n tro l, as in  the e x a m p le  b elo w :
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Site Res

Name ! 1 See State | Source Control |
¿SiNamo (b:WworkW...|
E * Q  images 
В П  products 
B * Q  support 

~[^014_btn_2.$wf 
abouthtml 
audio.gif 

”~ й  contacthtml 
~ index.html 

navbar.html

Files u n d er source contro l are in d icated  w ith  a  pad lock icon

Q  When you add new files to source control other team members must use a standalone source control 
client program (such as SourceSafe Explorer) or another method to download the new files to their 
computers for the first time. Nam о WebEditor cannot be used to retrieve files from the source control 
server that do not already exist in the local site on the client computer

1KB
2KB I I I
1KB
1KB a
5KB й
4KB й

C h e c k i n g  f i l e s  o u t  a n d  b a c k  i n

C h e c k in g  a f ile  out m eans d o w n lo a d in g  the latest v e rs io n  o f  the f ile  fro m  the so u rce  co n tro l s e rv e r and, at 

the sam e tim e, lo c k in g  the m aster c o p y  o n  the se rv e r so that other team  m em bers cannot re p la ce  it. W h e n  

y o u  h ave fin ish e d  e d itin g  a ch e ck e d -o u t file , y o u  sh o u ld  c h e c k  it b a c k  in — that is, u plo a d  the n e w  v e rs io n  

to the so u rce  co n tro l server, re p la c in g  the m aster c o p y  and u n lo c k in g  it.

To check files out

1. S w itch  to the Site M a n a g e r an d  co n n e ct (p.381) to the so u rce  co n tro l server.

2. In  the S ite  F ile s  pane, select the file s  to be c h e c k e d  out. (N o te  that an y d esired  file s  in  su b fo ld e rs  

m u st be e x p lic it ly  selected. S e le c tin g  the fo ld e r it s e lf  w i l l  not w o rk . A ls o , y o u  can n o t c h e c k  out a 

f ile  that is not u n d e r so u rce  c o n tro l.)

3 . O n  the S o u rc e  Control m enu, c l ic k  C h e c k  Out.

4. C o n fir m  that the d e sire d  f ile s  are selected  in  the file  list. T o  e x clu d e  an y file  in  the list fro m  b ein g  

c h e ck e d  out, deselect it.

5. C l i c k  O K .
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W h e n  the file s  h ave b een  s u c c e s s fu lly  ch e ck ed  out, a p a d lo c k -a n d -k e y  ic o n  w il l  ap p e a r in  the S o u rc e  

C ontrol co lu m n  o f  the S ite  F ile s  list  fo r each ch e ck ed -o u t file , as in  the exam ple b elo w :

^  Site Files

Name / 1 Size I State I Source Control
£ $  Namo [D:WworkW...
E - Q  images 
0 Q  products
S Q  support
p[^014_btn_2.$wf 1KB â

e §a b o u lh tm l^ ^ H 2KB
[“ ( â  audio.gif 1KB â
hullcontact. 1KB

index. 5KB « 1
lqinavbar.htrnl^^B 4KB *

C hecked -o u t files a re  in d ica ted  w ith  a pack lo ck-an d -key  icon 

To check files in

1. S w itch  to the S ite  M a n a g e r and co n n ect (p.381) to the so u rce  co n tro l server.

2. In  the Site F ile s  pane, select the file s  to be c h e ck e d  in. (N o te that a n y  d e sire d  file s  in  su b fo ld e rs  

m ust be e x p lic it ly  selected. S ele ctin g  the fo ld e r it s e lf  w ill  not w o rk . A ls o , the file s  to be ch e ck e d

in  m ust h a v e  ch e ck -o u t status, as in d icated  b y  a p a d lo ck -a n d -k e y  ic o n  ^ . )

3. O n  the S o u rc e  C o n tro l m enu, c l ic k  C h e c k  In.

4. C o n firm  that the d e sire d  file s  are selected in  the file  list. T o  e x clu d e  an y  f ile  in  the list  fro m  b e in g  

ch e ck e d  in, d e se le ct it.

5. I f  y o u  w ant to update the m aster co p ie s on the se rv e r but keep the file s  ch e ck e d  out so that y o u  can  

co n tin u e  to w o r k  o n  them, select the K e e p  th e se  file s  c h e c k e d  out c h e c k  box.

6. C l ic k  O K .

W h e n  a f ile  has been s u c c e s s fu lly  ch e ck e d  in, the p a d lo c k -a n d -k e y  ic o n  ^  in  the S o u r c e  Control co lu m n  

o f  the Site F ile s  list w i l l  re v e rt to a p a d lo c k  ic o n  £1.

R e t r i e v i n g  t h e  l a t e s t  v e r s i o n s  o f  f i l e s

A t  tim es, y o u  m ay w a n t to d o w n lo a d  the latest v e rs io n  o f  a f ile  fro m  the so u rce  c o n tro l s e rv e r w ithout, 

h o w ever, c h e c k in g  it out (a n d  thus lo c k in g  it against rep lacem en t b y  other team  m e m b e rs). T h is  is u se fu l
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w h e n  y o u  w ant to inspect, but not edit, the m ost up-to-d ate v e rs io n  on y o u r com puter, o r s im p ly  m a k e  sure  

y o u r lo c a l co p y  is  up to date.

To get the latest versions of files from the source control server

1. S w itch  to the Site M a n a g e r and co n n e ct (p.381) to the so u rce  control server.

2. In  the Site F ile s  pane, sele ct the f ile s  to be updated fro m  the server. (N o te  that a n y  d e sire d  file s  in  

sub fo ld ers m ust be e x p lic it ly  selected. S e le ctin g  the fo ld e r it s e lf  w ill  not w o rk . A ls o , y o u  can not  

update a file  that is  not u n d er so u rce  co n tro l.)

3. O n  the S o u rc e  C ontrol m enu, c l ic k  G e t L atest V e rsio n .

4. C o n firm  that the d e sire d  file s  a re  selected  in  the file  list. T o  e x clu d e  a n y  f ile  in  the list  fro m  b ein g  

updated, d eselect it.

5. C l ic k  O K .

R e m o v i n g  f i l e s  f r o m  s o u r c e  c o n t r o l

To remove files from source control

1. S w itch  to the Site M a n a g e r and co n n e ct (p.381) to the so urce co n tro l server.

2. In  the Site F ile s  pane, select the file s  to be re m o v e d  fro m  the server. (N o te  that an y  d esired  file s  in  

sub fo ld ers m ust b e e x p lic it ly  selected . S e le ctin g  the fo ld e r it s e lf  w ill  not w o rk . A ls o , y o u  can not  

rem o ve a f ile  that is  not u n d er s o u rc e  co n tro l.)

3. O n  the S o u rc e  C ontrol m enu, c l ic k  R e m o v e  from  S o u rc e  Control.

4. C o n firm  that the d e sire d  file s  are  selected  in  the file  list. T o  e x clu d e  an y  file  in  the list fro m  b ein g  

rem oved, d eselect it.

5. C l ic k  O K .

W h e n  the file s  have s u c c e s s fu lly  re m o v e d  so u rce  co n tro l, the p a d lo ck  ico n s l&  in  the S o u rc e  Control 

c o lu m n  o f  the S ite F ile s  list  fo r those f ile s  w i l l  d isa p p ear.
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7 Publishing and Maintaining a

Publishing is  the p ro ce ss  o f  u p lo a d in g  W e b  d o cu m en ts and reso u rce file s  that y o u  have created on y o u r  

co m p u ter to a W e b  server, so that pe o p le  on the Internet (o r  y o u r intranet) ca n  v ie w  them. T h e re  are tw o  

w a y s to p u b lish  w ith  N a m o  W e b E d ito r: the Quick Publish (p.392) co m m a n d  and the Publish (p.394) 
w in d o w .

B e fo re  p u b lish in g  fo r the first  tim e, y o u  n e e d  to d e fin e  a rem ote site (p.388) (a fo ld e r on a W e b  serv e r).

N a m o  W e b E d ito r also  in c lu d e s  several p o w e rfu l site m ainten ance tools in  the T o o ls  m enu. W ith  these tools,  

y o u  ca n  search fo r f ile s  b y  filen a m e, se a rch  and re p la ce  text throughout a site, ch an g e lin k s  throug ho ut a 

site, fin d  p ro b le m s w ith  h y p e rlin k s, and so  on. N a m o  W e b E d ito r can  also generate a site report, so y o u  can  

v ie w  im portant facts about y o u r site at a g la n ce.

In this section

Defining remote sites for publishing................................................................ p.388
Quick publishing.................................................................................................p.392
The Publish window........................................................................................... p.394
Opening and saving files directly on a Web server........................................p.404
Site maintenance.................................................................................................p.405
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Defining remote sites for publishing
A  remote site is  s im p ly  a fo ld e r on a W e b  server, into w h ic h  y o u  u p lo a d  the file s  that m ake up a W e b  site. 

B e fo re  y o u  p u b lish  a W e b  site, y o u  need to define at least one rem ote site— that is, y o u  need to tell N a m o  

W e b E d ito r w h e re  it sh o u ld  u p lo ad  the lo c a l site to.

T h e  p ro ce ss o f  d e fin in g  a rem ote site d iffe rs  d e p e n d in g  on the m ethod y o u  use to acce ss it. N a m o  

W e b E d ito r supports tw o a cce ss m ethods: File Transfer Protocol ( F T P )  and Windows file copy ( W in 3 2 ).  

F T P  is the standard m ethod o f  tra n sferrin g  file s  fro m  a co m p u ter to a W e b  server; it is  the m ost c o m m o n ly  

used m ethod o f  u p lo a d in g  W e b  sites. A lte rn a tiv e ly , i f  y o u r W e b  se rv e r h appens to be the sam e co m p u te r as  

the one y o u  ru n  N a m o  W e b E d ito r on, o r  i f  it is  on the sam e lo ca l area n e tw o rk  as y o u r com puter, then y o u  

can also use the W in 3 2  m ethod, w h ic h  uses the b u ilt-in  file  c o p y in g  a b ilit ie s  in  W in d o w s  (m u c h  the sam e  

as w hen y o u  c o p y  file s  fro m  fo ld e r to fo ld e r in  W in d o w s  E x p lo re r).

Required information for defining a site

I f  yo u  w il l  a cce ss the rem ote site u sin g  F T P , N a m o  W e b E d ito r needs the fo llo w in g  in fo rm atio n . ( I f  y o u  do  

not m anage the s e rv e r y o u rse lf, y o u  sh o u ld  get this in fo rm a tio n  fro m  y o u r W e b  hosting p ro v id e r o r  

netw ork a d m in istra to r.)

• H o s t  n a m e : T h e  W e b  server's  nam e as used  w h en  a cce ss in g  the se rv e r b y  F T P . F o r  exam ple,  

" ftp .e x a m p le .co m ".

•  P o r t  n u m b e r: T h e  port o n  w h ic h  the se rv e r accepts F T P  co n n e ctio n s. T h is  is  u su a lly  2 1 .

• D ir e c t o r y :  T h e  path o f  the fo ld e r to w h ic h  the site file s  w il l  be u plo ad ed . O n  m an y serve rs, this is  

either "/"  o r " /p u b lic _ h tm l", alth o u gh  it c o u ld  be anyth in g else. L e a d in g  and tra ilin g  sla sh es are  

optional.

• U s e r  n a m e : T h e  nam e y o u  use to lo g in  to the F T P  server.

• P a s s w o rd : T h e  p a ssw o rd  y o u  u se  w h e n  lo g g in g  on to the F T P  server.

I f  yo u  w ill  a cce ss the rem ote site u sin g  the W in 3 2  (W in d o w s  file  c o p y ) m ethod, N a m o  W e b E d ito r o n ly  

needs to k n o w  the path o f  the fo ld e r. O n  W in d o w s  servers, this is  often "C :\In e tp u b \w w w ro o t" o r a 

su b fo ld e r o f  it.

Optional HTTP information

W h e n  d e fin in g  a rem ote site, y o u  can  o p tio n a lly  enter the base U R L  that w i l l  be used to a cce ss the site in  a  

W e b  b ro w ser. N a m o  W e b E d it o r  uses this in fo rm a tio n  to associate the rem ote site w ith  a p a rtic u la r W e b  

(H T T P )  U R L .  A ft e r y o u  p u b lish  y o u r site, i f  y o u  o p en  a d o cum en t o n  it d ire c tly  b y  entering its U R L  in  the 

O pen d ia lo g  box, and then save the docum ent, N a m o  W e b E d ito r w i l l  re co g n iz e  the U R L  and au to m a tica lly  

connect to the rem ote site to save the d o cu m e n t d ire ctly  to it. Y o u  do not need to enter an H T T P  U R L  i f  

y o u  do not intend to o p en  docu m en ts o n  the site d ire c tly  b y  u sin g  the U R L  b o x  in  the O pen d ia lo g  box.
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If you do enter an HTTP URL in a remote site definition, make sure to include "http://" at the beginning of 
the URL, and do not include a file name at the end of the URL. Example: "http://www.example.com/".

In this section

Defining a remote site using FTP......................................................................p.389
Defining a remote site using Windows file copy............................................ p.390

D e f i n i n g  a  r e m o t e  s i t e  u s i n g  F T P

Remote.Site,Settlnĝ

ftp.exampie.ccfn

/pub&c.html/acme

smith

S¡te £)ame: jAcme Trinkets

; FTP in fo rm ation------
Ho^t name:

directory:

Us£r name:

£as:word |

F? Pa;:ivemode

HTTP information

U R L |http://www.exarnpie com/acme|

Type: [FTP 3  

Pfict [2 T

Cancel

D efin in g  a rem ote site (F T P  access m eth o d )

To define a remote site using FTP

1. On the File menu, click Remote Sites.
2. Click Add.
3. In the Site name box, type a name for this remote site. (The name can be anything you like.)
4. Leave the Type box set to FTP.
5. Under FTP target information, enter the FTP server's host name and port number; the path o f the 

folder to contain the site files; and your user name and password for accessing the FTP server.
(For more information about these items, see Defining remote sites for publishing, p.388.)

o If you want Namo WebEditor to remember your password instead of prompting you for it 
every time you connect to the FTP server, select the Remember password check box.
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o If you need to connect to the FTP server using passive mode, select the Passive mode 
check box. (Your Web hosting provider or network administrator can tell you if this is 
necessary.)

6. (Optional) Under HTTP information, enter the base URL that will be used to access the site in a 
Web browser. (See Defining remote sites for publishing, p.388.)

7. Click OK, and then click Close if you are finished defining remote sites, or click to New to define 
another remote site.

D e f i n i n g  a  r e m o t e  s i t e  u s i n g  W i n d o w s  f i l e  c o p y

D efin in g  a rem ote site (W in 3 2  access m ethod)

To define a remote site using Win32

1. On the File menu, click Remote Sites.
2. Click Add.
3. In the Site name box, type a name for this remote site. (The name can be anything you like.)
4. Click the Type box and select Win32.

Related topics

Defining a remote site using Windows file copy .p.390

Ш
Site name: |Acme Trinkets Type: I Win32 ▼!

г  Local/network information

Eath: I С: M netpub\wwwroot\acme\ Browse...

r  HTTP information

U R L I http://www. example, com/acme

OK I Cancel |
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5. U n d e r Local/netw ork information, enter the path o f  the fo ld e r that w il l  co n ta in  the site file s. ( C l i c k  

Browse to fin d  and select a fo ld e r.)

6. (O p tio n a l) U n d e r H T T P  information, enter the base U R L  that w il l  be u sed  to a cce ss the site in  a 

W e b  b ro w ser. (S e e  D e fin in g  rem ote sites fo r p u b lish in g , p .3 8 8 .)

7. C l ic k  O K , and then c l ic k  Close i f  y o u  are fin ish e d  d e fin in g  rem ote sites, o r c l ic k  to N ew  to d e fin e  

another rem ote site.

Related topics

Defining a remote site using FTP p.389
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Quick publishing
W h e n  y o u  are w o rk in g  w ith  a lo c a l site, y o u  ca n  p u b lish  one o r m o re file s  in  the lo ca l site to a p re sp e c ifie d  

W e b  site w ith  a s in g le  com m and, c a lle d  Q u ic k  P u b lish . W h e n  y o u  use Q u ic k  P u b lish , N a m o  W e b E d ito r  

im m e d ia te ly  u p lo a d s the selected f ile (s )  to the rem ote site w itho ut fu rth er interaction . Q u ic k  P u b lish  is  

great fo r q u ic k ly  u pd a tin g  m o d ifie d  file s  on a rem ote site after y o u  edit them. Q u ic k  P u b lish  is  o n ly  

a v a ila b le  w h e n  y o u  h a ve  a lo ca l site o p en  in  the Site M a n a g e r.

B e fo re  u sin g  Q u ic k  P u b lish  w ith  a p a rtic u la r lo c a l site fo r the first tim e, y o u  need to h ave d e fin e d  at least 

one rem ote site and then sp e c ifie d  the rem ote site to use fo r q u ic k -p u b lish in g  the lo ca l site. (S e e  P rep a rin g  

to use Q u ic k  P u b lish , p .3 9 2 .) O n ce  y o u 'v e  d one that, a ll it takes is  tw o c lic k s  to u p lo a d  the entire site o r  

selected file s  to the rem ote site.

In this section

Preparing to use Quick Publish 
Using Quick Publish................

P r e p a r i n g  t o  u s e  Q u i c k  P u b l i s h

B e fo re  u sin g  Q u ic k  P u b lish  fo r a n y  g iv e n  lo c a l site, y o u  need to do (o r  h ave a lrea d y  d o n e) tw o things:

• Define the rem ote site to w h ic h  the lo c a l site w ill  be u plo ad ed . (S e e  D e fin in g  rem ote sites fo r  

p u b lish in g , p .3 8 8 .)

• Specify the rem ote site to w h ic h  the lo c a l site w ill  be u plo ad ed .

W h e n  y o u  d e fin e  a rem ote site, it is  not a sso ciated  w ith  a n y  p a rtic u la r lo c a l site. T hat's w h y  y o u  also  need  

to s p e c ify  the rem ote site to use fo r the cu rre n t lo ca l site.

To specify a remote site for the local site

1. S w itc h  to the S ite M a n a g e r.

2 . O n  the File  m enu, c l ic k  S ite  P ro p erties.

3. C l ic k  the Publish to bo x and select the d e sire d  rem ote site. ( I f  y o u  have not yet d e fin e d  the rem ote  

site y o u  w a n t to use, c l ic k  the ... button to d e fin e  it n o w .)

4. C l ic k  OK.

.p.392

.p.393

392 Quick publishing



Chapter 7: Publishing and Maintaining a Site

Related topics

Defining remote sites for publishing................................................................ p.388

U s i n g  Q u i c k  P u b l i s h

O n ce  y o u  have prepared (p.392) N a m o  W e b E d ito r to use Q u ic k  P u b lish  fo r the current lo ca l site, y o u  can  

p u b lish  the entire site, o r selected files, w ith  ju s t  tw o c lic k s .

To quick-publish the current local site

1. In  the Site Files pane o f  the Site M an a ger, c l ic k  the ico n  o r  nam e o f  the cu rre n tly  o p en  lo c a l site.

2. O n  the File m enu, click Quick Publish.

To quick-publish one file in the current local site

• In  the Site Files pane o f  the Site M an a ger, r ig h t-c lic k  the ic o n  o r nam e o f  the file  y o u  w ant to 

p u b lish , and then c lic k  Quick Publish.

To quick-publish several files in the current local site

• In  the Site Files pane o f  the Site M a n a g e r, select each file  y o u  w ant to p u b lish . (T o  select adjacen t  

files, d raw  a box around them  w ith  the m ouse. T o  select non -a djacen t files, c l ic k  e a ch  w h ile  

h o ld in g  d o w n  the C trl k e y .)

• O n  the File m enu, c lic k  Q u ick Publish.

To quick-publish the current document in the main window

• O n  the File m enu, click Quick Publish.

u J  You can only Quick Publish a document that belongs to a local site.

Related topics

Preparing to use Quick Publish......................................................................... p.392

Quick publishing 393



Ñamo WebEditor 6 User Manual

The Publish window
U se  the Publish w in d o w  to u p lo a d  lo c a l f ile s  o r an entire lo ca l site to a W e b  server. Y o u  ca n  a lso  d o w n lo a d  

file s  fro m  a W e b  s e rv e r to y o u r lo c a l f ile  system .

T o  open the P u b lish  w in d o w , do one o f  the fo llo w in g :

• In  N a m o  W e b E d it o r’s m a in  w in d o w :

o  O n  the F ile  m enu, c l ic k  P ublish, 

o  O n  the Standard T o o lb a r, c l ic k  ©  (P u b lish ).

• In  the S ite  M a n a g e r w in d o w :

o  O n  the F ile  m enu, c l ic k  P ublish.

o O n  the toolbar, c l ic k  ©  (P u b lish ).
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T h e  Publish w indow

T h e  w in d o w  is  d iv id e d  into several panes. T h e  left s id e  sh o w s the lo c a l file s  an d  fo ld e rs  and a p re v ie w  o f  

the selected lo ca l file . T h e  rig h t side sh o w s the file s  and fo ld e rs  on the W e b  s e rv e r and a  p re v ie w  o f  the 

selected rem ote file . T h e  bottom  pane sh o w s the re su lts o f  the last operation.

Basic steps to publish a local site

1. D e fin e  the rem ote site (p.388) to u p lo a d  the lo c a l site to, i f  y o u  h ave not d e fin e d  it yet.
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2. O p en  the site in  the Site M a n a g e r, i f  it is  not a lre a d y  open.

3. C l ic k  the P u b lish  button o r  p re ss  F 4 .

4. C l ic k  Connect Remote Site, an d  then d o u b le -c lic k  the d e sire d  rem ote site.

5. O n  the File m enu, c l ic k  Publish Entire Site.

Basic steps to publish individual files

1. D e fin e  the rem ote site (p.388) to u p lo a d  the lo c a l f ile s  to, i f  y o u  h ave not d e fin e d  it yet.

2. C l ic k  the P u b lish  button o r  p re ss  F 4 .

3. C l ic k  Connect Remote Site, an d  then d o u b le -c lic k  the d esired  rem ote site.

4. In  the lo c a l pane, select the f ile s  y o u  w ant to p u b lish .

5. C l ic k  Upload o r M irror Upload, d ep e n d in g  on  h o w  y o u  w ant to u p lo a d  the file s  (se e  U p lo a d in g  to a 

rem ote site, p .3 9 8 ).

In this section

Understanding Site Mode vs. Explorer Mode................................................. p.395
Selecting files for publishing..............................................................................p.397
Uploading to a remote site .................................................................................p.398
Downloading from a remote site.......................................................................p.400
Deleting files on a remote site........................................................................... p.401
Changing access permissions of remote files and folders............................. p.401

Related topics

Quick publishing.................................................................................................p.392
Opening and saving files directly on a Web server........................................ p.404

U n d e r s t a n d i n g  S i t e  M o d e  v s .  E x p l o r e r  M o d e

T h e  Publish w in d o w  has tw o m odes: Site Mode an d  Explorer Mode. W h ic h  m ode is  in it ia lly  active  w h en  

y o u  open the Publish w in d o w  d e p e n d s on w h eth er a lo c a l site is  open in  the Site M a n a g e r. I f  a lo c a l site is  

open, the P u b lish  w in d o w  w ill  in it ia lly  be in  Site M o d e , but y o u  can  sw itch  to E x p lo re r M o d e . I f  n o  lo ca l  

site is  open, the P u b lish  w in d o w  w ill  b e  in  E x p lo re r M o d e , and y o u  can not sw itch  to Site M o d e.

Explorer Mode

In  E x p lo re r M o d e , the lo c a l pane o f  the Publish w in d o w  d isp la y s  a ll the file s  and fo ld e rs  on one d riv e  on  

y o u r com puter. (Y o u  ca n  ch o o se the d riv e  u sin g  the d riv e  b o x  in  the top righ t c o m e r o f  the pane.) In  this  

m ode, y o u  can  u p lo a d  a n y  f ile  o r fo ld e r o n  y o u r co m p u te r to a rem ote site. E v e n  i f  y o u  are not w o rk in g  

w ith  a lo c a l site m anaged b y  N a m o  W e b E d ito r, y o u  ca n  p u b lish  y o u r site file s  in  E x p lo re r  M o d e.
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The local pane of the Publish window in Explorer Mode

Site Mode

In  Site M o d e , the lo c a l pa n e o f  the Publish w in d o w  d isp la y s  o n ly  the file s  and fo ld e rs  that are part o f  the 

cu rren t lo c a l site. T h is  m akes it e a sie r to fin d  the file s  y o u  w ant to u pload, but the m a jo r advantage o f  Site  

M o d e  is  that it en ab les the Mirror Upload com m and, w h ic h  is  not a v a ila b le  in  E x p lo re r  M o d e . W ith  M ir ro r  

U p lo a d , y o u  can  select f ile s  and fo ld e rs  a n yw h ere on the lo c a l site and, w ith  one c lic k ,  u p lo a d  them  to the 

m a tch in g  lo ca tio n s o n  the rem ote site, w itho ut w o rry in g  about w h ic h  fo ld e r y o u  are in  o n  the rem ote site. 

(S e e  U p lo a d in g  to a rem ote site, p .3 9 8 .)
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The local pane o f the Publish window in Site M ode

To switch between Site Mode and Explorer Mode

D o  one o f  the fo llo w in g :

• O n the toolbar, c l ic k  ©  (S ite  M o d e ) o r  EES (E x p lo re r M o d e ).

• O n  the V ie w  m enu, c l ic k  S ite M o d e  o r E x p lo re r M ode.

(Y o u  ca n  o n ly  sw itch  betw een m o d es i f  a lo c a l site is  open in  the Site M a n a g e r.)

S e l e c t i n g  f i l e s  f o r  p u b l i s h i n g

T h e  fo llo w in g  are so m e tips fo r sele ctin g  f ile s  an d  fo ld e rs  in  the Local pane o f  the Publish w in d o w . O n c e  

y o u  h a ve  co n n e cted  to a rem ote site and sele cte d  one o r m o re lo c a l item s, y o u  can  p u b lish  them  b y  c l ic k in g  

the Upload button o r the M irror Upload button (a v a ila b le  in  Site M o d e  (p.395) o n ly ).

General selection methods

• T o  se le ct one item , c l ic k  it.

• T o  sele ct se v e ra l adjacen t item s, d ra w  a b o x  aro un d  them  w ith  the m ouse.

• T o  sele ct seve ra l nona djacen t item s, c l ic k  each  w h ile  h o ld in g  d o w n  the Ctrl key.

• T o  sele ct a ll item s, p ress Ctrl+A.
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Special selection commands

T h e  fo llo w in g  co m m a n d s in  the Publish w in d o w 's  Edit m enu are a lw a y s  ava ila b le .

• Select All: S elects a ll file s  and fo ld e rs

• Select Open Documents: S elects a ll d o cu m en ts that are op en  in  N a m o  W e b E d ito r

• Select M odified Documents: S elects a ll op en  docum ents that h ave un saved  changes

• Select Linked Files: S elects a ll d o cu m en ts and re so u rce  file s  to w h ic h  the cu rre n tly  selected  

d o c u m e n t(s) have lin k s

• Select Transfer-Failed Files: S elects a ll f ile s  that co u ld  not be transferred in  the last u p lo a d  o r  

d o w n lo a d  o p eratio n

• Invert Selection: In ve rts  the cu rren t sele ctio n  (the cu rre n tly  selected  item s are d eselected and the 

cu rre n tly  u n sele cte d  item s are selected )

Additional selection commands in Site Mode

T h e  fo llo w in g  co m m a n d s in  the Publish w in d o w ’s Edit m enu are o n ly  a v a ila b le  in  Site M o d e  (p.395).

• Select Unique Local Files: S elects a ll f ile s  that exist on the lo c a l site but not on  the rem ote site.

• Select Unique Remote Files: S elects a ll f ile s  that e xist on the rem ote site but not on  the lo c a l site.

Related topics

Understanding Site Mode vs. Explorer Mode.................................................. p.395

U p l o a d i n g  t o  a  r e m o t e  s i t e

The Publish window has three commands for transferring files from your computer to a remote site (a 
folder on a Web server):

• The Publish Entire Site command, available only in Site Mode (p.395), copies an entire local site to 
a remote site.

• The Mirror Upload command, available only in Site Mode (p.395), automatically copies selected 
local files and/or folders to their corresponding locations on a remote site, regardless of the 
current remote folder. For example, if the path (relative to the site's root folder) of a selected local 
file is "/global/images/example.gif', the Mirror Upload command will copy the file to the same 
location—''/global/images/example.gif'— on the remote site, no matter what the current remote 
folder is. If several local files in various folders are selected, the Mirror Upload command will copy 
each of them to its appropriate location on the remote site.

• The Upload command copies selected local files and/or folders to the current folder on a remote 
site. (See "Determining the current remote folder" below.)
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To upload an entire local site

1. I f  the Publish w in d o w  is  not open, p re ss  F 4  to o p en  it.

2. O n  the toolbar, c l ic k  @  (C o n n e c t  R e m o te  S ite).

3. D o u b le -c lic k  the rem ote site to u p lo a d  to. ( I f  y o u  h a ve  not d e fin e d  an y  rem ote sites, c l ic k  A d d  and  

d e fin e  o ne as d e crib e d  in  D e fin in g  rem ote sites fo r p u b lis h in g  (p.388).) N a m o  W e b E d it o r w i l l  n o w  

c o n n e ct to the rem ote site.

4 . O n  the File m enu, c lick  Publish Entire Site.

To upload selected Files and/or folders to a remote site

1. I f  the Publish w in d o w  is  not open, p re ss  F 4  to o p en  it.

2. O n  the toolbar, c l ic k  ©  (C o n n e c t  R e m o te  S ite).

3. D o u b le -c lic k  the rem ote site to u p lo a d  to. ( I f  y o u  h ave not d e fin e d  an y  rem ote sites, c l ic k  A d d  and  

d e fin e  one as d e crib e d  in  D e fin in g  rem ote sites fo r p u b lis h in g  (p.388).) N a m o  W e b E d it o r w i l l  n o w  

co n n e ct to the rem ote site.

4 . In  the L o ca l pane, select (p.397) the f ile s  a n d /o r fo ld e rs  y o u  w a n t to u pload .

5. C l ic k  (M irro r U p lo a d). N a m o  W e b E d it o r w il l  c o p y  the selected  file s  to th eir co rre sp o n d in g  

lo ca tio n s on the rem ote site au to m a tica lly .

To upload selected files and/or folders to a specific remote folder

1. I f  the Publish w in d o w  is  not open, p re ss  F 4  to open it.

2. O n  the toolbar, c l ic k  (C o n n e c t  R e m o te  Site).

3 . D o u b le -c lic k  the rem ote site to u p lo a d  to. ( I f  y o u  h a ve  not d e fin e d  a n y  rem ote sites, c l ic k  A d d  and 

d e fin e  one as d e crib e d  in  D e fin in g  rem ote sites fo r p u b lis h in g  (p.388).) N a m o  W e b E d it o r  w i l l  n o w  

co n n e ct to the rem ote site.

4. In  the L o ca l pane, select (p.397) the f ile s  a n d /o r fo ld e rs  y o u  w a n t to u pload.

5. In  the R em o te pane, select the fo ld e r to w h ic h  y o u  w a n t to u p lo a d  the lo c a l item s. (N o te  that the 

rem ote site's root fo ld e r is  in it ia lly  selected .)

6. C l i c k  (U p lo a d ).

Determining the current remote folder

N a m o  W e b E d it o r  u ses the fo llo w in g  ru le s  to d eterm ine w h ic h  rem ote fo ld e r is  cu rren t— that is, w h ic h  

rem ote fo ld e r w i l l  be the destin ation o f  an  U p lo a d  co m m an d  at an y  g iv e n  tim e. (T h e  cu rren t rem ote fo ld e r  

is  not rele va n t w h e n  y o u  use the M irror U p lo a d  co m m a n d .)

•  W h e n  y o u  co n n ect to a rem ote site, the cu rren t fo ld e r is  in it ia lly  the site's root (to p -le v e l) fo ld e r.

• I f  a  fo ld e r is  selected (h ig h lig h te d ), it is  the cu rren t fo ld er.

•  I f  a f ile  is  selected, the fo ld e r that co n ta in s it is  the cu rre n t fo ld e r.

•  I f  item s in  m u ltip le  fo ld e rs  are selected, the last selected item  d eterm ines the cu rre n t fo ld er.
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D o w n l o a d i n g  f r o m  a  r e m o t e  s i t e

In addition to using the Publish window to upload local files to a remote site, you can also download 
remote files to your computer. This capability is especially useful if you have accidentally deleted local site 
files on your computer.

The Publish window has two commands for transferring files from a remote site to your computer:

• The Mirror Download command, available only in Site Mode (p.395), automatically copies selected 
remote files and/or folders to their corresponding locations on the current local site, regardless of 
the current local folder. For example, if the path (relative to the site's root folder) of a selected 
remote file is "/global/images/example.gif', the Mirror Download command will copy the file to the 
same location—"/global/images/example.gif'— on the local site, no matter what the current local 
folder is. If  several remote files in various folders are selected, the Mirror Download command will 
copy each o f them to its appropriate location on the local site.

• The Download command copies selected remote files and/or folders to the current fo lde r  on the 
local site or file system. (See "Determining the current local folder" below.)

To download selected files and/or folders to a local site

1. If the Publish window is not open, press F4 to open it.

2. On the toolbar, click (Connect Remote Site).
3. Double-click the remote site to download from. Namo WebEditor will now connect to the remote 

site.
4. In the Remote pane, select (p.397) the files and/or folders you want to download.

5. Click (Mirror Download). Namo WebEditor will copy the selected files to their corresponding 
locations on the local site automatically.

To download selected files and/or folders to a specific local folder

1. If the Publish window is not open, press F4 to open it.

2. On the toolbar, click © (Connect Remote Site).
3. Double-click the remote site to download from. Namo WebEditor will now connect to the remote 

site.
4. In the Remote pane, select (p.397) the files and/or folders you want to download.
5. In the Local pane, select the folder to which you want to download the remote items. (In Explorer 

Mode, you can change to a different drive by selecting it from the box in the upper-right comer of 
the Local pane.)
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Determining the current local folder

Namo WebEditor uses the following rules to determine which local folder is current—that is, which local 
folder will be the destination of a Download command at any given time. (The current local folder is not 
relevant when you use the Mirror Download command.)

• When you open the Publish window, the current folder is initially the local site or file system’s 
root (top-level) folder.

• If a folder is selected (highlighted), it is the current folder.
• If a file is selected, the folder that contains it is the current folder.
• If items in multiple folders are selected, the last selected item determines the current folder.
• If no folder or file is selected, the current folder is the local site or file system's root folder.

6. Click &  (Download).

D e l e t i n g  f i l e s  o n  a  r e m o t e  s i t e

To delete files and/or folders on a remote site

1. If the Publish window is not open, press F4 to open it.
2. On the toolbar, click ©  (Connect Remote Site).
3. Double-click the remote site containing the items you want to delete. Namo WebEditor will now 

connect to the remote site.
4. In the Remote pane, select (p.397) the items you want to delete.
5. On the toolbar, click X  (Delete).

Be careful when deleting files on a remote site. Deleted remote files are generally not recoverable.

C h a n g i n g  a c c e s s  p e r m i s s i o n s  o f  r e m o t e  f i l e s  a n d  

f o l d e r s

0  Namo WebEditor can only change access permissions on servers that run Unix or a Unix-like 
operating system, not Windows.
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On Web servers that run Unix or Linux, the operating system controls access to files and folders through a 
system of access permissions (also called file permissions). Administrators can permit or deny read, write, 
or execute access to each file or folder, and these permissions can be set independently for the owner of the 
file, the group of users to which the owner belongs, and others (everyone else).

Files and folders that are part of a Web site must have these permissions set in such a way as to allow the 
Web server program to access them. If your Web site is hosted by a third-party provider, the administrator 
will most likely have set the permissions correctly when you opened your account, and no further action 
should be necessary. However, if you are setting up your own Web server, you may find it convenient to 
modify access permissions at the same time you upload your site files to the server. You can use the 
Change Permissions command in the Publish window to do so.

A discussion of appropriate access permissions is beyond the scope of this user's guide. If you need to 
change access permissions but are not sure what the appropriate permissions are, please contact your Web 
server administrator or consult your Web server documentation.

To change the access permissions of a remote file or folder

1. If the Publish window is not open, press F4 to open it.

2. On the toolbar, click ■© (Connect Remote Site).
3. Double-click the desired remote site. Namo WebEditor will now connect to the remote site.
4. In the Remote pane, select (p.397) the item or items for which you want to change access 

permissions.
5. On the File menu, click Change Permissions.

-Change Permissions _

Owner (-Group Others

F7 fiead (r) W Read(r) 17 Read (0
W Write (w) H  Write (w) V Write (w)

V £xecute(x) P  Execute (x) F  Execute (x)

Octal code: 

Quick setup

[mT

fPufanc [644Ï1I Cgl [755) Private [600]

QK Cancel

6. Do any of the following to set the desired permissions:
o Select and/or clear check boxes under Owner, Group, and/or Others, 
o Enter an octal code in the Octal code box.
o Click a button under Quick Setup to quickly set one of three common permission modes.
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7. Click OK.

Changing the access permissions o f  a fo lder does not affect the permissions o f  any files  or subfolders 
in it.

I f  Namo WebEditor fa ils  to set the specified access permissions, it may be because the Web server 
administrator has disabled permission changes by users.
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Opening and saving files directly on a Web 
server
You can open a document on a Web server, edit it, and then re-save it directly to the server without 
manually downloading and uploading it. This only works if you have read/write permissions for the file on 
the server.

The commands for opening and saving files directly on a Web server use the same list of remote sites 
(p.388) as the Publish window. Before you can use these commands, you must define at least one remote 
site.

To open a file on a Web server

1. On the File menu, click Open on Web Server.
2. Click the Remote site box and select a remote site. If you have not yet defined any remote sites, 

click the ... button to open the Remote Sites dialog box.
3. Navigate to the desired file, select it, and then click Open.

To save a file directly to a Web server

1. On the File menu, click Save on Web Server.
2. Click the Remote site box and select a remote site. If you have not yet defined any remote sites, 

click the ... button to open the Remote Sites dialog box.
3. Navigate to the desired folder and then click Save. (If the current file was opened from the same 

site, the original directory will already be displayed.)

0  When you open a file directly from a Web server, Namo WebEditor copies the file to a temporary local 
file. I f  you edit the file and use the Save command (rather than Save on Web Server) to save your 
changes, Namo WebEditor will only save the temporary file and not upload the edited file to the server. 
To save your changes to the Web server, make sure to use the Save on Web Server command.

Related topics

The Publish window........................................................................................... p.394
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Site maintenance
Namo WebEditor includes a host of site management tools, most of which can be found in the Tools menu 
in either the Site Manager or the main window.

In this section

Finding files........................................................................................................ p.405
Finding and replacing text throughout a site................................................... p.406
Finding broken links...........................................................................................p.409
Finding orphan files............................................................................................p.410
Checking external links...................................................................................... p.411
Changing character sets throughout a site........................................................p.412
Changing hyperlinks and file names to lowercase..........................................p.413
Viewing a site report.......................................................................................... p.414

F i n d i n g  f i l e s

You can use the Find Files command to search a local site or folder for files that match a specified name or 
name pattern. If you search a local site, the search will automatically include all of the site's subfolders as 
well as the site folder. If you search a folder, you can choose whether to include subfolders.

The Find Files command supports wildcard characters similar to those used in DOS commands:

• A question mark ('?') matches any single character. (Example: photo_?. html matches 
Mphoto_l.html” and "photo_2.htmr.)

• An asterisk ('*') matches any string of characters, including zero-length strings. (Example: 
photo* .htm* matches "photo.html" and "photo_3.htm”.)

To search for files in the current local site

1. On the Tools menu, click Find Files.
2. In the File name box, type the file name, partial file name, or pattern to search for; or click the 

triangle and choose from a list of recently searched items.
3. Select site in Search in. (This option is only available if a local site is open.)
4. Click Find.
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The search results will be displayed in the result box at the bottom of the Find Files window. You can open 
a found document by double-clicking its file name in the list.

To search for files in a specific folder

1. On the Tools menu, click Find Files.
2. In the File name box, type the file name, partial file name, or pattern to search for; or click the 

triangle and choose from a list of recently searched items.
3. Click Foler in Search in, and then enter the path of the desired folder in the box. You can click 

Browse to locate and select a folder, or click the triangle to choose from a list of recently searched 
folders.

4. If you want to include subfolders of the specified folder in the search, click Include subfolders.
5. Click Find.

The search results will be displayed in the result box at the bottom of the Find Files window. You can open 
a found document by double-clicking its file name in the list.

F i n d i n g  a n d  r e p l a c i n g  t e x t  t h r o u g h o u t  a  s i t e

Use the Global Find & Replace command to search for, and optionally replace, specified text in all the files 
in a local site or folder. If you search a local site, the search will automatically include all of the site's 
subfolders as well as the site folder. If you search a folder, you can choose whether to include subfolders.

The Global Find & Replace command does not support the use of wildcard characters. Please use an exact 
search string.

GD Be careful when performing a global replace. This operation cannot be undone.

To search for text in the current local site

1. Do one of the following:
o On the Edit menu in the main window, click Global Find & Replace, 
o On the Tools menu in the Site Manager window, click Global Find & Replace.

2. In the Find box, type the text to search for, or click the triangle and choose from a list of recently 
searched items.

3. Click Find in site. (This option is only available if a local site is open.)
4. Select the options to use for the search. (See Selecting search options, p.408 below.)
5. Click Find.
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The files containing the search text will be listed in the result box at the bottom of the Global Find & 
Replace window. You can open a document in the list by double-clicking its file name.

To search for and replace text in the current local site

1. Do one of the following:
o On the Edit menu in the main window, click Global Find & Replace, 
o On the Tools menu in the Site Manager window, click Global Find & Replace.

2. In the Find box, type the text to search for, or click the triangle and choose from a list of recently 
searched items.

3. Click Replace with and type the replacement text, or click the triangle and choose from a list of 
recently used replacement items.

4. Click Find in site. (This option is only available if a local site is open.)
5. Select the options to use for the search. (See Selecting search options, p.408 below.)
6. Click Replace.

Namo WebEditor will ask you to confirm starting the operation. When the operation is finished, the 
affected files will be listed in the result box at the bottom of the Global Find & Replace window. You can 
open a document in the list by double-clicking its file name.

To search for text in a specific folder

1. Do one of the following:
o On the Edit menu in the main window, click Global Find & Replace, 
o On the Tools menu in the Site Manager window, click Global Find & Replace.

2. In the Find box, type the text to search for, or click the triangle and choose from a list of recently 
searched items.

3. Click Find in folder, and then enter the path of the desired folder in the box. You can click Browse 
to locate and select a folder, or click the triangle to choose from a list of recently searched folders.

4. If you want to include subfolders of the specified folder in the search, click Include subfolders.
5. Select the options to use for the search. (See Selecting search options, p.408" below.)
6. Click Find.

The files containing the search text will be listed in the result box at the bottom of the Global Find & 
Replace window. You can open a document in the list by double-clicking its file name.

To search for and replace text in a specific folder

1. Do one of the following:
o On the Edit menu in the main window, click Global Find & Replace, 
o On the Tools menu in the Site Manager window, click Global Find & Replace.

2. In the Find box, type the text to search for, or click the triangle and choose from a list of recently 
searched items.
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3. Click Replace with and type the replacement text, or click the triangle and choose from a list of 
recently used replacement items.

4. Click Find in folder, and then enter the path of the desired folder in the box. You can click Browse 
to locate and select a folder, or click the triangle to choose from a list of recently searched folders.

5. If you want to include subfolders of the specified folder in the search, click Include subfolders.
6. Select the options to use for the search. (See Selecting search options, p.408 below.)
7. Click Replace.

Namo WebEditor will ask you to confirm starting the operation. When the operation is finished, the 
affected files will be listed in the result box at the bottom of the Global Find & Replace window. You can 
open a document in the list by double-clicking its file name.

Selecting search options

• Find in HTML documents only: select this if you want to exclude non-HTML files (such as CSS 
stylesheets) from the search.

• Find in hyperlinks only: select this if you want to limit the search just to the URLs of hyperlinks. 
This option is extremely useful for changing many links in one operation, without affecting other 
content. For example, you can search for links containing "www.example.com" and replace the 
site name with "www.namo.com", without replacing any instance of "www.example.com" that 
might exist in the text content of your documents.

• Match case: select this if you want to exclude occurrences of the search text that do not match the 
case of the specified text. For example, if you select this option and search for "Namo WebEditor", 
any occurrences of "namo webeditor" and "NAMO WEBEDITOR" will not be included in the 
results.

• Match whole words only: select this if you want to exclude any occurrence of the search text that is 
part of another word. For example, if you select this option and search for "photo", any occurrence 
of "photograph" will not be included in the results.

• Match full-/half-width: select this if you are searching for double-byte Asian text and you want to 
exclude occurrences of the search text that are not the same width as the specified text. This option 
has no effect when searching ordinary (Western) text.

• Find in HTML sources: select this if you want Namo WebEditor to search the HTML source code 
of documents, rather than the text that is visible in Edit mode or a browser. For example, use this 
option if you want to search for the file name of an image that may be used in one or more 
documents.
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F i n d i n g  b r o k e n  l i n k s

Use the Find Broken Links command to search a local site or folder for local hyperlinks that point to 
nonexistent documents or resources. The command will find both broken links and broken src references 
(such as in image tags). If any broken links are found, you can use the Global Find & Replace (p.406) 
command to replace them with valid links.

0  The Find Broken Links command does not check the validity of links that use full Internet URLs, such as 
"http://www. example, com/index.htmV'. It only checks links that contain a path and a fde name, such as 
"index.html" or "/images/example.gif'. As a result, the command will not find any external links (links 
that contain a server name) that may be broken. To find broken external links, use the Check External 
Links (p.411) command.

To find broken links in the current local site

1. Do one of the following:
o On the Tools menu in the main window, click Find Broken Links. 
o On the Tools menu in the Site Manager window, click Find Broken Links.

2. Click Site, and then click Find.

Any documents in the current local site that contain broken local links will be listed in the result box at the 
bottom of the Find Broken Links window. You can open a document in the list by double-clicking its file 
name.

To find broken links in a specific folder

1. Do one of the following:
o On the Tools menu in the main window, click Find Broken Links. 
o On the Tools menu in the Site Manager window, click Find Broken Links.

2. Click Folder, and then enter the path of the desired folder in the box. You can click Browse to 
locate and select a folder, or click the triangle to choose from a list of recently searched folders.

3. If you want to include subfolders of the specified folder in the search, click Include subfolders.
4. C l ic k  Fin d.

Any documents in the specified folder that contain broken local links will be listed in the result box at the 
bottom of the Find Broken Links window. You can open document in the list by double-clicking its file 
name.
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F i n d i n g  o r p h a n  f i l e s

Use the Find Orphan Files command to search a local site or folder for "orphan1’ documents or resource 
files. An orphan document is one to which no other document in the same site has links. Similarly, an 
orphan resource file (such as an image) is one that is not used by any document in the site. The presence of 
orphan files can indicate a problem; for example, you may have renamed a document but neglected to 
update links pointing to it in other documents. Therefore, it's a good idea to check for orphan files before 
publishing a site.

0  I f  you have created a site using the Site Wizard, the F ind Orphan Files command may f in d  several 
orphan image and other resource files  even i f  you have not changed o r removed any links in the site. 
This is normal and is not a cause fo r  concern.

To find orphan files in the current local site

1. Do one of the following:
o On the Tools menu in the main window, click Find Orphan Files, 
o On the Tools menu in the Site Manager window, click Find Orphan Files.

2. Click site, and then click Find.

Any orphan files in the current local site will be listed in the result box at the bottom of the Find Orphan 
Files window. You can open a document in the list by double-clicking its file name.

To find orphan files in a specific folder

1. Do one of the following:
o On the Tools menu in the main window, click Find Orphan Files, 
o On the Tools menu in the Site Manager window, click Find Orphan Files.

2. Click Folder, and then enter the path of the desired folder in the box. You can click Browse to 
locate and select a folder, or click the triangle to choose from a list of recently searched folders.

3. If you want to include subfolders of the specified folder in the search, click Include subfolders.
4. Click Find.

Any orphan files in the specified folder will be listed in the result box at the bottom of the Find Orphan 
Files window. You can open a document in the list by double-clicking its file name.
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C h e c k i n g  e x t e r n a l  l i n k s

Use the Check External Links command to find and check the validity of any external links in a local site or 
folder. When you use this command, Namo WebEditor will find and attempt to follow every link in the 
current site or the specified folder that points to an external document or resource file. Each external link 
found will be listed, and either "Connected" or "Not Connected" will appear next to the URL in the results 
list, indicating whether Namo WebEditor succeeded in following the link. Generally, a failure indicates that 
the specified document or resource does not exist at the location specified in the URL. Note, however, that 
if your computer is not connected to the Internet when you use the Check External Links command, the 
results list will show "Not Connected" for every external link.

Note that external links include not only links to files on another site, but any link that contains a server 
name, even if it points to a file on the current site. For example, if the main URL of the current site is 
"http://www.example.com/", the URL "http://www.example.com/images/example.gif' is considered an 
external link, even though the linked file is on the current site.

HO By default, the Check External Links command finds not only Web links (those that start with "http" or 
"https"), bat also non-Web links, such as those that point to e-mail addresses and FTP resources. 
However, Namo WebEditor cannot check the validity non-Web links. As a result, any non-Web link 
found by the Check External Links command will appear with the result f,Not Connected", even if  the 
link is valid.

To check external links in the current local site

1. Do one of the following:
o On the Tools menu in the main window, click Check External Links. 
o On the Tools menu in the Site Manager window, click Check External Links.

2. Click Find in site.
3. (optional) Click the Protocol box and select the type of link you want to find and check:

o To find all external links (including non-Web links such as ftp and mailto), select ALL. 
Note, however, that only http/https links will be checked for validity.

o To find and check only links to Web resources, select HTTP/HTTPS.
4. Click Check Links.

Each external link of the specified type found in the current local site will be listed in the result box at the 
bottom of the Check External Links window, along with the path of the document that contains it, and the 
result of the connection attempt. Note that non-Web links will always show "Not Connected". You can 
open a document in the list by double-clicking its file name.

To check external links in a specific folder

1. Do one of the following:
o On the Tools menu in the main window, click Check External Links.
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o On the Tools menu in the Site Manager window, click Check External Links.
2. Click Find in folder, and then enter the path of the desired folder in the box. You can click Browse 

to locate and select a folder, or click the triangle to choose from a list of recently searched folders.
3. If you want to include subfolders of the specified folder in the search, click Include subfolders.
4. (optional) Click the Protocol box and select the type of link you want to find and check:

o To find all external links (including non-Web links such as ftp and mailto), select ALL. 
Note, however, that only http/https links will be checked for validity.

o To find and check only links to Web resources, select HTTP/HTTPS.
5. C lick Check Links.

Each external link of the specified type found in the specified folder will be listed in the result box at the 
bottom of the Check External Links window, along with the path of the document that contains it, and the 
result of the connection attempt. Note that non-Web links will always show "Not Connected". You can 
open a document in the list by double-clicking its file name.

C h a n g i n g  c h a r a c t e r  s e t s  t h r o u g h o u t  a  s i t e

Using the Change Character Sets command, you can search a local site or folder for documents that use a 
particular character set (p.238), and then optionally change them to use a different character set.

0  Be careful when using this command to replace character sets. This operation cannot be undone.

To find documents that use a particular character set

1. Do one of the following:
o On the Tools menu in the main window, click Change Character Sets, 
o On the Tools menu in the Site Manager window, click Change Character Sets.

2. Click the Find encoding box and select the character set you want to search for.
3. Do one of the following:

o To search the current local site, click In site.
o To search a specific folder, click In folder, and then enter the path of the desired folder in 

the box. If you want to include subfolders of the specified folder in the search, click 
Include subfolders.

4 . Click Find.

Any documents using the specified character set will be listed in the result box at the bottom of the Change 
C haracter Sets window. You can open a document in the list by double-clicking its file name.
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1. Do one of the following:
o On the Tools menu in the main window, click Change Character Sets, 
o On the Tools menu in the Site Manager window, click Change Character Sets.

2. Click the Find encoding box and select the character set you want to search for.
3. Click the Replace with check box, and then click the adjacent box and select the new character set 

to apply to any found documents.
4. Do one of the following:

o To search the current local site, click In site.
o To search a specific folder, click In folder, and then enter the path of the desired folder in 

the box. If you want to include subfolders of the specified folder in the search, click 
Include subfolders.

5. Click Find. Any matching documents will be listed in the result box.
6. Click Replace.

To replace one character set with another throughout a site or folder

C h a n g i n g  h y p e r l i n k s  a n d  f i l e  n a m e s  t o  l o w e r c a s e

Many Web servers—particularly those running on Unix or Linux—are case-sensitive with respect to file 
and folder names. That is, they distinguish between uppercase and lowercase letters in file and folder 
names. This means, for example, that "example.html’’ and "Example.html" are not considered to be the 
same document by such Web servers.

This is not necessarily a problem. If you always take care to specify URLs with exactly the same 
capitalization as the paths and names of the files they point to, case-sensitivity doesn’t matter. But if you 
inadvertently create a link whose URL is capitalized differently from its destination, the link may not work 
once you publish the document to the Web, even if it seems to work in Namo WebEditor. (Windows is not 
case-sensitive with respect to file and folder names.)

To avoid such potential problems, it can be a good idea to change all file names, folder names, and URLs 
within a site to lowercase. Namo WebEditor has a special command to do just that. Using it ensures that 
hyperlinks and their destinations will always match case. Of course, you don’t need to do this if you never 
use uppercase in names and URLs.

To change all file names, folder names, and URLs in the current local site to lowercase

• On the Tools menu in the Site Manager, click Convert File Names to Lowercase.

O  This command is only available when you are working on a local site, and it cannot be undone.
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V i e w i n g  a  s i t e  r e p o r t

In seconds, the Site Manager can generate a comprehensive site report that includes the following 
information:

• Site properties, such as folder path and last modification date
• The site's navigational structure
• List of HTML documents, including such details as size, modification date, title, and character set
• List of broken links
• List of orphan files

To view a report for the current local site

• On the Tools menu of the Site Manager, click Generate Site Report.

The Site Manager generates the site report as an ordinary HTML document, which is automatically opened 
in the main window. If you want, you can save the report as you would any document.
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8 Advanced Techniques
This section covers advanced features of Namo WebEditor designed for more experienced Web authors.

In this section

Reusing content...................................................................................................p.416
Creating database-driven documents................................................................ p.430
Importing Excel worksheets.............................................................................. p.480
Creating charts from table data.........................................................................p.484
Working with source code................................................................................ p.506
Editing XML documents....................................................................................p.510
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Reusing content
On many Web sites—especially large ones—identical content areas are often repeated on many pages. For 
example, you might have a set of pages that all share the same navigation bar at the top and "boilerplate" 
copyright text at the bottom of each page. Although such areas of common content may not be difficult to 
replicate across many documents in the first place, it can be difficult to update every page when you make 
a change to the common content. Fortunately, there are ways to make it easier to update common content 
across multiple documents. The basic idea is to reuse content stored in a single source in multiple pages, 
rather than copying content to multiple documents.

Namo WebEditor supports three methods of reusing content in this way:

• You can put shared content in an ordinary HTML document and insert inline frames (p.416) in 
other documents to display that content. An inline frame is like a "window" in one document 
through which another document shows.

• You can use a server-side include (p.423)—a special command in a document that instructs the 
Web server to insert the contents of another document at the location of the command in the 
document’s source code. (Other SSI commands can be used to insert other items besides 
documents.)

• You can register a block of content in one document as a shared content block (p.420) and then 
insert the shared block in other documents. Documents that contain shared content blocks actually 
contain copies of the shared content, but Namo WebEditor updates the copies for you when you 
use the Update Shared Content Blocks command.

In this section

Inline frames..............
Shared content blocks
Server-side includes...

I n l i n e  f r a m e s

An inline frame is a special container that displays content from a specified document or URL. You can 
think of an inline frame in a document as a "window" through which you can view another document. In 
the example below, the inline frame displays the contents of a document named "lipsum.html".

.p.416

.p.420

.p.423
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Hello and welcome to my excellent home page featuring an inline frame!
Here it is:

Lorem ip sum dolor sit amet, consectetuer >•*
adipisdng dit AKquaxn mi est, solHdtudin
sed, malesuada in, adxpiscing a, purus.
Suspendisse id lacus. Donee neque est.
accumsan non, posuere et, mattis qms, est
Cras gravida tmdchmt massa. Praesent
hendrerit malesuada uraa. Nam laoreet,
rrat tn  penrfnr rw rtriim  a r m  w l i t  v^ctihn liw n

Neat, huh?
A n  in lin e  fra m e  exam ple

Inline frames have many uses. One powerful use of inline frames is to enclose the exact same content in 
several documents: instead of copying and pasting the shared content into each document, you can put it 
into a separate document that is displayed in inline frames in each document that needs it. The advantage of 
this approach is that you can later edit the shared content in one place, and all the documents that use it will 
"update" automatically.

In this section

Inserting an inline frame....................................................................................p.417
Editing a local document in an inline frame....................................................p.418
Modifying inline frame properties................................................................... p.418
Using an inline frame as the target of a link....................................................p.419
Deleting an inline frame.....................................................................................p.420

Related topics

Shared content blocks........................................................................................p.420

Inserting an inline frame

To insert an inline frame

1. Place the insertion point at the location you want to insert the inline frame.
2. On the Insert menu, click Inline Frame.
3. In the Source box, enter the path or URL to the document you want to display in the inline frame.
4. Specify values for any properties (p.418) you want to change, and then click OK.

[ 3  Since an inline frame is an inline element, you can insert it in the middle of a paragraph or other block 
element, as you can an image.
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EJ You cannot set the URL o f an inline frame to the document that contains it. Also, i f  the document in an 
inline frame itself contains an inline frame, you cannot set the URL of the "inner" inline frame to the 
"outer" containing document.

Editing a local document in an inline frame

If the source of an inline frame is a local document, the document can be edited directly inside the inline 
frame.

To edit a local document in an inline frame

1. Click inside the inline frame to place the insertion point in the framed document.
2. Edit the document as you would normally.

While the insertion point is inside an inline frame, the "focus" of much of Namo WebEditor's interface (the 
menu and toolbar commands, the mode tabs, the Inspector, and so forth) is on the framed document. So, for 
example, if you press Ctrl+S while the insertion point in inside the inline frame, Namo WebEditor will 
save the document displayed in the frame, rather than the document containing the frame. However, some 
commands, such as File > Open, remain focused on the containing document.

Modifying inline frame properties

An inline frame has several properties you can modify, including its source URL, name, size, margins, and 
so forth.

To modify the properties of an inline frame

1. Select the inline frame by clicking just outside it. (The pointer should be an arrow before you 
click.)

2. Do one of the following:
o Edit the property values on the Inspector.
o On the Format menu, click Inline Frame Properties, and then edit the property values in 

the In line Fram e Properties dialog box.

9  You can also open the In lin e  Fram e P rope rties dialog box by double-clicking just outside an 
inline frame.

The properties you can modify are described below.

Source The source path or URL of the document to be displayed in the inline frame.
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Name The name of the inline frame element. Can be used as the value of the target (p.419)
attribute of a hyperlink in the containing document.

Width The width of the inline frame, in pixels or as a percentage of the inline frame's parent
container.

Height The height of the inline frame, in pixels or as a percentage of the inline frame's parent
container.

Alignment The vertical alignment of the inline frame with respect to the line containing it.
Scrollbar Specifies whether to display scrollbars at the right and bottom sides of the inline frame. 

Auto means scrollbars will be displayed only when necessary.
Show border Specifies whether to display a thin border around the inline frame.
Hor. margin The size in pixels of the margin between the inline frame's content and its left and right 

edges.
Vert, margin The size in pixels of the margin between the inline frame's content and its top and bottom 

edges.
Hor. space The size in pixels of the empty space on both sides of the inline frame, separating it from 

surrounding content on the same line. The default value is zero.
Vert, space The size in pixels of the empty space above and below the inline frame, separating it from 

content above and below. The default value is zero.

Cascading style sheets provide finer control over the size, borders, and surrounding margins o f inline 
frames. Refer to the online CSS guide for more information.

Using an inline frame as the target of a link

A special property of inline frames is that they can serve as the targets (p. 170) of hyperlinks. If a link targets 
an inline frame, the link's destination will open in the frame rather than in the containing window. An inline 
frame can be the target only for links in the document that contains it, not for links in other documents.

To specify an inline frame as the target of a link

1. Select the desired inline frame by clicking just outside it. (The pointer should be an arrow before 
you click.)

2. On the Inspector, note the value in the Name box. If you wish, change the inline frame's name by 
editing this value.

3. Click the link. (The link must be in the same document as the inline frame.)
4. On the Inspector, type the inline frame's name in the Target box and press Enter.
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Deleting an inline frame

To delete an inline frame

1. Select the inline frame by clicking just outside it. (The pointer should be an arrow before you 
click.)

2. Press Delete.

S h a r e d  c o n t e n t  b l o c k s

A shared content block is an HTML fragment (a piece of an HTML document) that you create once and 
then insert in as many documents as you want. However, unlike a fragment that is simply copied from one 
document to another, each copy of a shared block retains a kind of connection to its source, so that changes 
you make to the shared block's source can be replicated automatically in every copy.

You can create a shared content block from almost any part of any Web document, such as a table, a layer, 
a set of navigation links, and so forth: if you can select it in Edit mode, you can make it into a shared block. 
Namo WebEditor stores shared content blocks in .nsc files, which are HTML files that contain just HTML 
fragments, rather than whole documents. To edit a shared content block, you edit the .nsc file that contains 
its source.

rri
ui! You can only create and use shared content blocks in documents that belong to a local site. I f  a local 

site is not open, the commands related to shared content will not be available.

In this section

Creating and managing shared content blocks................................................. p.420
Inserting a shared content block.........................................................................p.421
Editing and updating shared content blocks..................................................... p.422
Converting shared content to ordinary content................................................p.422

C r e a t i n g  a n d  m a n a g i n g  s h a r e d  c o n t e n t  b l o c k s

To create a shared content block

1. Select the content you want to save as a shared content block.
2. On the Insert menu, point to Shared Content, and then click Save as Shared Content Block.
3. In the Shared content name box, type a name for the shared content block, and then click Save.
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GD When you save a selection as a shared content block, the original selection does not become an
instance of the shared block. However, you can delete the original content and insert (p.421) a copy of 
the shared content block in its place.

Managing shared content blocks

All the shared content blocks you have created for a local site are listed in the Site Library (p.377) panel
when that site is open. If the Site Library panel is hidden, press A lt+ 9  to reveal it.

To remove a shared content block from the list, right-click it and then click Delete. Note that deleting a
shared content block does not remove any instances of it in your documents.

(Hi If you move, remove, or rename a shared content block, any instances of it in your documents will lose 
their connection with the shared source.

9  If you accidentally delete a shared content block and cannot find its file in the Recycle Bin, you can 
recreate it from one of its instances. Open a document containing an instance of the deleted block, 
flatten (p.422) the instance, and then save the content as a shared block using the same name as the one 
that was deleted.

I n s e r t i n g  a  s h a r e d  c o n t e n t  b l o c k

When you insert a shared content block into a document, Namo WebEditor creates an instance of the 
shared content at the location of the insertion point and ’’connects1’ it to the shared content block file. You 
can delete a shared content instance, but you cannot edit it. To modify a shared content instance, you must 
edit (p.422) the source file; all other instances of the shared content block will change as well.

In Edit mode, a shared content block inserted into a document is shown with a dashed blue outline around it.

To insert a shared content block

1. Place the insertion point at the location where you want to insert the shared block.
2. On the Site Library (p.377) panel, click 0  (Shared Content Blocks).
3. In the list of .nsc files, right-click the desired file and click Insert.

y  You can also insert a shared content block by dragging it from the S ite L ib ra ry  panel to the document 
window and clicking Insert F ile o r Image.

To remove a shared content instance

1. Select the shared content block in the document window by clicking any part of it.
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2. Press Delete.

E d i t i n g  a n d  u p d a t i n g  s h a r e d  c o n t e n t  b l o c k s

To edit a shared content block

1. On the Site Library (p.377) panel, double-click the shared content block you want to edit. The 
corresponding .nsc file will open in the document window.

2. After making the desired changes to the shared content, save the .nsc file and close it (press 
Ctrl+S and then Ctrl+F4).

All instances of the edited shared content block in any open documents will be updated immediately. 
However, instances in other documents will not be updated until you use the Update Shared Content Blocks 
command (see below).

9  You can also open a shared content file for editing by right-clicking any of its instances and clicking 
Edit Shared Content Block.

To update all shared content blocks

1. Switch to the Site Manager.
2. On the Tools menu, click Update Shared Content Blocks.

All shared content instances in the site will be immediately updated.

C o n v e r t i n g  s h a r e d  c o n t e n t  t o  o r d i n a r y  c o n t e n t

You can convert an instance of a shared content block to ordinary content that is no longer connected to the 
shared content source.

To convert a shared content instance to ordinary content

• Right-click any part of the shared content block and then click Flatten Shared Content Block.

To convert all shared content in all the documents in a local site to ordinary content

1. Switch to the Site Manager.
2. On the Edit menu, click Flatten Shared Content.
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S e r v e r  S i d e  I n c l u d e s

Server Side Includes, or SSI, are special commands that can be added to HTML documents to tell the Web 
server to insert some information that does not exist in the document itself. When a Web server encounters 
an SSI command, it executes it and inserts the result into the copy of the document sent to the Web browser, 
replacing the command with its result.

Namo WebEditor supports inserting three kinds of SSI commands in Edit mode:

include (p.424)
The include command inserts the contents of a file that exists on the Web server. Typically, the 
file to be included contains HTML or plain text. For example, you might use an include command 
in multiple documents to insert a common footer in each document, avoiding the need to copy and 
paste the footer content into each document. (See Inserting the contents of a file on the server, 
p.424.)

echo (p.426)
The echo command inserts the value of an environment variable—that is, some piece of 
information provided by the Web server regarding the current document or the server environment. 
Examples include the document's file name, the local date and/or time, and the name and version 
of the Web server software. (See Inserting the value of an environment variable, p.426.)

time format (p.428)
The time format command can be used to tell the Web server how to format the date/time strings 
produced by any succeeding echo commands that output a date or time. (See Controlling the date­
time format for an echo command, p.428.)

Notes about using SSI commands

• If you include an SSI command in a document, you should set its file name extension to ".shtml” 
rather than ".html" or ".htm". Most servers are configured by default to look for SSI commands 
only in documents that have a ".shtml" or ".shtm" file name extension (".shtml" is compatible with 
more servers).

• Since SSI commands require a Web server to execute the command and output its result, SSI 
command results do not appear when you preview a document using either Namo WebEditor's 
built-in preview mode or a Web browser. To view SSI results in a document, you must publish 
(p.387) the document to a Web server and then view the published document in a browser.

• Not all Web servers support SSI, and some that do support SSI may not be configured correctly to 
enable it. If you find that SSI commands in your documents do not work, even though you have 
changed the documents' file name extensions appropriately, check your Web server software 
documentation or contact your Web server administrator.
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In this section

Inserting the contents o f a file on the server.................................................... p.424
Inserting the value of an environment variable................................................p.426
Controlling the date-time format for an echo command................................ p.428

I n s e r t i n g  t h e  c o n t e n t s  o f  a  f i l e  o n  t h e  s e r v e r

The SSI include command tells the Web server to insert the contents of a specified file residing on the 
server into the current document, at the location of the command in the document's source code, before 
sending it to a Web browser. The file to be included should contain HTML or plain text; the command 
cannot be used to insert images or other binary files.

There are two basic situations where using an include command can be convenient. You should consider 
using an include command in either of the following situations:

• You have a piece of content that you want to repeat identically in several documents. Rather than 
copying and pasting the common content in each document, you can save the common content in 
its own document and use an include command to have the Web server dynamically insert the 
content in each document that needs it. This technique not only saves disk space, but also makes it 
easier to change the common content if necessary. An example of this situation is a footer that you 
want to repeat identically on every page of a site.

• You have a document that is mostly static, but in which a relatively small piece of content must 
change frequently. In this case, rather than editing the entire document every time you need to 
change one small part of it, you can keep the frequently-changing content in a separate file and 
edit just that file. An example of this situation is a "message of the day" that changes daily in an 
otherwise unchanging or rarely-changing document. (However, if the frequently-changing content 
makes up most of the document, or if your needs are more complicated, you should consider 
creating a database-driven document (p.430) rather than using include commands.)

To insert an include command

1. Place the insertion point at the location in the current document where you want the file to be 
inserted by the Web server.

2. On the Insert menu, point to SSI, and then click Include.
3. Select the appropriate Type option as follows:

o If the file to be included is in the same folder as the document, or in a subfolder of the 
document’s folder, select File, 

o If the file to be included is outside of the document* folder, select Virtual.
4. In the Path box, enter the path of the file to be inserted. (See the note below about acceptable 

kinds of paths.)
5. Click OK.
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If the specified file exists in the local file system at the specified path, Namo WebEditor will display its 
contents in the document window at the location where you inserted the include command. Otherwise, it 
will display a dialog box stating that the specified file could not be found. This is no cause for concern; as 
long as the file exists at the specified path on the Web server when you publish the document, the include 
command will be successful.

If the display of special tag marks is enabled, an "SSI" box (tUD ) will also appear at the location of the 
include command, just before the included file contents (if displayed).

P iuJ After inserting any SSI command, make sure to change the file name extension of the containing
document (not the inserted file) to shtml

Notes regarding include commands

• When specifying the path of the file to be included, if you specified the Type as Virtual, you can 
enter an absolute path, such as "/footer.html", or a relative path, such as "footer.html" or 
"../footer.html". The path may not contain a domain name—thus,
"http://www.example.com/footer.html" and "www.example.com/footer.html" are not valid. If you 
specified the Type as File, the path must be relative and must point to a file in the document's 
folder or a subfolder of it.

• Be careful when using an include command to insert an HTML file. When a Web server 
encounters an include command, it always inserts the entire contents of the file at the location of 
the command in the containing document, regardless of the file's content. As a result, if you use an 
include command to insert a complete HTML document into another HTML document, the 
resulting combined document generated by the server will contain two sets of <html> tags, two 
sets of <body> tags, and so forth—in violation of the rules of HTML. Although most Web 
browsers deal with such problems gracefully, there can be undesired consequences. For example, 
if the included document contains a style sheet, a Web browser may apply its styles to the 
containing document as well, which may not be what you want. To avoid such problems, it's a 
good idea to make sure that the included file contains only HTML elements that normally occur 
within the <body> element—what is called an HTML fragment. In other words, it should not 
contain <html>, <head>, and <body> elements, or any elements that go inside a <head> element, 
such as <style>.

• Keep in mind that the outermost element or elements of an included HTML fragment will become 
a child element or children elements of whatever element contains the include command in the 
containing document. Consequently, you should take care that an included HTML fragment not 
contain elements that should not occur in the containing element (or, conversely, that the 
containing element be an element that can legally contain the elements in the included fragment). 
For example, if the containing element is an inline element, such as <span>, the included fragment 
should not contain any block-level elements, such as <p>; or if the included fragment does contain 
block-level elements, the containing element should also be a block-level element.

• If the file to be included contains plain text (without HTML markup), note that white space in its 
content will be treated by Web browsers the same as any other white space in HTML documents. 
Any line breaks in the text will be converted to spaces, and multiple adjacent spaces will be 
converted to a single space. If you want browsers to preserve line breaks and other white space in
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an included text file, insert the include command in a <pre> element. (While the insertion point is 
in the paragraph containing the include command, click the Element box on the Formatting 
Toolbar and select Preformatted Text.)

I n s e r t i n g  t h e  v a l u e  o f  a n  e n v i r o n m e n t  v a r i a b l e

The SSI echo command tells the Web server to insert the value of an environment variable at the location 
of the command in the document's source code, before sending it to a Web browser. An environment 
variable is a piece of information, provided by the server, about the current document or some operating 
aspect of the server itself. You can use an echo command in a document to, for example, have the server 
insert the local time or the document's last modification date in a paragraph somewhere in the document. 
The server determines the value of the specified environment variable at the time it encounters the echo 
command.

To insert an echo command

1. Place the insertion point at the location in the current document where you want the environment 
variable's value to be inserted by the Web server.

2. On the Insert menu, point to SSI, and then click Echo.
3. Click the Variable box, type or select the desired environment variable, and then click OK.

If the display of special tag marks is enabled, an "SSI” box ([Ell) will appear at the location of the echo 
command.

The environment variables that are selectable in the Variable box are described below.

( 3  You can type the name o f any environment variable into the Variable box, even if it is not available in 
the drop-down menu.

General-purpose variables

These variables have general usefulness.

DATE_GMT The GMT (Greenwich Mean Time) date/time at the moment the Web server
executes the echo command. The format is controlled by a config timefmt 
(p.428) command.

DATE_LOCAL The local date/time at the moment the Web server executes the echo command.
The format is controlled by a config timefmt (p.428) command.

DOCUMENT_NAME The file name of the current document.
DOCUMENT_URI The virtual path of the current document.
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HTTP.ACCEPT
HTTP.REFERRER

HTTP_USER_AGENT
LAST.MODIFIED

REMOTE_ADDR
REMOTE_HOST
REMOTE_USER

SERVER_NAME
SERVER.PORT
SERVER_PROTOCOL

SERVER_SOFTWARE

The URL of the page from which the user came to the current document 
(usually by clicking a hyperlink), if any.
The name and version of the browser.
The local date/time when the current document was last modified. The format is 
controlled by a config timefmt (p.428) command.
The IP address of the user's computer.
The hostname of the user’s computer.
The username of the user (only available if the user logged in to access the 
current document).
The Web server’s hostname, DNS alias, or IP address.
The port number of the Web server (usually 80) for the current communication.
The name and version number of the Internet protocol (such as HTTP) for the 
current communication.
The name and version of the Web server software.

The MIME types accepted by the browser.

CGI-specific variables

These variables are only meaningful when the document being served was generated by a CGI script.

CONTENT.LENGTH 
CONTENTTYPE 
GATEWAYJNTERFACE 
PATH INFO

The length of any content attached to the query by the browser.
The type of any content attached to the query by the browser.
The version of CGI in use by the server.
The extra path information, if any, appended to the script’s path name 
by the browser.
The same as PATH_INFO, but translated from a virtual path to a 
physical path.
The query string, if any, appended to the script's URL by the browser. 

QUERY_STRING JJNESCAPED The unescaped version of QUERY_STRING.
REQUEST__METHOD The method by which the browser request was made (such as GET or

POST).
SCRIPT_NAME The virtual path of the current script.

PATH.TRANSLATED

QUERY_STRING

Related topics

Controlling the date-time format for an echo command................................ p.428
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C o n t r o l l i n g  t h e  d a t e - t i m e  f o r m a t  f o r  a n  e c h o  

c o m m a n d

When a Web server encounters an echo command requesting a date/time, the result is formatted according 
to default date/time format of the server. You can change the date/time format by inserting a config 
command with the timefmt parameter before the relevant echo command. The results of any date-related 
echo commands located after the config timefmt command in the same document will use the specified 
date/time format.

To set the date/time format for an echo command

1. Place the insertion point anywhere in the current document before the echo command(s) for which 
you want to set the date/time format.

2. On the Insert menu, point to SSI, and then click Time Format.
3. Under Time Format, click the date or time format you want to use, or click Custom Format and 

enter any combination of date/time format codes and separators (see table below).
4. Click OK.

If the display of special tag marks is enabled, an "SSI” box (t^jl) will appear at the location of the config 
command.

Date/time format codes

You can enter any combination of the following codes in the Custom Format box to create your own 
custom date/time format. You can also enter spaces and punctuation marks as separators. (But do not use
"%" as a separator.)

Code Meaning
%a abbreviated weekday name
%A full weekday name
%b abbreviated month name
%B full month name
%c country-specific date/time format
%C default date/time format
%d day of month 01 to 31
%D date as %m/%d/%y
%e day of month 1 to 31 (single digits are preceded by blanks)
%h abbreviated month name (same as %b)
%H hour 00 to 23
%I hour 01 to 12
%j day of year 001 to 366
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Code Meaning
%m month of year 01 to 12
%M minute 00 to 59
%n line break
%p AM/PM
%r time as %I:%M:%S %p
%R time as %H:%M
%S second 00 to 61
%t tab character
%T time as %H:%M:%S
%U week number (Sunday is the first day of the week)
%w day of week (Sunday = 0)
%W week number (Monday is the first day of the week)
%x country-specific date format
%X country-specific time format
%y 2-digit year 00 to 99
%Y 4-digit year
%Z time zone
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Creating database-driven documents
With Namo WebEditor’s Database Wizard, you can easily create database-driven Web documents without 
programming.

In this section
Introduction to database-driven documents............................................ p.430
Supported document standards and database connections........................ p.432
Requirements for using the Database Wizard..........................................p.433
Setting up an ODBC data source...........................................................p.435
Overview of the Database Wizard......................................................... p.435
Creating an output block.......................................................................p.437
Creating an input block.........................................................................p.452
Joining fields from two or more database tables...................................... p.458
Using parameters with database-driven documents..................................p.460
Filtering and sorting database records.....................................................p.463
Working with block elements................................................................p.466
Modifying block properties................................................................... p.476
Formatting database-driven content....................................................... p.477
Adding static content to a database-driven document............................... p.478

I n t r o d u c t i o n  t o  d a t a b a s e - d r i v e n  d o c u m e n t s

A database-driven document (also called a dynamic document) is a Web document in which some or all of 
the content does not exist in the document itself but is retrieved from a database when the document is 
requested by a Web browser.

How database-driven documents work
When a Web browser requests an ordinary HTML document, the Web server simply sends the document as 
it is, without modification. As a result, the copy of the document in the browser's memory is exactly the 
same as the copy on the server's file system. Database-driven documents, however, work differently. When 
a browser requests a database-driven document, what it receives from the server is not the document that 
exists on the server’s file system, but rather a generated document, based on the original, that the server 
creates "on the fly" when it receives the request. The original document acts as a kind of template, which 
the server "fills in" with content from a database.
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A database-driven document contains instructions in server-side scripts that tell the server to retrieve 
specific information from a database. When the server receives a request from the browser for a database- 
driven document, the following things happen:

1. The server opens the document and reads the instructions in it.
2. The server retrieves the data specified in the script from the specified database.
3. The server generates an HTML document from the retrieved data, using the original document as a 

template.
4. The server sends the generated document to the browser.

Why use database-driven documents?
A database-driven approach is primarily useful for large sites that have many similar pages, because the 
Web developer can design a single document (the template) that becomes the basis for many generated 
documents. This approach separates content (the data) from presentation (the HTML formatting), allows 
content to be centralized, and makes it much easier to change the design of the site.

As an example, consider a typical online bookstore. It may have hundreds or even thousands of pages, one 
for each book the store carries, yet all are probably much the same. Each page displays a book title, an 
author name, a price, a brief description, and so forth, all formatted the same way from page to page. To 
author every page individually would be a huge task, and there would be a lot of duplication (and thus 
wasted disk space), since much of the HTML would be exactly repeated on every page. And if the Web 
developer decided to change the design of the site even a little, every page would have to be edited— 
another huge project.

But if the online bookstore is database-driven, these problems are avoided. Instead of a document for every 
book, a single document template along with a database serve as the basis for thousands of generated 
documents. The information remains in a central location, where it is easily managed, and changing the 
design of the generated pages requires editing just the template.

About query strings
In our hypothetical online bookstore, each link to a book description page uses the same document URL, 
but attaches a different query string to the end of the URL. The query string tells the Web server which 
book the user is interested in. For example, a link to the description page for The Grapes of Wrath might 
look like h ttp : //www. exam ple. c o m /d e ta i l . asp?bookid=11424. "Detail.asp" is the file name 
of the dynamic document, "bookid" is a query parameter, and 11424 is the parameter's value—the ID of the 
requested book. Instructions in the document itself tell the server in which database table to look for the 
information, while the query string identifies the particular record to retrieve.
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S u p p o r t e d  d o c u m e n t  s t a n d a r d s  a n d  d a t a b a s e  

c o n n e c t i o n s

There are several dynamic document standards and ways of connecting to databases that can be used to 
implement a database-driven site. Namo WebEditorfs Database Wizard supports several of the most 
popular combinations of these variables and offers you the choice of which combination to use for your site. 
From the user’s (site visitor's) point of view, it does not matter what you choose, since all combinations 
generate ordinary HTML compatible with all browsers. Your choice of standards depends largely on the 
software that is installed (or that you are willing to install) on your Web server.

Namo WebEditor supports the following dynamic document standards:

ASP (Active Server Pages)
ASP is Microsoft's dynamic document standard. ASP support is built into Microsoft's web server 
programs, Internet Information Server (IIS) and Personal Web Server (PWS). If your Web server 
runs one of these programs, you do not need to install additional software to use ASP. Other Web 
servers can be made to support ASP through the addition of third-party software such as Sun ONE 
Active Server Pages (http://wwws.sun.com/software/chilisoft/) or Instant ASP 
(http://www.stryon.com/products.asp?s=l).

Namo WebEditor supports the use of ODBC for connecting to databases from ASP documents.

PHP (PHP Hypertext Preprocessor)
PHP is an open-source Web scripting language maintained by the Apache Software Foundation. 
PHP support is not built into any Web server program; to use it, you must install the PHP program 
on your server. The program is free and available for many operating systems; many Linux 
distributions include PHP as a standard option. Visit http://www.php.net/ for more information.

Namo WebEditor supports the use of the following methods for connecting to databases from PHP 
documents:

• ODBC (for any ODBC-supporting database)
• Direct TCP/IP connection (only for MySQL databases)

JSP (JavaServer Pages)
JSP is Sun's dynamic document standard based on the Java programming language. Many Web 
server programs have built-in support for JSP; others can be made to support it through an add-on 
engine. See http://java.sun.com/products/jsp/industry.html for a list of supporting servers and 
engines.

Namo WebEditor supports the use of the following methods for connecting to databases from JSP 
documents:

432 Creating database-driven documents

http://wwws.sun.com/software/chilisoft/
http://www.stryon.com/products.asp?s=l
http://www.php.net/
http://java.sun.com/products/jsp/industry.html


Chapter 8: Advanced Techniques

• ODBC (for any ODBC-supporting database)
• JDBC (for MySQL, IBM DB2, Oracle, Microsoft SQL Server, and other databases)

,w*m%

Sejoong Namo Interactive does not recommend or endorse any particular dynamic document standard, 
database platform, or Web server platform.

Related topics
Requirements for using the Database Wizard.........................................p.433
Setting up an ODBC data source........................................................... p.435

R e q u i r e m e n t s  f o r  u s i n g  t h e  D a t a b a s e  W i z a r d

ODBC driver for your database
Although the Database Wizard can create pages that connect to a database through TCP/IP or 
JDBC, the wizard itself uses ODBC to connect to your database for the purpose of obtaining 
information about the database's tables and fields. Microsoft Windows has built-in ODBC drivers 
for the following database types: Microsoft Access, Microsoft Excel, Microsoft FoxPro, Microsoft 
Visual FoxPro, Microsoft SQL Server, dBase, Oracle, Paradox, and text files. ODBC drivers for 
many other databases are available, both free and commercial. To find an ODBC driver for your 
database, try searching the Web (for example, search for "MySQL ODBC driver").

Web server program installed and running on your desktop computer
To enable previewing database-driven documents using Namo WebEditor's built-in preview mode, 
a Web server program supporting the dynamic document format you want to use must be installed 
on the computer on which you use Namo WebEditor. Some no-cost options for obtaining a Web 
server program are listed below:

• If you use Windows 2000 or Windows XP Professional, Microsoft Internet Information 
Server (IIS) is either already installed on your computer or available as an installation option 
in the Add/Remove Windows Components application. IIS has built-in support for ASP.

• If you use Windows NT 4 Workstation or Windows 95, you can install Microsoft Personal 
Web Server (PWS) as part of the Windows NT 4.0 Option Pack, a free download from 
Microsoft's Web site
(http://www.microsoft.com/ntserver/nts/downloads/recommended/NT40ptPk/default.asp). 
PWS has built-in support for ASP.

• If you use Windows 98, you can install PWS from your Windows 98 installation CD in the 
\add-ons\pws folder. PWS has built-in support for ASP.

• For any 32-bit version of Windows (Windows 95 or later), you can download and install the 
free Apache HTTP Server (http://httpd.apache.org/). Note that you must install additional
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software to enable Apache HTTP Server to work with dynamic documents; one free option is 
the PHP program, which supports PHP (http://www.php.net).

If you do not want to preview your database-driven documents using Namo WebEditor’s built-in
preview mode, you do not need a Web server program on your desktop computer.

ÛÜÜ If you have IIS or PWS running on your desktop computer, Namo WebEditor automatically configures 
it to support previewing database-driven documents. However, if  you choose to run a different Web 
server program, you must manually configure it to have a virtual directory named "namoweb" pointing 
to the root directory o f your boot drive (for example, C:\). For Apache, you can do this by adding the 
following line to your httpd.conf file:

A lia s  /namoweb "C:/"

Web server software that supports ASP, PHP, or JSP installed and running on the Web server
To actually use the database-driven documents you create using the Database Wizard, your Web
server must be equipped with software to interpret and execute the instructions in those documents.
The required software depends on the dynamic document standard you want to use.

• For ASP documents: If your Web server runs Microsoft's Internet Information Server (IIS) 
or Personal Web Server (PWS), no additional software is required. Other Web server 
programs may require the addition of third-party software such as Sun ONE Active Server 
Pages (http://wwws.sun.com/software/chilisofl/) or Instant ASP 
(http://www.stryon.com/products.asp?s= 1 ).

• For PHP documents: Your Web server must have the PHP software installed on it. PHP can 
be downloaded for free from http://www.php.net/ or (if your Web server runs on Linux/Unix) 
the download site for your Linux/Unix distribution.

• For JSP documents: Many Web server programs have built-in support for JSP. Others can be 
made to support it through an add-on engine. See
http://java.sun.com/products/jsp/industry.html for a list of supporting servers and engines.

0  Sejoong Namo Interactive does not recommend or endorse any particular dynamic document standard, 
database platform, or Web server platform.

Related topics
Supported document standards and database connections........................ p.432
Setting up an ODBC data source........................................................... p.435
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S e t t i n g  u p  a n  O D B C  d a t a  s o u r c e

The Database Wizard must connect to your database through ODBC to obtain information about the 
database's tables and fields. Therefore, you must register your database as an ODBC data source.

To register an ODBC data source
1. On the Start menu, point to Settings, and then click Control Panel.
2. Do one of the following, depending on your operating system:

o in Windows 95/98/Me/NT 4: Double-click ODBC Data Sources, 
o in Windows 2000/XP: Double-click Administrative Tools, and then double-click Data 

Sources (ODBC).
3. Click the System DSN tab, and then click Add.
4. Select the appropriate driver for your database type. For example, if you are using an Microsoft 

Access database, select Microsoft Access Driver. Then, click Finish.
5. Enter a name for the new data source.
6. Complete the remaining steps, which vary depending on the selected driver.

When you have finished creating the data source, its name should appear in the System Data Sources list, 
along with the selected driver. Click OK to close the dialog box.

Related topics
Supported document standards and database connections 
Requirements for using the Database Wizard................

O v e r v i e w  o f  t h e  D a t a b a s e  W i z a r d

The Database Wizard creates blocks of database-driven content, rather than entire documents. A block can 
be inserted into any document, including one with existing static content. You can add static content to a 
document before and after creating a database-driven block in it.

When you save a document in which you have added a database-driven block, Namo WebEditor changes 
the file name extension to .asp, .php, or .jsp, depending on the dynamic document standard (p.432) you 
have selected.

Types of blocks
The Database Wizard can create six kinds of database-driven content blocks. Four are output blocks, which 
present information retrieved from a database in various formats. The other two are input blocks, forms that 
accept data from users and then insert it into a database.

p.432
p.433
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The output block types are:

• Table blocks (p.438), which display multiple database records in a tabular format with one row per 
record and one column per field;

• List blocks (p.440), which display multiple records in a serial arrangement where each records 
takes up multiple lines, one line per field;

• Detail blocks (p.443), which display a single record; and
• Chart blocks (p.445), which display quantitative data from multiple records as a chart or graph.

The input block types are:

• Input blocks (p.452), which take user-provided data and insert it into a database as a new record; 
and

• Modification blocks (p.454), which take user-provided data and update an existing database 
record with it.

Most types of blocks are mutually exclusive. For example, you cannot insert both a table block and an input 
block in the same document. Also, most block types can only have one instance in a single document, so 
you cannot put two list blocks (for example) in the same document. The only exceptions to these rules are 
detail and chart blocks. You can combine a detail or chart block with any other type of block, and any 
number of detail or chart blocks can exist in the same document.

Basic steps of the Database Wizard
Most of the steps in the Database Wizard are the same, regardless of block type. Below is a brief overview 
of the common steps.

Step 1: Choosing a dynamic document standard and database connection method
In the first step, you decide whether to use ASP, PHP, or JSP as the dynamic document standard 
for the current document; choose a database connection type, such as ODBC or JDBC; and specify 
the operating system of your Web server. The Web server OS setting is only used if you are 
creating a chart block; it is used to determine which version to save of the CGI program that draws 
the chart.

Step 2: Specifying a data source
In the second step, you select an ODBC data source (if using ODBC) or specify the location of a 
database (if using another connection method). If you are using a connection method other than 
ODBC, you also need to select an ODBC data source so that the Database Wizard can get table 
and field information from the database.

Step 3: Selecting database fields
In the third step, the wizard displays a list of the fields in each table of the database. You select the 
fields that you want to include in the block.
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Step 4: Specifying a filter
In the fourth step, you specify a filter condition (p.463) that filters the database records. This is 
optional for table, list, and chart blocks, but it is mandatory for detail and modification blocks, 
since these block types can only display (or modify) a single record. In this step you also specify a 
join condition (p.458) if you selected fields from more than one table in the previous step; and an 
optional sort condition, which determines how the records will be sorted. This step is absent when 
you are creating an input block.

Step 5: Adding or removing block elements
In the fifth step, the wizard displays a list of the block elements that will be included in the block 
by default. Every database-driven block consists of a number of block elements, each of which 
performs some individual function in the block. For example, an output element displays the 
contents of one database field; a page link element presents a generated set of hyperlinks for 
navigating multiple output pages; and so forth. You can remove block elements you don’t want to 
include, and you can add additional elements.

In addition to these common steps, there are a few steps that only apply to certain block types. These are 
explained in the individual subsections covering each block type.

Related topics
Creating an output block...................................................................... p.437
Creating an input block........................................................................ p.452

C r e a t i n g  a n  o u t p u t  b l o c k

An output block displays information from one or more records in a database.

In this section
Creating a table block.. 
Creating a list block.... 
Creating a detail block 
Creating a chart block.

p.438
p.440
p.443
p.445

Related topics
Creating an input block..............
Overview of the Database Wizard.

p.452
p.435
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Creating a table block

A table block displays multiple database records in a tabular format. Each row of the table shows 
information from one record, while each column represents a database field.

N am e P h o n e E -m ail

John  Hum phries | 303-848-3093 ! johnny@ exam ple.com  j

J a n e  Doer 212-845-8965 ! jdoer@ exam ple.com

M ickM iggler 904-897-5626 m m @ exam ple.com

| B etty  Boopie 3 1 M 8 M 1 1 4 . boopie@ exam ple.com  j

Bob Hoffman 1 6M -847-5555: bhoff@ example.com 1

Hairy P o tte r 312-985-9696 hpott@ exam ple.com  !

i n u m __________ ________ .................................... _ j

A simple table block in Preview mode

Starting the Database Wizard
1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click Table Block.

Step 1: Document Type
1. Click the Script type box and select the dynamic document standard (p.432) you want to use.
2. Click the Database box and select the appropriate connection method for your database. (If you 

chose ASP as the script type, you will only be able to select ODBC.)
3. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database, 

o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
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3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 
for preview box and select the ODBC data source (p.435) corresponding to your database.

4. Click Next.

Step 3: Database Fields
1. For each database field you want to include in the table block, select the field in the box on the left 

and click Add. To add all the fields in a table, select the table and click Add.
2. Click Next.

Step 4: Selection Statement
1. If you added fields from more than one table in Step 3 of the wizard, enter a join condition (p.458) 

in the Join box.
2. If you want to filter the database records according to some criteria, enter a filter condition (p.463) 

in the Filter box.
3. If you want the records to be sorted a particular way in the table block, enter a sort condition 

(p.463) in the Sort by box.
4. Click Next.

Step 5: Block Elements
1. If you want to remove one or more unnecessary block elements, select each and click Remove. 

(However, do not remove the Page Link Set element unless you intend to display all the records on 
one page.)

2. Click Next.’

Step 6: List Settings
1. In the Number of rows box, enter the number of rows you want the table block to display on a page. 

(If the number of records exceeds this number, page links will be automatically inserted at the 
bottom of the table block so that users can see all records.)

2. Click Finish.

When you finish the Database Wizard, the table block will be inserted into the current document. In Edit
mode, the block will initially look something like the following:

Customers .N ame Customers .PhoneNnmber Customers-EmailAddress

[val] [val] [val]

[£ < ;] [12 2 4 5 fi2 £ 2 iQ ][£ S i]

Example of a table block in Edit mode before modification

The highlighted words "[val]" in the second row represent output elements. These placeholders will be 
replaced with generated content—actual data from the database—when the document is opened in a 
browser. Do not delete a placeholder, unless you want to remove the corresponding block element.
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The default column headers are simply the names of the database fields you selected in Step 3 of the wizard. 
Since these headers are static, plain text, you can replace them with any content you want.

The bottom row of the table contains a placeholder for page links that will be dynamically generated by the 
Web server when the number of records to be displayed exceeds the number of rows you specified for the 
table block.

To preview the table block with generated content, switch to Preview mode.

You can format the table block as you would an ordinary table. You can also format the text inside it and 
add static content, such as images. For more information about formatting a block, see Formatting 
database-driven content, p.477.

Related topics
Joining fields from two or more database tables
Working with block elements.........................
Formatting database-driven content................

Creating a list block

A list block displays multiple database records in series. Each record occupies a borderless table inside one 
cell of a single-column table, and each field occupies one row in the record's table.

Name: John Humphries
Phone: 303-848-3093
E-mail: johnny@example.com

Name: Jane Doer
Phone: 212-845-8965
E-mail: jdoer@example.com

Name: Mick Miggler
Phone: 904-897-5626
E-mail: mm@example.com

[ 1 2 3 4 5 6 7 8 ]  f » 1

A simple list block in Preview mode
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1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click List Block.

Step 1: Document Type
1. Click the Script type box and select the dynamic document standard (p.432) you want to use.
2. Click the Database box and select the appropriate connection method for your database. (If you 

chose ASP as the script type, you will only be able to select ODBC.)
3. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database, 

o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 

for preview box and select the ODBC data source (p.435) corresponding to your database.
4. Click Next.

Step 3: Database Fields
1. For each database field you want to include in the list block, select the field in the box on the left 

and click Add. To add all the fields in a table, select the table and click Add.
2. Click Next.

Step 4: Selection Statement
1. If you added fields from more than one table in Step 3 of the wizard, enter a join condition (p.458) 

in the Join box.
2. If you want to filter the database records according to some criteria, enter a filter condition (p.463) 

in the Filter box.
3. If you want the records to be sorted a particular way in the list block, enter a sort condition (p.463) 

in the Sort by box.
4. Click Next.

Starting the Database Wizard
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Step 5: Block Elements
1. If you want to remove one or more unnecessary block elements, select each and click Remove. 

(However, do not remove the Page Link Set element unless you intend to display all the records on 
one page.)

2. Click Next.

Step 6: List Settings
1. In the Number of rows box, enter the number of records you want the list block to display on a 

page. (If the number of records exceeds this number, page links will be automatically inserted at 
the bottom of the list block so that users can see all records.)

2. Click Finish.

When you finish the Database Wizard, the list block will be inserted into the current document. In Edit 
mode, the block will initially look something like the following:

Customers.Name Jvalj J
Customers JPhoneNumber Jval] \

Customers FjnaflAddress Jval] \ j

|[<g] [1 2245  fiZfiSlfl] [>>] "|

Example of a list block in Edit mode before modification

The highlighted words "[val]" in the right column represent output elements. These placeholders will be 
replaced with generated content—actual data from the database—when the document is opened in a 
browser. Do not delete a placeholder, unless you want to remove the corresponding block element.

The default element labels in the left column are simply the names of the database fields you selected in 
Step 3 of the wizard. Since these headers are static, plain text, you can replace them with any content you 
want.

The bottom row of the outer table (the table that contains all the record tables) contains a placeholder for 
page links that will be dynamically generated by the Web server when the number of records to be 
displayed exceeds the number of rows you specified for the list block.

To preview the list block with generated content, switch to Preview mode.

You can format the list block as you would an ordinary table. You can also format the text inside it and add 
static content, such as images. For more information about formatting a block, see Formatting database- 
driven content, p.477.
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Joining fields from two or more database tables..................................... p.458
Working with block elements............................................................... p.466
Formatting database-driven content.......................................................p.477

Related topics

Creating a detail block

A detail block displays a single database record. Each database field occupies one row in a table.

Name John Humphries
Company Acme Widgets. Inc.
Street Address 92MontvaleAve.
City Stoneham
State/Province MA
Postal Code 02148
Country USA
Phone
Number 303-848-3093

E-mail Address johnny@example.com

Notes Birthday is 6/2/70. Wife: Marianne. 
No kids.

A simple detail block in Preview mode

Starting the Database Wizard
1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click Detail Block.

Step 1: Document Type
1. Click the Script type box and select the dynamic document standard (p.432) you want to use.
2. Click the Database box and select the appropriate connection method for your database. (If you 

chose ASP as the script type, you will only be able to select ODBC.)
3. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database.
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o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 

for preview box and select the ODBC data source (p.435) corresponding to your database.
4. Click Next.

Step 3: Database Fields
1. For each database field you want to include in the detail block, select the field in the box on the 

left and click Add. To add all the fields in a table, select the table and click Add.
2. Click Next.

Step 4: Selection Statement
1. If you added fields from more than one table in Step 3 of the wizard, enter a join condition (p.458) 

in the Join box.
2. In the Filter box, enter a filter condition (p.463) to select the record to be displayed in the detail 

block. (For information about configuring a detail block to display a specific record depending on 
the value of a parameter in the URL, see Using parameters with database-driven documents, 
p.460.)

3. Click Next.

Step 5: Block Elements
1. If you want to remove one or more unnecessary block elements, select each and click Remove.
2. Click Finish.

When you finish the Database Wizard, the detail block will be inserted into the current document. In Edit 
mode, the block will initially look something like the following:
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Customers.Name | [v ^ __________________  J

Cnstomers.Company | [val] |

Customers. StrectAddress | [val] |

Customers.City | [val] |

Customers. StateOrProvince [val]

Customers PostalCode jj[val] j

Costomers.Country j [val]

Customers PhoneNumber [val]

Customers£ma3Address j[val] |

Customers JNotes | [val]

Example of a detail block in Edit mode before modification

The highlighted words "[val]" in the right column represent output elements. These placeholders will be 
replaced with generated content—actual data from the database—when the document is opened in a 
browser. Do not delete a placeholder, unless you want to remove the corresponding block element.

The default element labels in the left column are simply the names of the database fields you selected in 
Step 3 of the wizard. Since these headers are static, plain text, you can replace them with any content you 
want.

To preview the detail block with generated content, switch to Preview mode.

You can format the detail block as you would an ordinary table. You can also format the text inside it and 
add static content, such as images. For more information about formatting a block, see Formatting 
database-driven content, p.477.

Related topics
Joining fields from two or more database tables
Working with block elements.........................
Formatting database-driven content.................

Creating a chart block

A chart block displays quantitative information from multiple records in a database table as a chart or graph.

p.458
p.466
p.477
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Regional Sales

Widgets Gewgaws

□  Japan □  United States □  Korea

A simple chart block in Preview mode

Data requirements

The database table you wish to use in a chart block must meet certain requirements:

• The table must have at least one numerical field, which contains the quantitative values to be 
charted. However, if there is more than one number field, the chart block will only use one.

• If you want the chart block to use series or category labels taken from the database table, both 
series and category labels must exist in the table. If only one set of labels exist in the table, the 
chart block cannot use it and you must enter both sets of labels manually.

Examples of valid database tables for use with a chart block

E x a m p le  1

RecJD Country Product Unit_Sales
1 United States Widgets 748
2 United States Gewgaws 514

3 Sweden Widgets 225
4 Sweden Gewgaws 287
5 Japan Widgets 369
6 Japan Gewgaws 654

This table is ideal for use with a chart block. There is only one number field, and there are two 
string fields, one of which will be used as the source of series labels and the other for category 
labels. The chart produced from this table can have either two series and three categories, or three
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series and two categories, depending on whether the countries are series and the products are 
categories, or vice versa.

Example 2

RecJD Measurement Month Value

1 Mean Temperature January 19

2 Mean Temperature February 20

3 Mean Temperature March 22

4 Mean Temperature April 25

5 Mean Temperature May 26

6 Mean Temperature June 28

This table is also well suited for use with a chart block. In this table, there is one series (Mean 
Temperature) and six categories (the months).

Example 3

RecJD Value

1 748

2 514

3 225

4 287

5 369

6 654

This table is suitable for use with a chart block, but since it provides only values and no labels, the 
series and/or category labels will need to be entered manually. The number of series and 
categories must also be specified manually.

Starting the Database Wizard
1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click Chart Block.

Step 1: Document Type
1. Click the Script type box and select the dynamic document standard (p.432) you want to use.
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2. Click the Database box and select the appropriate connection method for your database. (If you 
chose ASP as the script type, you will only be able to select ODBC.)

3. Click the Server OS box and select the operating system used by your Web server. The Database 
Wizard needs this information in order to determine which version of the chart drawing CGI 
program to save with the document.

4. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database.

o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 

for preview box and select the ODBC data source (p.435) corresponding to your database.
4. Click Next.

Step 3: Database Fields
1. For each database field you want to include in the chart block, select the field in the box on the left 

and click Add. To add all the fields in a table, select the table and click Add.
2. Click Next.

Step 4: Selection Statement
1. If you added fields from more than one table in Step 3 of the wizard, enter a join condition (p.458) 

in the Join box.
2. If you want to filter the database records according to some criteria, enter a filter condition (p.463) 

in the Filter box.
3. If you want the records to be sorted a particular way in the chart block, enter a sort condition 

(p.463) in the Sort by box.
4. Click Next.

Step 5: Chart Settings
1. Under Source fields, click the Value box and select the numerical database field that will provide 

the numerical values for the chart block.
2. Under Series and categories, click Retrieve from database if you want the chart block to obtain 

series and category labels from the database. Otherwise, leave the Enter manually option selected 
and, in the Number of categories and Number of series boxes, enter the number of categories and
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series you want the values to be organized into. (See "Entering series and category labels 
manually" later in this section.)

3. If you selected the Retrieve from database option, click the Series names box and select the 
database field that will provide the series labels, and then click the Category names box and select 
the database field that will provide the category labels.

4. Click Next.

Step 6: Chart Type
1. Select a basic chart type by clicking one of the small icons at the top of the dialog box, and then 

select a subtype by clicking one of the large icons in the selection box.
2. If you want the chart to have a 3D-like appearance, select the Use 3D effect check box, and then 

enter the desired values in the Depth of 3D effect and 3D perspective angle boxes.
3. Click Next.

Step 7: Chart Titles
1. If you want the chart to have a title, in the Chart title box, type an optional title for the chart, and 

then under Chart title location, select one of the six available title positions.
2. If you want titles for the X- and Y-axes of the chart, type them in the boxes under Axis titles.
3. Click Finish.

When you finish the Database Wizard, the chart block will be inserted into the current document. In Edit
mode, the block will initially look something like the following:

R e g io n a l  S a le s

/ / /
. /
. /
. /
. /
. /
/
/ / — /

■
Example of a chart block in Edit mode before modification

To preview the chart block with generated content, switch to Preview mode.
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Entering series and category labels manually

If the database table you use for a chart block does not contain appropriate series and category labels, you 
must enter these labels manually and also specify how many series and categories the chart should have.
Do the following:

1. In Step 5 of the Database Wizard, under S e r i e s  a n d  c a t e g o r i e s ,  select E n t e r  m a n u a l l y  and enter the 
number of categories and series in the N u m b e r  o f  c a t e g o r i e s  and N u m b e r  o f  s e r i e s  boxes.

2. When you have completed the wizard, double-click the chart block to open the Chart Block 
Properties dialog box.

3. Click the Series tab.
4 .  Select the first series in the list box on the left, and then enter a label for it in the S e r i e s  n a m e  box.

Chart Bock Settings | Chart Type | Tile Series | Values | Ti 

Select a series and modify its options on the right.

iHiiiHSHECByi ¿ef*e$ name:
jj^J ............. (United SM

5. Select the next series and enter its label in the S e r i e s  n a m e  box. Repeat for each series.
6. Click the V a l u e s  tab.
7. In the C a t e g o r y  column of the table at the top, double-click the green cell in the first data row, as 

shown below, and enter the label for the first category.
Chart Hock Settings | Chart Type | Tile | Series Values | Trendlir*

i iUnited States Russia Japan
14

hi • 'n 14 15

Chart Bock Settings | Chart Type | Tile | Series Values | Trendline

I [United States Japan Russia
I Widgets) J  | 1 9

II. I 12 18

8. Double click the next green category cell and enter the label for the next category. Repeat for each 
category.

9. When finished, click OK.

Changing the appearance of a chart block

Chart blocks are similar in most ways to static charts created using the Chart Wizard (p.484). You can 
modify their appearance in many of the same ways. For information about changing the appearance of 
charts, see Modifying chart properties, p.487.
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When you create a chart block, Namo WebEditor saves a CGI program in the same folder as the document 
containing the block. This program actually draws the database-driven chart on the Web page when the 
document is opened in a browser. Normally, when you publish the document, you upload the CGI file 
along with the document to the same server folder. However, some Web servers require that CGI programs 
be kept in a special folder, separate from documents. (Often, this special folder is named "cgi-bin" and 
exists at the top level of the site’s file system.) If your Web server has such a requirement, you must modify 
the default CGI path for the chart block and copy the CGI file to the server's CGI folder.

To modify the CGI path, do this:
1. After you have completed the Database Wizard, double-click the chart block to open the Chart 

Block Properties dialog box.
2. Click the Chart Block Settings tab.
3. In the CGI path box, enter the path of your server's CGI folder. You can enter either a relative path 

based on the document's location, such as "../cgi-bin/”, or an absolute path from the root of the 
site's file system, such as "/cgi-bin/".

4. Click OK and save the document.

When you publish the document, make sure to upload the CGI program file to your server's CGI folder. 
You should find the CGI file in the document’s folder on your local file system, with a file name like 
"wed_chart_windows.cgi". The last part of the file name (before the extension) varies depending on the 
server operating system you specified in Step 1 of the Database Wizard. If you cannot find the CGI file in 
the document folder, you can find a copy of it in the l i b \ D B W i z a r d  subfolder of the folder in which you 
installed Namo WebEditor. For example, if you installed Namo WebEditor in the default location on your 
C drive, the folder containing the CGI files is C : \ P r o g r a m  F i l e s \ N a m o \ W e b E d i t o r  6 \ l i b \ D B W i z a r d .

0  If you change the CGI path, you will no longer be able to preview the chart block on your computer 
unless you copy the CGIfile to the same path on your local file system. For example, if  you specified 
the CGI path as "/cgi-bin", you should copy the CGI file to the C:\cgi-binfolder, creating the folder if 
necessary.

Related topics
Joining fields from two or more database tables..................................... p.458
Modifying chart properties................................................................... p.487

Changing the CGI path for a chart block
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C r e a t i n g  a n  i n p u t  b l o c k

An input block is a form that allows users to insert a new record into a database or update an existing 
record.

In this section
Creating an input block........
Creating a modification block

Related topics
Creating an output block......
Overview of the Database Wizard

Creating an input block

An input block is a database-driven form that is used to insert a new record into a database. The form is 
contained in a table.

Order Date 0 3 jJ/|3 1 jd /|2 0 0 3 jJ

Customer Name ¡Henry Cartier

Product | Namo WebEditor 6.0 English

Quantity |2~  '

Remarks

Deliver by 3/22 latest.

f SubrmtOrder j Reset Form

A simple input block in Preview mode

Starting the Database Wizard
1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click Input Block.

Step 1: Document Type
l . Click the Script type box and select the dynamic document standard (p.432) you want to use.

.p.437

.p.435

.p.452

.p.454
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2. Click the Database box and select the appropriate connection method for your database. (If you 
chose ASP as the script type, you will only be able to select ODBC.)

3. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database.

o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 

for preview box and select the ODBC data source (p.435) corresponding to your database.
4. Click Next.

Step 3: Database Fields
1. For each database field you want to include in the input block, select the field in the box on the left 

and click Add. To add all the fields in a table, select the table and click Add. (Note: for an input 
block, you can only include database fields from one table only. The wizard will not allow you to 
include fields from multiple tables.)

2. Click Next.

Step 4: Block Elements
1. If you want to remove one or more unnecessary block elements, select each and click Remove.
2. Click Next.

Step 5: Input Method
1. Click either the GET option or the POST option, depending on how you want the browser to 

submit the data in the input block to the Web server. POST is usually preferable, since this method 
imposes no limit on the amount of data that can be submitted. Choose GET only if you have a 
specific reason to do so.

2. In the Result page URL box, enter an optional path or URL for a result page. If you leave this box 
empty, users will see a simple "Input process complete" message when they submit the input form. 
A more useful result page might be a document that contains a table block (p.438) or list block 
(p.440) displaying the latest records in the database table that was just updated.

3. Click Finish.

When you finish the Database Wizard, the input block will be inserted into the current document. In Edit
mode, the block will initially look something like example below:
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OrdersDate |12_^J/J25_:IJ /]1990_3J |l1

Orders.Customer |stmg

Orders-Prodnct |12345

Orders.Quantity 112345

Orders. Comment
t e l l
ted2

<1 ^
Submftquery | Reset |

Example of an input block in Edit mode before modification

The input element placeholders in the right column are shown with example values that indicate the type of 
the input element. To change the properties of an input element, double-click it.

The default element labels in the left column are simply the names of the database fields you selected in 
Step 3 of the wizard. Since these labels are static, plain text, you can replace them with any content you 
want.

You can replace a box-type input element with a database-driven drop-down menu or radio button group 
(p.471). This is useful when you want to restrict the values users can input in a particular database field, or 
you want to display a menu o f possible selections instead o f forcing users to enter a numeric value (such as 
Orders.Product in the example above).

You can format an input block as you would an ordinary table. You can also format the text inside it and 
add static content, such as images. For more information about formatting a block, see Formatting 
database-driven content, p.477.

Related topics
Modifying input element properties........................................................p.475
Working with block elements................................................................p.466
Replacing an input box with an input control.......................................... p.471
Formatting database-driven content........................................................p.477

Creating a modification block

A modification block is a database-driven form that is used to modify an existing record in a database. The 
form is contained in a table.
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Order Date | 0 3 j J / | 3 1 j J / | 2 0 0 3 j J

Customer Name (Henry Cartier

Product | NamoWebEditor 6.0 English j J

Quantity |2

!

Remaries

I

Deliver by 3/22 latest. > |
i : 
I ; i

- i

f Submit Order ! Reset Form

A simple modification block in Preview mode

Starting the Database Wizard
1. Place the insertion point anywhere in the current document.
2. On the Insert menu, point to Database, and then click Modification Block.

Step 1: Document Type
1. Click the Script type box and select the dynamic document standard (p.432) you want to use.
2. Click the Database box and select the appropriate connection method for your database. (If you 

chose ASP as the script type, you will only be able to select ODBC.)
3. Click Next.

Step 2: Data Source
1. Do one of the following, depending on your selection in the Database box in Step 1 of the wizard:

o If you chose ODBC: Click the Data source box and select the ODBC data source (p.435) 
corresponding to your database, 

o If you chose MySQL:
1. In the MySQL host box, enter the hostname or IP address and port number of 

your MySQL server, replacing the text within brackets. Also delete the brackets.
2. In the MySQL DB name box, enter the name of your MySQL database.

o If you chose one of the JDBC connection methods (for a JSP document): In the Data 
source URL box, replace the parameters in brackets with appropriate values for your 
database. Also delete the brackets.

2. If your data source or database is password-protected, fill in the User ID and Password boxes.
3. If you chose a connection method other than ODBC in Step 1 of the wizard, click the ODBC DSN 

for preview box and select the ODBC data source (p.435) corresponding to your database.
4. Click Next.
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Step 3: Database Fields
1. For each database field you want to include in the modification block, select the field in the box on 

the left and click Add. To add all the fields in a table, select the table and click Add. (Note: for a 
modification block, you can only include database fields from one table only. The wizard will not 
allow you to include fields from multiple tables.)

2. Click Next.

Step 4: Selection Statement
1. In the Filter box, enter a filter condition (p.463) to select the record to be modified. (For 

information about configuring a modification block to display a specific record depending on the 
value of a parameter in the URL, see Using parameters with database-driven documents, p.460.)

2. Click Next.

Step 5: Block Elements
1. If you want to remove one or more unnecessary block elements, select each and click Remove.
2. Click Next.

Step 6: Input Method
1. Click either the GET option or the POST option, depending on how you want the browser to 

submit the data in the modification block to the Web server. POST is usually preferable, since this 
method imposes no limit on the amount of data that can be submitted. Choose GET only if you 
have a specific reason to do so.

2. In the Result page URL box, enter an optional path or URL for a result page. If you leave this box 
empty, users will see a simple "Input process complete" message when they submit the input form. 
A more useful result page might be a document that contains a table block (p.438) or list block 
(p.440) displaying the latest records in the database table that was just updated.

3. C lick Finish.

When you finish the Database Wizard, the modification block will be inserted into the current document. In
Edit mode, the block will initially look something like example below:
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Orders JDate |11

Orders.Customer |stnng

Orders-Product 112345

Ordcrs.Qnantity 112345

Orders.Comment

tod1
text2

L ^
Submit query Reset

Example of an modification block in Edit mode before modification

The input element placeholders in the right column are shown with example values that indicate the type of 
the input element. To change the properties of an input element, double-click it.

The default clement labels in the left column are simply the names of the database fields you selected in 
Step 3 of the wizard. Since these labels are static, plain text, you can replace them with any content you 
want.

You can replace a box-type input element with a database-driven drop-down menu or radio button group 
(p.471). This is useful when you want to restrict the values users can input in a particular database field, or 
you want to display a menu of possible selections instead of forcing users to enter a numeric value (such as 
Orders.Product in the example above).

You can format a modification block as you would an ordinary table. You can also format the text inside it 
and add static content, such as images. For more information about formatting a block, see Formatting 
database-driven content, p.477.

Related topics
Using parameters with database-driven documents.................................p.460
Modifying input element properties.......................................................p.475
Working with block elements...............................................................p.466
Replacing an input box with an input control..........................................p.471
Formatting database-driven content.......................................................p.477
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J o i n i n g  f i e l d s  f r o m  t w o  o r  m o r e  d a t a b a s e  t a b l e s

About joining database tables
When you create a database-driven output block involving a database that has more than one table, often 
the information you want to retrieve is spread across two or more tables. In such cases, you must specify a 
join condition for the block that describes how records in each of the tables match up.

For example, say you have a database table called Orders, in which each record contains information about 
an order placed by one of your customers for some product you make. You want to create a table block 
(p.438) to display these orders in tabular form on a Web page.

If your Orders database table stands alone, having no relationship with other tables in the database, then 
you only need to use fields in the Orders table in the table block. Presumably, the Orders database table will 
have fields for order date, customer name, product name, quantity, and so forth; and this is exactly what 
you want to be displayed in the table block.

Now, suppose you have a more sophisticated database, in which the Orders table has a Customer field that 
contains not names but ID numbers. Another table in the database—call it Customers—contains names, 
addresses, phone numbers, and so forth for each customer ID. In this case, if you were to use only fields 
from the Orders table in your table block, the table block would display customer ID numbers, not names. 
To make the table block display customer names, you need to change the output element linked to the 
Orders.Customer database field so that it links to the Customers.Name field instead.

However, simply changing the output element to use Customers.Name is not enough. Without additional 
information, the server would not know how records in the Customers table match up with records in the 
Orders table, and thus would not know which customer name to retrieve for a given order record. A join 
condition provides this information.

A join condition specifies the relevant relationship between two database tables. It consists of the names of 
two fields from two tables, with an equality sign in the middle:

T able_l.F ield_l = Table_2.Field_2

For our example scenario, the appropriate join condition would be:

Orders.Customer = Customers.ID

This statement tells the server: "For each customer ID in the Orders table, retrieve the customer name from 
the record in the Customers table that has the same ID number."

Join conditions can have multiple equations separated by "AND". Multiple equations are necessary when 
an output block uses more than two database tables. To continue our example, if the Orders database 
contains both customers and products as ID numbers, and you want the table block to display product
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names as well as customer names, you would need to use the Name field from the Products table and 
modify the join condition as follows:

Orders.Customer = Customers.ID AND Orders. Product = Products.ID

This statement tells the server: "For each customer ID in the Orders table, retrieve the customer name from 
the record in the Customers table that has the same ID number; and for each product ID in the Orders table, 
retrieve the product name from the record in the Products table that has the same ID number."

In the Database Fields step of the Database Wizard, if you are using fields from multiple database tables, 
you need to include not only the fields that will be displayed in the output block, but also all the fields that 
are involved in the join condition. Thus, in our example, the following database fields would be included.

From the Orders table:

• Orders.Date
• Orders.Customer
• Orders.Product
• Orders.Quantity

From the Customers table:

• Customers.ID
• Customers.Name

From the Products table:

• Products.ID
• Products.Name

To create an output block that uses fields from multiple tables

1. Start the Database Wizard for the desired type of output block and complete steps 1 and 2.
2. In step 3 of the wizard, Database Fields, add all the fields that match the following criteria:

o Database fields for which you want output elements in the output block
o Database fields that are involved in relationships between the tables included in the 

output block
3. In step 4 of the wizard, Selection Statement, enter the appropriate join condition in the Join box. 

(Clicking the ... button next to the Join box reveals a menu of available database fields and 
operators; you can select one instead of typing it in manually.)

4. In step 5 of the wizard, Block Elements, remove the output elements corresponding to database 
fields you do not want to be displayed in the output block. (For example, you may wish to remove 
output elements corresponding to numeric ID fields in the database.)

Join: | Order s. Customer « Customer. ID
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5. Complete the remainder of the Database Wizard.

To modify an output block to use fields from multiple tables

1. Right-click anywhere inside the block, point to Database, and then click Block Properties.
2. Click the Database Fields tab.
3. Add all the fields that match the following criteria:

o Database fields for which you want output elements in the output block 
o Database fields that are involved in relationships between the tables included in the 

output block
4. Click the Selection Statement tab.
5. In the Join box, enter the appropriate join condition relating the tables included in the output block. 

(Clicking the ... button next to the Join box reveals a menu of available database fields and 
operators; you can select one instead of typing it in manually.)

6. Click OK.
7. Double-click the placeholder for an output element that you want to change to link to a different 

database field.
8. Click the ... button next to the Database field box and select the item corresponding to the desired 

database field. (For example, if the desired database field is Customers.Name, select 
<f,Customers.Name>.

9. Click OK.
10. Repeat steps 7 through 9 for each output element you want to change.

U s i n g  p a r a m e t e r s  w i t h  d a t a b a s e - d r i v e n  d o c u m e n t s

A parameter, as it relates to the Web, is a variable that is appended to the end of a URL pointing to a 
database-driven document. Both the parameter's name and its value are included in the URL. For example, 
in the URL:

http://\vww.example.com/news/article.php?id= 1124

the parameter is the string that follows the question mark. The word "id” is the parameter's name, and 1124 
is its value.

Parameters can be used in three different ways with database-driven documents created using the Database 
Wizard:

Source Information | Data Source | Database Fields Selection Statement | Table Settings |

Join: jOrders. Customer = Customer.lD
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• A parameter can determine the database record or records displayed in a block.
• A parameter can provide the contents of an output element.
• A parameter can provide the default value for an input element.

Using a parameter to determine the record displayed in a block
Much of the power of database-driven Web documents lies in their ability to display different content, 
depending on a parameter that is appended to the URL that links to such a document. The same document 
on the Web server serves as a template for many different generated documents that the server sends to 
Web browsers.

For example, say you have a document named article.php, containing a detail block (p.443) that displays 
one article in a database of news stories. A typical URL for this document might look like:

http://www.example.com/news/article.php?id=1124

The parameter (the part of the URL that follows the question mark) tells the server which article is being 
requested—in this case, the article whose ID number is 1124. Since the parameter's value can vary, the 
same URL can be used to display many different articles by simply changing the value of the parameter.

To use a parameter to determine the record that is displayed in a block, you include a reference to it in the 
filter condition (p.463) for the block. You can use a parameter in the filter condition of any kind of block 
except input blocks (p.452). (Since an input block does not retrieve a record from the database, it cannot 
make use of a parameter in this way.)

To include a parameter in a filter condition, click the... button next to the Filter box and select the 
parameter. For more information about entering filter conditions, see Filtering and sorting database records, 
p.463.

Using a parameter to provide the contents of an output element
Usually, an output element is used to display the contents of a database field. However, you can make an 
output element display the value of a parameter instead. To specify a parameter for an output element, click 
the ... button next to the Database field box in the Output Element Properties dialog box and select a 
parameter. For more information, see Adding an output element, p.467.

Using a parameter to provide the default value for an input element
Any input element can be assigned a default value, which determines the initial contents or selection of the 
input element when the document is opened in a browser. You can specify a fixed default value, such as the 
string "John Smith" or the number 42, or you can specify that the default value be equal to the value of a 
parameter. To set a default value to the value of a parameter, click the ... button next to the Default value 
box in properties dialog box for the input element and select a parameter. For more information, see 
Modifying the properties of an input box, p.475.
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Parameters in generated hyperlinks
Although you can create an ordinary (static) link to a dynamic document and include a parameter in the 
link, a much more powerful way to use parameters is to have the Web server generate hyperlinks in another 
dynamic document. This can be done using a hyperlink output element (p.469) in an output block.

For example, say you have a list block that displays a list of headlines from a database of news stories. It 
might look something like this:

Man Dies in Bizarre Bowling Accident 
"Gangs of New York" Rovallv Snubbed at Oscars 
Red Sox Win World Series (of Line Dancing)
Star Trek Fan Defends Vulcan Mating Ritual 
Scientist Savs Smoking Reduces Risk of Jogging 
[ 1 2 ] [ > > ]

In this list block, each news headline is a hyperlink to another dynamic document that displays the whole 
article. The hyperlinks are generated by the Web server from a base URL you specify—for example, 
/news/article.php. The server appends to the base URL a parameter whose name is the same for each link, 
but whose value depends on the value of a field in the individual database record.

For more information about hyperlink output elements, see Adding a hyperlink output element, p.469.

In this section
Registering a parameter........................................................................p.462

Related topics
Filtering and sorting database records 
Adding a hyperlink output element....

R e g i s t e r i n g  a  p a r a m e t e r

Before you can use a parameter with a database-driven document created with the Database Wizard, you 
first need to register it. Registering a parameter creates a definition for the parameter in the document's 
source code and allows it to be used in any database-driven block in the document. You can register a 
parameter either within the Database Wizard or after you have completed the wizard.

.p.463

.p.469
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To register a parameter within the Database Wizard

1. In step 4 of the wizard, Selection Statement, click the ... button next to the Filter box and then click 
<Add New Arguments

2. Click Add. A new parameter will appear in the parameter list, and its name will be highlighted.
Parameters I

Argument name I Datatype I Argument type I Input method | Add.. |

3 2 3 3 0 5 3 ^ Integer User GET
fiemove |

3. Type a name for the parameter and press Enter.
4. Double-click the word Integer in the Data type column, and then select the appropriate data type. 

(You should select the data type that matches the data type of the database field that the parameter 
will be used with in the filter condition. For example, if the parameter will be used with a numeric 
ID field, select Integer.)

5. Click OK.

To register a parameter after completing the Database Wizard

1. Right-click anywhere in the document, point to Database, and then click Document Properties.
2. Click the Parameters tab.
3. Click Add. A new parameter will appear in the parameter list, and its name will be highlighted.

Source Wormation | Document Type Parameters |

Argument name I Datatype I Argument type I Input method |

ÎHSSËEn Integer User GET
fidd..

Remove |

4. Type a name for the parameter and press Enter.
5. Double-click the word Integer in the Data type column, and then select the appropriate data type. 

(You should select the data type that matches the data type of the database field that the parameter 
will be used with in the filter condition. For example, if the parameter will be used with a numeric 
ID field, select Integer.)

6. Click OK.

F i l t e r i n g  a n d  s o r t i n g  d a t a b a s e  r e c o r d s

About filter conditions
You can restrict the records that an output block displays by specifying a filter condition for the block. A 
filter condition is optional for table (p.438), list (p.440), and chart (p.445) blocks, but it is mandatory for 
detail blocks (p.443), which always display only a single record. A filter condition is also required for a
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modification block (p.454), since only one record can be modified at a time. Filter conditions are not 
applicable to input blocks (p.452).

A filter condition consists of the name of database field, an operator, and a value:

[f ie ld  name] [operator] [value]

For example, in a table block that lists CDs in a music collection, the filter condition:

CDs.Artist = "Miles Davis"

would cause the block to display only the records where the Artist field contained ’’Miles Davis”. 
Alternatively, the filter condition CDs . NumberOf Tracks > 10 would cause the block to display only 
the records where the NumberOfTracks field contained a number greater than 10.

Filter conditions can include multiple criteria separated by the keywords AND and OR. The condition:

CDs.Artist = "Miles Davis" AND CDs.NumberOfTracks > 10

would cause the block to display only the records that matched both criteria, whereas the condition:

CDs.Artist = "Miles Davis" OR CDs.NumberOfTracks > 10

would cause the block to display all the records that matched either criterion.

You can use the NOT keyword to construct a negative filter condition. For example, NOT CDs. A r t is t  
= "Miles D a v is" would select all the records where Artist did not contain "Miles Davis". NOT can be 
combined with AND or OR as well, but be careful how you phrase such a filter condition. The following 
conditions have different meanings:

NOT CDs.Artist = "Miles Davis" OR CDs.NumberOfTracks > 10

NOT ( CDs.Artist = "Miles Davis" OR CDs.NumberOfTracks > 10 )

The first condition means "Select the records where Artist is not "Miles Davis" or where NumberOfTracks 
is greater than 10." whereas the second condition means "Select the records where Artist is not "Miles 
Davis" am/NumberOfTracks is not greater than 10." The second condition is equivalent to:

NOT CDs.Artist = "Miles Davis" AND NOT CDs.NumberOfTracks > 10

Another keyword, IN, is used to test whether the value of a field matches one of a set of values. For 
example, the condition:
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CDs.Artist IN ( "Miles Davis", "Chuck Berry", "Eminem" ) 

would select all the records where Artist was one of the values in the set.

To specify a filter condition for a block
1. Do one of the following:

o Within the Database Wizard, go to step 4, Selection Statement, 
o After completing the Database Wizard, right-click anywhere inside the block, point to 

Database, click Block Properties, and then click the Selection Statement tab.
2. In the Filter box, enter the desired filter condition. (Clicking the... button next to the Filter box 

reveals a menu of available database fields, parameters, and operators; you can select one instead 
of typing it in manually.)

3. Click OK or Next.

Using a parameter in a filter condition
A parameter (p.460) can replace a value in a filter condition. This allows a database-driven document to 
display a different record or set of records depending on the value of the parameter given in the URL used 
to link to it.

For example, a detail block could have a filter condition like the following:

Customers.ID = <a,cid>

Then, if the URL that links to the document containing the detail block is something like 
"detail.asp?cid=123", the detail block will display the customer record whose ID is 123.

Before you can use a parameter in a filter condition, you have to register (p.462) it. Once you have 
registered it, you can insert the parameter in a filter condition by clicking the ... button next to the Filter box 
and selecting the parameter. The menu displays only parameters that have been registered. Parameters are 
listed in the form <aparameter__name>, where parameter_name is replaced with the name o f the parameter.

About sort conditions
You can sort the records that some types of output block display by specifying a sort condition for the 
block. A sort condition is optional for table (p.438), list (p.440), and chart (p.445) blocks. Sort conditions are 
not applicable to detail blocks (p.443), modification block (p.454), or input blocks (p.452).

A sort condition consists simply of one or more database field names. If more than one, the field names are 
separated by commas. For example, in a table block listing the CDs in a music collection, the sort 
condition:

CDs.Artist, CDs.Title

Filter: jCDs.Artist = "Miles Davis"
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would cause the records to be sorted first by artist name and then by CD title.

To sort in reverse order, add the keyword DESC after a field name. For example, the sort condition:

CDs.Artist DESC, CDs.Title

would cause the records to be sorted first by artist name in descending order and then by CD title in normal 
(ascending) order.

To specify a sort condition for a block

1. Do one of the following:
o Within the Database Wizard, go to step 4, Selection Statement, 
o After completing the Database Wizard, right-click anywhere inside the block, point to 

Database, click Block Properties, and then click the Selection Statement tab.
2. In the Sort box, enter the desired sort condition. (Clicking the ... button next to the Sort box 

reveals a menu of available database fields and keywords; you can select one instead of typing it 
in manually.)

S ort by: |CDsAtist DESC. CDs.Title

3. Click OK or Next.

Related topics
Using parameters with database-driven documents..................................p.460

W o r k i n g  w i t h  b l o c k  e l e m e n t s

The functional units in database-driven content blocks are called block elements. Each block element 
performs some unique function in the block, such as displaying the value of one database field. (A block 
can also contain static, non-database-driven elements, but these are not considered block elements.)

When you complete the Database Wizard, the finished block has a certain number and composition of 
block elements. However, the mix of elements in the block is not fixed; you can change it at any time. You 
can remove unnecessary elements, add elements you had not previously planned to use, or replace existing 
elements with others. In addition, you can change an output element so that it displays the contents of a 
different database field, and you can modify various properties of an input element.
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Removing block elements.................................................................... p.467
Adding an output element.................................................................... p.467
Adding an input box............................................................................ p.468
Adding a hyperlink output element....................................................... p.469
Replacing an input box with an input control..........................................p.471
Adding a hidden input element.............................................................p.474
Changing a block element's associated database field..............................p.475
Modifying input box properties.............................................................p.475

In this section

Removing block elements

To remove a block element
1. Click the block element you want to remove.
2. Press Delete.

If the database field associated with a removed block element is not associated with any other element, you 
can remove it from the list of database fields used by the block. Doing so is normally optional, but it is 
required if you have removed or will remove the field from the database itself.

To remove an unused database field
1. Right-click inside the block, point to Database, and then click Block Properties.
2. Click the Database Fields tab.
3. Select the unused field in the list box on the right and click Remove.
4. Click OK.

0  Removing a database field from the list offields used by a block does not remove it from the database 
itself

Adding an output element

You can add a new output element to any kind of block except chart blocks. An output element can display 
either the contents of a database field or the value of a parameter (p.460) (but not both).

03  An output element in an input block can only display the value of a parameter (p.460), not the contents 
of a database field.
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To add an output element that displays the contents of a database field
Adding an output element for a database field is a two-step process. First, you need to add the database 
field that the element will be associated with to the list of database fields used by the block. (If the relevant 
database field is already in the list, you can skip this step.) Then, you insert the new output element into the 
block.

1. Right-click inside the block, point to Database, and then click Block Properties.
2. Click the Database Fields tab.
3. In the list of database tables and fields on the left, select the field that the new output element will 

be linked to, click Add, and then click OK.
4. In the table that contains the database-driven content block, insert a new row or column to contain 

the new output element and (optionally) its label.
5. Right-click inside the cell you added for the new element, point to Database, and then click Insert 

Output Element.
6. Click the ... button next to the Database field box, select the database field you added in step 3 

from the menu, and then click OK.
7. If you added a cell for the new element's label, click inside it and type the label.

To add an output element that displays the value of a parameter
1. In the table that contains the database-driven content block, insert a new row or column to contain 

the new output element and (optionally) its label.
2. Right-click inside the cell you added for the new element, point to Database, and then click Insert 

Output Element.
3. Click the ... button next to the Database field box, select the desired parameter and then click OK. 

(The menu will only list parameters that have been registered. For information about registering 
parameters, see Registering a parameter, p.462.)

4. If you added a cell for the new element's label, click inside it and type the label.

Related topics
Adding a hyperlink output element..........................
Changing a block element’s associated database field

Adding an input box

You can add a new input box to an input block or a modification block. There are four kinds of input 
boxes:

• Number input boxes accept numbers
• String input boxes accept one line of text
• Text input boxes accept multiple lines and paragraphs of text
• Date input boxes accept dates and/or times

.p.469

.p.475
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Adding an input box is a two-step process. First, you need to add the database field that the element will be 
associated with to the list of database fields used by the block. (If the relevant database field is already in 
the list, you can skip this step.) Then, you insert the new input box into the block.

To add an input box
1. Right-click inside the block, point to Database, and then click Block Properties.
2. Click the Database Fields tab.
3. In the list of database tables and fields on the left, select the field that the new input box will be 

associated with, click Add, and then click OK.
4. In the table that contains the input or modification block, insert a new row or column to contain 

the new input box and (optionally) its label.
5. Right-click inside the cell you added for the new element, point to Database, and then click the 

Insert command corresponding to the type of input box you want to add.
6. Click the Target field box and select the database field you added in step 3. (The menu will only 

list database fields whose data type matches the type of the input box.)
7. In the Default value box, optionally enter a default value for the input box. (If you want the default 

value to be provided by a parameter (p.460), click the ... button next to the Default value box and 
select a parameter. The menu will only list parameters that have been registered (p.462).)

8. Do one of the following, depending on the type of the input box:
o If you are adding a number or string input box, specify its width (in characters) and its 

maximum input length.
o If you are adding a text input box, specify its width (in characters) and its height (in lines), 
o If you are adding a date input box, specify the date/time format. Click the Date format 

triangle to select a common format, or click the ... button next to the Date format box to 
build the desired format from individual components (year, month, day, hour, minute, 
and second).

9. Click OK.
10. If you added a cell for the new input box’s label, click inside it and type the label.

Related topics
Modifying the properties of an input box.................
Replacing an input box with an input control...........
Changing a block element's associated database field

Adding a hyperlink output element

About hyperlink output elements
A hyperlink output element is an output element that generates hyperlinks (p. 165) from the contents of 
database fields. The examples below illustrate the difference between ordinary output elements and 
hyperlink output elements in the "Name" column of a simple table block (p.438):

p.475
p.471
p.475
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Name Phone 
John Humphries 303-848-3093 
Jane Doer 212-845-8965 
Mick Miggler 904-897-5626 
Betty Boopie 316-985-4114 
Bob Hoffman 604-847-5555 
[1 2 2 ] [>>]

Name Phone
John Humohries 303-848-3093 
Jane Doer 212-845-8965 
Mick Miaaler 904-897-5626 
Bettv Boopie 316-9854114 
Bob Hoffman 604-847-5555 
[1221D±]

Ordinary output elements Hyperlink output elements

When you create a hyperlink output element, you specify a base URL that applies to the generated 
hyperlink for every record, and you also specify a parameter (p.460) that will be appended to the base URL 
for every link. Most importantly, you can set the value of this parameter to a variable that represents the 
contents of a particular database field in the current record. Thus, for example, if the base URL points to a 
document containing a detail block (p.443), the hyperlink generated for each record can pass the ID number 
of the current record to the destination document and result in that record being displayed in the detail 
block.

Each link that a hyperlink output element generates has the form: 

base_URL?parameter_name=current_value_of__f ie ld

where current_value_of_f ield is the contents of the specified database field in the current record. 
In the example table block shown above, if the base URL is http://www.example.com/detail.asp, the 
parameter name is "cid", the database field providing the parameter value is Customers.ID, and John 
Humphries's customer ID number is 291, then the URL of the link for John Humphries would be:

h ttp ://www.example.com/detail.asp?cid=291

Clicking the link would open the detail.asp document and pass to it the cid=291 parameter. If detail.asp 
contains a detail block showing a full record in the Customers database, and the filter condition (p.463) for 
the detail block is:

Customers.ID = <a,cid>

then the content of the detail block will be the customer record for John Humphries.

You can add a hyperlink output element to any kind of block except chart blocks. You cannot create a 
hyperlink output element within the Database Wizard, but you can replace an ordinary output element with 
a hyperlink output element after you finish the wizard.
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(EJ Although it is possible to insert a hyperlink output element in an input block, neither the content it
displays nor the value of the parameter it passes to the destination document can come from a
database field. However, these items can be supplied by parameters passed to the document containing
the input block.

To add a hyperlink output element to a block
1. Place the insertion point in an empty cell of the table containing the block. (Insert a new row or 

column if necessary.)
2. On the Insert menu, point to Database, and then click Output Element with Hyperlink.
3. Click the ... button next to the Database field box and select the database field that will provide the 

content displayed by the output element. (If the desired field is not listed, click Cancel and add it 
to the list of fields used by the block in the Database Fields tab of the Block Properties dialog 
box.)

4. In the Base URL box, enter the URL of the destination document for the links generated by the 
hyperlink output element. (If the URL will be supplied by a parameter passed to the current 
document, click the ... button next to the Base URL box and select the parameter.)

5. Under Parameter, in the Name box, enter the name you want to use for the parameter that will be 
included in the generated links.

6. Click the ... button next to the Value box and select the database field that will provide the value of 
the parameter. (If the desired field is not listed, click Cancel and add it to the list of fields used by 
the block in the Database Fields tab of the Block Properties dialog box.)

7. Click OK.

If the document specified as the destination of the generated links contains a database-driven content block 
created with the Database Wizard, you need to register (p.462) the parameter in that document before you 
can use it in that document’s filter condition. (See Registering a parameter, p.462.)

Related topics
Adding an (ordinary) output element.....................................................p.467
Using parameters with database-driven documents.................................p.460
Registering a parameter........................................................................ p.462
Filtering and sorting database records....................................................p.463
Creating a detail block.........................................................................p.443

Replacing an input box with an input control

About input controls
Input controls provide an alternative to input boxes for users to enter information in input blocks (p.452) or 
modification blocks (p.454). Whereas an input box requires a user to type information into the box, an input 
control presents a set of predefined choices from which a user makes a selection.

Creating database-driven documents 471



Ñamo WebEditor 6 User Manual

• Drop-down menus, which display a list of choices in a menu that "drops down” when the user 
clicks it

• Radio button groups, which are groups of labeled buttons similar to the choices in a multiple- 
choice question

In both types, the choices are mutually exclusive—that is, the user can only choose one item.

The primary benefit of using an input control instead of an input box for a particular database field is that it 
allows you to limit what users can enter. For example, if one of the database fields involved in an input 
block is intended to contain the name of the country a user lives in, it makes sense to limit what the user 
can enter to a list of known countries.

An equally important benefit of using an input control is that it allows you to insulate users from the real 
value that is entered into a particular database field, by "hiding" values behind labels supplied by a related 
field. For example, say you have an input block that your users use to provide information for a customer 
support inquiry, and one of the pieces of data the users must provide is the identity of the product the 
inquiry is regarding. Let's assume the inquiry table in your customer support database has a field for 
product ID, but not for product name. However, forcing users to enter a product ID number in an input box 
is not exactly user-friendly. Instead, you can use a drop-down menu that obtains product names from a 
products table, while it supplies a numerical ID value to the inquiry table.

Note: Although it is possible to create an input control within the Database Wizard, it is usually easier to 
replace an input box with an input control after completing the wizard.

To replace an input box with a drop-down menu
1. Click the input box you want to replace, and then press Delete.
2. On the Insert menu, point to Database, and then click Drop-Down Menu. The Database Wizard for 

drop-down menus will open.
3. Click Next to skip to Step 2 of the wizard. (You cannot change any of the settings in Step 1.)
4. Specify the data source settings for the menu. (This step is identical to the corresponding step in 

the Database Wizard for input blocks and other block types. For details, see "Step 2: Data Source" 
in Creating an input block (p.452).)

5. Click Next to continue to Step 3 of the wizard.
6. In the list of tables and fields on the left, select the database field that will supply the labels in the 

menu, and then click Add.
7. Select the database field that will supply the values of items in the menu, and then click Add.
8. Click Next to continue to Step 4 of the wizard.
9. If the two fields you added in the previous step of the wizard are not from the same table, enter a 

join condition (p.458) in the Join box.
10. If you want to filter the choices in the menu according to some criteria, enter a filter condition 

(p.463) in the Filter box.
11. If you want the menu items to be sorted a particular way, enter a sort condition (p.463) in the Sort 

by box.

There are two kinds o f input controls you can create with Namo WebEditor:

472 Creating database-driven documents



Chapter 8: Advanced Techniques

12. Click Next to continue to the last step of the wizard.
13. Click the triangle on the Target field box and select the database field that will receive the value of 

the selected item in the menu. (This should be the same as the target field of the input box you 
deleted in step 1.)

14. Click the Item labels source field box and select the database field that will supply the labels in the 
menu.

15. Click the Item values source field box and select the database field that will supply the values of 
items in the menu.

16. In the Default value box, optionally enter a default value for the menu. (If you want the default 
value to be provided by a parameter (p.460), click the ... button next to the Default value box and 
select a parameter. The menu will only list parameters that have been registered (p.462).)

17. Click Finish.

To replace an input box with a radio button group
1. Click the input box you want to replace, and then press Delete.
2. On the Insert menu, point to Database, and then click Radio Button Group. The Database Wizard 

for radio button groups will open.
3. Click Next to skip to Step 2 of the wizard. (You cannot change any of the settings in Step 1.)
4. Specify the data source settings for the radio button group. (This step is identical to the 

corresponding step in the Database Wizard for input blocks and other block types. For details, see 
"Step 2: Data Source" in Creating an input block (p.452).)

5. Click Next to continue to Step 3 of the wizard.
6. In the list of tables and fields on the left, select the database field that will supply the labels of the 

radio buttons, and then click Add.
7. Select the database field that will supply the values of the radio buttons, and then click Add.
8. Click Next to continue to Step 4 of the wizard.
9. If the two fields you added in the previous step of the wizard are not from the same table, enter a 

join condition (p.458) in the Join box.
10. If you want to filter the choices in the radio button group according to some criteria, enter a filter 

condition (p.463) in the Filter box.
11. If you want the radio buttons to be sorted a particular way, enter a sort condition (p.463) in the Sort 

by box.
12. Click Next to continue to the last step of the wizard.
13. Click the triangle on the Target field box and select the database field that will receive the value of 

the selected radio button. (This should be the same as the target field of the input box you deleted 
in step 1.)

14. Click the Button labels source field box and select the database field that will supply the labels of 
the radio buttons.

15. Click the Button values source field box and select the database field that will supply the values of 
the radio buttons.

16. In the Default value box, optionally enter a default value for the radio button group. (If you want 
the default value to be provided by a parameter (p.460), click the ... button next to the Default value 
box and select a parameter. The menu will only list parameters that have been registered (p.462).)

17. Click Finish.
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Related topics
Adding an input box.............................................................................p.468

Adding a hidden input element

When you create an input or modification block (p.452), the Database Wizard automatically creates an input 
box for each database field you include in the block, so that the user can enter a value for the field. 
Sometimes, however, you may want a particular database field to receive a value that is not provided by the 
user, but is instead either (A) provided by a parameter (p.460) passed to the document containing the input 
block or (B) a fixed value provided by the document itself. In such cases, you can associate the database 
field with a hidden input element.

A hidden input element acts like other input elements in that it provides a value for one database field, but 
unlike other input elements it is not visible in the input block, and users cannot interact with it. A hidden 
input element must be assigned a default value, which is always the value that will be inserted into its 
associated database field. The default value can either be a fixed value you specify when you create the 
element, or be provided by a parameter passed to the containing document.

Adding a hidden input element is a two-step process. First, you need to add the database field that the 
element will be associated with to the list of database fields used by the input or modification block. (If the 
relevant database field is already in the list, you can skip this step.) Then, you insert the new hidden input 
element into the block.

To add a hidden input element
1. Right-click inside the block, point to Database, and then click Block Properties.
2. Click the Database Fields tab.
3. In the list of database tables and fields on the left, select the field that the hidden input element 

will be associated with, click Add, and then click OK.
4. Place the insertion point anywhere inside the table containing the input or modification block. 

(Since the new element will be hidden, it does not matter where you put it, as long as it is inside 
the block.)

5. On the Insert menu, point to Database, and then click Hidden Input Element.
6. Click the Target field box and select the database field you added in step 3.
7. In the Default value box, enter the mandatory default value for the hidden input element. (If you 

want the default value to be provided by a parameter (p.460), click the ... button next to the Default 
value box and select a parameter. The menu will only list parameters that have been registered 
(p.462).)

8. Click OK.

If the display of special tag marks is enabled, you will see a hidden form field mark 0  at the location you 
inserted the hidden input element. To show or hide special tag marks, click ‘L i (Show/Hide Special Tag 
Marks) on the Standard Toolbar.

474 Creating database-driven documents



Chapter 8: Advanced Techniques

Adding an input box..........................................
Changing a block element's associated database field

Related topics
p.468
p.475

Changing a block element's associated database field

After completing the Database Wizard, you can easily change the database field associated with any output 
or input element in the block.

To change the database field associated with a block element
1. Double-click the block element.
2. Do one of the following, depending on the type of the element:

o If the element is an output element, click the ... button next to the Database Field box and 
select the desired database field.

o If the element is an input box, click the Target field button and select the desired database 
field.

o If the element is an input control (drop-down menu or radio button group), click the 
Target and Source Fields tab, and then click the Target field button and select the desired 
database field.

3. Click OK.

Related topics
Modifying the properties of an input box...........................................p.475

Every input box has certain properties that you can modify after you complete the Database Wizard. These 
include:

• For string and number input boxes:
o Box width (in characters) 
o Maximum input length (in characters)

• For text input boxes:
o Box width (in characters) 
o Box height (in lines of text)

• For date input boxes:
o Date/time format

Modifying the properties of an input box
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To modify the properties of an input box
1. Double-click the input box.
2. Edit the input box's properties and then click OK.

When changing the format template of a date input box, the following keywords have the following 
meanings:

yy year (4 digits) 
mm month (2 digits) 
dd date (2 digits) 
hh hour (24-hour format) 
mi minute

You can freely rearrange the keywords in any order. Any other characters in the template, such as 
punctuation marks, are static text and will appear in the date input box exactly as entered. For user- 
friendliness, you may wish to substitute words for some or all of the default punctuation characters, as in 
the example below:

Namo WebEditor 6 User Manual

You can modify various properties of a database-driven content block after completing the Database 
Wizard. To do so, right-click inside the block, point to Database, and then click Block Properties.

For help with any tab of the Block Properties dialog box, press F1 while the dialog box is open.

Date format: (Month: mm Date: dd Year: yy Time: hh:mi (24-hour clock)

Related topics
Adding an input box.................................................
Changing a block element's associated database field

.p.468

.p.475

M o d i f y i n g  b l o c k  p r o p e r t i e s
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F o r m a t t i n g  d a t a b a s e - d r i v e n  c o n t e n t

You can format output elements in database-driven content blocks as you can ordinary, static text. Any 
formatting you apply to an output element is applied to all of the generated content that results from it when 
the document is viewed in a browser. As with static text, you can either use single-instance formatting 
(p.212) with an output element or apply a style (p.212) to it. For information about formatting content, see 
Formatting content, p.210.

To apply character-level formatting to an output element, such as font family or font size, select the 
element placeholder (the highlighted word "[val]") and then apply the formatting.

To apply paragraph-level formatting, such as alignment or line spacing, place the insertion point on either 
side of the element placeholder and then apply the formatting.

Note that since an output element is an indivisible unit, any formatting you apply to it applies to all of the 
generated content that replaces the placeholder; you cannot format parts of the generated content 
individually.

Each output element in a block occupies one cell of an HTML table that the Database Wizard creates to 
arrange the elements neatly on the page. Therefore, in addition to applying character- and paragraph-level 
formatting to an output element, you can modify the properties of the table cell that contains it, as well as 
the properties of the table that contains the entire block. For example, you can adjust the widths and heights 
of the cells, change the horizontal or vertical alignment of the cell contents, or change the border settings of 
the table. For information about editing the properties of tables and cells, see Tables, p. 182.

i3  When applying a style to an output element, note that the results may differ depending on whether you 
select the element before applying the style. If you select the element first, Namo WebEditor will create 
a <span> tag around the output element and apply the style to the <span> tag. But if you just place 
the insertion point next to the output element and then apply a style, Namo WebEditor will create a 
<p> tag around the element and apply the style to the <p> tag. In most cases, the results will look the 
same, but certain formatting properties, such as background color, look differently depending on 
whether they are applied to a <span> or a <p>.

□  If the contents of a database field displayed by an output element include HTML tags, the markup will 
affect the appearance of the contents, when viewed in a browser, in the same way that they would with 
static content.

Related topics
Adding static content to a database-driven document..............................p.478
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A d d i n g  s t a t i c  c o n t e n t  t o  a  d a t a b a s e - d r i v e n  d o c u m e n t

Because a database-driven document acts as a template for documents generated by a Web server, any 
static content—ordinary HTML content that exists in the document itself, rather than coming from a 
database—in it is reproduced by the server without alteration in the generated documents. For example, if a 
dynamic document contains a static heading at the top of the page, the same heading will appear in all the 
generated documents, in the same place.

You can add static content to a database-driven document both before and after creating a database-driven 
block in it.

You can insert static content both outside and inside a database-driven block. Inside a block—which is 
always contained in an HTML table—you can insert static content inside both empty cells and cells that 
contain block elements. However, you cannot insert static content inside a block element itself.

The examples below two views of a database-driven document containing a list block, in Edit mode and in 
Preview mode. Static content has been added both outside and inside the block. Block elements have also 
been rearranged within the block and formatted (p.477). Database-driven content in the Preview example is 
shown with a gray background to distinguish it from static content.

• N e w s
1111

! Namo > News
1111

; £ Top Stories 
i

1
Œ) Press Releases 11

| ! [V30 : © Reviews & Awards !i
E Press Kits !1! I Added: №  i 1
(5 Media Relations 1 1

: [ N  } 1|1

: [<<][123456Z891Û ][>>]1
«111

Example list block >vith inner and outer static content (Edit mode)
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1 N e w s
| Namo > News

£ Top Stories Œ) Press Releases

Scientist Says Smoking Reduces Risk of 
Jogging

Œ) Reviews & Awards 
® Press Kits

Added: 7/4X003
Aliquam sit amet nibh. In sit amet neque a eras 
pellentesque hendrerit. Morbi sapien. Cum sociis natoque 
penatibus et magnis dis parturient montes, nascetur 
ridiculus mus. Phasellus consectetuer tellus ac enim. Proin 
arcu orci, tincidunt et, aliquam nec, blandit ut, nisi.

Œ) Media Relations

Department of Homeland Security Warns 
Against Excessively Loose Pants
Added: 5/25/2003
Duis tincidunt mattis mauris. Donee odio arcu, suscipit 
sed, lobortis vel, sagittis in, odio. Morbi eu felis. Sed 
gravida nibh ac arcu. Proin metus nulla, scelerisque vel, 
commodo vitae, consequat sit amet, risus.

[<<][1234][>>]

Example list block with inner and outer static content (Preview)

Related topics
Form atting database-driven content............................................................................p.477
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Importing Excel worksheets
Namo WebEditor can import an Excel worksheet (one "sheet" in an Excel spreadsheet file) into a Web 
document, converting it to an ordinary HTML table (p. 182). The formatting of the worksheet is preserved as 
closely as possible, within the limitations of HTML.

You can choose from three methods of importing a worksheet:

• The table can be dynamically linked to the original Excel file. If you edit the worksheet later, you 
can have Namo WebEditor update the table with the changes to the worksheet.

• A copy of the worksheet can be embedded into the Web document. If you make changes to the 
embedded worksheet, Namo WebEditor automatically updates the table.

• The worksheet can be imported as a static table with no further relationship to the worksheet.

Which method you choose depends on your requirements for the table that results from importing the 
worksheet. If you want to be able to update the table to reflect any changes to the original worksheet, 
choose linking. If you don't need to maintain a link to the original worksheet, but you do want to be able to 
edit the table in Excel, choose embedding. If you just need a static copy of the worksheet in your Web 
document, choose static importing.

In  t h i s  s e c t io n

Importing an Excel worksheet with linking.....
Importing an Excel worksheet with embedding 
Importing an Excel worksheet as a static table.

.p.480

.p.481

.p.482

I m p o r t i n g  a n  E x c e l  w o r k s h e e t  w i t h  l i n k i n g

When you import an Excel worksheet with "linking", Namo WebEditor converts it to an HTML table 
(p. 182) and maintains a link to the original worksheet. (This process is unrelated to hyperlinks.) Since the 
table and worksheet are linked, you can then tell Namo WebEditor to update the table if you later edit the 
worksheet.

El If the Excel spreadsheet file to be imported contains more than one worksheet, Namo WebEditor will 
only import the first one.

0  In order for the link to the original worksheet to be maintained, the spreadsheet file must remain in the 
same location in the local file system as when you imported it. If the spreadsheet file is moved or 
deleted, you will not be able to update the imported table with changes to the worksheet.
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To import an Excel worksheet with linking
1. Place the insertion point in an empty paragraph.
2. On the Insert menu, point to Other, and then click Spreadsheet.
3. Click Browse, locate and select the Excel file to be imported, and then click Open.
4. Under Insertion method, click Link to original spreadsheet, and then click OK.

When you click OK, Namo WebEditor will launch or switch to Excel, open the specified spreadsheet file, 
import the first worksheet, and then close the file (or Excel) and return to itself.

To update a table after changing the linked worksheet

• Right-click the table, and then click Update Spreadsheet Contents.

Namo WebEditor will launch or switch to Excel, open the specified spreadsheet file, re-import the 
worksheet, and then close the file (or Excel) and return to itself.

y  You can quickly launch Excel for editing the worksheet by right-clicking the imported table and 
clicking E dit Spreadsheet When you close the spreadsheet or Excel, Namo WebEditor will 
automatically update the table.

Related topics
Importing an Excel worksheet with embedding...................................... p.481
Importing an Excel worksheet as a static table........................................p.482

I m p o r t i n g  a n  E x c e l  w o r k s h e e t  w i t h  e m b e d d i n g

When you import an Excel worksheet with embedding, Namo WebEditor converts it to an HTML table 
(p. 182) and embeds a hidden copy of the worksheet in the Web document. As a result, you can always edit 
the worksheet in Excel—even if the original file is no longer available—and Namo WebEditor will 
automatically update the table to reflect your changes to the worksheet. The table does not preserve any 
relationship with the original worksheet—only with the embedded copy of it.

Note that the file size of the Web document will increase by the size of the worksheet that is embedded in it.

hD I f  the Excel spreadsheet file to be imported contains more than one worksheet, Namo WebEditor will 
only import the first one.

To import an Excel worksheet with embedding
1. Place the insertion point in an empty paragraph.
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2. On the Insert menu, point to Other, and then click Spreadsheet.
3. Click Browse, locate and select the Excel file to be imported, and then click Open.
4. Under Insertion method, click Embed into HTML document, and then click OK.

When you click OK, Namo WebEditor will launch or switch to Excel, open the specified spreadsheet file, 
import the first worksheet, and then close the file (or Excel) and return to itself.

To edit an embedded worksheet
1. Right-click the imported table, and then click Edit Spreadsheet. (The embedded worksheet will 

open in Excel.)
2. Edit the worksheet as desired. When you are finished, exit Excel.

Namo WebEditor will automatically update the table to reflect your changes to the embedded worksheet. 

Related topics
Importing an Excel worksheet with linking.........................................p.480
Importing an Excel worksheet as a static table.................................... p.482

I m p o r t i n g  a n  E x c e l  w o r k s h e e t  a s  a  s t a t i c  t a b l e

When you import an Excel worksheet as a static table, Namo WebEditor simply converts it to an HTML 
table (p. 182) and inserts it in the current document. The table does not preserve any relationship with the 
original worksheet.

0  I f  the Excel spreadsheet f i le  to be im ported contains more than one worksheet, Nam o W ebEditor w ill 
only im port the f irs t  one.

To import an Excel worksheet as a static table
1. Place the insertion point in an empty paragraph.
2. On the Insert menu, point to Other, and then click Spreadsheet.
3. Click Browse, locate and select the Excel file to be imported, and then click Open.
4. Under Insertion method, click Static import, and then click OK.

When you click OK, Namo WebEditor will launch or switch to Excel, open the specified spreadsheet file, 
import the first worksheet, and then close the file (or Excel) and return to itself.

Related topics
Importing an Excel worksheet with linking.........................................p.480
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Creating charts from table data
You can use Namo WebEditorTs Chart Wizard to create a chart or graph from numerical data in a table 
(p. 182). For example, the following table of rainfall quantities in two countries:

111 Jan Feb Mar Apr May Jun
1

Argentina 416 582 ¡ 5211 875 216 395

Mozambique 125 366 1! 9951 525 149 745

can be made into this chart:

A v e r a g e  R a in fa l l ,  J a n u a r y - J u n e
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or this graph:
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I  Argentina 
□  Mozambique

484 Creating charts from table data



Chapter 8: Advanced Techniques

A v e ra g e  R a in fa l l ,  J a n u a r y - J u n e

You can convert a chart or graph from one type to another and modify other aspects, such as titles and 
colors. Every time you modify a chart, Namo WebEditor generates a new bitmap image for it.

3  Charts and graphs created with the Chart Wizard are not dynamic; they are not updated if you change 
the source data in a table. However, you can edit the values in a chart or graph through the Chart 
Properties dialog box.

In this section
Using the Chart Wizard........................................................................ p.485
Modifying chart properties................................................................... p.487
Understanding chart types.................................................................... p.49l

U s i n g  t h e  C h a r t  W i z a r d

Chart Wizard provides you with three steps to create a chart: selecting a chart template, arranging data, and 
titling the chart. The properties you do not specify will have the default values. You can also modify these 
values in the Chart Properties dialog box.

In this section
Chart Wizard Step 1 Chart Type.......................................................... p.486
Chart Wizard Step 2 Data Series.......................................................... p.486
Chart Wizard Step 3 Title................................................................... p.487
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Chart Wizard Step 1 Chart Type

In the Chart Wizard stepl, specify the chart type and shape. Some chart types can use 3D effect.

Before you create a chart, you must create a table, or insert a spread sheet in the edit window.

Step 1 of creating a chart
1. Create a table or insert a spread sheet.
2. Place the cursor in the table, on the Insert menu, point to Other, and then click Chart, or on the 

Table menu, click Create Chart in the shortcut menu.
3. Among tool buttons at the top in Chart Wizard Chart Type (Step 1 of 3) dialog box, select the 

chart type you want.
4. Select subtype using the icons in the selection. When you click a subtype icon, a description 

appears below the selection box.
5. Check Use 3D effect. Set Depth of 3D effect for 10%, and 3D perspective angle as you desire.
6. In the Chart Preview, confirm the chart appearance, and then click Next to move to the Chart 

Wizard Step 2 (p.486).

Related topics
Understanding chart types..................................................................... p.491

Chart Wizard Step 2 Data Series

Specify the data range properly. Adjust the position of the Series and Categories. Decide whether to swap 
X/Y axis. View the result in the preview window.

Step 2 of creating a chart
1. In the Chart Wizard Date Series (Step 2 of 3) dialog box, select First row contains series names 

and First column contains category names.
2. In the X/Y axis, if you select Swap X/Y axis, the values of the row and column will be switched.
3. In the Chart preview, confirm the data and chart appearance. Click Next to move to Chart Wizard 

Step 3 (p.487).

Related topics
Adjusting data series..........................................................................p.489
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Chart Wizard Step 3 Title

Put a title to the chart and decide its position. And specify the titles of X axis and Y axis.

Example Step 3 of Making The Housing Construction Trend Chart
1. In the Chart title of the Chart Wizard Title (Step 3 of 3) dialog box, enter the title you want to use.
2. In the Chart title location, choose the position of the title using the radio buttons. To hide the title, 

select Hide title.
3. In the axis title, enter titles for the X and Y axes respectively in the X-axis title and the Y-axis title.
4. In the Chart Preview, confirm the chart appearance, and then click Finish.

Related topics
Change Chart Title.............................................................................. p.488

M o d i f y i n g  c h a r t  p r o p e r t i e s

The properties of the chart created by Chart Wizard can be modified in the Chart Properties dialog box. 
However, when you adjust the size of the chart, you should use the mouse.

In this section
Changing the chart type....................................................................... p.487
Changing chart titles............................................................................p.488
Modifying data series...........................................................................p.488
Adjusting data series............................................................................p.489
Adding trendlines................................................................................ p.489
Modifying axes...................................................................................p.490
Changing chart formatting................................................................... p.490
Resizing a chart...................................................................................p.491

Changing the chart type

After you make a chart, you can change the type of the chart. Chart Wizard provides 8 types of charts, and 
each type has several chart templates. With these templates, you can create various kinds of charts.
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To change the chart type, double-click the relevant chart, or in the shortcut menu, select Chart Properties.
In the Chart type tab of the Chart Properties dialog box, select the chart type to replace with.

Change chart type
1. Double-click the chart, or in the shortcut menu, select Chart Properties.
2. In the Chart type tab of the Chart Properties dialog box, select the chart type you want to replace 

with using the tool buttons at the top of the dialog box.
3. Select a subtype of the selected chart type.
4. In the Chart preview, confirm the chart appearance, and click OK.

Related topics
Understanding chart types.....................................................................p.491

Changing chart titles

After you create a chart, you can modify the Chart title, Chart title location and Axis titles.

To change the chart title, double-click the relevant chart, or in the shortcut menu, select Chart properties. In 
the Title tab of the Chart Properties dialog box, change the title and title location.

Change the chart title and chart title location
1. Double-click the relevant chart, or in the shortcut menu, select Chart properties.
2. Select the Title tab in the Chart Properties dialog box. Remove the existing chart title and enter 

new one in the Chart title.
3. Change the position of the chart title using the raditon buttons in the Chart title location.
4. Remove the existing X axis title and enter new one in X-axis title.
5. In the Chart preview, confirm the chart appearance, and click OK.

Modifying data series

After you create a chart, you can specify/modify the Series of the legend. You can specify the Series name, 
Data label, Legend position, etc.

To modify the series, double-click the relevant chart, or in the shortcut menu, select Chart properties. In the 
Series tab of the Chart Properties dialog box, specify the items.

Change the series name and the legend position
1. Double-click the relevant chart, or in the shortcut menu, select Chart properties.
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2. Select the Series tab in the Chart Properties dialog box. Select the series you want to change 
options of in the list on the left, and enter the new name in the Series name.

3. Select a type of label to put next to each data in the Data labels drop-down menu.
4. Select the legend location in the Legend position (all series), or select Hide legend.
5. In the Chart preview, confirm the chart appearance, and click OK.

Adjusting data series

After you create a chart, you can adjust the data range. You can swap X/Y axis, enter/modify the data, and 
add/remove the rows/columns.

To adjust the data range, double-click the relevant chart, or in the shortcut menu, select Chart properties. In 
the Values tab of the Chart Properties dialog box, adjust the data range.

Insert a row and enter the data
1. Double-click the relevant chart, or in the shortcut menu, select Chart properties.
2. In the Values tab of the Chart Properties dialog box, place your mouse pointer on the title of a 

row, and right-click to open the shortcut menu. Select Insert Rows.
3. Double-click a cell of the inserted row, and enter the data. You can also enter the data in the Value.
4. In the Chart preview, confirm the chart appearance, and click OK.

9  If  you click Swap X/YAxis, the X-axis and the Y-axis will be switched. You can delete rows and 
columns in the shortcut menu by selecting Delete Rows or Delete Columns.

Adding trendlines

After you make a chart, you can insert trendlines in it. A trendline shows the trend of the data with a line. If 
you use trendlines, you can predict the values even in the range where the date is not yet inputted, and 
therefore they are often used for the stock price analysis or sales analysis. The trendline is generally used to 
predict the long term change, rather than the short term change. Trendlines can be added to the unstacked 
column type, unstacked line graph type, Scatter type, etc. For the detailed information about trendlines, 
refer to the Trendlines tab of the Chart Properties dialog box.

To insert a trendline into the chart, double-click the relevant chart, or in the shortcut menu, select Chart 
properties. In the Trendlines tab of the Chart Properties dialog box, specify the trendlines.

Insert a second polynominal trendline into the chart
1. Double-click the chart, or in the shortcut menu, select Chart Properties.
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2. Select the Trendlines tab in the Chart Properties dialog box, and select the series in the list box of 
Select series.

3. Select a trend line type in the list box in the Trendline type, and then click Add. To remove a 
trendline, select the trendline in the Displayed trendlines, and then press Remove.

4. If you wish to show the data series and the type of each trendline in the legend, select Show 
trendlines in legend.

5. In the Chart preview, confirm the chart appearance, and click OK.

Modifying axes

Specify the value and scale of the axis. In the list, select the axis to modify, and specify the title, value and 
scale of it.

To set up axis, double-click the relevant chart, or in the shortcut menu, select Chart Properties. In the Axis 
tab of the Chart Properties dialog box, specify axis properties.

Specify Y-axis value and scale

1. Double-click the chart, or in the shortcut menu, select Chart Properties.
2. Select the Axis tab in the Chart Properties dialog box, and select the axis you want to edit in the 

list on the left.
3. Deselect Configure data range automatically, and configure the range manually in Min. value, Max 

value, Major scale, Minor scale.
4. In the Chart preview, confirm the chart appearance, and click OK.

Changing chart formatting

After you make a chart, you can modify the Font, Background color, line, border, data points, etc. To 
change the chart format, select a format to change in the list, and modify it.

To set up the chart format, double-click the relevant chart, or select Chart Properties in the shortcut menu. 
In the Chart Formatting tab of the Chart Properties dialog box, select a format to change in the list.

Set up the chart title format

1. Double-click the chart, or in the shortcut menu, select Chart Properties.
2. In the Chart Formatting tab of the Chart Properties dialog box, select the Main title in the list on 

the left.
3. Press Font, and change the font and font size as you desire, and click OK.
4. Deselect Hide in the Color, and then choose the color you like for the background. Deselect Hide 

in the Lines/borders, and choose the color you like.
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5. In  the C hart preview , co n firm  the chart appearance, and click OK.

Resizing a chart

After you make a chart, you can resize it. To resize, drag the handle of the chart with your mouse.

Whenever you resize the chart, a new GIF file of the chart will be generated. Therefore, the chart image 
never gets distorted. However the title, X/Y axis title, legend, thickness of lines, etc does not change. So, 
you have to adjust them separately: use the Chart Formatting Tab of the Chart Properties dialog box.

Resize the chart
If you select the chart with you mouse, 8 handles will appear. Select one of those handles, and drag it to the 
size you want.

9  When you drag a resize handle, the changed size of the chart is shown in the popup box. The size 
format shown in th popup is WidthXHeight (%).

U n d e r s t a n d i n g  c h a r t  t y p e s

Namo WebEditor’s Chart Wizard provides 8 types of charts. Using those charts, you can make your 
document easy to understand and stylish. The chart types which can be created by the Chart Wizard are as 
below.

In this section
Chart type: Column..............................................................................p.492
Chart type: Bar.................................................................................... p.494
Chart type: Line.................................................................................. p.496
Chart type: Scatter................................................................................p.499
Chart type: Pie..................................................................................... p.500
Chart type: Doughnut........................................................................... p.501
Chart type: Stacked Area..................................................................... p.502
Chart type: Radar................................................................................ p.504
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C h a r t  t y p e :  C o l u m n

The colum n type chart is used to show the fluctuation o f  the values over a certain period o f  time. It is also 
used to com pare each item ’s value. Y ou can read the transitional changes in the column chart. X-axis 
displays the items. Y -axis displays the values.

The kinds o f  colum n type charts are colum n chart, Stacked colum n chart, 3D column chart, 100% stacked 
colum n chart. The follow ing are the samples.

Column chart

C liait T itle

18030
10ÛÛÛ -W4z:
140»

12000 
§10000 
5 IM04- 

6000-- 
4ÛÛ0--
20» J-

0

>4462:

3 4
CJltgoiy

492 Creating charts from table data



Chapter 8: Advanced Techniques

Stacked column chart
Shows each item’s contribution rate to the total value. 

Chart Title

1*003 
1ÎC0D 
14000 
12000 

gicooo

> eooof- 

COOO- 
4C00- — 
2000-1- 

0
3 4
Category

I"! ter«* A □  %tnts 6 □  tries C Q  tone* D

3D column chart
Com pares the values by item and by series at the same time. 

Chart Title

HOOD-/
i
iccod- /  

. /© €000 
<5
> ecoD- 

4C0D 

2003

. /

. /

n

01 1 1 , 1 —r  {t----
1 2  3 4 

Category
9 0

[ ]  A Q  Utit? ft □  №  C PI 0
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100% stacked column chart
Shows each item's contribution rate to the total value in percentage.

100 % 

to  1 

eot 

0*1 

» i  

o*

C h a r t  t y p e :  B a r

The bar type charts are used to compare the magnitude of several items. In the bar type chart, X-axis 
(items) becomes the vertical axis, and Y-axis (values) becomes the horizontal axis.

The kinds of bar type charts are Bar chart, Stacked bar chart and 100% stacked bar chart. The following are 
the samples.

Qiart Title

□  A □  t t ñ t í  D 0  U ht* C □  D
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Bar chart

Series A 

Wtt* I

IE 
S«nci F 

S*rWf 0
0 1  2 3 4 6  0 ?  

Vjlut

Stacked bar chart
Shows each item’s contribution rate to the total value. 

Chan Tide

Series A 

krttf I 
Series C

Tb
°  Series E 

Sm s  F 

Series 0

0  Item 1 0  IUm2

Chart Tltlo

1

----- 1------1------1------1------1J
— i

s

—— .----1------ ]■"... I....  -1
1 1 1 1

1 fr----- 1------1 ♦ 1------
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100% stacked bar chart
Shows each item's contribution rate to the total value in percentage.

Chart Title

n tom 1 [[] Item 2

C h a r t  t y p e :  L i n e

Line graphs are commonly used to show trends over a period of time. X-axis displays the items. Y-axis 
displays the values.

The kinds of line graphs are Linear, Line with markers, Stacked line, Stacked line with markers and 100% 
stacked line. The following are the samples.
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Linear

Chan Tide

—  A —  e  —  C —  UrttS 0

Line with markers
D isp lays  the values w ith  m arkers

Chart Title

C ittg o iy

Series A  Serlt* B -r*  Series C -h - Seri« D
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Stacked line
Shows each item’s contribution rate to the total value. 

Chart Title

1 2 3 4 « 6
Cat*g ftiy

—  Siilu A —  Sorte? B — StfVu C — D

Stacked line with markers
With markers, shows each item's contribution rate to the total value.

Chart Hilo

1 2  3 4 6 6
Cfftegory

498 Creating charts from table data



Chapter 8: Advanced Techniques

100% stacked line
Shows trends over a period of time in percentage. 

Chart Title

ICO X

to X 

.MX35

20% 

Û 1 3 A
Cjt«goiy

— Ui«tA — ttites C — («us 0

C h a r t  t y p e :  S c a t t e r

A scatter graph is used to show a sequence of irregular values. It displays the data by using XY coordinates. 
It is often used for scientific data.

To use the scatter graph, the chart should have X values and corresponding Y values 

Scatter Graph (Chart)

Chart Title

-•« Strttf A 

•«- StrieiC
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C h a r t  t y p e :  P i e

A pie chart shows the occupation rate of each item’s value in a series. Since the pie chart uses only one 
series, it is useful for emphasizing a certain item. If you apply R a i s e  s l i c e  up or Pull s l i c e  out to an item, the 
selected item will become conspicuous.

Pie Chart

Chart Title 

20%

n  Series A Q  Series D Q] Series C Series D

If you select Pull slice out in the 3D pie chart options of the Series tab, it becomes like below. 

Chart Title
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If you select Raise slice up in the 3D pie chart options of the Series tab, it becomes like below.

Chait Title
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C h a r t  t y p e :  D o u g h n u t

Like a pie chart, the doughnut type chart shows the occupation rate of each item’s value among a series. 
However, it is a bit different from the pie type chart in that multi-series doughnut charts can compare 
different series of values at the same time. Each ring of the doughnut chart means one series.

The kinds of doughnut type charts are Doughnut chart and Multi series doughnut chart. The following are 
the samples.
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Doughnut chart

Chart Tide

("I S«ri«*A Q StntsG Q 6«ritxC Q S«ric?D

Multi series doughnut chart
You can compare more than two series of values. Each ring of the doughnut chart means a series. 

Chart Title

I"! Scries A |  Series D Q Stries C Q Scries D

C h a r t  t y p e :  S t a c k e d  A r e a

The stacked area chart shows the quantitative relation between the total valuses and each item's value. It 
also shows the contribution rate of each item to the total changes over a period of time. The sum of all areas 
becomes the total value of the entire data.
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The kinds of staked area charts are Stacked area chart and 100% stacked area chart. The following are the 
samples.

Stacked area chart

C hari Title

Cittgorjf

□  Utas A 0  6 Q  îtx : C □  tmu 0

100% stacked area chart
Shows the contribution rate of each item to the total changes over a period of time in percentage. 

C hart Tltlo

□  A □  $41« 6 □  S*TWS C □  d

Creating charts from table data 503



Ñamo WebEditor 6 User Manual

C h a r t  t y p e :  R a d a r

In a Radar Chart, all values of the same series are connected with lines on the coordinates. A radar chart is 
often used to compare data values. It is useful for assessing which item is dominant in what series, and for 
analyzing relations between items of diffrenent series.

The kinds of radar charts are Radar Chart, Radar Chart with markers and Area radar chart. The following 
are the samples.

Radar chart

Chan Title

— Strîef A
— Sftfl*rB
—  Serie? C

Radar chart with makers
Shows the values with markers.

Chart Title

Strut A 
Series 0 
Series C
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Area radar chart
Compares the item values and shows which items are dominant. 

Chart Title

n  €tri«A
□  Series 0
□  S tru * c
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W o r k in g  w ith  s o u r c e  c o d e

With Namo WebEditor, advanced users and students of HTML can work directly with the HTML source 
code underlying a Web document. To access the source code of the current document, click the HTML tab 
at the bottom of the main window or press F 6. Pressing F 6  again returns you to visual editing mode.

Namo WebEditor can also display simultaneous views of Edit and HTML modes by splitting the main 
window into two panes. Changes you make in the visual editing pane are instantly reflected in the source 
pane. (Changes made in the source pane are reflected in the visual editing pane as soon as you click the 
visual editing pane.) To turn on simultaneous view, on the View menu, select Mode and then click Edit & 
HTML, or press F6.

Namo WebEditor can check that a document's source code conforms to various versions of the HTML and 
XHTML standards. Namo WebEditor can also also clean up source code to optimize its readability (to 
humans).

In this section
W orking in  H TM L m ode 

V alidating source code....

C leaning up  source c o d e .

W o r k i n g  i n  H T M L  m o d e

To switch to HTML (source editing) mode, click the HTM L tab at the bottom of the main window or press 
F 6 . You can also work simultaneously in HTML and visual editing mode: on the View menu, select Mode 
and then click Edit & HTML.

Source editing features and options
Working in Namo WebEditor's HTML mode is much like using a text editor, but with enhancements 
designed to make working with HTML easier. The default enhancements, all of which can be toggled or 
customized, include:

Source co loring
Various parts of the source code are colored according to their function. Colored items include 
tags, attribute names, attribute values, entities, comments, CSS selectors and properties, and so 
forth.

.p.506

.p.508

.p.509
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Line numbering
Source code line num bers are displayed in the left margin.

Current line highlighting
The current line (the line containing the insertion point) is highlighted to make it easy  to see where 
you are in the source code.

Auto indent
W hen you start a new line o f  code after a line that is indented, Nam o W ebEditor autom atically 
indents the new line by the same am ount.

Soft-wrap
Lines that are too long to fit in the w indow  are "soft-w rapped” at the right margin, so you don’t 
have to scroll horizontally to see a w hole line.

To change any o f  these settings or others, such as the font used in HTM L mode, right-click anyw here in the 
HTM L window and click Source Editing Options.

Inserting elements in HTML mode
You can quickly insert some kinds o f  elem ents in HTM L m ode using com m ands and toolbar buttons, rather 
than by typing. The com m ands, submenus, and buttons you can use to insert elements in H TM L m ode are 
listed below.

On the Insert menu:

• Image > Image, Clip A rt
•  Hyperlink
• Horizontal Rule
• Line Break
• Form Field
• Script > Body Script
• Object
• Com ment
• Other > Date & Tim e, N on-B reaking Space

On the Table menu:

• New Table

On the Standard Toolbar:

Q } Insert Clip Art 

G l Insert Image
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H  Create Table 
Hyperlink

On the Formatting Toolbar:

• Font
• Font Size
B Bold
I Italic
u Underline

Getting help on tags and properties

Namo WebEditor includes a comprehensive HTML and CSS online reference. To view it, press Shift+F1.

V a l i d a t i n g  s o u r c e  c o d e

Namo WebEditor can check a document's source code to see if it conforms to a particular version of the 
HTML or XHTML standard. Non-conforming items in the source are listed in the R e s u l t s  window, with 
line numbers.

The HTML and XHTML versions that Namo WebEditor can validate against are:

• HTML 2.0
• HTML 3.2
• HTML 4.0 (Strict)
• HTML 4.0 (Loose, Transitional, Frameset)
• XHTML 1.0 (Strict)
• XHTML 1.0 (Loose, Transitional, Frameset)

Namo WebEditor can also check whether a document is compatible with various versions of popular 
Windows browsers. The supported browsers and versions are:

• Internet Explorer 3.0,4.0, 5.0, 5.5, and 6.0
• Netscape 3.0,4.0, and 6.0
• Opera 4.0, 5.0, and 6.0

To validate source code or check browser compatibility
1. On the Tools menu, click Verify HTML.
2. Select the version of HTML or XHTML you want to validate against.
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3. If you want to check for compatibility with a particular browser, select the Check browser 
compatibility with the following browsers check box and then select one or more check boxes 
corresponding to the desired browser version(s).

4. Click OK.

C l e a n i n g  u p  s o u r c e  c o d e

Namo W ebEditor can clean up and/or reform at messy source code in docum ents created in other program s.

Namo W ebEditor can perform  the follow ing cleanup functions:

• Remove proprietary tags added by  M icrosoft W ord
• Remove em pty elements (such as < a > < /a > )
• Remove redundantly nested tags (such as < b > H e l lo  < b > w o r l d < / b x / b > )
•  Remove optional closing tags (such as closing < /p >  tags)
•  Integrate adjacent <font> tags w here possible
•  Remove com m ents
• Remove occurrences of a specified tag

Nam o W ebEditor can reform at source code in the following ways:

• Wrap long lines after a specified number of characters
• Indent child elements by a specified number of spaces or tabs
• Capitalize tag nam es
• Capitalize attribute nam es

To clean up or reformat the current document's source code
1 . On the Tools menu, click C l e a n  U p  HTML.
2. Select the desired options, and then click OK.

ED After performing a cleanup operation, i f  you do not like the result, immediately return to Edit mode 
and use the Undo command. This is the only way to reverse the effects of a cleanup or reformatting 
operation, short of manual editing.
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E d it in g  X M L  d o c u m e n t s

Although Namo WebEditor cannot create new XML documents, you can use it to edit existing ones.

To open an XML document
1 . On the File menu, click O p e n .

2. Click the Files of type box and select XML Files or All Files.
3. Find the desired XML file, select it, and then click O p e n .

Alternatively, you can simply drag an XML file from Windows Explorer to Namo WebEditor.

In Edit mode, Namo WebEditor displays an XML document as a tree, similar to the folder tree in Windows 
Explorer. The image below shows part of an example XML document as it appears in Edit mode.

E (D  tag name »'applet* deprecated«"yes* ;a
0  (¡D fbxxy !

1..[§] hello lady i_j
$  (Dpupose

1 0  Embeds a Java applet This tag is <a href=*deprecat 
E {¡D syntax end_t3g=*Required"

1 [¡0 <applet>...</applet>
E l )  required.attribute name=Vidth*
1 B (D  a_ya!ue

j E [ | )  value 
| L [U Length 
| B l)Snk

L O  vabetypes.htmllength 
| B (D  a_desaiptjon

j--@  The width of the applet
n iiî  rAnirpH affrihitfp nam̂sTv*inht"

< ~ ' 1 ......
P a r t  o f an  X M L  d o c u m e n t in  E d it  m ode

Various icons represent different kinds of nodes in the document tree:

D Element
D Text (PCDATA)

CDATA section
m Processing Instruction
D Entity reference

Comment
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To collapse a node, hiding its child nodes, click the minus sign to the left of the node’s icon. To expand a 
node, click the plus sign.

In HTML mode, Namo WebEditor displays the source text of an XML document. You can edit the XML 
source directly, as in a text editor.

In this section
W orking w ith X M L  e le m e n ts ..............................

W orking w ith X M L attribu tes..............................

Preview ing and validating an X M L docum ent

W o r k i n g  w i t h  X M L  e l e m e n t s

The example below shows five nodes in an XML document tree. The root element ("book”) and two of its 
child elements ("title” and "author”) are each represented by an element node ( D )  . The title and author 
elements each contain text content, represented by child text nodes ( tU ).

B  ( D  book 
s  Jg) title
i 1...[ | ]  A Tale o f Two Cities

B -f lD  author
1...U  Charles Dickens

To edit an element's text content

• Double-click its child text node.

To add text content to an element
1. Right-click the element node, point to Insert Node, and then click Text.
2. Enter the text and then click OK.

To rename an element
1. Double-click the element node.
2. Enter the new name in the Name box. (Click the triangle to select one of the element names in use 

in the document.)

To add an element
1. Right-click the intended parent node of the new element, point to Insert Node, and then click 

Element.

p .5 1 1 

p .5 13 

p.513
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2. Enter the name of the new element in the Name box. (Click the triangle to select one of the 
element names in use in the document.)

To remove a node
1. Click the node and press Delete.

To move a node
1. Drag the node on top of another node. (If you hold down the Ctrl key while dragging, the dragged 

node will become a child of the node you drop it on. Otherwise, it will become its first preceding 
sibling.)

To copy a node
1. Right-click the node and click Clone N ode.
2. Specify the number of copies you want and whether to also copy the node's contents and/or 

children, and then click OK.

To add a CDATA section to an element
1. Right-click the element node, point to Insert Node, and then click CDATA.
2. Enter the CDATA text and then click OK.

To add an entity reference section to an element
1. Right-click the element node, point to Insert N ode, and then click Entity R eference.
2. Enter the entity name and then click OK.

To add a processing instruction to an element
1. Right-click the element node, point to Insert N ode, and then click Processing Instruction.
2. Enter the processing instruction and then click OK.

To add a comment to an element
1. Right-click the element node, point to Insert N ode, and then click C om m ent.
2. Enter the comment and then click OK.

Related topics
W orking w ith XM L a ttr ib u te s ..................................................................................... p .5 13
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W o r k i n g  w i t h  a t t r i b u t e s

In the example below, the root element ("Book”) has an attribute ("in_stock"). The attribute’s name and 
value are shown to the right of the element name.

B'*{jD Book ¡n_stDdc«"yes’
$ 1 )  Title

| s l  A  T a l e  o f  T w o  O t i e s  

To edit or rename an attribute
1. Double-click the element node.
2. Select the desired attribute in the list box and click Modify, or just double-click the attribute.

To add an attribute
1. Double-click the element node.
2. Click Add.

To remove an attribute
1. Double-click the element node.
2. Select the desired attribute in the list box and click Remove.

P r e v i e w i n g  a n d  v a l i d a t i n g  a n  X M L  d o c u m e n t

Although Namo WebEditor requires Internet Explorer 4.0 or later to power its built-in preview mode, only 
Internet Explorer 5.0 or later support XML. Therefore, in order to preview an XML document in Namo 
WebEditor, you must have Internet Explorer 5.0 or later installed on your computer.

If an XML document contains or links to an XSL stylesheet, Namo WebEditor’s built-in preview will 
display the transformed version of the document, just as Internet Explorer would.

When you save an XML document that contains or links to a DTD (Document Type Declaration), Namo 
WebEditor validates the document against the DTD. If there are any errors, a dialog box appears and 
displays the nature and location of the first error. However, please note that Namo WebEditor will still save 
the document despite any errors it finds.
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9 Appendices
This section contains information about miscellaneous features of and utilities included with Namo 
WebEditor, and a list of keyboard shortcuts.

In this section
M iscellaneous featu res ...................................................................................................p .5 16

Included u tilities...............................................................................................................p .526

K eyboard sh o rtc u ts .........................................................................................................p.541
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M is c e l la n e o u s  f e a t u r e s

In this section
Key m acro s......................................................................................................................... p .5 16

A uto C o rre c t...................................................................................................................... p .5 18

Quick In se r t ........................................................................................................................p .5 19

Spell checking.................................................................................................................... p .520

Sending e -m ail...................................................................................................................p.521
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K e y  m a c r o s

If you use a particular sequence of keystrokes frequently, you can record a key macro  to remember them 
and then "play” the macro back instead of retyping the sequence every time.

In this section
R ecording and p lay ing  back  a key m a c ro ................................................................ p .5 16

Saving and reusing key m acros....................................................................................p .5 17

R e c o r d i n g  a n d  p l a y i n g  b a c k  a  k e y  m a c r o

To record a key macro
1. On the Tools menu, point to Key Macro, and then click Start Recording. Alternatively, press 

Ctrl+Shift+M.
2. Type the sequence of keystrokes you want to record.
3. When finished typing, on the Tools menu, point to Key Macro, and then click Stop Recording. 

Alternatively, press Ctrl+Shift+M again.

(El Key macros only rem em ber keystrokes. They do not record m ouse movements and  clicks.
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To play back the last recorded key macro
Do one of the following:

• On the Tools menu, point to Key Macro, and then click Play Macro.
• Press Ctrl+M.

Related topics
Saving and reusing key m acro s................................................................................... p .5 17

S a v i n g  a n d  r e u s i n g  k e y  m a c r o s

When you record a new key macro using the Start Recording command (Ctrl+Shift+M), Namo WebEditor 
"forgets" the last macro you recorded, if any. If you want Namo WebEditor to remember more than one key 
macro at a time, you need to use the Key Macro Manager dialog box to save and play back macros. With 
the Key Macro Manager, you can permanently save any number of key macros and play back any macro by 
selecting it from a list.

To save the last recorded macro
1. On the Tools menu, point to Key Macro, and then click Macro Manager; or press Ctrl+Shift+O.
2. Click Add.
3. In the Macro name box, type a name for the macro so that you can identify it in the list of saved 

macros.
4. (optional) In the Description box, type a brief description of the macro to help yourself remember 

what was recorded.
5. Under Source, click Save previously recorded macro.
6. Click OK.

To play back a saved macro
Once you save a recorded key macro, you can no longer play it back with the Play Macro command 
(Ctrl+M). To play back a saved macro, use the Key Macro Manager.

1. On the Tools menu, point to Key Macro, and then click Macro Manager; or press Ctrl+Shift+O.
2. In the macro list, select the macro you want to play back.
3. (optional) In the Repetitions box, specify the number of times to repeat playback of the macro.
4. Click Play Macro or press Alt+P.

3  To quickly select and p lay  back a saved  macro, press Ctrl+Shift+O, type the fir s t  fe w  characters o f  the 
macro's name, and then p ress Alt+P.
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A u t o  C o r r e c t

Namo WebEditor’s Auto Correct feature automatically corrects common spelling and typographical errors 
as you type; for example, replacing "teh" with "the". If a word you mistype frequently is not in the built-in 
list, you can define an Auto Correct entry for it. Auto Correct only replaces a word after you press the 
space bar or the E n t e r  key.

You can also use Auto Correct to create shortcuts for text strings that you use frequently. For example, you 
could define an entry that replaces "sni" with "Sejoong Namo Interactive, Inc.". Then, whenever you typed 
"sni" followed by a space or the E n t e r  key, Namo WebEditor would automatically expand the shortcut to 
the full word or phrase you defined.

0  Auto Correct is enabled by default. However, it is initially se t to prom pt you  fo r  confirmation before 
replacing each shortcut or m istyped word. To turn o f f  confirmation and let Auto Correct replace words 
without prom pting you, deselect the Always show this dialog before replacing check box the next time 
you  see the Confirm Auto Correct dialog box.

To add an Auto Correct entry
1. On the Tools menu, click Auto Correct; or press S h i f t + F 7 .

2. Click Add.
3. In the R e p l a c e  box, type the word or shortcut you want Auto Correct to replace.
4 .  In the With box, type the word or phrase you want Auto Correct to substitute for the R e p l a c e  string.
5. (optional) If desired, select the Comment check box and enter a comment about the Auto Correct 

entry.
6. Click OK.

To disable or re-enable a specific Auto Correct entry
1. On the Tools menu, click Auto Correct; or press S h i f t + F 7 .

2. Click the check box next to the entry you want to disable or enable.

To disable Auto Correct
1. On the Tools menu, click Auto Correct; or press S h i f t + F 7 .

2. Deselect the Enable auto correct check box.

Special characters used in Auto Correct entries
The Auto Correct function recognizes three special characters—the hyphen ("-"), the asterisk ("*"), and the 
"at" sign ("@")—that you can use in entries to modify how a string will be replaced:

• A hyphen at the beginning or end of the R e p l a c e  string tells Auto Correct to replace it only  if it 
occurs as part of a larger word. A corresponding hyphen at the beginning or end of the With string 
tells Auto Correct to retain the rest of the word before or after the R e p l a c e  string while replacing.
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An asterisk at the beginning or end of the R eplace string tells Auto Correct to replace it every time, 
whether or not the string occurs as part of a larger word. A corresponding asterisk at the beginning 
or end of the With string tells Auto Correct to retain the rest of the word before or after the 
Replace string while replacing.
If an entry's R eplace string starts with an @ sign, and its With string is a URL, then Auto Correct 
will, instead of replacing the R eplace  string with the With string, add a hyperlink to the specified 
URL on each occurrence of the R eplace string. (For this to work, you must type the @ sign before 
the replace string in the document window as well.)

Some examples:

Replace With 
-ship -boat

-ful-
*ship

-less-
*boat

Example result
"membership” becomes "memberboat" (but "ship" by itself is not 
changed)
"tactfully" becomes "tactlessly"
"lordship" becomes "lordboat" and "ship" becomes "boat"

@Namo http://www.namo.com/ Namo

Q u i c k  I n s e r t

Quick Insert is a function with which you can define frequently used words or web documents, and call 
them out wherever and whenever you need them just by using the shortcut name of the Quick Insert item. 
The items that you can define as Quick Insert Items can be words, multilined paragraphs, web documents, 
etc. The web document used as a Quick Insert item can include any format such as font type, paragraph 
style, etc. and any object such as a table, image, etc.

You may set the shortcut name as "Morning", and the relevant Quick Insert item as "Good Morning, 
everybody!" In this case, if you type in "Morning," and press C t r l + = ,  t h e n  " M o r n i n g "  w i l l  b e  r e p l a c e d  b y  

" G o o d  M o r n i n g ,  e v e r y b o d y ! "

OHO Once you  define Q uick Insert items, yo u  can call them out anytime even after you  close the current 
document, or exit Nam o W ebEditor. Also yo u  can selectively remove them.

In this section
Defining a Quick Insert item ........................................................................................p.520

Inserting a Quick Insert item ........................................................................................p .520
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D e f i n i n g  a  Q u i c k  I n s e r t  i t e m

To add a Quick Insert item
1. On the Tools menu, click Quick Insert.
2. Click Add.
3. Enter a name to identify the Quick Insert item.
4. In the Item to insert section, enter the text to insert for this item.
5. Click OK.

To add a Quick Insert item that inserts a file

1. On the Tools menu, click Quick Insert.
2. Click Add.
3. Enter a name to identify the Quick Insert item.
4. In the Item to insert section, click File, and then click Browse and select the file to use.
5. Click OK.

0  To remove a  Quick Insert item, select the item to remove in the list, and then click R e m o v e .

I n s e r t i n g  a  Q u i c k  I n s e r t  i t e m

To insert a Quick Insert item using the keyboard only

• Type the name of the desired Quick Insert item and press Ctrl+=.

To select and insert a Quick Insert item
1. On the Tools menu, click Quick Insert.
2. Select the item to insert.
3. Click Insert.

S p e l l  c h e c k i n g

Namo WebEditor can check your spelling automatically as you type, highlighting misspelled words with 
red underlines. You can also manually initiate spell checking of an entire document in one operation. When 
automatic spell checking is enabled, words that Namo WebEditor thinks are misspelled are highlighted 
with a wavy red underline, as in tbsi£X2C3pfil.
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Namo WebEditor 6 includes spelling dictionaries for eleven European languages, plus four dialects: U.S. 
English, U.K. English, Canadian English, French, German, Danish, Dutch, Finnish, Italian, Norwegian, 
Portuguese, Brazilian Portuguese, Spanish, and Swedish. Any two of the dictionaries can be active at one 
time, so you can check your spelling in two languages at once.

If Namo WebEditor flags a word that you know is spelled correctly, you can add the word to your user 
dictionary to prevent Namo WebEditor from flagging it again.

To disable automatic spell checking
1. On the Tools menu, click Preferences, and then click the Edit tab.
2. Under Spell checking, deselect the Check spelling as you type check box.

To change the active spelling dictionaries
1. On the Tools menu, click Preferences, and then click the Edit tab.
2. Under Spell checking, click the Spelling dictionary 1 box and select the desired primary dictionary.
3. (optional) Click the Spelling dictionary 2 box and select the desired secondary dictionary.

To spell check a document

• On the Tools menu, click Check Spelling.

The Spelling Check dialog box will appear.

S e n d i n g  e - m a i l

You can e-mail the current document in one step. The Send E-mail command will open a message 
composition window in your default e-mail client and automatically attach the current Namo WebEditor 
document to the new message.

Also, Namo WebEditor includes several document templates that are specially designed to be used for e- 
mail. These templates include such things as stationery backgrounds, greetings, and even suggested layouts 
for various types of electronic mail.

To send the current document in an e-mail
1. On the File menu, click Send E-mail. Your default e-mail client will open a new message 

composition window, and the document will be automatically attached.
2. Enter the recipient address, subject, and body of the message, and then send the message as you 

normally do.
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To create a document using an e-mail template
1. On the File menu, click New.
2. Select the E-mail template category.
3. Select the desired template and click OK.
4. Replace the placeholder text and images (if any) in the template with your own content.

O p e n i n g  M i c r o s o f t  W o r d  d o c u m e n t s

You can import a Microsoft Word (*.doc) document, converting it to HTML format, and edit it in Namo 
WebEditor. You can preserve the document format and appearance when you import it. You can also 
import the text only.

To import a Word document
1. On the File menu, click Open.
2. In the Open dialog box, select "MS Word Files (*.doc)" as the file format.
3. Select the Word file to import, and click Open.
4. In the External File Import Options dialog box, specify the import options, and click OK.

o Keep Original Format: Keeps the original document appearance as possible. Also imports 
the Word style as it is. 

o Use <FONT> tags only: Does not include the Word style, and uses only the HTML 
<Font> tags.

o Import text only : Ignores the layout of the document, and just brings the text of the Word 
document.

Usually, content copied  by pressing  Ctrl+C in the W ord docum ent w ill have the sam e effect as "Keep  
Original Form at" function . I f  yo u  ju s t  want to convert the W ord docum ent to HTML, this func tion  is 
useful. However, in this case, it m ay be difficult to edit it. I f  you  want to edit an im ported W ord  
document, it is recom m ended to select either nUse <FONT> tags o n ly” or "Im port text o n ly" option.

D o c u m e n t  o u t l i n e s  a n d  t a b l e s  o f  c o n t e n t s

Namo WebEditor provides "Document Outline" function by which you can see the hierarchical structure of 
the document. If you select View > Document Outline, the document outline window appears in the left side 
of the edit window. However, if the document has no heading tags ( <hl>, <h2> .<h6>), nothing will 
appear in the document outline window.
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You can also insert the table of contents in the document by using the "Make Table of Contents” command 
in the document outline window. It automatically generate the bookmarks and hyperlinks to them.

In this section
Viewing a docum ent outline 

C reating a table o f  contents..

V i e w i n g  a  d o c u m e n t  o u t l i n e

If your document contains headings that use the standard HTML heading tags (<hl>, <h2>, etc.), you can 
view a hierarchical outline of the document. In case the whole contents of the document is long, you can 
easily move to the content you want to see. The length of the title in the document outline window can be 
adjusted by the list level.

Headings that use the <hl> tag are at the highest level; those that use <h6>, at the lowest level.

To reveal the document outline window

• On the View menu, click Document Outline, or press Alt+3.

To move around the document using the document outline window

• In the document outline window, select the content you want to move to.

To specify the levels to view in the document outline
1. Right-click in the document outline window.
2. Select the desired level in the shortcut menu. (For example, select "Show List Level 3", to view 

only the items on the first three levels.)

C r e a t i n g  a  t a b l e  o f  c o n t e n t s

The document outline shows the hierarchical structure of the document only in its window. However, if 
you use the "Make Table of Contents" function, you can actually insert the table of contents in the 
document. It automatically generate the bookmarks and hyperlinks to them.

To create a table of contents
1. On the View menu, click Document Outline, or press Alt+3.
2. In the document outline window, right-click to open the shortcut menu.
3. Select Make Table of Contents in the shortcut menu.

p.523

p.523

Miscellaneous features 523



Ñamo WebEditor 6 User Manual

4 .  In M a k e  T a b l e  o f  C o n t e n t s  dialog box, select C r e a t e  h y p e r l i n k s  t o  c o n t e n t  and I n s e r t  b o o k m a r k s  

w h e n  m a k i n g  h y p e r l i n k s .

5 . Click O K .

T h e  e q u a t i o n  e d i t o r

By using Namo WebEditor's built-in equation editor, you can easily insert mathematical equations and 
scientific formulas, using a large variety of special symbols, into your documents without needing to know 
a complicated math typesetting language like LaTeX. Even better, Namo WebEditor automatically 
generates a bitmapped version of your equation and inserts it into the document for you, so any user can 
view the equation in an ordinary browser.

T o  i n s e r t  a  m a t h e m a t i c a l  e q u a t i o n

1. On the Insert menu, click Equation.
2. Enter the desired equation. Use your keyboard to type ordinary numbers and letters. Use the 

buttons to enter special symbols.
3. (optional) If you know LaTeX, you can fine-tune the equation by clicking the Script tab and 

editing the LaTeX script manually.
4 .  Click O K  when done.

T o  e d i t  o r  r e s i z e  a n  e q u a t i o n

1. Double-click the equation in the document window.
2. Edit the equation as desired, and/or change its viewing size by clicking the ^2 and /2  buttons.
3. Click O K  when done.

0  The bitm apped im ages that N am o W ebEditor generates fo r  equations are stored  by default in an  
"images'1 subfolder o f  the docum ent's fo lder. To change the image location, do the fo llow ing:

1. On the Tools menu, click Preferences, and then click the Save tab.
2. In the Save equation images in folder box, enter a path relative to the current document's folder.
3. Click O K .
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S p e c i a l  c h a r a c t e r  o p e r a t i o n s

Various special functions related to characters and character sets may be found in the C h a n g e  C h a r a c t e r  

Format submenu of the Tools menu.

To change the case of selected text
1. Select the desired text.
2 . On the T o o l s  menu, point to C h a n g e  C h a r a c t e r  F o r m a t ,  and then click C h a n g e  C a s e .

3 . Select the desired case and click O K .

To change the width of double-byte Asian characters
1. Select the desired Asian text.
2 .  On the T o o l s  menu, point t o  C h a n g e  C h a r a c t e r  F o r m a t ,  and then c l i c k  C h a n g e  C h a r a c t e r  W i d t h .

3 .  C l i c k  e i t h e r  F u l l - w i d t h  o r  H a l f - w i d t h .

4. Under T a r g e t ,  select the types of characters to change.
5 . Click O K .

To convert between Hiragana and Katakana
1. Select the desired Japanese text.
2 .  On the T o o l s  menu, point to C h a n g e  C h a r a c t e r  F o r m a t ,  and then click C o n v e r t  H i r a g a n a / K a t a k a n a .

3 . Select the desired change and click O K .

To convert symbols in the selected text to double-byte characters
When a document containing double-byte characters has been opened in a text editor using a single-byte 
character set and then saved, the double-byte characters may have been with ASCII codes. If this has 
happened, you can recover the original characters using the C o n v e r t  S y m b o l s  t o  D B C S  command.

1. Select the text to be converted.
2 .  On the T o o l s  menu, point t o  C h a n g e  C h a r a c t e r  F o r m a t ,  and then c l i c k  C o n v e r t  S y m b o l s  t o  D B C S .
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U t ilit ie s  in c lu d e d  w ith  N a m o  W e b E d it o r

When you install Namo WebEditor, various Web utilities—Namo Capture, Namo GIF Animator, Namo 
Image Slicer—are installed as well.

• With Namo Capture, you can capture the screen, a window, or some other selection on the screen 
and save it to an image file.

• With Namo GIF Animator, you can create GIF animations.
• With Namo Image Slicer, you can slice an image into several pieces and export the pieces to an 

HTML table.

In this section
N am o C ap tu re ...........

Nam o GIF A nim ator 

N am o Im age S lic e r ..

N a m o  C a p t u r e

Use Namo Capture to take still pictures of your screen or various parts of it, including windows, menus, 
arbitrary rectangular areas, and the mouse pointer.

To start Namo Capture

• Click the S t a r t  button, point to P r o g r a m s ,  point to N a m o  W e b  Utilities, and then click N a m o  

C a p t u r e .

Basic operation
Namo Capture is very easy to use. The basic method of operation is as follows:

1. Specify the type of capture.
2. Arrange your screen so that you can see what you want to capture.
3. Press the Activate Capture hotkey.
4. If the chosen capture type requires it, select the area to capture.

At the end of this process, you will see a new window inside Namo Capture's main window, displaying 
what you captured. You can then do any of the following:

• Zoom in to see the captured image in greater detail
• Copy all or part of the captured image to the clipboard
• Save the captured image to a file

.p.526
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In the Capture Options dialog box, you can specify whether to use a right mouse click or a keypress to take 
a capture; how to cancel a capture, and whether to include the mouse pointer when capturing a screen area.

1. On the Capture menu, click Options.
2. Under Activate Capture Hotkey, choose the method of triggering a capture. You can choose to use 

a right mouse click or a keystroke, which can be any letter key or function key (such as F2), with 
or without the Ctrl and/or Shift modifier key.

3. Under Cancel Capture Hotkey, choose the method of cancelling a capture. You can choose to use 
the Esc key or another keystroke, which can be any letter key or function key (such as F2), with 
or without the Ctrl and/or Shift modifier key. (Use the Cancel Capture hotkey when you have 
started the capture process by specifying a capture type, but then you decide you don't want to go 
through with the capture after all. By cancelling the capture, you are telling Namo Capture not to 
intercept the next right mouse click or capture keystroke.)

4. Select or deselect the Include mouse pointer check box to tell Namo Capture whether or not to 
include the mouse pointer when capturing a screen area. (Needless to say, this option has no effect 
when you are capturing the mouse pointer itself.) You can toggle this setting outside of the 
Capture Options dialog box by clicking Include Mouse Pointer on the Capture menu or №  on the 
toolbar.

5. Click OK.

Specifying what to capture
The first step in taking a screen capture is specifying the type of capture you want to take. You can do so by 
selecting an item on the Capture menu or clicking a button on the toolbar. The capture types are described

Setting up the  Activate C apture hotkey and o ther options

below.

Button Capture Type Description
M Desktop Captures the entire screen.
□ Active Frame Captures the active main window.
□ Window Captures a selected window or sub-window.

5 Menu Captures the pulled-down menu.
LJ Rectangle Captures any rectangular region of the screen.
n Ellipse Captures any elliptical (round) region of the screen.
[hi Mouse Pointer Captures the mouse pointer.

LEI Once you specify a capture type, Namo Capture w ill automatically hide its own window. This is to 
prevent its appearing in a full-screen capture.

Capturing the entire screen
1. On the Capture menu, click Desktop.
2. Arrange the windows on the screen as desired.
3. Press the Activate Capture hotkey.
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Capturing an entire window
1. On the Capture menu, click Active Frame.
2. Bring the window you want to capture to the front.
3. Press the Activate Capture hotkey.

Capturing a sub-window
The main window of a Windows program may contain several distinct regions, like panes or toolbars, that 
are technically windows in their own right. You can capture one of these "sub-windows” using Namo 
Capture. 'j*

1. On the Capture menu, click Window.
2. Bring the program containing the window or sub-window you want to capture to the front.
3. Press the Activate Capture hotkey. The mouse pointer will turn into a reticle or gunsight shape to 

indicate window selection mode.
4. Move the mouse pointer over the window or sub-window you want to capture. As you move the 

mouse, different windows or sub-windows will be highlighted with a solid black rectangle. When 
the window or sub-window you want to capture is highlighted, press the left mouse button.

W A fter pressing  the Activate Capture hotkey, yo u  can still sw itch to a different program  by pressing  
Alt+Tab. D o not try to sw itch program s by clicking a button on the task bar, since that w ill cause the 
task bar its e lf to be captured.

Capturing a menu
1. On the Capture menu, click Menu.
2. Bring the program containing the menu you want to capture to the front.
3. Pull down the desired menu.
4. Press the Activate Capture hotkey.

0  I f  you  capture a submenu, a ll o f  its ancestors are captured as well. I f  a menu item is highlighted (by 
having the m ouse po in ter over it) when yo u  press the Activate Capture hotkey, that item w ill be 
highlighted in the captured im age as w e ll

Capturing a rectangular or elliptical screen area
1. On the Capture menu, click Rectangle or Ellipse, depending on the shape you want to capture.
2. Arrange the windows on the screen as desired.
3. Press the Activate Capture hotkey. The mouse pointer will turn into a crosshair with a rectangle or 

an oval.
4. Left-click and drag the mouse pointer over the desired area. A dashed rectangle or ellipse will 

appear, indicating the area that will be captured. Release the mouse button when the desired area is 
covered.

El When you  capture an elliptical area, the area outside o f  the ellipse extending to the borders o f  the 
image will be white. There is no option to change this background color.
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1. On the Capture menu, click Mouse Pointer.
2. Do whatever you have to do to change the mouse pointer into the shape you want to capture.
3. Press the Activate Capture hotkey.

Copying a captured image (or part of it) to the clipboard
After you capture something, the whole image is automatically selected. To copy the whole image to the 
clipboard, click Copy on the Edit menu or ©  on the toolbar, or press Ctrl+C. To copy just part of the image, 
select the desired area before copying. To select an area of the image, click LJ on the toolbar and then draw 
a box around the desired part of the image. You can restore the selection to the whole image by pressing 
Ctrl + A.

It is often easier to select part of an image if you zoom in first. To do so, click a  on the toolbar and then 
click the image repeatedly until the desired magnification is reached. You can also zoom in by pressing the 
keypad + key on your keyboard. To zoom back out, press keypad -.

Saving a captured image to a file

To save the current captured image to a file, click S a v e  on the F i l e  menu or H  on the toolbar. You can 
save in either GIF or BMP format; to choose the format, click the S a v e  a s  t y p e  box in the S a v e  As dialog 
box.

G IF form at usually produces much sm aller file s  than BM P , but it is lim ited to 256 colors. When saving  
a capture that contains m any colors (such as a photograph or a gradient), choose B M P  fo rm a t f o r  best 
results.

Capturing the  m ouse pointer

N a m o  G I F  A n i m a t o r

The animation GIF file, when inserted into a web document, shows an moving image. The advantage of the 
animation GIF file is that it does not require any separate plug-in as in the case of Flash files, Shockwave 
files, etc.

If you use Namo GIF Animator which is provided along with Namo WebEditor, you can easily make GIF 
animation with GIF or BMP files.

In this section
Starting N am o G IF A nim ator 

Setting up the edit w indow ....

Creating an an im a tio n .............
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V iew ing and setting anim ation properties.

Editing fram es....................................................

Setting a transparent c o lo r ............................

Editing co lors.....................................................

Setting delay tim e and rep ea t.......................

Preview ing your an im atio n ...........................

Saving your an im a tio n ....................................
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S t a r t i n g  N a m o  G I F  A n i m a t o r

To start Namo GIF Animator, click the Start button, point to Programs, point to Namo Web Utilities, and 
then click Namo GIF Animator. In case you use Namo GIF Animator frequently, it is recommended to 
register it on the ’’External Programs" list of Namo WebEditor so that you can use it conveniently.

To register Namo GIF Animator on the external programs list of Namo WebEditor
1. On the Tools menu, click External Programs.
2. In the Preferences dialog box, select External Programs tab.
3. At the Name in Program 3, enter "Namo GIF Animator", and click Browse to find the path. In case 

you install Namo WebEditor at "C:\Program Files", the Namo GIF Animator’s path becomes 
"C:\Program Files\Namo\WebEditor 6\bin\Tools\NamoAniGif.exe."

4. Click OK to register it as an external program of Namo WebEditor.

To zoom the canvas
You can zoom out the size of the canvas of the animation.

1. On the Tools menu, click Crop Canvas.
2. Bring the mouse pointer over the frame. Drag it to select the area you want.
3. The size of the canvas will be zoom outd to the size of the area you have cropped.

To zoom in/out the content of the edit window
On the View menu, click Zoom in or Zoom out. You can also use the toolbar.

• To zoom in the window, on the View menu, click Zoom in, or click @lon the toolbar.
• To zoom out the window, on the View menu, click Zoom out, or click ^ o n  the toolbar.
• To see the actual view, on the View menu, click Actual Pixels, or click ^ o n  the toolbar.

S e t t i n g  u p  t h e  w o r k  e n v i r o n m e n t
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To show/hide the toolbar
To show/hide the toolbar, on the View menu, click Toolbar.

To show/hide the status bar
To show/hide the status bar, on the View menu, click Status Bar.

C r e a t i n g  a n  a n i m a t i o n

The animation GIF file may seem as a single image. But, in fact, it is a combination of several images. 
When the GIF animation plays, the images are shown in sequence. Each of the image is called a ’’frame.”

To create a new animation
1. In the menu, File menu, click New.
2. On the Edit menu, click Insert Frame.
3. Click Add.
4. Select a GIF or BMP format image and click Open.
5. Repeat steps 2 through 4 for each additional frame.
6. Click OK.

When adding several images at once, you can change their order by clicking Move Up or Move Down in the 
Insert Frame dialog box.

Chapter 9: Appendices

V i e w i n g  a n d  s e t t i n g  a n i m a t i o n  p r o p e r t i e s

To view or set the properties of a frame
1. Select a frame.
2. In the Properties window, click the Frame tab.

0  F ram es are nam ed according to the ir position in the animation sequence , starting fro m  "Fram e  /" .

To view or set the properties of an animation
1. In the Properties window, click the Animation tab.
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E d i t i n g  f r a m e s

You can change the order of the frames and edit its images. In case there is an unnecessary frame, you can 
cut it out, and keep the necessary ones. Besides, you can change the position of the image in a frame, and 
rotate it.

To change the order of frames
1. Select the frame to move.
2. On the Edit menu, click Move Frame Up or Move Frame Down. You can also click T or 4̂  on the 

toolbar.

To crop a frame
1. Select a frame.
2. On the Tools menu, click Crop Image, or click ISon the toolbar.
3. Draw a box around the part of the image you want to keep. When you release the mouse button, 

the rest of the image will be deleted.

To shift a frame
1. Select a frame.
2. On the Tools menu, click Move Image, or click *J*on the toolbar.
3. Click and move the frame to the desired position.

y  To undo any change, press Ctrl+Z.

S e t t i n g  a  t r a n s p a r e n t  c o l o r

You can set a transparent color for one or more frames of an animation, so that the background of a Web 
document can be seen "through" areas of those frames that have that color.

To set a transparent color
1. Select the frame or frames for which you want to set a transparent color. (To select multiple 

contiguous frames, click the first, and then click the last while holding down the Shift key. To 
select multiple non-contiguous frames, click each while holding down the Ctrl key.)

2. On the Tools menu, click Select Transparent Color.
3. Select the color you want to be transparent. You can select a color in the image by clicking on the 

image in the preview area. Use the button to zoom into the preview to make it easier to select a 
color.

4. Click OK.
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To see the frames of the animation as they would appear on a Web page with a white background, on the 
View menu, click Hide Transparent Color, or click ifton the toolbar.

To hide tran sp a ren t colors

E d i t i n g  c o l o r s

You can change one or more colors in one or more frames by editing their color palettes.

To edit the color palette of a frame
1. Select a frame.
2. On the Tools menu, click Edit Palette, or click ©on the toolbar.
3. Select a color that you want to change. (You can select a color in the image by clicking in the 

preview area.)
4. Click Change Color.
5. Select a new color and click OK.
6. Click OK.
7. Repeat steps 3 through 6 for each color you want to change.

S e t t i n g  d e l a y  t i m e  a n d  r e p e a t

You can set the delay time, or interval between two frames, independently for each frame of an animation.
You can also specify how many times an animation will repeat.

To set the delay time for a frame
1. Select the frame or frames for which to set the delay time. (Press Ctrl+A to select the whole 

animation.)
2. On the Frame tab of the Properties window, in the Delay time box, specify the delay time in 

hundredths of a second.

Specifying repetitions
Repetitions are controlled on the Animation tab of the Properties window.

• To make the animation play just once, deselect the Repeat check box.
• To make the animation repeat a certain number of times, select the Repeat check box and then 

enter a number in the Repetitions box.
• To make the animation loop endlessly, select both the Repeat and Loop forever check boxes.
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P r e v i e w i n g  y o u r  a n i m a t i o n

To preview the current animation, click Preview on the View menu or ► on the toolbar, press F5. This will 
open the Preview window.

In the Preview window, you can use the various buttons at the bottom to move through the animation. You 
can also jump to a specific frame by dragging the frame slider.

S a v i n g  y o u r  a n i m a t i o n

To save the current animation

• On the File menu, click Save, or click H  on the toolbar.

To save a selected frame
1. Select the frame to save.
2. On the Edit menu, click Save Frame, or click on the toolbar.

N a m o  I m a g e  S l i c e r

Use Namo Image Slicer to break an image up into several pieces, like the pieces of a jigsaw puzzle. Slicing 
an image in this way has several benefits, including the following:

• Browsers can download several pieces of a sliced image at the same time, causing the whole 
image to load faster.

• Slicing an image gives you more flexibility when placing the image in a table (p. 182), since you 
can put pieces of the image into adjacent cells to suit your design requirements.

• You can create several variations of an image—for example, with different text components—by 
creating several versions of one piece of the image instead of editing the whole image.

• You can put hyperlinks on different parts of a sliced image without using an image map (p.177).

In this section
Creating a project and im porting an im a g e ..............................................................p.535

Setting up export se ttings............................................................................................... p.535

Setting up snap and grid se ttin g s................................................................................. p .536

Creating, m oving, and  resizing s l ic e s ........................................................................p .537
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R eordering overlapping slices ..................................................................................... p.537

Deleting slices...................................................................................................................p .538

Specifying export options for a  specific slice .........................................................p.538

Dealing w ith undefined a reas .......................................................................................p .539

Exporting a sliced im age to H T M L ........................................................................... p.539

C r e a t i n g  a  p r o j e c t  a n d  i m p o r t i n g  a n  i m a g e

Before slicing an image, you have to create new N am o Image Slicer project.

To create a new project

•  On the F i l e  menu, click N e w ,  or click Q o n  the toolbar.

Next, import the image you want to slice.

To import an image for slicing

1. On the File menu, click Import Image, or click IÊ1 on the toolbar.
2. Select the desired image and click Open.

S e t t i n g  u p  e x p o r t  s e t t i n g s

Before exporting a sliced image to H T M L , you should set up a few export settings the w ay you want. These 
settings are found on the D e f a u l t s  tab o f  the P r o p e r t i e s  panel. ( I f  the P r o p e r t i e s  panel is hidden, reveal it 
by clicking P r o p e r t i e s  on the W i n d o w  menu.)

HTML options

•  Export as Namo layout box: Select this option i f  you want the image slices to be exported as a 
layout box (p.91) instead o f an ordinary table.

•  U s e  < s p a c e r >  t a g s :  You m ay need to select this option to make a sliced image appear correctly in  
some Netscape browsers.

Default image format

•  File format: Specify the default file  format in which to save the image slices. (Y ou  can override 
(p.538) the default format for a specific slice, i f  you want.) I f  you select G IF format, the Color 
reduction box is enabled; click it and select one o f  the following color reduction methods:

o M e d i a n  Cut: Prioritizes colors in order o f  frequency in use. This option is best for images 
w ith many colors, like photographs.
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o Octree: Preserves the original palette if the image source is a GIF file or an 8-bit PNG file, 
o Popularity: If possible, the original palette will be preserved. Use this option if you want 

the image to be as precise as possible with the fewest colors.

Image folder
This setting specifies the path of the folder where the image files created from the slices will be saved. The 
path is relative to the exported HTML file. For example, if the image folder path is "images\", and you 
export the HTML file to the folder "C:\web", the images will be saved in "C:\web\images".

S e t t i n g  u p  s n a p  a n d  g r i d  s e t t i n g s

Namo Image Slicer's snap and grid functions make it easier to slice images precisely. These functions are 
controlled through the Snap/Grid/Zoom tab of the Properties panel. (If the Properties panel is hidden, 
reveal it by clicking Properties on the Window menu.)

Snap settings
When snap-to-neighbors is enabled, the edges of a new slice "snap” to the edges of neighboring slices and 
to the image borders when the mouse pointer is close to a neighboring slice or an image border. Enabling 
snap-to-neighbors makes it easy to "tile" the image into slices precisely, without having to click and move 
the mouse precisely. To enable snap-to-neighbors, select the Snap to neighbors check box. The number in 
the Tolerance box specifies how close the mouse pointer must be to a neighboring slice or an image border 
before the edge of the new slice will snap to it.

Grid settings
When the grid is enabled, the image is covered by a virtual grid, like the lines on graph paper. The edges of 
new slices "snap" to the gridlines, making it easy to draw slices that are the same size or an even multiple 
of some base size. You can specify the horizontal and vertical grid spacing independently, and you can 
optionally offset the origin of the grid by some distance horizontally and/or vertically relative to the image's 
top left comer.

To enable the grid and set its properties, do the following:
1. Select the Grid check box.
2. Specify the horizontal and vertical grid spacing in the Spacing X and Y boxes, respectively. (To 

specify different grid spacing values for the horizontal and vertical axes independently, deselect 
the Sync X-Y check box.)

3. (optional) Specify the distance by which the origin of the grid is offset from the origin of the 
image using the Offset X and Y boxes.

4. To enable snap-to-grid, select the Snap to grid check box.
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ED You must explicitly enable snap-to-grid by selecting the Snap to grid check box. It is deselected by 
default.

0  Snap-to-grid and snap-to-neighbors are mutually exclusive: enabling one will disable the other.

0  Snapping also works when you move and resize slices, not just when you create them.

C r e a t i n g ,  m o v i n g ,  a n d  r e s i z i n g  s l i c e s

To creating a slice

1. On the Tools menu, click Slicer, or click I?  on the Work Tools bar. (The Slicer Tool is selected 
by default when you import an image.)

2. Draw a box around a part of the image. When you release the mouse button, that part of the image 
is shaded green, indicating that it is now a slice.

Repeat step 2 for each slice you want to create.

To move a slice

1. On the Tools menu, click Selection, or click ̂  on the Work Tools bar.
2. Drag the desired slice to the desired position.

To resize a slice

1. On the Tools menu, click Selection, or click ̂  on the Work Tools bar.
2. Click to select the slice you want to resize.
3. Drag any of its resize handles in any direction.

9  You can temporarily switch from the Slicer Tool to the Selection Tool or vice versa by holding down 
the Ctrl key.

R e o r d e r i n g  o v e r l a p p i n g  s l i c e s

When two or more sliced areas overlap, you can control their top-to-bottom order. This affects the way the 
overlapping slices are themselves sliced.

1. Switch to the Selection Tool. (Click ^ on the Work Tools bar.)
2. Select a slice that overlaps with another.
3. Click any of the following buttons on the Work Tools bar:
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o  ( B r i n g  t o  F r o n t )  to  m a k e  th e  se le c te d  s lic e  to p m o s t

o  ( B r i n g  F o r w a r d )  to  " ra ise "  th e  se le c te d  s lice  o n e  lev e l

o  f c  ( S e n d  B a c k w a r d )  to  " lo w e r"  th e  se le c te d  s lic e  o n e  le v e l

o  ( S e n d  T o  B a c k )  to  m a k e  th e  se le c te d  s lice  b o tto m m o s t

D e l e t i n g  s l i c e s

To delete a slice

1. Switch to the Selection Tool. (Click ^ on the Work Tools bar.)
2. Select the slice to delete.
3. Press Delete.

S p e c i f y i n g  e x p o r t  o p t i o n s  f o r  a  s p e c i f i c  s l i c e

You can change the export options of a specific slice through the Slice tab of the Properties panel while the 
slice is selected.

Changing the export type
Normally, Namo Image Slicer exports each slice as an ordinary image inside a table cell. However, you can 
specify that a specific slice be exported as the background image for its corresponding table cell, or that its 
corresponding table cell be left empty.

To change this setting, click the Export the selected slice as box and select an option.

Overriding the default image format
Y o u  c a n  sp e c ify  th a t  a  sp e c if ic  s lic e  b e  sa v e d  in  a d if fe re n t  im a g e  fo rm a t f ro m  th e  d e fa u lt  (p.535). T o  d o  so , 
do  th is :

1. Under Image format, deselect Use default.
2. Click the File format box and select a format. If you select GIF format, the Color reduction box is 

enabled; click it and select one of the following color reduction methods:
o Median Cut: Prioritizes colors in order of frequency in use. This option is best for images 

with many colors, like photographs,
o Octree: Preserves the original palette if the image source is a GIF file or an 8-bit PNG file,
o Popularity: If possible, the original palette will be preserved. Use this option if you want 

the image to be as precise as possible with the fewest colors.
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Norm ally, Nam o Image Slicer nam es each exported image file automatically, by appending a  sequential 
four-digit num ber to the project name. H ow ever, you can specify an arbitrary file nam e for any  given slice.

1 . U nder F i l e n a m e ,  deselect U s e  a u t o n a m i n g .

2. In the box, enter the desired file name. (Do not include an extension, since N am o Im age Slicer will 
add one automatically.)

Specifying a file nam e

D e a l i n g  w i t h  u n d e f i n e d  a r e a s

W hen you slice an image, you don’t have to cover the entire im age with slices. You can leave parts o f  the 
image undefined— that is, not covered by  slices. By default, Nam o Image Slicer will autom atically divide 
undefined areas into the smallest possible num ber o f  slices and export them along w ith the slices you have 
explicitly created. However, you can change the w ay N am o Image Slicer exports undefined areas. To do so, 
click the S l i c e  tab o f  the P r o p e r t i e s  panel w hile no slice is selected. The E x p o r t  u n d e f i n e d  a r e a s  a s  box has 
three options:

•  N o r m a l  i m a g e s :  Nam o Image Slicer will autom atically divide undefined areas into "im plicit” 
slices and export them  in the sam e w ay as "explicit" slices.

•  C e l l  b a c k g r o u n d  i m a g e s :  The sam e as N o r m a l  i m a g e s ,  except that the implicit slices will becom e 
background images for the table cells they correspond to.

•  Empty cells: Nam o Im age Slicer w ill only export explicit slices. The table cells corresponding to 
undefined areas will be empty.

E x p o r t i n g  a  s l i c e d  i m a g e  t o  H T M L

W hen you have finished slicing an image, you can export it to HTM L. W hat this m eans is:

•  The image portion covered by each slice is saved as a separate image file. (In the case o f  
"implicit" slices, an image file m ay or may not be saved, depending on the state o f  the E x p o r t  

u n d e f i n e d  a r e a s  a s  (p.539) setting on the Slice tab o f  the P r o p e r t i e s  panel.)

• Namo Image Slicer generates an HTM L docum ent and insert a table or layout box into it, 
depending on the state o f  the E x p o r t  a s  N a m o  l a y o u t  b o x  (p.535) option on the D e f a u l t s  tab o f  
the P roperties panel. This table o r layout box is divided into a certain num ber o f  cells, one cell for 
each slice (including any "im plicit" slices covering undefined areas o f  the original image).

•  Each saved image file is inserted into its corresponding table cell in the HTM L docum ent, either 
as a normal image (using an <im g> tag) or as the cell's background image (p.202).
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To export a sliced image to HTML

1 . On the File menu, click Export H T M L , or click B  on the toolbar.
2. Navigate to the folder where you want to save the HTML document, specify a file name, and then 

click Save.

The new images will be saved in the folder specified in the I m a g e  f o l d e r  box on the E x p o r t  tab of the 
P r o p e r t i e s  panel.
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K e y b o a r d  s h o r t c u t s

File-related sho rtcu ts .......................................................................................................p .541

W indow /panel/view  sho rtcu ts ..................................................................................... p.541

Text editing shortcu ts..................................................................................................... p.542

Inserting shortcuts............................................................................................................p.543

Form atting sh o rtc u ts .......................................................................................................p.544

Table-related shortcu ts...................................................................................................p.544

Fram e-related sho rtcu ts..................................................................................................p.545

Utility shortcuts.................................................................................................................p.545

Other shortcuts..................................................................................................................p.546

F ile - re la te d  s h o r tc u t s

Keystroke Function
Ctrl + D Save document as...
Ctrl + N New document
Ctrl + 0 Open document...
Ctrl + P Print...
Ctrl + S Save document
Ctrl + F4 Close document
Ctrl + FI Document properties.

W in d o w /p a n e l /v ie w  s h o r tc u t s

Keystroke Function
Ctrl + W Window list...
Alt + Shift + R Show/hide rulers
Alt + 0 Results panel
Alt + 1 Site Manager window
Alt+ 2 Inspector panel
Alt + 3 Document Outline
Alt+ 4 Timeline panel
Alt+ 5 Tag Selector
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Keystroke Function
Alt + 6 Layers panel
Alt + 7 Actions panel
Alt + 8 Formatting panel
Alt + 9 Site Library panel
Ctrl + / Show/hide panels
Ctrl + Tab Switch to next document
Ctrl + Shift + Tab Switch to previous document
F4 Publish window
Ctrl + F4 Close document window
F5 Auto-detect encoding / Revert to saved
Shift + F5 Refresh screen
F6 Cycle mode forward
Shift + F6 Cycle mode backward
FI 1 Preview document in Browser 2 (default: Internet Explorer)
F12 Preview document in Browser 1 (default: Netscape)

T e x t e d i t in g  s h o r t c u t s

Keystroke Function
Ctrl + A Select all
Ctrl + С Copy selection to clipboard
Ctrl + V Paste from clipboard
Ctrl + X Cut selection to clipboard
Ctrl + Y Delete line
Ctrl + Z Undo
Alt + Z Redo
Ctrl + Backspace Delete word left
Alt + Backspace Undo
Ctrl + Insert Copy selection to clipboard
Shift + Insert Paste from clipboard
Ctrl + Delete Delete word right
Ctrl + Home Move to top of document
Ctrl + End Move to end of document
Ctrl + Page Up Move to top of window
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Keystroke Function
Ctrl + Page Down Move to bottom of window
Ctrl + Left Move to beginning of previous word
Ctrl + Right Move to beginning of next word
Shift + Ctrl + Left Extend selection to beginning of previous word
Shift + Ctrl + Right Extend selection to beginning of next word
Shift + Up Extend selection up one line
Shift + Down Extend selection down one line
Home Move to beginning of line
End Move to end of line
Shift + Home Extend selection to beginning of line
Shift + End Extend selection to end of line
F3 Find again
F7 Check spelling
Shift+ F7 Auto Correct...

I n s e r t in g  s h o r tc u t s

Keystroke Function
Ctrl + Shift + A Insert layer
Ctrl + G Add bookmark...
Ctrl + Shift + I Insert image / Image properties...
Alt + Shift + 1 Image effects...
Ctrl + Space Insert non-breaking space
Ctrl + Enter Insert page break
Shift + Enter Insert line break
Ctrl + = Quick Insert (after typing Quick Insert keyword
Ctrl + F7 Insert symbol...
F9 Create hyperlink...
Shift + F9 Remove hyperlink
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F o rm a tt in g  s h o r t c u t s

K eystroke 

Ctrl + В 

Ctrl + E 

Ctrl + 1 

Ctrl + J 

Ctrl + L 

Ctrl + T 

Ctrl + U 

Ctrl + 1-6  

Ctrl + 7 

Ctrl + 8 

Ctrl + 9 

Ctrl + 0 (zero)

Ctrl + [

Ctrl + ]

Alt + Enter 

F2

Shift + F2 

Ctrl + F6 

F8

Shift + F8

T a b le - re la te d  s h o r tc u t s

Keystroke
Tab

Shift + Tab 

Del

Shift + Del 

Ctrl + Shift + L 

Ctrl + Shift + T 

Alt + Shift + T 

Ctrl + F8

Function
Bold

Clear character formatting 

Italic

A pply last font color 

Font...

Format paragraph...

Underline

Heading 1~6

Preform atted text

N um bered list

Bulleted list

Norm al paragraph

Decrease indentation

Increase indentation

View properties o f  selected element

Paste format

Copy format...

Define styles...

Join lists 

Split list

Function
M ove to next cell 

M ove to previous cell 

Delete selected cell contents 

Delete selected cells 

Cell properties...

Table properties...

Select table 

M erge cells

544 Keyboard shortcuts



Chapter 9: Appendices

Keystroke 
Ctrl + Shift+ F8

Function 
Split cells..

F r a m e - r e la te d  s h o r tc u t s

Keystroke
Ctrl H- Shift + N 
Ctrl + Shift + О 
Ctrl + Shift + P 
Ctrl + Shift + R 
Ctrl + Shift + S

Function
New document in frame 
Open document in frame.. 
Print frameset...
Frame properties...
Save all frames

U tility  s h o r tc u t s

Keystroke
Ctrl + F
Ctrl + Shift + F
Ctrl + H
Ctrl + R
Ctrl + К
Ctrl + M
Ctrl + Shift+ M
Ctrl + Shift + 0 (zero)
Shift + FI 1
Shift+ F12

Function
Find...
Global find and replace...
Find and replace...
Find and replace...
Assign temporary bookmark (press Ctrl + K followed by 1-9) 
Play key macro
Record key macro / stop recording 
Key macro manager...
Import document from Browser 2 
Import document from Browser 1
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O th e r  s h o r tc u t s

Keystroke 
Alt + Click 
Alt + Shift + S 
Alt + Shift + W 
FI
Shift + FI 
Alt + X 
Alt + F4

Function
Open hyperlink destination 
Save site 
Script Wizard...
Help
HTML/CSS Reference 
Exit Namo WebEditor 
Exit Namo WebEditor
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