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Producing E-Books from InDesign: EPUB and Kindle
By Anne-Marie Concepción and Gabriel Powell

The material in this article is taken from one of the most popular and 
well received presentations at the recent InDesignSecrets Print and 
ePublishing Conference. Two lively and effective speakers delivered this 
fast-paced presentation, and it was obvious the hundreds of people in 
attendance were hanging onto every word. Some even photographed 
the material as it was presented on screen. TSR is pleased to present this 
information because it delivers in-depth insights on a task many pub-
lishers are struggling to complete efficiently. 

Some publishers are turning to third-party services to convert books to 
e-books when the process could be done with lower costs and better re-
sults in-house. The material in this presentation will help publishers create 
effective multi-channel workflows. It will also help graphic designers and 
production staff who need to know how to convert files into an e-book.

The Anatomy of an EPUB File
The EPUB format is a free and open e-book standard developed by the 
International Digital Publishing Forum . It is essentially a mini Web site. 
An EPUB is a package of several XML files, any number of HTML files, 
one or more CSS files, all the images for the publication, and possibly a 
few font files. All of these files work together to create the e-book expe-
rience. The files are packaged together into a single ZIP archive that is 
given the .epub file extension.

Preparing a Document for Export from InDesign
�� InDesign CS4: Choose File > Export for Digital Editions.

�� InDesign CS5: Choose File > Export For > EPUB.

�� InDesign CS5.5: Choose File > Export and then select EPUB from 
the Format drop-down list.

What is NOT exported 
from an InDesign file?

�� Master page items 
such as automatic page 
numbers.

�� Page breaks, column 
breaks, and frame breaks.

�� The formatting of text 
formatted with nested 
styles and GREP styles 
(CS4 and CS5).

�� The exact position of 
images unless they 
are anchored within 
text, added to the XML 
structure pane (CS5 and 
CS5.5), or added to the 
Articles panel (CS5.5).

�� Table and cell formatting 
(CS4 and CS5). 

�� A table of contents 
generated with a TOC 
style (CS4 and CS5). 

�� An index generated with 
InDesign’s Index panel.
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Controlling the Reading Order of Text and Graphics
There are three methods for controlling the reading order of text and 
graphics in an EPUB file. The method to select depends on the version 
of InDesign:

�� Based on page layout (CS4–CS5.5), 

�� Same as XML structure (CS5 and CS5.5), or 

�� Same as Articles panel (CS5.5).

Controlling Page Breaks and Chapter Breaks
There are four methods for controlling page breaks and chapter breaks:

�� Use an InDesign book file: To start a chapter or specific section of 
an e-book on its own page, create a separate InDesign document 
for it. Then, combine all the documents together into an InDesign 
book file (File > New > Book) and export the EPUB file.

�� Base the breaks on the first level TOC entries (CS5 Only): To 
use this method, first create a TOC Style (Layout > Table of Contents 
Styles). Define one or more first level TOC entries. When exporting 
the EPUB file, select Include InDesign TOC Entries (Contents section) 
and then select Use First Level Entries as Chapter Breaks.

�� Insert page breaks before and/or after images (CS5.5): 
Specify a page break before and/or after specific images (via 
Object Export Options) or insert them globally for all images 
when exporting an EPUB file.

�� Create chapter breaks at a specific paragraph style (CS5.5): 
Create and apply a paragraph style (such as Chapter Title) to all 
paragraphs which start at the top of a new section or chapter. 
When exporting the EPUB file, select Break Document at 
Paragraph Style (Contents section) and specify a paragraph style 
in the menu to the right of the option.

Text Formatting Tips
�� Use paragraph and character styles to control the formatting of 

text. The applied styles are used as the basis for generating the 
CSS styles in the EPUB file.

�� The appearance of text formatted locally (without using a style) 
can be maintained by selecting the Preserve Local Overrides 
option when exporting an EPUB file. However, this process can 
result in a messy CSS file.

�� Convert nested styles and GREP styles to character styles (CS4 and 
CS5). Download the handy Apply Nested Styles script to automate 
this process.

�� Remove all unnecessary forced line breaks (soft-returns). InDesign 
CS5.5 provides an option to remove all soft-returns when 
exporting an EPUB file.

�� Replace all non-breaking (hard) hyphens with discretionary (soft) 
hyphens using the Find/Change feature. 

�� Replace all extra paragraph returns between paragraphs with 
Space Before and/or Space After.

�� Points are converted nicely to EM units in the CSS file (12pt = 1em).  
 
The EM unit is very useful in CSS, since it can adapt automatically 
to the font size the reader uses.

�� If using InDesign’s Bullets and Numbering feature to create 
bulleted and numbered lists, export these as HTML lists.

�� Footnotes are converted to bidirectional hyperlinks. With 
InDesign CS4 and CS5, hyperlinks are converted to endnotes. 
With InDesign CS5.5, users may choose to place footnotes after 
the paragraph or convert them to endnotes.
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Optimizing Images for CS4 and CS5 exports
�� Insert images as anchored objects to control their position in the 

EPUB file.

�� To control the space before and after an anchored image, apply 
a paragraph style to the paragraph to which the graphic is 
anchored and define the appropriate Space Before and Space 
After values.

�� Create a single image for the cover if the image is made up of 
multiple components.

�� Convert InDesign artwork to external images and place them 
back into the file. Keep in mind an InDesign file can be placed 
within an InDesign file.

�� Use the points or pixels measurement systems when sizing 
graphics.

�� When exporting an EPUB file, choose Optimized from the Copy 
Images menu in the Images section of the Export Options dialog 
box. Also specify the Formatted option.

Optimizing Images for CS5.5 exports
InDesign CS5.5 significantly improves image export to EPUB. Here are 
the highlights:

�� Resolution: A standard resolution of images in pixels per inch (ppi) 
may be selected. Choose 72, 96, 150, or 300 ppi.

�� Image Size: Specify whether the image size is fixed (same 
behavior as CS4 and CS5) or resized relative to the width of the 
page. The Relative to Page option sets a relative percentage value 
based on the size of the image relative to the InDesign page 
width. As a result, the images rescale relative to the width of the 
reading area.

�� Image Alignment and Spacing: Specify how the images are 
aligned (left, center, right) and spaced (top and bottom padding). 
These export options apply globally to all images unless custom 
alignment and spacing has been applied via Object Export 
Options (Object menu). Image Conversion: Images can be 
exported as GIF, JPEG, or PNG files.

Adding the Final Touches
�� Table of Contents. To create a typical table of contents at 

the beginning of an e-book, manually insert the text and use 
hyperlinks or cross-references to create hyperlinked entries (CS4 
and CS5). InDesign CS5.5 automatically exports a hyperlinked 
table of contents if the TOC is generated with InDesign’s Table of 
Contents feature.

�� Navigation Guide. The navigation guide often appears as a 
menu in an e-book and allows a reader to quickly jump to a 
particular section or chapter. InDesign automatically creates 
the navigation guide based on the document name(s) or a TOC 
style. Specify the TOC style to use when exporting an EPUB file 
(Contents section).

�� Insert Metadata. Metadata is information about an e-book. 
It is essential to include metadata in every e-book, because it 
makes the material searchable. To insert metadata, choose File > 
File Info. Fill out Document Title, Author, Description, Keywords 
(subject categories), and Copyright Notice fields. When you 
export an EPUB file, fill out the Publisher Entry and Unique 
Identifier (ISBN) fields.

Editing an EPUB File
Once an EPUB file has been unarchived, any text editor can be used to 
edit the content. However, a dedicated XML/ HTML editor is ideal for 
its flexibility and power. (TSR note: this is an excellent recommendation. 
While a plain vanilla text editor will get the job done, the tasks of editing 
and tracking edits is much easier when a dedicated tool is used.)
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oXygen XML Editor or oXygen XML Author are great because these pro-
grams open EPUBs directly, allows users to edit the content, save the chang-
es, and instantly view the results in an e-reader.. Visit oxygenxml.com.

Sigil is a multi-platform WYSIWYG e-book editor. Visit code.google.
com/p/sigil/ to learn more.

Here are some of the reasons to edit an EPUB file:

�� Add/modify the metadata,

�� Customize the navigation guide, or

�� Fix the CSS and HTML markup for drop caps, paragraph rules, 
boxed text, word spacing and letter spacing, floating elements 
(text wrap, table formatting, and other niceties InDesign does not 
do very well yet).

Testing and Validating
�� View the e-books on different e-readers (desktop version): 

�� Adobe Digital Editions 

�� EPUB Reader Add-on for Firefox 

�� Sony Reader Library Application

Things to Look For
�� Is the text properly formatted using paragraph and character 

styles? 

�� Are all special or foreign characters displaying correctly? 

�� Are the images in the correct position?

�� Do all the hyperlinks and cross-references work? 

�� Is the metadata is correct? 

�� Is the table of contents (navigation guide) in the right order?

Use a preflight profile in InDesign to flag issues. Test and validate e-
books at threepress.org. Test each device used to read the e-book 
such as Adobe Supported e-readers (such as theSony Reader and 
Barnes & Noble Nook), and the Apple iPad.

The Workflow: InDesign to Kindle

http://www.oxygenxml.com/
http://code.google.com/p/sigil/
http://code.google.com/p/sigil/
http://www.threepress.org/document/epub-validate/
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Converting an EPUB File for the Amazon Kindle
TSR Note: Although Amazon has added support for PDF in the most re-
cent versions of the Kindle, the file of choice for the Kindle is still MOBI. 
Publishers wishing to have the most trouble-free reader experience on 
the Kindle should, at this time, still plan to convert EPUB files to MOBI 
for Kindle readers. The process, while involved, does not need to be time 
consuming or error prone. The instructions from the speakers presented 
here will aid the process enormously.

�� Use KindleGen to convert an EPUB file to a MOBI file.

�� Use KindlePreviewer to view the MOBI file on your computer.

�� For more information about formatting a Kindle e-book, read the 
book Kindle Formatting: The Complete Guide by Joshua Tallent.

Special Requirements
�� The cover image must be a 600 px by 800 px JPEG standalone file. 

The image must also be referenced in the content.opf file.

�� A navigational TOC and a content TOC with hyperlinks must be 
included. TSR

The Workflow: Kindle (MOBI format) About the Presenters
Anne-Marie Concepción owns a busy cross-media 
design studio in Chicago and is one of the industry’s 
best-known Adobe trainers and consultants. She 
also presents many video tutorials at lynda.com. 

In addition, Anne-Marie hosts InCopySecrets.com, 
designed for editors and designers working in an In-
Design/InCopy workflow and writes the free month-

ly e-zine InCopyFlow. Learn more about Anne-Marie at her company’s 
Web site: senecadesign.com. 

Gabriel Powell is the author of Instant InDesign, 
Creating eBooks with Adobe InDesign CS4 & CS5, 
and Learn Adobe Photoshop CS4 by Video. He is 
also a contributing author to InDesign Magazine 
and the producer of the Instant InDesign video 
podcast. As a Senior Solutions Consultant for Typefi 
Systems and an Adobe Certified Instructor, Gabriel 
teaches InDesign, Typefi Publish, and other appli-

cations to creative professionals throughout Western Europe and the 
United States. He specializes in automated XML publishing, template 
building, and e-book publishing. He is also the founder of The Nether-
lands InDesign User Group in Amsterdam. Learn more about Gabriel at 
his company’s Web site: typefi.com.

http://lynda.com
http://InCopySecrets.com
http://senecadesign.com
http://typefi.com
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Resources

Books, Videos, and White Papers 
Creating e-books with Adobe InDesign CS4 and CS5 by Gabriel 
Powell (Video)

InDesign to EPUB, Kindle, and the iPad by Anne-Marie 
Concepción (Video: CS 5 / CS4)

Straight to the Point by Liz Castro (Peachpit Press) (EPUB) 

How to Create an e-book with Adobe InDesign CS5 by Rufus 
Deuchler (Abracadabra) (Book)

E-Books: From Adobe InDesign to the Apple iBookstore by 
Adobe and Anne-Marie Concepción (PDF)

Ask a CS Pro: From InDesign to the iBookstore by Anne-Marie 
Concepción (Recorded Webinar)

Creating EPUBs for the iPad using InDesign CS5.5 by Terry White 
(Video)

Creating e-books with InDesign CS4 by Adobe (PDFs)

Producing e-books from Adobe InDesign by Gabriel Powell  
(Videos)

Software 
Sigil, a free, multi-platform e-book editor

Adobe Digital Editions, a free mutli-platform e-book viewer 
(EPUB and PDF)

OxyGen, a commercial XML/EPUB editor

PhoneDisk, free/commercial multi-platform utility to mount 
iPads as a hard drive 

Springy, commercial utility for Mac OS X to edit contents of 
EPUBs without extracting files 

TextWrangler, free Mac OS X utility for editing an EPUB’s 
XHTML and CSS files 

EditPlus, commercial Windows utility for editing an EPUB’s 
XHTML and CSS files 

Notepad++, open source Windows text editor

http://www.video2brain.com/en/products-40.htm
http://www.lynda.com/tutorial/75445
http://www.lynda.com/tutorial/75446
http://www.elizabethcastro.com/epub
http://rufus.deuchler.net/2010/10/how-to-create-an-e-book-with-adobe-indesign-cs5.html
http://www.adobe.com/go/idtoipad
http://bit.ly/AskCSPro_ePub
http://tv.adobe.com/watch/cs-55-design-premium-feature-tour-/create-more-compelling-ebooks-withindesign-cs55/
http://www.adobe.com/products/creativesuite/design/crossmedia_resources/e-books_software.html
http://instantindesign.com/index.php?view_category=Video%20Podcasts
http://code.google.com/p/sigil/
http://www.adobe.com/products/digitaleditions/
http://www.oxygenxml.com/epub.html
http://macroplant.com/phonedisk/
http://www.springyarchiver.com/
http://www.barebones.com/products/textwrangler/
http://www.editplus.com/
http://notepad-plus-plus.org/
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