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Adobe Releases Major Creative Cloud Updates and 
Technical Communication Suite 5
Editor’s Note: in mid-January after the publication of the last issue of the 
Seybold Report (14.1), Adobe announced a number of major updates to 
several Creative Cloud apps including Photoshop CC, InDesign CC, and 
Illustrator CC. In keeping with the CC update policy, the new features and 
capabilities were available to CC users immediately after the announce-
ment. In addition, Adobe has announced the availability of Technical 
Communication Suite 5 with Document Type Definition (DTD) support.

The first section of this article is a recap of the news. The remainder of the 
article is an examination of some of the new capabilities including Photo-
shop CC Perspective Warp and 3-D design and using Typekit in InDesign 
CC, and Illustrator CC Live Corners. We also briefly discuss some of the 
new features in Technical Communication Suite 5. 

We recommend our readers who are Adobe Creative Cloud users experi-
ment with the new features as the features are significant and worth some 
exploration time. While this article includes details and images created by 
Adobe or by our staff, the full range of the new capabilities made possible 
by these new updates should be experienced by users themselves. 

The Adobe News In Brief
 � New features in Photoshop CC include Perspective Warp, which 

changes the viewpoint from which an object is seen, and Linked 
Smart Objects which, if used, will update the final design if the 
referenced file is changed. 

 � Adobe has announced it has added 3-D design and modeling 
capabilities to Adobe Photoshop CC. The company says the new 
3-D imaging capabilities will enable those who wish to create 3-D 
designs from scratch or refine an existing 3-D model to produce 
print-ready 3-D models using familiar Photoshop tools. 

 � In addition, completed designs can be printed from Photoshop CC 
to a locally connected 3-D printer or via built-in access to online 
3-D print services. 

 � Photoshop CC now supports the most popular desktop 3-D 
printers—such as the MakerBot Replicator—and also supports the 
full range of materials available on Shapeways.

 � New features in Adobe Illustrator CC and InDesign CC make it 
easier to use the Adobe Typekit font service. It is now possible 
to integrate Typekit fonts into print projects, PDF files, DPS apps, 
and more. New functionality in InDesign CC is aimed at making 
searching the Typekit desktop font library a much easier task.

 � InDesign CC includes new support for the EPUB 3.0 specification 
and also includes new ways to add interactivity to e-books, the 
ability to add pop-up footnotes easily, and offers simplified 
hyperlink creation and management. 

 � The latest version of Illustrator CC makes it easier to create editable 
rounded corners with the new Live Corners controls. Other new 
and improved capabilities include more intuitive drawing with 
the rebuilt Pencil Tool, the ability to modify existing objects and 
change the view of perspective drawings with Path Segment 
Reshape, and export responsive SVG code and graphics.

 � Adobe has announced the availability of Adobe Technical 
Communication Suite 5. This latest version comes with 
Document Type Definition (DTD) support and enables multi-
channel publishing. All major components of Adobe Technical 
Communication Suite were updated.
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Photoshop CC Perspective Warp
Photoshop users who have wished for a way to put things in their images 
into the proper perspective* will welcome Perspective Warp. All kidding 
aside, as the example Adobe staff demonstrated during the press brief-
ing on this capability indicated, this new feature will quickly become the 
favorite new tool of many Photoshop users. 

Simply stated, Perspective Warp lets Photoshop users take various im-
ages or parts of an image and shape them so all pieces come together in 
a single, accurate perspective. This new capability is more than sizing or 
twisting an image or segment of an image. The software sizes and rotates 
the material simultaneously as the user manipulates the warp points. 

The image at top right was created by Seybold Report staff and is a screen 
grab from a brief video created by Adobe to help illustrate the new abili-
ties Perspective Warp provides. At the front of the train, the warp selec-
tion rectangle is visible; this portion of the image can be warped by click-
ing on one of the points and moving it. (To see the full video the image 
appears in, simply click on the image.)

The way the Perspective Warp capability works is something difficult to 
describe in a few words, but is understood quickly when seen in a video. 
Thus, we recommend viewing the video provided by Adobe. Once seen in 
action, anyone familiar with Photoshop should have no problem warping 
images as desired, but a few moments of practice will be required for the 
first image. 

The image at bottom right is taken from another brief video from Adobe; 
this video presents an introduction to Perspective Warp and the other 
new features in Photoshop CC including Linked Smart Objects, Camera 
Shake Reduction, and 3-D printer support. Even though the video is only 
a few minutes long, viewing the video will provide enough information 
for deciding which of the new features is the most useful and appropriate 
for a particular project.

* We apologize for the pun, but then again, we could not resist the op-
portunity to make it.

Click on the image above to activate a brief video created by Adobe to show how the 
Perspective Warp capability in Photoshop CC works. Click on the image below to activate 
another brief video about the new features which Adobe has added to Photoshop CC. 
The image below shows the use of Camera Shake Reduction, also a new feature. An 
Internet connection is required to view the videos.

http://tv.adobe.com/watch/creative-cloud-for-video/perspective-warp/
http://tv.adobe.com/watch/creative-cloud-for-video/photoshop-cc-overview-january-2014/
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Working with Photoshop CC Linked Smart Objects
Even if only one person is working on image edits for even a simple proj-
ect, keeping track of the status and placement of edited images can be a 
daunting task. Adobe added Linked Smart Objects (LSOs) to Photoshop 
CC to help make this task easier. With it, objects may be used and up-
dated simultaneously across multiple Photoshop documents. Once cre-
ated, Photoshop will updated the contents of linked smart objects when 
anyone changes the source image file.

Adobe has updated the Help files for Photoshop CC to include instruc-
tions on how to create and update (as needed) LSOs. But, here is a short 
snippet of instruction on how to create LSOs for those who want to try 
the process right away:

 � Choose File > Place Linked.

 � Select an appropriate file and click Place.

The LSO is created, and its existence is displayed in the Layers panel with 
a link icon. 

Users can also create a LSO in an open document by dragging-and-
dropping the appropriate file while keeping the following key pressed: 
(Windows) Alt key (Mac) Opt key. To change this default behavior, turn 
off Preferences > General > Always Create Smart Objects While Placing.

To update LSOs: if an external source file changes while a Photoshop 
document referencing the linked file is open, the relevant LSO is auto-
matically updated. However, when a user opens a Photoshop document 
containing out-of-sync LSOs, the user can force-update the smart objects:

 � Right-click a linked smart object layer and select Update Modified 
Content.

 � Select Layer > Smart Objects > Update Modified Content

Another useful feature related to LSOs is it is also possible to replace the 

contents of a LSO or multiple LSOs almost automatically. This capability 
will come in very handy for users who do projects which contain many (or 
mostly) images such as catalogs and will be especially useful for projects 
which contain many low-resolution placeholder images which must be 
replaced with higher resolution final ones. Note: When a LSO is replaced, 
any scaling, warping, or effects applied to the original Smart Object are 
maintained.

Photoshop CC 3-D Design and Printing Capabilities
Although few people have 3-D imaging devices connected to their design 
workstations these days, some people do, and we expect the number of 
designers working on 3-D design projects to increase significantly within 
the next few years. So, we suggest Photoshop CC users try out the new 
3-D design capabilities even if they do not (yet) have a 3-D printer handy.

We show, in the screen capture below, the 3-D palettes which appear 
when 3-D design work is being done in Photoshop CC. Note the various 
options for setting the 3-D properties (bottom right of the image) and 
the other controls (top right of image). Although some of these design 
options are similar to those for 2-D work done in Photoshop, users must 
be prepared to spend a considerable amount of time, at least a few hours 
or more, to learn how to manipulate the 3-D design options.
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Once a 3-D object has been designed or edited in Photoshop, the user 
can choose a number of 3-D printing options. To access and change these 
options:

 � Select Window > Workspace > 3D to switch to the 3D workspace.

 � Open the 3-D model in Photoshop. and, if necessary, customize the 
size of the 3D model while opening it.

 � Select 3D > 3D Print Settings.

Photoshop currently supports the following local 3-D printers: 

 � 3D Systems Cube,

 �  MakerBot Replicator 2,

 �  MakerBot Replicator 2x, and

 �  ZCorp Full Color.

 � Photoshop  also supports several Shapeways.com profiles.

Using Typekit in InDesign CC
Adobe says InDesign CC will now automatically search the Typekit desk-
top font library for missing fonts and offer the option to use those fonts, 
or similar fonts, if a match exists. We found, though, the automatic part 
does not happen without some initial manual intervention. 

Desktop font sync is available to customers with a paid monthly or an-
nual Creative Cloud subscription (excluding single-app subscriptions) or 
a Portfolio, Performance, or Business standalone Typekit plan which has 
been linked to an Adobe ID. Users with one of these subscriptions can 
sync with Typekit but will need to follow a few steps to sync up InDesign. 
Once Typekit is synced, the fonts are available in the users Creative Cloud 
apps. Here is the link to the instructions: http://help.typekit.com/custom-
er/portal/articles/1145956-syncing-typekit-fonts-to-your-desktop.

Not all Typekit fonts can be synced with Creative Cloud applications. When following the 
instructions for syncing Typekit fonts to the desktop, make sure to click the Desktop icon 
(see below) under the Available For section in the Typekit user interface.

By adding 3-D printing 
capabilities to Photoshop 
CC, Adobe has made it 
much easier for designers 
and creators to experiment 
with 3-D design and 
printing. Shown at right is 
the 3-D print settings from 
Photoshop CC.  From this 
one box, a user can select the 
printer (see the list at left for 
the currently supported local 
3-D printers) and various 
settings such as detail level 
and print dimensions.
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EPUB 3.0 Support Enhancements in InDesign CC
Note: since EPUB 3.0 support is very important to many Seybold Report 
readers, we have included the full list of EPUB enhancements in InDesign 
CC. Many of these will be helpful for speeding up multi-channel publish-
ing efforts. The list includes:

 � Style to class name mapping.

 � Style class ownership-handling of CSS class name collisions.

 � Clean markup for Ordered/Numbered Lists.

 � Improved heuristic for determining bullet and numbering structure.

 � Static ordered list removed from EPUB export.

 � Improved HTML markup and CSS for Convert To Text list Export 
option.

 � Version string metadata.

 � Improved naming convention of CSS classes to match their 
purpose.

 � CSS generated for Japanese ruby tag.

 � Scripting support for EPUB book export.

 � New export warning or error message dialog.

 � Improved mapping of bullet character to list-style-type property.

 � Break-before property mapping.

 � Access to iBooks reader device fonts.

 � Font embedding on the iBooks reader is now supported.

 � EPUB 3.0 with Layout option removed from EPUB export.

 � Mapping paragraph keeps attributes to CSS paragraph properties.

 � Support for more than one CSS class name in ‘Style To Tag/Class’ 
fields of paragraph, character, and object styles.

 � Empty <p> and <li> ranges are removed.

Live Corners and the Pencil Tool in Illustrator CC 
Live Corners in a new feature which will make it easier for designers and 
illustrators to smooth out the rough edges in their designs. This is anoth-
er new feature in a CC app which will make some designers very happy 
and which will save them considerable time. In brief, Live Corners allows 
an Illustrator CC user to have greater control of the shape of corners and 
sharp angles without trying to draw a curve freehand. As can be seen in 
the image below taken from the Adobe Web site, a peak can be turned 
into a convex or concave shape or even flattened using Live Corners. 

In addition, the Pencil Tool has been improved to make it easier to use. 
New capabilities include better curve-fitting, auto-closing of paths, and 
drawing of constrained and unconstrained straight line segments.
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Updates to Adobe Technical Communication Suite 5
And, if all these new features for Creative Cloud users were not enough, 
Adobe has also been busy working on making major changes to Techni-
cal Communication Suite 5. If we were to include the full list of changes 
and updates, the list would take up more than a few pages. 

So, we decided to focus on the changes related to multi-channel publish-
ing and also to other activities we know are popular with our readers. For 
the full list, please see the product documentation on the Adobe Web site: 
http://www.adobe.com/products/technicalcommunicationsuite.html.

Here is our list of the updates and improvements made to the latest ver-
sion of Adobe Technical Communication Suite we feel will be of greatest 
interest to our readers:

 � Dropbox-powered sharing and collaboration in Adobe RoboHelp 
11 and FrameMaker 12 

 � e-Learning content integration—Rapidly author interactive 
e-Learning and HTML5-based m-Learning content using Adobe 
Captivate 7.

 � Publish HTML5 and SWF content created with Adobe Captivate 7 
to a wider range of formats using Adobe RoboHelp 11.

 � Multi-channel publishing support—Publish to HTML5, WebHelp, 
CHM, e-book (EPUB 3, Kindle Format 8, MOBI), native mobile apps 
(Android, Blackberry, iOS, Symbian, Windows), Adobe AIR, PDF, 
Microsoft Word, Adobe FlashHelp, JavaHelp, Eclipse Help, and 
Oracle Help for Java.

 � Single-click responsive HTML5 publishing—Generate responsive 
HTML5 output for multiple devices EPUB 3, Kindle Format 8 (KF8), 
and MOBI support

 � Out-of-the-box support for MathML equations—Create or edit 
MathML equations within Adobe FrameMaker 12 with native 

integration with MathFlow Structure and Style Editors from Design 
Science. Import a MathML equation into FrameMaker as an image, 
auto-size it, and save its source in the XML file. Automatically 
render all documents including XML with embedded MathML 
equations.

 � XPath 2.0 support—Eliminate the need to browse through 
numerous lines of XML code. Use the XPath pod in Adobe 
FrameMaker 12 to search and find elements and apply functions to 
them. 

Our Take
Clearly, as the detail presented in this article indicates, the latest changes 
Adobe has made to Creative Cloud apps and to its Technical Communica-
tion Suite are extensive. Even the changes made to a single app are worth 
spending hours examining and experimenting with because being well 
versed in them will help users become more productive with the software.

In addition, we found the help materials and introductory videos pre-
sented by Adobe on the company’s Web site to be useful in learning 
about the details and in figuring out how to find or trigger some of the 
new capabilities. That said, there is so much capability new in the most 
recent updates to these Creative Could apps, we expect plenty of training 
classes and third-party how-to lessons will be available on the Web and 
in person soon. 

However, after studying the material presented in this article, our readers 
will be better prepared to use the new capabilities and to decide which 
deserve further study and practice. TSR
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